Guida

Informazioni su Sophos Endpoint Security and Control

Sophos Endpoint Security and Control è una suite integrata di software per la sicurezza.

Sophos Anti-Virus rileva e rimuove virus, trojan, worm e spyware, oltre che adware e altre applicazioni potenzialmente indesiderate. La tecnologia HIPS (Host Intrusion Prevention System) può anche proteggere il computer da file sospetto e rootkit. Inoltre, Malicious Traffic Detector (rilevamento del traffico malevolo) è in grado di rilevare le comunicazioni tra i vostri computer e i server di comando e controllo coinvolti in attacchi botnet o di altri tipi di malware.

Sophos Behavior Monitoring utilizza la tecnologia HIPS per proteggere i computer con sistema operativo Windows dalle minacce non identificate o del giorno zero, oltre che da comportamento sospetto.

Sophos Live Protection migliora il rilevamento di nuovo malware, senza il rischio di rilevamenti indesiderati. Questo avviene mediante ricerca istantanea in base alle più aggiornate versioni di malware conosciute. Quando viene identificato un nuovo malware, Sophos è in grado di inviare aggiornamenti entro pochi secondi.

Sophos Web Protection fornisce una protezione avanzata contro le minacce del web impedendo l'accesso a percorsi noti per essere host di malware. Blocca l'accesso dei computer a tali siti, mediante la ricerca dei loro dati in tempo reale all'interno del database online Sophos. Effettua anche la scansione dei dati e dei file scaricati, oltre che verificare la reputazione dei file.

Sophos Application Control (controllo applicazioni) blocca applicazioni non autorizzate quali Voice over IP, messaggistica istantanea, condivisione file e software di gioco.

Sophos Device Control (controllo dispositivi) blocca dispositivi di memorizzazione esterni non autorizzati e tecnologie di connessione wireless.

Sophos Data Control (controllo dati) evita la perdita accidentale di dati che possono portare all'identificazione personale da computer gestiti.

Sophos Web Control consente di fornire protezione e controllo, oltre a rilevare i computer situati al di fuori della rete aziendale o in roaming.

Sophos Client Firewall impedisce a worm, trojan e spyware il furto e la distribuzione di informazioni sensibili, oltre che prevenire gli attacchi di pirati informatici.

Sophos AutoUpdate (autoaggiornamento) offre un aggiornamento a prova di errore e il controllo della larghezza di banda quando gli aggiornamenti vengono eseguiti da connessioni di rete a bassa velocità.

Sophos Tamper Protection (blocco rimozione) impedisce a malware noto e utenti non autorizzati (utenti con conoscenze tecniche limitate) la disinstallazione del software di sicurezza Sophos o la disabilitazione tramite l'interfaccia Sophos Endpoint Security and Control.

Argomento successivo: Pagina iniziale


Pagina iniziale

Quando si apre la finestra di Sophos Endpoint Security and Control, nel riquadro a destra viene visualizzata la Pagina iniziale che consente la configurazione e l'utilizzo del software.

Durante l'utilizzo di Sophos Endpoint Security and Control, il contenuto del riquadro a destra cambierà. Per tornare alla Pagina iniziale, cliccare sul pulsante Pagina iniziale nella barra degli strumenti.

Argomento precedente: Informazioni su Sophos Endpoint Security and Control
Argomento successivo: Gruppi Sophos


Gruppi Sophos

Sophos Endpoint Security and Control limita l'accesso a determinate parti della rete solo ai membri di specifici gruppi Sophos.

Quando viene installato Sophos Endpoint Security and Control, tutti gli utenti del computer vengono inizialmente assegnati a un gruppo Sophos in base al gruppo Windows di appartenenza.
Gruppo Windows | Gruppo Sophos
Administrators | SophosAdministrator
Power Users | SophosPowerUser
Utenti | SophosUser

Gli utenti non assegnati ad alcun gruppo Sophos, inclusi gli utenti ospiti, possono svolgere solo le seguenti operazioni:

  • Scansione in accesso
  • Scansione dal menu del tasto destro del mouse

SophosUsers

I membri del gruppo SophosUsers possono svolgere tutte le operazioni riportate qui sopra e quelle elencate di seguito:

  • Apertura della finestra Sophos Endpoint Security and Control
  • Impostazione ed esecuzione delle scansioni su richiesta
  • Configurazione della scansione dal menu del tasto destro del mouse
  • Gestione, con diritti limitati, degli oggetti in quarantena
  • Creazione e configurazione delle regole del firewall

SophosPowerUsers

I membri del gruppo SophosPowerUsers hanno gli stessi diritti di quelli del gruppo SophosUsers, oltre ai seguenti diritti aggiuntivi:

  • Maggiori privilegi nella gestione della quarantena
  • Accesso al gestore autorizzazioni

SophosAdministrators

I membri del gruppo SophosAdministrators possono utilizzare e configurare qualsiasi parte di Sophos Endpoint Security and Control.
Nota: Se il blocco rimozione è abilitato, i membri del gruppo SophosAdministrator devono conoscere la password del blocco rimozione per poter eseguire le seguenti operazioni:
  • Configurazione della scansione in accesso
  • Rilevamento di comportamento sospetto
  • Disabilitazione del blocco rimozione

Per ulteriori informazioni, consultare la sezione Il blocco rimozione in questo computer.

Argomento precedente: Pagina iniziale
Argomento successivo: Aggiunta di utenti al gruppo Sophos


Aggiunta di utenti al gruppo Sophos

Gli amministratori di dominio o i membri del gruppo Windows Administrators possono cambiare il gruppo Sophos a cui appartiene un determinato utente. Solitamente questa operazione viene svolta per modificare i diritti di accesso a Sophos Endpoint Security and Control.

Per aggiungere utenti al gruppo Sophos:

  1. Se si utilizza Windows, aprire Gestione computer.
  2. Nella struttura ad albero della console, cliccare su Utenti.
  3. Cliccare col tasto destro del mouse sull'account utente e poi su Proprietà.
  4. Nella scheda Membro di, cliccare su Aggiungi.
  5. In Immettere i nomi degli oggetti da selezionare, digitare il nome di un gruppo Sophos:
    • SophosAdministrator
    • SophosPowerUser
    • SophosUser
  6. Se si desidera verificare il nome del gruppo Sophos, cliccare su Controlla nomi.
La prossima volta che l'utente accederà al computer, i diritti di accesso a Sophos Endpoint Security and Control saranno cambiati.

Note

  • Per aprire Gestione computer, cliccare su Start e successivamente su Pannello di controllo. Cliccare due volte su Strumenti di amministrazione e due volte su Gestione computer.
  • Per rimuovere un utente da un gruppo utenti Sophos, dalla scheda Membro di, selezionare il gruppo da Membro di e cliccare su Rimuovi.
Argomento precedente: Gruppi Sophos
Argomento successivo: Configurazione dei diritti utente per il Gestore quarantena


Configurazione dei diritti utente per il Gestore quarantena

Se si appartiene al gruppo SophosAdministrator, è possibile configurare i diritti utente per il Gestore quarantena.

  1. Cliccare su Home > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Diritti utente per Gestore quarantena.
  2. Selezionare il tipo di utente che svolgerà un certo tipo di azione.
    Nota: eccezion fatta per l'opzione Autorizza, i diritti qui impostati vengono applicati solo al Gestore quarantena.
    Opzione | Descrizione
    Disinfetta settori | Gli utenti possono disinfettare il boot sector del floppy disk.
    Disinfetta file | Gli utenti possono disinfettare documenti e programmi.
    Cancella file | Gli utenti possono cancellare file infetti.
    Sposta file | Gli utenti possono spostare i file infetti in un'altra cartella.
    Autorizza Gli utenti possono autorizzare oggetti sospetti, adware e PUA, al fine di consentirne l'esecuzione nel computer.

    Questa opzione è applicabile sia al Gestore autorizzazioni che al Gestore quarantena.
Argomento precedente: Aggiunta di utenti al gruppo Sophos
Argomento successivo: Scansione in accesso e su richiesta


Scansione in accesso e su richiesta

Scansione in accesso

La scansione in accesso rappresenta il principale metodo di protezione contro virus e altre minacce.

Ogni qual volta si apra, salvi, copi o rinomini un file, Sophos Anti-Virus ne esegue la scansione e ne consente l'accesso solo se tale file non costituisce una minaccia per il computer o se ne è autorizzato l'utilizzo.

Per ulteriori informazioni, consultare la sezione Configurazione della scansione in accesso.

Scansione su richiesta

La scansione su richiesta fornisce protezione aggiuntiva. Come intuibile dal nome, è l'utente che avvia la scansione su richiesta. È possibile eseguire una scansione di tutto, da un file singolo all'intero computer.

Per ulteriori informazioni, consultare la sezione Tipi di scansione su richiesta.

Argomento precedente: Configurazione dei diritti utente per il Gestore quarantena
Argomento successivo: Migliori pratiche per la scansione in accesso


Migliori pratiche per la scansione in accesso

Questa sezione offre consigli per poter utilizzare la scansione in accesso al meglio.

Si consiglia l'utilizzo delle impostazioni predefinite per la scansione in accesso, per ottenere il giusto equilibrio fra la protezione dei computer dalle minacce e la resa del sistema. Per informazioni sulle impostazioni consigliate per la scansione in accesso, consultare l'articolo 114345 della knowledge base del supporto Sophos (http://www.sophos.com/it-it/support/knowledgebase/114345.aspx).

Argomento precedente: Scansione in accesso e su richiesta
Argomento successivo: Configurazione della scansione in accesso


Configurazione della scansione in accesso

Avvertenza:
La scansione in accesso potrebbe non rilevare i virus, se sono installati determinati software di cifratura. Modificare i processi di avvio per assicurarsi che i file vengano decifrati quando inizia la scansione in accesso. Per ulteriori informazioni su come utilizzare criteri antivirus e HIPS con software di cifratura, consultare l'articolo 12790 della knowledge base Sophos http://www.sophos.com/it-it/support/knowledgebase/12790.aspx.
Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.
Per impostazione predefinita, Sophos Anti-Virus rileva e disinfetta le seguenti minacce durante la scansione in accesso:
  • virus
  • trojan
  • worm
  • spyware

Per configurare la scansione in accesso:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Scansione in accesso.
  2. Per apportare modifiche alla tempistica in cui viene eseguita la scansione in accesso, in Verifica file in, impostare le opzioni secondo quanto descritto qui di seguito.
    Opzione | Descrizione
    Lettura | Scansione dei file quando copiati, spostati o aperti.
    Rinomina | Scansione dei file quando rinominati.
    Scrittura | Scansione dei file quando salvati o creati.
  3. In Esegui scansione alla ricerca di, impostare le opzioni come descritto di seguito.
    Opzione | Descrizione
    Adware e PUA L'adware visualizza messaggi pubblicitari, quali messaggi pop up, che possono incidere sulla produttività degli utenti e sull'efficienza del sistema.

    I PUA (Potentially Unwanted Applications) non sono malevoli, ma inappropriati per reti aziendali e ambienti lavorativi.
    File sospetti | I file sospetti presentano una serie di caratteristiche comunemente, ma non esclusivamente, riscontrate in virus.
  4. In Altre opzioni di scansione, impostare le opzioni come descritto di seguito.
    Opzione | Descrizione
    Accesso alle unità con settore di avvio infetti Attivare questa opzione per consentire l'accesso a uno mezzo o dispositivo rimovibile infetto, quale CD di avvio, floppy disk o unità flash USB.

    Utilizzate questa opzione soltanto su consiglio del supporto tecnico di Sophos.

    Consultare anche l'argomento della sezione Risoluzione dei problemi Accesso alle unità con settore di avvio infetti.
    Scansione di tutti i file | Si consiglia di lasciare questa opzione disabilitata, dal momento che può avere ripercussioni negative sulle performance del computer. Eseguire la scansione di tutti i fili solo durante una scansione settimanale.
    Scansione dei file di archivio Abilitare questa opzione per eseguire la scansione dei contenuti degli archivi o di file compressi. Eseguire questa operazione solo se si scaricano e distribuiscono tali file senza estrarne il contenuto.

    Si consiglia di lasciare questa opzione disabilitata, dal momento che rallenta notevolmente la scansione.

    Si sarà comunque protetti da eventuali minacce presenti nei file di archivio o compressi, dal momento che tutti i componenti dei file di archivio o compressi che potrebbero contenere malware verranno bloccati dalla scansione in accesso:

    • Quando si apre un file estratto dal file di archivio, tale file viene sottoposto a scansione.
    • I file compressi tramite utilità di compressione dinamiche, quali PKLite, LZEXE e Diet, vengono sottoposti a scansione.
    Scansione della memoria di sistema Abilitare questa opzione per seguire automaticamente una scansione di background a cadenza oraria per rilevare malware nascosti nella memoria di sistema del computer (la memoria utilizzata dal sistema operativo).
    Nota: Questa opzione è disponibile solo per i sistemi operativi a 32 bit.
Argomento precedente: Migliori pratiche per la scansione in accesso
Argomento successivo: Disabilitazione temporanea della scansione in accesso


Disabilitazione temporanea della scansione in accesso

Se si appartiene al gruppo SophosAdministrator, può presentarsi la necessità di disabilitare temporaneamente la scansione in accesso per motivi di manutenzione o per la risoluzione di alcuni problemi e successivamente di riabilitarla. È possibile disabilitare la protezione in accesso, ma continuare ad eseguire scansioni su richiesta del computer.

Sophos Endpoint Security and Control conserva le impostazioni scelte in questa pagina, anche dopo il riavvio del computer. Se si disabilita la scansione in accesso, il computer risulta non protetto finché la scansione in accesso non venga riabilitata.

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > ConfiguraScansione in accesso.
  2. Deselezionare la casella di spunta Consenti scansione in accesso per questo computer.
Argomento precedente: Configurazione della scansione in accesso
Argomento successivo: Configurazione della disinfezione in accesso


Configurazione della disinfezione in accesso

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.
Per configurare la disinfezione in accesso:
  1. Cliccare su Pagina inizialeAntivirus e HIPSConfigura antivirus e HIPSConfiguraScansione in accesso.
  2. Cliccare sulla scheda Disinfezione.
  3. Per disinfettare automaticamente gli oggetti infetti, in Virus/spyware, selezionare la casella di spunta Disinfetta automaticamente gli oggetti contenenti virus o spyware.
    Nota: Se si seleziona tale opzione, la disinfezione di virus/spyware darà inizio a una scansione completa del sistema, che cercherà di rimuovere dal computer tutti i virus. Ciò potrebbe richiedere molto tempo.
  4. In Viruses/spyware, selezionare l'azione che Sophos Anti-Virus dovrà intraprendere contro gli oggetti infetti, nel caso la disinfezione automatica sia stata disabilitata o non riesca:
    Opzione Descrizione
    Nega solo l'accesso Sophos Anti-Virus chiede quale azione intraprendere prima di continuare.

    Si tratta di un'impostazione predefinita.
    Cancella

    Nega l'accesso e sposta in

                 Utilizzare queste impostazioni soltanto su consiglio del supporto tecnico di Sophos.

    Utilizzare altrimenti il Quarantine Manager (gestore quarantena) per disinfettare il computer dai virus e spyware rilevati da Sophos Anti-Virus. Consultare la sezione Gestione di virus e spyware in quarantena.
  5. In File sospetti, selezionare l'azione che Sophos Anti-Virus intraprenderà ogni qual volta rilevi file contenenti codici utilizzati comunemente da malware:
    Opzione Descrizione
    Nega l'accesso Sophos Anti-Virus chiede quale azione intraprendere prima di continuare.

    Si tratta di un'impostazione predefinita.
    Cancella

    Nega l'accesso e sposta in

                 Utilizzare queste impostazioni soltanto su consiglio del supporto tecnico di Sophos.

    Utilizzare invece il Quarantine Manager per disinfettare il computer dai file sospetti rilevati da Sophos Anti-Virus. Consultare la sezione Gestione di file sospetti in quarantena
Argomento precedente: Disabilitazione temporanea della scansione in accesso
Argomento successivo: Ripristino dei file checksum scansionati


Ripristino dei file checksum scansionati

L'elenco dei file checksum scansionati viene ripristinato quando viene eseguito un aggiornamento di Sophos Anti-Virus, oppure quando viene riavviato il computer. L'elenco viene ricostruito con i nuovi dati mano a mano che i file vengono scansionati da Sophos Anti-Virus.

È possibile ripristinare l'elenco di file checksum sottoposti a scansione direttamente da Sophos Endpoint Security and Control, senza dover riavviare il computer.

Per ripristinare i file checksum sottoposti a scansione:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Scansione in accesso.
  2. Nella scheda Scansione, cliccare su Elimina contenuto cache.
Argomento precedente: Configurazione della disinfezione in accesso
Argomento successivo: Specificazione delle estensioni dei file per la scansione in accesso


Specificazione delle estensioni dei file per la scansione in accesso

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

È possibile specificare quali estensioni dei file debbano essere verificate durante la scansione in accesso.

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Scansione in accesso.
  2. Cliccare sulla scheda Estensioni ed impostare le opzioni secondo quanto descritto di seguito.

    Scansione di tutti i file

    Cliccare su questa opzione per abilitare la scansione di tutti i file, indipendentemente dall'estensione del file.

    Consenti scelta delle estensioni da esaminare

    Cliccare su questa opzione per restringere la scansione ai soli file con un'estensione particolare, specificata nella lista delle estensioni.

    Avvertenza:
    l'elenco delle estensioni include i tipi di file che Sophos consiglia di esaminare. Fare attenzione se si modifica l'elenco secondo quanto descritto di seguito.

    Per aggiungere un'estensione alla lista, cliccare su Aggiungi. È possibile utilizzare il carattere jolly "?" al posto di un singolo carattere.

    Per rimuovere un'estensione dalla lista, selezionare l'estensione e cliccare su Rimuovi.

    Per modificare un'estensione nella lista, selezionare l'estensione e cliccare su Modifica.

    Selezionando Consenti scelta delle estensioni da esaminare, l'opzione Scansione dei file senza estensione viene selezionata per impostazione predefinita. Per disabilitare la scansione dei file senza estensione, deselezionare Scansione dei file senza estensione.

Argomento precedente: Ripristino dei file checksum scansionati
Argomento successivo: Tipi di scansione su richiesta


Tipi di scansione su richiesta

Scansione dal menu del tasto destro del mouse

Esegue in qualsiasi momento la scansione di file, cartelle o unità in Windows Explorer.

  • Esecuzione della scansione dal menu del tasto destro del mouse

Scansione personalizzata

Esegue la scansione di set di file o cartelle specifici. È possibile eseguire una scansione personalizzata sia manualmente, sia pianificandone un'esecuzione autonoma.

  • Esecuzione di una scansione personalizzata
  • Pianificazione di una scansione personalizzata

Scansione completa del computer

Esegue in qualsiasi momento la scansione dell'intero computer, incluso il boot sector e la memoria di sistema.

  • Esecuzione della scansione completa del computer
Argomento precedente: Specificazione delle estensioni dei file per la scansione in accesso
Argomento successivo: Specificazione delle estensioni dei file per la scansione su richiesta


Specificazione delle estensioni dei file per la scansione su richiesta

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

È possibile specificare quali estensioni dei file debbano essere verificate durante la scansione su richiesta.

  1. Dal menu Configura, cliccare su Estensioni ed esclusioni su richiesta.
  2. Cliccare sulla scheda Estensioni ed impostare le opzioni secondo quanto descritto di seguito.

    Scansione di tutti i file

    Cliccare su questa opzione per abilitare la scansione di tutti i file, indipendentemente dall'estensione del file.

    Consenti scelta delle estensioni da esaminare

    Cliccare su questa opzione per restringere la scansione ai soli file con un'estensione particolare, specificata nella lista delle estensioni.

    Avvertenza:
    l'elenco delle estensioni include i tipi di file che Sophos consiglia di esaminare. Fare attenzione se si modifica l'elenco secondo quanto descritto di seguito.

    Per aggiungere un'estensione alla lista, cliccare su Aggiungi. È possibile utilizzare il carattere jolly "?" al posto di un singolo carattere.

    Per rimuovere un'estensione dalla lista, selezionare l'estensione e cliccare su Rimuovi.

    Per modificare un'estensione nella lista, selezionare l'estensione e cliccare su Modifica.

    Selezionando Consenti scelta delle estensioni da esaminare, l'opzione Scansione dei file senza estensione viene selezionata per impostazione predefinita. Per disabilitare la scansione dei file senza estensione, deselezionare Scansione dei file senza estensione.

Argomento precedente: Tipi di scansione su richiesta
Argomento successivo: Configurazione della scansione dal menu del tasto destro del mouse


Configurazione della scansione dal menu del tasto destro del mouse

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.
Per impostazione predefinita, Sophos Anti-Virus rileva e disinfetta le seguenti minacce durante la scansione dal menu del tasto destro del mouse:
  • virus
  • trojan
  • worm
  • spyware
  • adware e altre applicazioni potenzialmente indesiderate (PUA)

Per configurare la scansione da menu del tasto destro del mouse:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Scansione dal menu del tasto destro del mouse.
  2. In Esegui scansione alla ricerca di, impostare le opzioni come descritto di seguito.
    Opzione | Descrizione
    Adware e PUA L'adware visualizza messaggi pubblicitari, quali messaggi pop up, che possono incidere sulla produttività degli utenti e sull'efficienza del sistema.

    I PUA (Potentially Unwanted Applications) non sono malevoli, ma inappropriati per reti aziendali e ambienti lavorativi.
    File sospetti | I file sospetti presentano una serie di caratteristiche comunemente, ma non esclusivamente, riscontrate in virus.
  3. In Altre opzioni di scansione, impostare le opzioni come descritto di seguito.
    Opzione | Descrizione
    Scansione di tutti i file | Si consiglia di lasciare questa opzione disabilitata, dal momento che può avere ripercussioni negative sulle performance del computer. Eseguire la scansione di tutti i fili solo durante una scansione settimanale.
    Scansione dei file di archivio Abilitare questa opzione per eseguire la scansione dei contenuti degli archivi o di file compressi. Eseguire questa operazione solo se si scaricano e distribuiscono tali file senza estrarne il contenuto.

    Si consiglia di lasciare questa opzione disabilitata, dal momento che rallenta notevolmente la scansione.

    Si sarà comunque protetti da eventuali minacce presenti nei file di archivio o compressi, dal momento che tutti i componenti dei file di archivio o compressi che potrebbero contenere malware verranno bloccati dalla scansione in accesso:

    • Quando si apre un file estratto dal file di archivio, tale file viene sottoposto a scansione.
    • I file compressi tramite utilità di compressione dinamiche, quali PKLite, LZEXE e Diet, vengono sottoposti a scansione.
Argomento precedente: Specificazione delle estensioni dei file per la scansione su richiesta
Argomento successivo: Configurazione della disinfezione dal menu del tasto destro del mouse


Configurazione della disinfezione dal menu del tasto destro del mouse

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.
Per configurare la disinfezione dal menu del tasto destro del mouse:
  1. Cliccare su Home > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Scansione dal menu del tasto destro del mouse.
  2. Cliccare sulla scheda Disinfezione.
  3. Per disinfettare automaticamente gli oggetti infetti, in Virus/spyware, selezionare la casella di spunta Disinfetta automaticamente gli oggetti contenenti virus o spyware.
  4. Selezionare l'azione che Sophos Anti-Virus dovrà intraprendere contro gli oggetti infetti, nel caso la disinfezione automatica non sia stata abilitata o non riesca:
    Opzione Descrizione
    Solo log Sophos Anti-Virus si limita a registrare gli oggetti infetti nel log della scansione. Consultare la sezione Visualizzazione del log della scansione.

    Si tratta di un'impostazione predefinita.
    Cancella

    Sposta in

                 Utilizzare queste impostazioni soltanto su consiglio del supporto tecnico di Sophos.

    Utilizzare altrimenti il Quarantine Manager (gestore quarantena) per disinfettare il computer dai virus e spyware rilevati da Sophos Anti-Virus. Consultare la sezione Gestione di virus e spyware in quarantena.

  5. In File sospetti, selezionare l'azione che Sophos Anti-Virus intraprenderà ogni qual volta rilevi file contenenti codici utilizzati comunemente da malware:
    Opzione Descrizione
    Solo log Sophos Anti-Virus si limita a registrare gli oggetti infetti nel log della scansione.

    Si tratta di un'impostazione predefinita.
    Cancella

    Sposta in

                 Utilizzare queste impostazioni soltanto su consiglio del supporto tecnico di Sophos.

    Utilizzare altrimenti il Quarantine Manager (gestore quarantena) per disinfettare il computer dai virus e spyware rilevati da Sophos Anti-Virus. Consultare la sezione Gestione di file sospetti in quarantena
  6. Per rimuovere i componenti conosciuti di adware e Potentially Unwanted Applications (PUA) dai computer di tutti gli utenti, in Adware e PUA, selezionare la casella di spunta Disinfetta automaticamente adware e PUA.
    La rimozione non annulla le modifiche già apportate da adware o PUA.
    • Per informazioni su come visionare nel sito web di Sophos gli effetti collaterali di adware o PUA, consultare la sezione Informazioni sulla disinfezione.
    • Per informazioni su come disinfettare il computer da adware e PUA utilizzando il Quarantine Manager, consultare la sezione Gestione di adware e PUA in quarantena.
Argomento precedente: Configurazione della scansione dal menu del tasto destro del mouse
Argomento successivo: Esecuzione della scansione dal menu del tasto destro del mouse


Esecuzione della scansione dal menu del tasto destro del mouse

È possibile esaminare file, cartelle e unità da Windows Explorer o dal computer eseguendo la scansione dal menu del tasto destro del mouse.

  1. Utilizzando Windows Explorer o nel computer, selezionare il file, la cartella o l'unità disco che si desidera scansionare.
    È possibile selezionare file e cartelle multipli.
  2. Cliccare col tasto destro del mouse sull'oggetto selezionato e successivamente cliccare su Scansione con Sophos Anti-Virus.

Se vengono rilevate minacce o applicazioni controllate, cliccare su Dettagli e consultare la sezione Gestione degli oggetti in quarantena della Guida in linea.

Argomento precedente: Configurazione della disinfezione dal menu del tasto destro del mouse
Argomento successivo: Creazione di una scansione personalizzata


Creazione di una scansione personalizzata

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Scansioni.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Cliccare su Imposta una nuova scansione.
  3. Nel campo di testo Nome scansione, digitare un nome per la scansione.
  4. Nel riquadro Oggetti da esaminare, selezionare le unità e le cartelle che si desidera esaminare. A questo scopo, selezionare la casella alla sinistra di ogni unità o cartella. Per informazioni sulle icone visualizzate accanto alle caselle, consultare Simboli degli oggetti da esaminare.
    Nota: Le unità o le cartelle non disponibili (perché non sono in linea o sono state cancellate) vengono visualizzate con un carattere barrato. Vengono rimosse dal riquadro Oggetti da esaminare se vengono deselezionate o se si apporta una modifica alla selezione della o delle unità o cartelle madri.
  5. Per configurare ulteriormente la scansione, cliccare su Configura scansione (per informazioni, v. Configurazione di una scansione personalizzata).
  6. Per pianificare la scansione, cliccare su Pianifica scansione (per informazioni, v. Pianificazione di una scansione).
  7. Cliccare su Salva per salvare la scansione oppure Salva e avvia per salvare e avviare la scansione.
Argomento precedente: Esecuzione della scansione dal menu del tasto destro del mouse
Argomento successivo: Rappresentazione degli oggetti da sottoporre a scansione


Rappresentazione degli oggetti da sottoporre a scansione

Nel riquadro Oggetti da esaminare, nella casella accanto a ciascun oggetto (unità o cartella) vengono visualizzate diverse icone, a seconda degli oggetti da esaminare. Queste icone sono raffigurate e descritte qui sotto.
Icona | Descrizione
 | L'oggetto e relativi sotto-oggetti non sono selezionati per la scansione.
 | L'oggetto e relativi sotto-oggetti sono selezionati per la scansione.
 | L'oggetto è parzialmente selezionato: non l'oggetto in sé ma alcuni suoi sotto-oggetti sono selezionati per la scansione.
 | L'oggetto e relativi sotto-oggetti sono esclusi da questa specifica scansione.
 | L'oggetto è parzialmente escluso: l'oggetto è selezionato ma alcuni suoi sotto-oggetti sono esclusi da questa particolare scansione.
 | L'oggetto e relativi sotto-oggetti sono esclusi da tutte le scansioni su richiesta, perché è stata impostata un'esclusione su richiesta. Per informazioni, consultare la sezione Esclusione di oggetti dalla scansione in accesso.
Argomento precedente: Creazione di una scansione personalizzata
Argomento successivo: Configurazione di una scansione personalizzata


Configurazione di una scansione personalizzata

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.
Per impostazione predefinita, Sophos Anti-Virus rileva e disinfetta le seguenti minacce durante la scansione personalizzata:
  • virus
  • trojan
  • worm
  • spyware
  • adware e altre applicazioni potenzialmente indesiderate (PUA)
  • Rootkit

Per configurare una scansione personalizzata:

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Scansioni.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Scansioni disponibili, selezionare la scansione che si desidera modificare e poi cliccare su Modifica.
  3. Cliccare su Configura scansione.
  4. In Esegui scansione alla ricerca di, impostare le opzioni come descritto di seguito.
    Opzione | Descrizione
    Adware e PUA L'adware visualizza messaggi pubblicitari, quali messaggi pop up, che possono incidere sulla produttività degli utenti e sull'efficienza del sistema.

    I PUA (Potentially Unwanted Applications) non sono malevoli, ma inappropriati per reti aziendali e ambienti lavorativi.
    File sospetti | I file sospetti presentano una serie di caratteristiche comunemente, ma non esclusivamente, riscontrate in virus.
    Rootkit Se membri del gruppo SophosAdministrator, la scansione alla ricerca di rootkit viene sempre eseguita ogni qual volta si esegua una scansione completa del computer.

    È possibile eseguire la scansione alla ricerca di rootkit come parte di una scansione personalizzata.

  5. In Altre opzioni di scansione, impostare le opzioni come descritto di seguito.
    Opzione | Descrizione
    Scansione di tutti i file | Si consiglia di eseguire la scansione di tutti i file solo durante la scansione settimanale; la scansione di tutti i file limita le prestazioni del computer.
    Scansione dei file di archivio Abilitare questa opzione per eseguire la scansione dei contenuti degli archivi o di file compressi. Eseguire questa operazione solo se si scaricano e distribuiscono tali file senza estrarne il contenuto.

    Si consiglia di lasciare questa opzione disabilitata, dal momento che rallenta notevolmente la scansione.

    Si sarà comunque protetti da eventuali minacce presenti nei file di archivio o compressi, dal momento che tutti i componenti dei file di archivio o compressi che potrebbero contenere malware verranno bloccati dalla scansione in accesso:

    • Quando si apre un file estratto dal file di archivio, tale file viene sottoposto a scansione.
    • I file compressi tramite utilità di compressione dinamiche, quali PKLite, LZEXE e Diet, vengono sottoposti a scansione.
    Scansione della memoria di sistema Abilitare questa opzione per seguire automaticamente una scansione di background a cadenza oraria per rilevare malware nascosti nella memoria di sistema del computer (la memoria utilizzata dal sistema operativo).
    Nota: Questa opzione è disponibile solo per i sistemi operativi a 32 bit.
    Esegui scansione a priorità più bassa | In Windows Vista e superiore, eseguire la scansione personalizzata con priorità più bassa in modo tale da avere un impatto minimo sulle applicazioni per gli utenti.
Argomento precedente: Rappresentazione degli oggetti da sottoporre a scansione
Argomento successivo: Configurazione della disinfezione per una scansione personalizzata


Configurazione della disinfezione per una scansione personalizzata

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.
Per configurare la disinfezione per una scansione personalizzata:
  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Scansioni.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Scansioni disponibili, selezionare la scansione che si desidera modificare e poi cliccare su Modifica.
  3. Cliccare su Configura scansione.
  4. Cliccare sulla scheda Disinfezione.
  5. Per disinfettare automaticamente i file infetti, in Virus/spyware, selezionare la casella di spunta Disinfetta automaticamente i file contenenti virus o spyware.
  6. Selezionare l'azione che Sophos Anti-Virus dovrà intraprendere contro gli oggetti infetti, nel caso la disinfezione automatica non sia stata abilitata o non riesca:
    Opzione Descrizione
    Solo log Sophos Anti-Virus si limita a registrare gli oggetti infetti nel log della scansione personalizzata. Consultare la sezione Visualizzazione del log per la scansione personalizzata.

    Si tratta di un'impostazione predefinita.
    Cancella

    Sposta in

                 Utilizzare queste impostazioni soltanto su consiglio del supporto tecnico di Sophos.

    Utilizzare altrimenti il Quarantine Manager (gestore quarantena) per disinfettare il computer dai virus e spyware rilevati da Sophos Anti-Virus. Consultare la sezione Gestione di virus e spyware in quarantena.
  7. In File sospetti, selezionare l'azione che Sophos Anti-Virus intraprenderà ogni qual volta rilevi file contenenti codici utilizzati comunemente da malware:
    Opzione Descrizione
    Solo log Sophos Anti-Virus si limita a registrare gli oggetti infetti nel log della scansione.

    Si tratta di un'impostazione predefinita.
    Cancella

    Sposta in

    Utilizzare queste impostazioni soltanto su consiglio del supporto tecnico di Sophos.

    Utilizzare altrimenti il Quarantine Manager (gestore quarantena) per disinfettare il computer dai virus e spyware rilevati da Sophos Anti-Virus. Consultare la sezione Gestione di file sospetti in quarantena
  8. Per rimuovere i componenti conosciuti di adware e Potentially Unwanted Applications (PUA) dai computer di tutti gli utenti, in Adware e PUA, selezionare la casella di spunta Disinfetta automaticamente adware e PUA.
    La rimozione non annulla le modifiche già apportate da adware o PUA.
    • Per informazioni su come visionare nel sito web di Sophos gli effetti collaterali di adware o PUA, consultare la sezione Informazioni sulla disinfezione.
    • Per informazioni su come disinfettare il computer da adware e PUA utilizzando il Quarantine Manager, consultare la sezione Gestione di adware e PUA in quarantena.
Argomento precedente: Configurazione di una scansione personalizzata
Argomento successivo: Pianificazione di una scansione personalizzata


Pianificazione di una scansione personalizzata

Se si appartiene al gruppo SophosAdministrator, è possibile pianificare una scansione personalizzata o visualizzare e modificare le scansioni pianificate create da altri utenti.

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Scansioni.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Scansioni disponibili, selezionare la scansione che si desidera modificare e poi cliccare su Modifica.
  3. Cliccare su Pianifica scansione.
  4. Nella finestra di dialogo Pianifica scansione, selezionare Abilita operazione pianificata.

    Selezionare il giorno o i giorni nei quali la scansione dovrà essere eseguita.

    Aggiungere l'orario (o gli orari) cliccando su Aggiungi.

    Se necessario, rimuovere o modificare un orario selezionandolo e cliccando rispettivamente su Rimuovi o Modifica.

  5. Digitare nome utente e password. Assicurarsi che il campo relativo alla password non sia vuoto.
    La scansione pianificata viene eseguita con i diritti di accesso di quell'utente.
Nota: Se la scansione rileva componenti di una minaccia nella memoria, e non è stata impostata la scansione per la disinfezione automatica di virus/spyware, la scansione si blocca. Ciò avviene poiché procedere con la scansione potrebbe consentire la diffusione di questa minaccia. Occorre effettuare la disinfezione della minaccia, prima di poter eseguire nuovamente la scansione.
Argomento precedente: Configurazione della disinfezione per una scansione personalizzata
Argomento successivo: Esecuzione di una scansione personalizzata


Esecuzione di una scansione personalizzata

Nota: Non è possibile eseguire una scansione personalizzata pianificata manualmente. Le scansioni pianificate sono visualizzate nella lista Scansioni disponibili con un'icona a forma di orologio.
  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Scansioni.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Scansioni disponibili, selezionare la scansione che si desidera eseguire e poi cliccare su Avvia.
    Viene visualizzata una finestra di dialogo che mostra l'avanzamento della scansione e nel riquadro Sophos Endpoint Security and Control compare il Riepilogo delle attività.
Nota: Se la scansione rileva componenti di una minaccia nella memoria, e non è stata impostata la scansione per la disinfezione automatica di virus/spyware, la scansione si blocca. Ciò avviene poiché procedere con la scansione potrebbe consentire la diffusione di questa minaccia. Occorre effettuare la disinfezione della minaccia, prima di poter eseguire nuovamente la scansione.

Se vengono individuate minacce o applicazioni controllate, cliccare su Dettagli e consultare la sezione Gestione degli oggetti in quarantena.

Argomento precedente: Pianificazione di una scansione personalizzata
Argomento successivo: Rinomina di una scansione personalizzata


Rinomina di una scansione personalizzata

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Scansioni.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Scansioni disponibili, selezionare la scansione che si desidera modificare e poi cliccare su Modifica.
  3. Nella casella Nome scansione, digitare il nuovo nome della scansione.
Argomento precedente: Esecuzione di una scansione personalizzata
Argomento successivo: Visualizzazione del log per la scansione personalizzata


Visualizzazione del log per la scansione personalizzata

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Scansioni.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Scansioni disponibili, cliccare su Riepilogo della scansione personalizzata.
  3. Nella finestra di dialogo Riepilogo, cliccare sul link nella parte inferiore della finestra.
Dalla pagina log, è possibile copiare il log negli appunti, oppure inviarlo per e-mail o stamparlo.

Per trovare un testo specifico all'interno del log, cliccare su Trova e inserire il testo desiderato.

Argomento precedente: Rinomina di una scansione personalizzata
Argomento successivo: Visualizzazione del riepilogo di una scansione personalizzata


Visualizzazione del riepilogo di una scansione personalizzata

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Scansioni.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Scansioni disponibili, cliccare su Riepilogo della scansione personalizzata.
Argomento precedente: Visualizzazione del log per la scansione personalizzata
Argomento successivo: Cancellazione di una scansione personalizzata


Cancellazione di una scansione personalizzata

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Scansioni.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Scansioni disponibili, selezionare la scansione che si desidera cancellare e poi cliccare su Cancella.
Argomento precedente: Visualizzazione del riepilogo di una scansione personalizzata
Argomento successivo: Esecuzione della scansione completa del computer


Esecuzione della scansione completa del computer

Per eseguire la scansione dell'intero sistema in uso nel computer, inclusi boot sector e memoria di sistema:

Nella pagina Home, sotto Antivirus e HIPS, cliccare su Scansione del computer.
Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.

Viene visualizzata una finestra di dialogo che mostra l'avanzamento della scansione e nella finestra Sophos Endpoint Security and Control compare il Riepilogo delle attività.

Nota: Se la scansione rileva componenti di una minaccia nella memoria, si interrompe. Ciò avviene poiché procedere con la scansione potrebbe consentire la diffusione di questa minaccia. Occorre effettuare la disinfezione della minaccia, prima di poter eseguire nuovamente la scansione.

Se vengono individuate minacce o applicazioni controllate, cliccare su Dettagli e consultare Gestione degli oggetti in quarantena.

Argomento precedente: Cancellazione di una scansione personalizzata
Argomento successivo: Esclusione di oggetti dalla scansione in accesso


Esclusione di oggetti dalla scansione in accesso

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Per modificare l'elenco di file, cartelle e unità esclusi dalla scansione in accesso:

  1. Cliccare su Home > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Scansione in accesso.
  2. Cliccare sulla scheda Esclusioni, quindi scegliere una delle seguenti opzioni.
    • Per specificare file, cartelle o unità che si desidera escludere da una scansione in accesso, cliccare su Aggiungi.
    • Per cancellare un'esclusione, cliccare su Rimuovi.
    • Per modificare un'esclusione, cliccare su Modifica.
  3. Per aggiungere o modificare un oggetto escluso, nella finestra di dialogo Escludi oggetto, selezionare il Tipo di oggetto.
    Il tipo di oggetto Tutti i file remoti può essere utilizzato per escludere i file non archiviati nelle unità locali. Selezionare questa opzione se si desidera aumentare la velocità di accesso a questi file e si ritiene affidabile il loro percorso remoto.
  4. Specificare il Nome dell'oggetto utilizzando il pulsante Sfoglia o digitandolo nella casella di testo.
    Nota: se si lavora su una piattaforma a 64 bit, nella finestra di dialogo Escludi oggetto il pulsante Sfoglia non è visibile.

    Per informazioni su come inserire il nome di un oggetto, consultare la sezione Specificazione delle esclusioni di scansione.

Argomento precedente: Esecuzione della scansione completa del computer
Argomento successivo: Esclusione di oggetti dalla scansione su richiesta


Esclusione di oggetti dalla scansione su richiesta

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

La procedura descritta qui sotto si riferisce a tutte le scansioni su richiesta. Per informazioni su come escludere determinati oggetti da una scansione personalizzata, consultare la sezione Creazione di una scansione personalizzata.

Per modificare l'elenco di file, cartelle e unità esclusi dalla scansione su richiesta:

  1. Cliccare su Home > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Estensioni ed esclusioni su richiesta.
  2. Cliccare sulla scheda Esclusioni, quindi scegliere una delle seguenti opzioni.
    • Per specificare file, cartelle o unità che si desidera escludere da una scansione su richiesta, cliccare su Aggiungi.
    • Per cancellare un'esclusione, cliccare su Rimuovi.
    • Per modificare un'esclusione, cliccare su Modifica.
  3. Per aggiungere o modificare un oggetto escluso, nella finestra di dialogo Escludi oggetto, selezionare il Tipo di oggetto.
  4. Specificare il Nome oggetto utilizzando il pulsante Sfoglia o digitandolo nella casella di testo.
    Nota: se si lavora su una piattaforma a 64 bit, nella finestra di dialogo Escludi oggetto il pulsante Sfoglia non è visibile.

    Per informazioni su come inserire il nome di un oggetto, consultare la sezione Specificazione delle esclusioni di scansione.

Argomento precedente: Esclusione di oggetti dalla scansione in accesso
Argomento successivo: Specificazione delle esclusioni di scansione


Specificazione delle esclusioni di scansione

Convenzioni di nomenclatura standard

Sophos Anti-Virus convalida percorsi e nomi file degli oggetti che si desidera escludere dalla scansione, in base alla convenzioni di denominazione di Windows. Per esempio, il nome di una cartella può contenere spazi, ma non solo.

Estensioni file multiple

Nei nomi file con estensioni multiple, l'ultima estensione viene considerata come estensione e le altre come parte del nome:

MySample.txt.doc = nome file MySample.txt + estensione .doc.

Esclusione di file, cartelle, processi o unità specifici

Tipo di esclusione | Descrizione | Esempi | Commenti
File specifico | Specificare sia il percorso che il nome per poter escludere un determinato file. Il percorso può includere una lettera di unità o il nome di una condivisione di rete. | C:\Documents\CV.doc \\Server\Users\?Documents\CV.doc \\Server\Users\Documents\CV.doc | Per assicurarsi che le esclusioni vengano applicate correttamente, aggiungere nome file e cartella sia nella versione estesa che conforme alla 8.3: C:\Programmi\Sophos\Sophos Anti-Virus C:\Progra~1\Sophos\Sophos~1 Per ulteriori informazioni, consultare l'articolo 13045 della knowledge base.
Processi specifici | Indicare sia il percorso che il nome del file per poter escludere un file eseguibile (processo) specifico. | C:\Windows\notepad.exe | Occorre specificare il percorso completo.
Tutti i file con lo stesso nome | Indicare il nome di un file senza percorso per escludere tutti i file aventi lo stesso nome ovunque si trovino nel file system. | spacer.gif |
Tutti gli oggetti di un'unità o condivisione di rete | Specificare la lettera dell'unità o il nome della condivisione per escludere tutti gli oggetti contenuti in un'unità o condivisione di rete | C: \\Server\<nomecondivisione>\ | Quando viene specificata una condivisione di rete, includere una barra finale dopo il nome della condivisione.
Cartella specifica | Indicare il percorso di una cartella che comprenda una lettera di unità o il nome di una condivisione di rete, per escludere tutti gli oggetti presenti in quella cartella e nelle relative sottocartelle. | D:\Tools\logs\ | Includere una barra finale dopo il nome della cartella.
Tutte le cartelle con lo stesso nome | Indicare il percorso di una cartella senza alcuna lettera di unità o nome di condivisione di rete, per escludere qualsiasi oggetto presente in quella cartella e nelle relative sottocartelle in tutte le unità o condivisioni di rete. | \Tools\logs\ (esclude le seguenti cartelle: C:\Tools\logs\, \\Server\Tools\logs\) | È necessario indicare tutto il percorso fino alla lettera di unità o al nome della condivisione di rete. In questo esempio, specificando \logs\ non verrebbe escluso alcun file.

Caratteri jolly

È possibile utilizzare solamente i caratteri jolly specificati in questa tabella.

Nota: Solamente * e ? Possono essere adoperati su Windows Server 2003.
Token | Corrispondenze | Commenti
* (asterisco) Zero o più caratteri, eccetto \ oppure /. Per esempio:

c:\*\*.txt esclude tutti i file aventi nome *.txt nelle cartelle di primo livello in C:\.

Nota: * non può essere utilizzato con le cartelle be
** (due asterischi) Zero o più caratteri, inclusi \ e /, quando racchiusi tra caratteri \ o / oppure quando vengono utilizzati all’inizio o alla fine di un'esclusione.

Qualsiasi altro uso di ** viene considerato come un * singolo, e troverà corrispondenza con zero o più caratteri, eccetto \ oppure /.

 Per esempio:
  • c:\foo\**\bar troverà corrispondenza con: c:\foo\bar, c:\foo\more\bar, c:\foo\even\more\bar
  • **\bar troverà corrispondenza con c:\foo\bar
  • c:\foo\** troverà corrispondenza con c:\foo\more\bar
  • c:\foo**bar troverà corrispondenza con c:\foomorebar ma NON con c:\foo\more\bar
\ (barra rovesciata) | \ oppure /.
/ (barra) | / oppure \.
? (punto interrogativo) | Un unico carattere, a meno che non si trovi al termine di una stringa, dove può corrispondere anche a zero caratteri.
. (punto) Un punto, OPPURE la stringa vuota alla fine di un nome file, se il pattern termina con un punto e il nome file non ha un’estensione. Notare che:
  • *.* troverà corrispondenza con tutti i file
  • *. troverà corrispondenza con tutti i file privi di estensione
  • "foo." troverà corrispondenza con "foo" e "foo."

Esempi

Ecco alcuni esempi di utilizzo dei caratteri jolly.

Espressione | Interpretata come | Descrizione
foo | **\foo | Esclude tutti i file aventi nome foo (in qualsiasi percorso).
foo\bar | **\foo\bar | Esclude tutti i file aventi nome bar in una cartella avente nome foo (in qualsiasi percorso).
*.txt | **\*.txt | Esclude tutti i file aventi nome *txt (in qualsiasi percorso).
C: | C: | Esclude l’unità C: dalla scansione (incluso il record di avvio principale dell’unità).
C:\ | C:\ | Esclude tutti i file dell’unità C: dalla scansione (ma include nella scansione il record di avvio principale dell’unità).
C:\foo\ | C:\foo\ | Tutti i file e le cartelle sotto C:\foo, inclusa anche C:\foo.
C:\foo\*.txt | C:\foo\*.txt | Tutti i file contenuti in C:\foo aventi nome *.txt.

Variabili per le esclusioni

Durante l’impostazione delle esclusioni di scansione, è possibile utilizzare variabili.

La seguente tabella indica le variabili e gli esempi di percorso corrispondente per ciascun sistema operativo.

Variabile | Windows 7 o successivi, Windows Server 2008 o successivi | Windows Server 2003, Windows XP, Windows Vista
%allusersprofile%\ | C:\ProgramData\ | C:\Documents and Settings\All Users\
%appdata%\ | C:\Users\*\AppData\Roaming\ | C:\Documents and Settings\*\Application Data\
%commonprogramfiles%\ | C:\Program Files\Common Files\ | C:\Program Files\Common Files\
%commonprogramfiles(x86)%\ | C:\Program Files (x86)\Common Files\ | C:\Program Files (x86)\Common Files\
%localappdata%\ | C:\Users\*\AppData\Local\ | C:\Documents and Settings\*\Local Settings\Application Data\
%programdata%\ | C:\ProgramData\ | C:\Documents and Settings\All Users\Application Data\
%programfiles%\ | C:\Program Files\ | C:\Program Files\
%programfiles(x86)%\ | C:\Program Files (x86)\ | C:\Program Files (x86)\
%systemdrive%\ | C: | C:
%systemroot%\ | C:\Windows\ | C:\Windows\
%temp%\ o %tmp%\ | C:\Users\*\AppData\Local\Temp\ | C:\Documents and Settings\*\Local Settings\Temp\
%userprofile%\ | C:\Users\*\ | C:\Documents and Settings\*\
%windir%\ | C:\Windows\ | C:\Windows\
Argomento precedente: Esclusione di oggetti dalla scansione su richiesta
Argomento successivo: Monitoraggio del comportamento


Monitoraggio del comportamento

In quanto parte della scansione in accesso, Sophos Behavior Monitoring protegge i computer con sistema operativo Windows dalle minacce non identificate o del giorno zero, oltre che da comportamento sospetto.

Il rilevamento in fase di esecuzione può rilevare minacce che non possono essere identificate prima dell'esecuzione. Il monitoraggio del comportamento utilizza i seguenti metodi di rilevamento in fase di esecuzione per identificare eventuali minacce:
  • Rilevamento di comportamento malevolo e sospetto
  • Rilevamento di buffer overflow

Rilevamento di comportamento malevolo e sospetto

Il rilevamento di comportamento sospetto utilizza l'Host Intrusion Prevention System (HIPS) di Sophos per analizzare dinamicamente il comportamento di tutti i programmi in esecuzione sul computer, per rilevare e bloccare qualsiasi attività dall'aspetto malevolo. Per comportamento sospetto si intendono ad esempio le modifiche al registro che potrebbero consentire l'esecuzione automatica di un virus al riavvio del computer.

Il rilevamento di comportamento sospetto controlla tutti i processi di sistema alla ricerca di segni che indichino la presenza di malware attivo, quali scritture sospette nel registro o azioni di copiatura file. Può essere impostato in modo tale da avvertire l'amministratore e/o bloccare il processo.

Il rilevamento di comportamento malevolo coincide con l'analisi dinamica di tutti i programmi in esecuzione nel computer e ha lo scopo di rilevare e bloccare attività apparentemente malevoli.

Rilevamento di buffer overflow

Il rilevamento di buffer overflow è fondamentale nel trattamento delle minacce del giorno zero.

Analizza dinamicamente il comportamento dei programmi in esecuzione nel sistema per poter rilevare eventuali tentativi di sfruttare un processo in esecuzione tramite tecniche di buffer overflow. Intercetta attacchi che puntano a vulnerabilità della sicurezza nei software e applicazioni del sistema operativo.

Argomento precedente: Specificazione delle esclusioni di scansione
Argomento successivo: Abilitazione del monitoraggio del comportamento


Abilitazione del monitoraggio del comportamento

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se parte del gruppo SophosAdministrator è possibile abilitare il monitoraggio del comportamento.

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Monitoraggio del comportamento.
  2. Nella finestra di dialogo Configura monitoraggio del comportamento, selezionare la casella Abilita monitoraggio del comportamento.
Argomento precedente: Monitoraggio del comportamento
Argomento successivo: Blocco di comportamento malevolo


Blocco di comportamento malevolo

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Il rilevamento di comportamento malevolo coincide con l'analisi dinamica di tutti i programmi in esecuzione nel computer e ha lo scopo di rilevare e bloccare attività apparentemente malevoli.

Se membri del gruppo SophosAdministrator, è possibile modificare le impostazioni per il rilevamento e la segnalazione di comportamento malevolo:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Monitoraggio del comportamento.
  2. Nella finestra di dialogo Configura monitoraggio del comportamento, selezionare la casella Abilita monitoraggio del comportamento.
  3. Per allertare l'amministratore e bloccare episodi di comportamento malevolo, selezionare la casella di spunta Rileva comportamento sospetto.
Argomento precedente: Abilitazione del monitoraggio del comportamento
Argomento successivo: Prevenzione di comportamento sospetto


Prevenzione di comportamento sospetto

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Il rilevamento di comportamento sospetto controlla tutti i processi di sistema alla ricerca di segni che indichino la presenza di malware attivo, quali scritture sospette nel registro o azioni di copiatura file. Può essere impostato in modo tale da avvertire l'amministratore e/o bloccare il processo.

Se membri del gruppo SophosAdministrator, è possibile modificare le impostazioni per il rilevamento e la segnalazione di comportamento sospetto:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Monitoraggio del comportamento.
  2. Nella finestra di dialogo Configura monitoraggio del comportamento, selezionare la casella Abilita monitoraggio del comportamento.
  3. Selezionare la casella di spunta Rileva comportamento malevolo.
  4. Per allertare l'amministratore e bloccare eventuali processi sospetti, selezionare la casella Rileva comportamento malevolo.
  5. Per allertare l'amministratore, ma non bloccare eventuali processi sospetti, selezionare la casella di spunta Avvisa solo, non bloccare comportamento sospetto.

Per avere protezione massima, si consiglia di abilitare il rilevamento di file sospetti. Per ulteriori informazioni, consultare i seguenti argomenti:

  • Configurazione della scansione in accesso
  • Configurazione della scansione dal menu del tasto destro del mouse
  • Configurazione di una scansione personalizzata
Argomento precedente: Blocco di comportamento malevolo
Argomento successivo: Prevenzione di buffer overflow


Prevenzione di buffer overflow

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Il rilevamento di buffer overflow analizza dinamicamente il comportamento dei programmi in esecuzione nel sistema per poter rilevare eventuali tentativi di sfruttare un processo in esecuzione tramite tecniche di buffer overflow.

Se membri del gruppo SophosAdministrator, è possibile modificare le impostazioni per il rilevamento e la segnalazione di buffer overflow:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Monitoraggio del comportamento.
  2. Nella finestra di dialogo Configura monitoraggio del comportamento, selezionare la casella Abilita monitoraggio del comportamento.
  3. Per avvisare l'amministratore e bloccare il buffer overflow, selezionare la casella di spunta Rileva buffer overflow.
  4. Per avvisare l'amministratore, ma non bloccare episodi di buffer overflow, selezionare la casella di spunta Avvisa solo, non bloccare.
Argomento precedente: Prevenzione di comportamento sospetto
Argomento successivo: Sophos Live Protection


Sophos Live Protection

Sophos Live Protection decide se un file sospetto rappresenta una minaccia e, quando ciò accade, agisce immediatamente secondo quanto specificato nella configurazione disinfezione di Sophos Anti-Virus.

Sophos Live Protection migliora il rilevamento di nuovo malware, senza il rischio di rilevamenti indesiderati. Questo avviene mediante ricerca istantanea in base alle più aggiornate versioni di malware conosciute. Quando viene identificato un nuovo malware, Sophos è in grado di inviare aggiornamenti entro pochi secondi.

Sophos Live Protection utilizza le seguenti opzioni:

  • Abilita Live Protection

    Se la scansione antivirus su un computer ha identificato un file come sospetto, ma non riesce poi a determinare se sia pulito o malevolo, in base ai file di identità delle minacce (IDE) memorizzati nel computer, alcuni dati del file (come il checksum e altri attributi) vengono inviati a Sophos per un'ulteriore analisi.

    La verifica “in-the-cloud” esegue la ricerca istantanea di un file sospetto nel database di SophosLabs. Se il file viene identificato come pulito o malevolo, la decisione viene inviata al computer e lo stato del file viene automaticamente aggiornato.

  • Invio automatico dei file campione a Sophos

    Se un file viene considerato sospetto, ma non può essere identificato con certezza come malevolo solo in base ai suoi dati, è possibile permettere la richiesta da parte di Sophos di un campione del file. Se tale opzione è abilitata, e Sophos non detiene ancora un campione del file, il file verrà inviato automaticamente.

    L'invio di file campione permette a Sophos di migliorare continuamente il rilevamento del malware senza il rischio di falsi positivi.

Argomento precedente: Prevenzione di buffer overflow
Argomento successivo: Attivazione e disattivazione delle opzioni di Sophos Live Protection


Attivazione e disattivazione delle opzioni di Sophos Live Protection

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se si appartiene al gruppo SophosAdministrator, è possibile attivare o disattivare Sophos Live Protection:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Sophos Live Protection.
  2. Nella finestra di dialogo Sophos Live Protection:
    • Per attivare o disattivare l'invio a Sophos dei dati dei file, selezionare o deselezionare la casella di spunta Attiva Live Protection.

    • Per attivare o disattivare l'invio a Sophos di campioni di file, selezionare o deselezionare la casella di spunta Invia automaticamente file campione a Sophos.

      Questa opzione è disponibile solamente se Attiva Live Protection è già stata selezionata.

Nota

Quando si invia il campione di un file a Sophos per la scansione in linea, insieme al campione vengono sempre inviati i dati del file.

Argomento precedente: Sophos Live Protection
Argomento successivo: Visualizzazione del log di Sophos Live Protection


Visualizzazione del log di Sophos Live Protection

I dati dei file inviati a Sophos per le scansioni in linea e gli aggiornamenti di stato dei file una volta completate le scansioni vengono registrati nel log della scansione del computer.

Se Sophos Live Protection è attiva, il log mostra:

  • Il percorso di tutti i file, i cui dati sono stati inviati a Sophos.
  • L'orario in cui tali dati sono stati inviati
  • La causa dell'errore (se conosciuta) se l'invio dei dati non è riuscito.
  • Lo stato attuale del file (per esempio, “virus/spyware” se il file è stato identificato come malevolo).

Per visualizzare il log della scansione:

  • Nella Pagina iniziale, sotto Antivirus ed HIPS, cliccare su Visualizza log antivirus e HIPS.

    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.

Dalla pagina log, è possibile copiare il log negli appunti, oppure inviarlo per e-mail o stamparlo.

Per trovare un testo specifico all'interno del log, cliccare suTrova e inserire il testo desiderato.

Argomento precedente: Attivazione e disattivazione delle opzioni di Sophos Live Protection
Argomento successivo: Sophos Web Protection


Sophos Web Protection

Sophos Web Protection offre una protezione ancora più efficace contro le minacce web. Include le seguenti funzioni:

  • Filtraggio URL in tempo reale
  • Scansione dei contenuti scaricati
  • Verifica della reputazione dei file scaricati

Filtraggio URL in tempo reale

Il filtraggio URL in tempo reale consente di bloccare l'accesso a siti web noti per ospitare malware. Questa funzione opera una ricerca in tempo reale all'interno del database online di Sophos in cui vengono raccolti i siti web infetti.

Quando viene bloccato l'accesso a un sito web malevolo, viene registrato un evento nel log della scansione. Per informazioni su come visualizzare il log della scansione, consultare la sezione Visualizzazione del log della scansione.

Scansione dei contenuti

La scansione dei contenuti esegue la scansione dei dati e dei file scaricati da Internet (o Intranet) e rileva contenuto malevolo in modo proattivo. Questa funzione esegue la scansione di contenuti ospitati in qualsiasi percorso, compresi quelli non facenti parte del database dei siti web infetti.

Reputazione del download

La reputazione del download viene definita in base all'età dei file, alle loro fonti e prevalenza, oltre che a un'approfondita analisi dei contenuti e ad altre caratteristiche specifiche.

Nota: l'analisi della reputazione del download è solo supportata in computer Windows 7 o successivi.

Per impostazione predefinita, viene visualizzato un avviso ogniqualvolta venga effettuato il download di un file con reputazione bassa o sconosciuta. Sophos consiglia di non effettuare il download di tali file. Se si ritiene la fonte e l'entità di pubblicazione attendibili, è possibile scegliere di effettuare comunque il download. Le azioni intraprese e le URL dei file vengono registrati nel log di scansione.

Nota: la reputazione del download viene definita in base ai dati raccolti nel database in-the-cloud dei SophosLabs e richiede l'abilitazione di Sophos Live Protection per poter effettuare ricerche ed ottenere dati (Sophos Live Protection è abilitata per impostazione predefinita).

Per maggiori informazione sulla reputazione del download, consultare l'articolo 121319 della knowledge base.

Impostazioni di configurazione della Protezione Web

La funzionalità di Protezione Web è abilitata per impostazione predefinita e consente di bloccare l'accesso a siti Web malevoli, effettuare la scansione dei contenuti scaricati, oltre che di verificare la reputazione dei file scaricati.

Per maggiori informazioni sulle impostazioni relative alla Protezione Web e su come modificarle, consultare la sezione Configurazione di Sophos Web Protection.

Browser Web supportati

I seguenti browser Web supportano la funzionalità di protezione Web:

  • Internet Explorer
  • Edge
  • Google Chrome
  • Firefox (esclusa la funzionalità per il rilevamento della reputazione dei download)
  • Safari (esclusa la funzionalità per il rilevamento della reputazione dei download)
  • Opera

I contenuti web a cui si accede non utilizzando un browser supportato non verranno filtrati e quindi non potranno essere bloccati.

Argomento precedente: Visualizzazione del log di Sophos Live Protection
Argomento successivo: Configurazione di Sophos Web Protection


Configurazione di Sophos Web Protection

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Per modificare le impostazioni di Sophos Web Protection:

  1. Cliccare su Pagina iniziale > Anti-virus e HIPS > Configura antivirus e HIPS > Configura > Protezione web.
  2. Per bloccare o sbloccare l'accesso a siti web malevoli, di fianco all'opzione Blocca l'accesso ai siti malevoli, selezionare Attivato o Disattivato. Questa opzione è abilitata per impostazione predefinita.
    Per informazioni su come autorizzare un sito web classificato come malevolo, consultare la sezione Autorizzazione all'utilizzo di un sito web.
  3. Per attivare o disattivare la scansione dei dati e file scaricati, di fianco all'opzione Scansione dei contenuti, selezionare Scansione in accesso, Attivato o Disattivato.
    Per impostazione predefinita è selezionata l'opzione Scansione in accesso, vale a dire, la scansione dei contenuti viene disattivata o attivata contemporaneamente alla scansione in accesso.
  4. Per modificare le azioni intraprese ogniqualvolta venga scaricato un file con reputazione bassa o sconosciuta, sotto Reputazione del download, di fianco all'opzione Azione, selezionare Richiedi conferma all'utente (impostazione predefinita) oppure Solo log.
    • Se si seleziona l'opzione Richiedi conferma all'utente, ogniqualvolta venga effettuato il download di un file a bassa reputazione, viene visualizzato un avviso informativo in cui si chiede se bloccare o consentire il download. Sophos consiglia di non effettuare il download di tali file. Se si ritiene la fonte e l'entità di pubblicazione attendibili, è possibile scegliere di effettuare comunque il download. Sia che si scelga di bloccare o consentire il download e l'URL del file verrà aggiunta una voce a riguardo nel log delle scansioni.
    • Se si seleziona l'opzione Solo log, non verrà visualizzato alcun avviso e il download verrà consentito e registrato nel log.
  5. Per stabilire quanto rigido debba essere il rilevamento della reputazione, di fianco all'opzione Soglia, selezionare Consigliata (impostazione predefinita) o Rigida.
    • Se si seleziona l'opzione Consigliata, ogniqualvolta venga effettuato il download di un file con reputazione bassa o sconosciuta, viene visualizzato un allarme e/o creata una nuova voce nel file di log.
    • Se si seleziona l'opzione Rigida, ogniqualvolta venga effettuato il download di un file con reputazione media, bassa o sconosciuta, viene visualizzato un allarme e/o creata una nuova voce nel file di log.

Per maggiori informazione sulla reputazione del download, consultare l'articolo 121319 della knowledge base.

Per informazioni su come visualizzare il log della scansione, consultare la sezione Visualizzazione del log della scansione.

Argomento precedente: Sophos Web Protection
Argomento successivo: Autorizzazione di adware e PUA


Autorizzazione di adware e PUA

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se si desidera eseguire adware o un'applicazione che Sophos Anti-Virus ha classificato come potenzialmente indesiderata, è possibile autorizzarla.

Per autorizzare adware e PUA:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Autorizzazione.
  2. Nella scheda Adware o PUA, nell'elenco Adware e PUA noti, selezionare adware o PUA.
  3. Cliccare su Aggiungi.
L'adware o PUA appare nell'elenco Adware o PUA autorizzati.
Nota: È anche possibile autorizzare adware e PUA dal gestore quarantena. Per informazioni su come procedere, consultare la sezione Gestione di adware e PUA in quarantena.
Argomento precedente: Configurazione di Sophos Web Protection
Argomento successivo: Blocco di adware e PUA autorizzati


Blocco di adware e PUA autorizzati

Per evitare che adware e PUA attualmente autorizzati vengano eseguiti nel computer:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Autorizzazione.
  2. Nella scheda Adware o PUA, nell'elenco Adware o PUA autorizzati, selezionare adware o PUA che si desidera bloccare.
  3. Cliccare su Rimuovi.
Argomento precedente: Autorizzazione di adware e PUA
Argomento successivo: Autorizzazione di oggetti sospetti


Autorizzazione di oggetti sospetti

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se si desidera autorizzare un oggetto che Sophos Anti-Virus ha classificato come sospetto, è possibile farlo nel modo seguente.

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Autorizzazione.
  2. Cliccare sulla scheda relativa al tipo di oggetto rilevato (per es. Buffer overflow).
  3. Cliccare sull'elenco Noto e selezionare l'oggetto sospetto.
  4. Cliccare su Aggiungi.
L'oggetto sospetto compare nell'elenco Autorizzato.
Nota: È anche possibile autorizzare oggetti sospetti nel Gestore quarantena. Per informazioni su come fare ciò, consultare le seguenti sezioni:
  • Gestione di file sospetti in quarantena
  • Gestione di comportamento sospetto in quarantena
Argomento precedente: Blocco di adware e PUA autorizzati
Argomento successivo: Preautorizzazione di oggetti sospetti


Preautorizzazione di oggetti sospetti

Se si desidera autorizzare un oggetto che Sophos Endpoint Security and Control non ha ancora classificato come sospetto, è possibile preautorizzarlo.

Per preautorizzare un oggetto sospetto:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Autorizzazione.
  2. Cliccare sulla scheda relativa al tipo di oggetto rilevato (per es. Buffer overflow).
  3. Cliccare su Nuova voce.
  4. Trovare l'oggetto sospetto e cliccarvi due volte.
L'oggetto sospetto compare nell'elenco Autorizzato.
Argomento precedente: Autorizzazione di oggetti sospetti
Argomento successivo: Autorizzazione all'utilizzo di un sito web


Autorizzazione all'utilizzo di un sito web

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se si desidera sbloccare un sito classificato come malevolo da Sophos, è possibile aggiungerlo all'elenco dei siti autorizzati. Gli URL di un sito web autorizzato non vengono verificati dal filtro web online di Sophos.

Avvertenza:
Autorizzare un sito web classificato come malevolo potrebbe esporre a minacce; assicurarsi che l'accesso al sito sia sicuro prima di autorizzarlo.

Per autorizzare l'utilizzo di un sito web:

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Configura > Autorizzazione.
  2. Cliccare sulla scheda Siti web.
  3. Cliccare su Aggiungi.
  4. Inserire il nome di dominio o l'indirizzo IP.
Il sito web compare nell'elenco dei Siti web autorizzati.
Argomento precedente: Preautorizzazione di oggetti sospetti
Argomento successivo: Gestore quarantena


Gestore quarantena

Il Gestore quarantena consente di gestire gli oggetti individuati mediante la scansione e non eliminati automaticamente durante la stessa. Ciascun oggetto viene conservato qui per una delle ragioni seguenti.

  • Non è stata scelta alcuna opzione di disinfezione (disinfezione, cancellazione, spostamento) per il tipo di scansione durante la quale è stato individuato l'oggetto.
  • È stata scelta un'opzione di disinfezione per il tipo di scansione durante la quale è stato individuato l'oggetto, ma l'opzione non ha funzionato correttamente.
  • L'oggetto ha un'infezione multipla e contiene ancora altre minacce.
  • La minaccia è stata rilevata solo parzialmente. Per rilevarla in maniera completa, è necessaria una scansione completa del computer. Per scoprire come procedere, consultare la sezione Esecuzione di una scansione completa del computer.
  • L'oggetto manifesta un comportamento sospetto.
  • L'oggetto è un'applicazione controllata.
Nota: Adware, PUA e infezioni multicomponente rilevate durante la scansione in accesso sono sempre elencate nel Gestore quarantena. La disinfezione automatica di adware, PUA e infezioni multicomponente non è disponibile per la scansione in accesso.

L'opzione di disinfezione potrebbe non aver funzionato correttamente a causa di diritti di accesso insufficienti. Se si dispone di diritti maggiori, è possibile utilizzare il Gestore quarantena per gestire l'oggetto o gli oggetti.

Le minacce rilevate durante la scansione delle pagine web non sono elencate nel Gestore quarantena perché non vengono scaricate nel computer. Non è quindi necessaria alcuna azione.

Argomento precedente: Autorizzazione all'utilizzo di un sito web
Argomento successivo: Layout del Gestore quarantena


Layout del Gestore quarantena

Il Gestore quarantena elenca tutti gli oggetti rilevati durante la scansione rendendo possibile interventi mirati da parte dell'utente. Gli elementi inclusi nella finestra del Gestore quarantena sono elencati di seguito.

Cliccare sull'elenco Mostra per filtrare i tipi di oggetti visualizzati.
L'identità dell'oggetto, completa di link alla sua analisi pubblicata sul sito web di Sophos.
Nome file e percorso dell'oggetto.

Se l'oggetto risulta associato a un rootkit, viene visualizzato come Nascosto.

Se accanto al nome del file appare il collegamento dettagli, significa che l'oggetto presenta un'infezione multicomponente. Cliccare sul link per visualizzare l'elenco degli altri componenti che formano l'infezione. Se alcuni componenti sono associati al rootkit, la finestra di dialogo indicherà che si tratta di componenti nascosti.
L'azione da intraprendere su un determinato oggetto.

Se l'oggetto non è nascosto, è possibile intraprendere tre tipi di azione: Disinfetta, Cancella e Sposta.

Cliccando su una delle azioni, questa viene eseguita immediatamente dopo averla confermata. I file nascosti possono essere solo disinfettati.
L'elenco degli oggetti rilevati.

Per ordinare gli oggetti, cliccare su uno dei titoli delle colonne visualizzate.
Cliccare su Seleziona tutto per eseguire la stessa azione su tutti gli oggetti dell'elenco.

Per deselezionare un oggetto, deselezionare la relativa casella di spunta nella colonna Tipo.
Se sono stati selezionati tutti gli oggetti dell'elenco e si desidera deselezionarli, cliccare su Deseleziona tutti.

Per selezionare un oggetto, selezionare la relativa casella di spunta nella colonna Tipo.
Cliccare Cancella dalla lista per rimuovere gli oggetti selezionati dall'elenco senza intraprendere alcuna azione specifica.

Gli oggetti non verranno cancellati dal disco.
Cliccare su Esegui azione per visualizzare l'elenco di azioni che è possibile eseguire sugli oggetti selezionati.
Argomento precedente: Gestore quarantena
Argomento successivo: Gestione di virus e spyware in quarantena


Gestione di virus e spyware in quarantena

Nota: Il termine virus si riferisce a qualsiasi virus, worm o trojan o ad altro software malevolo.
  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Gestisci elementi messi in quarantena.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Mostra, cliccare su Virus/spyware.

Nelle colonne sono visualizzate informazioni relative a ciascun oggetto.

Nome visualizza l'identità rilevata da Sophos Anti-Virus. Per ulteriori informazioni sul virus e spyware, cliccare sull'identità. SophosAnti-Virus si connette quindi all'analisi del virus o spyware disponibile sul sito web di Sophos.

Dettagli visualizza il nome e la posizione dell'oggetto. Se l'oggetto è associato a un rootkit, viene visualizzato come "Nascosto". Se accanto al nome del file appare il collegamento dettagli, significa che l'oggetto presenta un'infezione multicomponente. Cliccare sul link per visualizzare la lista degli altri componenti che formano l'infezione. Se uno dei componenti è associato a un rootkit, la finestra di dialogo indica che alcuni componenti sono nascosti.

Azioni disponibili visualizza le azioni eseguibili sull'oggetto. A meno che l'oggetto non sia nascosto, sono disponibili tre azioni: Disinfetta, Cancella e Sposta, come descritto sotto. Cliccando su una delle azioni, questa viene eseguita sull'oggetto dopo averla confermata. I file nascosti possono essere solo disinfettati.

Gestione degli oggetti infetti

Per gestire virus e spyware, utilizzare i pulsanti descritti sotto.

Seleziona tutto/Deseleziona tutto

Cliccare su questi pulsanti per selezionare oppure per deselezionare tutti gli oggetti. Ciò consente di eseguire la stessa azione su un gruppo di oggetti. Per selezionare o deselezionare un determinato oggetto, selezionare la casella alla sinistra del tipo di oggetto.

Cancella dalla lista

Cliccare su questa opzione per rimuovere dalla lista gli oggetti selezionati, se si è certi che non contengono virus o spyware. Gli oggetti non verranno comunque cancellati dal disco.

Esegui azione

Cliccare su questa opzione per visualizzare una lista di azioni eseguibili sugli oggetti selezionati.

  • Cliccare su Disinfetta per rimuovere un virus o spyware dagli oggetti selezionati. La disinfezione dei documenti non annulla le modifiche che il virus può aver apportato al documento.
    Nota: Per una rimozione completa dal computer di alcuni virus e spyware formati da diversi componenti, sarà necessario riavviare il computer. In questo caso viene data la possibilità di scegliere di riavviare il computer immediatamente o in un secondo tempo. Le operazioni conclusive di rimozione saranno eseguite dopo il riavvio del computer.
    Nota: La disinfezione di alcuni virus provoca l'esecuzione di una scansione completa del sistema, la quale cerca di disinfettare tutti i virus. Ciò potrebbe richiedere molto tempo. L'azione disponibile cambia e diventa Disinfezione fino al completamento della scansione.
  • Cliccare su Cancella per cancellare gli oggetti selezionati dal computer. Utilizzare questa funzione con cautela.
  • Cliccare su Sposta per spostare gli oggetti selezionati in un'altra cartella. Gli oggetti vengono spostati nella cartella che è stata specificata durante l'impostazione della disinfezione. Spostando un file eseguibile si riducono le probabilità che venga eseguito. Utilizzare questa funzione con cautela.
Avvertenza:
Se si cancella o si sposta un file infetto, il computer potrebbe smettere di funzionare correttamente, perché non riesce a trovare il file. Inoltre, un file infetto può essere solo parte di un'infezione multipla, nel qual caso la sua cancellazione o il suo spostamento non comporterà la disinfezione del computer. In questo caso, rivolgersi al supporto tecnico di Sophos per ricevere assistenza nella gestione degli oggetti.

Per informazioni su come contattare il supporto tecnico, consultare la sezione Supporto tecnico.

Per configurare l'azione da eseguire, consultareConfigurazione dei diritti utente per Gestore quarantena.

Argomento precedente: Layout del Gestore quarantena
Argomento successivo: Gestione di adware e PUA in quarantena


Gestione di adware e PUA in quarantena

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Gestisci elementi messi in quarantena.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Mostra, cliccare su Adware o PUA.

Nelle colonne sono visualizzate informazioni relative a ciascun oggetto.

Nome visualizza l'identità rilevata da Sophos Anti-Virus. Per ulteriori informazioni sull'adware o PUA, cliccare sull'identità. Sophos Anti-Virus si connette quindi all'analisi dell'adware o PUA disponibile sul sito web di Sophos.

Dettagli visualizza il sottotipo di adware e PUA. Se l'oggetto è associato a un rootkit, viene visualizzato come "Nascosto". Se accanto al sottotipo appare il collegamento dettagli, significa che l'oggetto è un adware e PUA multicomponente. Cliccare sul link per visualizzare l'elenco degli altri componenti che formano l'adware o PUA. Se uno dei componenti è associato a un rootkit, la finestra di dialogo indica che alcuni componenti sono nascosti.

Azioni disponibili visualizza le azioni eseguibili sull'oggetto. Sono disponibili due azioni, autorizzazione e rimozione, come descritto sotto. Cliccando su una delle azioni, questa viene eseguita sull'oggetto dopo averla confermata.

Gestione di adware e PUA

Per gestire adware e PUA, utilizzare i pulsanti descritti sotto.

Seleziona tutto/Deseleziona tutto

Cliccare su questi pulsanti per selezionare oppure per deselezionare tutti gli oggetti. Ciò consente di eseguire la stessa azione su un gruppo di oggetti. Per selezionare o deselezionare un determinato oggetto, selezionare la casella alla sinistra del tipo di oggetto.

Cancella dalla lista

Cliccare su questa opzione per rimuovere l'oggetto dalla lista gli oggetti selezionati, se sono affidabili. Gli oggetti non verranno comunque cancellati dal disco.

Esegui azione

Cliccare su questa opzione per visualizzare una lista di azioni eseguibili sugli oggetti selezionati.

  • Cliccare su Autorizza per autorizzare gli oggetti selezionati, se affidabili. Tale opzione aggiunge gli oggetti alla lista degli adware e PUA autorizzati in modo che Sophos Anti-Virus non ne impedisca l'esecuzione nel computer.
  • Cliccare su Disinfetta per rimuovere dal computer, per tutti gli utenti, tutti i componenti noti degli oggetti selezionati. Per rimuovere dal computer adware e PUA, è necessario che l'utente appartenga a entrambi i gruppi Windows Administrators e SophosAdministrator.
Nota: per una rimozione completa dal computer di alcuni adware e PUA formati da diversi componenti, sarà necessario riavviare il computer. In questo caso viene data la possibilità di scegliere di riavviare il computer immediatamente o in un secondo tempo. Le operazioni conclusive di rimozione saranno eseguite dopo il riavvio del computer.

Per configurare le azioni da eseguire, consultare Configurazione dei diritti utente per Gestore quarantena.

Per visualizzare la lista degli adware e PUA noti e autorizzati, cliccare su Configura autorizzazione.

Argomento precedente: Gestione di virus e spyware in quarantena
Argomento successivo: Gestione di file sospetti in quarantena


Gestione di file sospetti in quarantena

Un file sospetto è un file che presenta una serie di caratteristiche comunemente, ma non esclusivamente, riscontrate in virus.

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Gestisci elementi messi in quarantena.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Mostra, cliccare su File sospetti.

Nelle colonne sono visualizzate informazioni relative a ciascun oggetto.

Nome visualizza l'identità rilevata da Sophos Anti-Virus. Per ulteriori informazioni sul file sospetto, cliccare sull'identità. Sophos Anti-Virus si connette all'analisi del file sospetto disponibile sul sito web di Sophos.

Dettagli visualizza il nome e la posizione dell'oggetto. Se l'oggetto è associato a un rootkit, viene visualizzato come "Nascosto".

Azioni disponibili visualizza le azioni eseguibili sull'oggetto. A meno che l'oggetto non sia nascosto, sono disponibili tre azioni: Autorizza, Cancella e Sposta, come descritto qui sotto. Cliccando su una delle azioni, questa viene eseguita sull'oggetto dopo averla confermata. I file nascosti possono essere solo autorizzati.

Gestione dei file sospetti

Per gestire i file sospetti, utilizzare i pulsanti descritti sotto.

Seleziona tutto/Deseleziona tutto

Cliccare su questi pulsanti per selezionare oppure per deselezionare tutti gli oggetti. Ciò consente di eseguire la stessa azione su un gruppo di oggetti. Per selezionare o deselezionare un determinato oggetto, selezionare la casella alla sinistra del tipo di oggetto.

Cancella dalla lista

Cliccare su questa opzione per rimuovere l'oggetto dalla lista gli oggetti selezionati, se sono affidabili. Gli oggetti non verranno comunque cancellati dal disco.

Esegui azione

Cliccare su questa opzione per visualizzare una lista di azioni eseguibili sugli oggetti selezionati.

  • Cliccare su Autorizza per autorizzare gli oggetti selezionati, se affidabili. Tale opzione aggiunge gli oggetti alla lista degli oggetti sospetti autorizzati in modo che Sophos Anti-Virus non ne impedisca l'accesso.
  • Cliccare su Cancella per cancellare gli oggetti selezionati dal computer. Utilizzare questa funzione con cautela.
  • Cliccare su Sposta per spostare gli oggetti selezionati in un'altra cartella. Gli oggetti vengono spostati nella cartella che è stata specificata durante l'impostazione della disinfezione. Spostando un file eseguibile si riducono le probabilità che venga eseguito. Utilizzare questa funzione con cautela.
Avvertenza:
Se si cancella o si sposta un file infetto, il computer potrebbe smettere di funzionare correttamente, perché non riesce a trovare il file.

Per configurare le azioni da eseguire, consultare Configurazione dei diritti utente per il Gestore quarantena.

Per visualizzare la lista dei file sospetti autorizzati, cliccare su Configura autorizzazione.

Argomento precedente: Gestione di adware e PUA in quarantena
Argomento successivo: Gestione di comportamento sospetto in quarantena


Gestione di comportamento sospetto in quarantena

Il termine Comportamento sospetto indica un'attività apparentemente malevola.

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Gestisci elementi messi in quarantena.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Mostra, cliccare su Comportamento sospetto.

Nelle colonne sono visualizzate informazioni relative a ciascun oggetto.

Nome visualizza l'identità rilevata da Sophos Anti-Virus. Per ulteriori informazioni sul comportamento, cliccare sull'identità. Sophos Anti-Virus si connette all'analisi del comportamento disponibile sul sito web di Sophos.

Dettagli visualizza il nome e la posizione dell'oggetto.

Azioni disponibili visualizza le azioni eseguibili sull'oggetto. Se è stato abilitato il blocco del comportamento sospetto è disponibile la sola azione di autorizzazione, come spiegato di seguito. Cliccando sull'azione, questa viene eseguita sull'oggetto dopo averne dato conferma.

Gestione del comportamento sospetto

Per gestire il comportamento sospetto, utilizzare i pulsanti descritti sotto.

Seleziona tutto/Deseleziona tutto

Cliccare su questi pulsanti per selezionare oppure per deselezionare tutti gli oggetti. Ciò consente di eseguire la stessa azione su un gruppo di oggetti. Per selezionare o deselezionare un determinato oggetto, selezionare la casella alla sinistra del tipo di oggetto.

Cancella dalla lista

Cliccare su questa opzione per rimuovere l'oggetto dalla lista gli oggetti selezionati, se sono affidabili. Gli oggetti non verranno comunque cancellati dal disco.

Esegui azione

Cliccare su questa opzione per visualizzare una lista di azioni eseguibili sugli oggetti selezionati.

  • Cliccare su Autorizza per autorizzare gli oggetti selezionati, se affidabili. Tale opzione aggiunge gli oggetti alla lista degli oggetti sospetti autorizzati, cosicché Sophos Anti-Virus non ne impedisca l'esecuzione.

Per configurare le azioni da eseguire, consultare Configurazione dei diritti utente per Gestore quarantena.

Per visualizzare la lista dei comportamenti sospetti autorizzati, cliccare su Configura autorizzazione.

Argomento precedente: Gestione di file sospetti in quarantena
Argomento successivo: Gestione di applicazioni controllate in quarantena


Gestione di applicazioni controllate in quarantena

Un'applicazione controllata è un'applicazione la cui esecuzione nel computer è impedita dai criteri di sicurezza aziendali.

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Gestisci elementi messi in quarantena.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'elenco Mostra, cliccare su Applicazioni controllate.

Nelle colonne sono visualizzate informazioni relative a ciascun oggetto.

Nome visualizza l'identità rilevata da Sophos Anti-Virus. Per ulteriori informazioni sull'applicazione controllata, cliccare sull'identità. Sophos Anti-Virus si connette all'analisi dell'applicazione controllata, disponibile sul sito web di Sophos.

Dettagli visualizza il sottotipo di applicazione controllata. Se accanto al sottotipo appare il collegamento dettagli, cliccarvi sopra per visualizzare l'elenco degli altri componenti che formano l'applicazione controllata.

Azioni disponibili visualizza le azioni eseguibili sull'oggetto. Non è tuttavia disponibile alcuna azione per le applicazioni controllate a parte la cancellazione dell'oggetto dall'elenco, come descritto sotto.

Gestione delle applicazioni controllate

Per gestire le applicazioni controllate, utilizzare i pulsanti descritti sotto.

Seleziona tutto/Deseleziona tutto

Cliccare su questi pulsanti per selezionare oppure per deselezionare tutti gli oggetti. Ciò consente di eseguire la stessa azione su un gruppo di oggetti. Per selezionare o deselezionare un determinato oggetto, selezionare la casella alla sinistra del tipo di oggetto.

Cancella dalla lista

Cliccare su questa opzione per rimuovere gli oggetti selezionati dalla lista. Gli oggetti non verranno comunque cancellati dal disco. È necessario che le applicazioni controllate vengano autorizzate dalla console centrale prima di poterle utilizzare.

Argomento precedente: Gestione di comportamento sospetto in quarantena
Argomento successivo: Disinfezione


Disinfezione

La disinfezione elimina le minacce presenti nel computer tramite una delle seguenti azioni:

  • Rimuove virus/spyware dal settore di avvio del floppy disk, da documenti, programmi e qualsiasi altro oggetto sottoposto a scansione
  • Sposta o cancella i file sospetti
  • Cancella adware o PUA

Quando Sophos Anti-Virus esegue la disinfezione automatica degli oggetti contenenti virus/spyware, procede alla cancellazione di tutto il malware puro, mentre invece tenta di disinfettare gli oggetti contaminati. I file sottoposti a disinfezione risultano danneggiati permanentemente, dal momento che la scansione antivirus non può sapere cosa contenessero i file contaminati prima di essere colpiti da infezione.

Disinfezione dei documenti

La disinfezione dei documenti non annulla gli effetti collaterali dovuti a virus/spyware nel documento. Consultare la sezione Informazioni sulla disinfezione per sapere come visualizzare, sul sito web di Sophos, i dettagli sugli effetti collaterali dei virus/spyware.

Disinfezione dei programmi

La disinfezione dei programmi deve essere usata soltanto come misura temporanea. È poi necessario sostituire i programmi disinfettati utilizzando i dischi originali o una copia di backup pulita.

Disinfezione delle minacce web

La disinfezione non è necessaria per le minacce rilevate tramite la scansione delle pagine web perché non vengono scaricate nel computer.

Nota: L'opzione di disinfezione potrebbe non riuscire ad annullare tutte le azione intraprese dalla minaccia nel computer. Per esempio, se la minaccia ha cambiato il valore di un'impostazione, la disinfezione potrebbe non essere a conoscenza del valore precedente. Potrebbe essere quindi necessario controllare la configurazione del computer. La disinfezione dei documenti infetti non annulla le modifiche che il virus può aver apportato a tali documenti.
Argomento precedente: Gestione di applicazioni controllate in quarantena
Argomento successivo: Informazioni sulla disinfezione


Informazioni sulla disinfezione

Quando nel computer viene rilevata una minaccia, è importante controllarne l'analisi sul sito web di Sophos per avere informazioni e consigli sulla disinfezione. Far ciò da:

  • Allarme sul desktop (scansione in accesso)
  • Finestra di dialogo che mostra l'avanzamento della scansione (scansione personalizzata e scansione dal menu del tasto destro del mouse)
  • Gestore quarantena (tutti i tipi di scansione)

Informazioni tramite l'allarme sul desktop

Se nel computer è abilitata la scansione in accesso, Sophos Anti-Virus visualizza un allarme sul desktop ogni volta che rileva una minaccia.

Nella finestra di messaggio, cliccare sul nome della minaccia sulla quale si desidera ottenere informazioni. Sophos Anti-Virus si collega all'analisi della minaccia pubblicata sul sito web di Sophos.

Informazioni tramite la finestra di avanzamento della scansione

Per la scansione personalizzata o la scansione dal menu del tasto destro del mouse, nel log visualizzato nella finestra di avanzamento della scansione (o nella finestra di riepilogo della scansione, visualizzata al termine della scansione), cliccare sul nome della minaccia sulla quale si desidera ottenere informazioni.

Sophos Anti-Virus si collega all'analisi della minaccia pubblicata sul sito web di Sophos.

Informazioni tramite Gestore quarantena

  1. Nella Pagina iniziale, sotto Antivirus e HIPS, cliccare su Gestisci elementi messi in quarantena. Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nella colonna Nome, cliccare sul nome della minaccia sulla quale si desidera ottenere informazioni.

Sophos Anti-Virus si collega all'analisi della minaccia pubblicata sul sito web di Sophos.

Argomento precedente: Disinfezione
Argomento successivo: Configurazione della messaggistica desktop relativa all'antivirus


Configurazione della messaggistica desktop relativa all'antivirus

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Per consentire a Sophos Anti-Virus di visualizzare i messaggi sul desktop quando viene rilevata una minaccia, procedere come segue. Ciò vale soltanto per la scansione in accesso.

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Allarmi > Messaggistica.
  2. Nella finestra di dialogo Messaggistica, cliccare sulla scheda Messaggistica desktop. Impostare le opzioni come descritto di seguito.

    Abilita messaggistica desktop

    Selezionare questa opzione per consentire a Sophos Anti-Virus di visualizzare i messaggi sul desktop quando viene rilevata una minaccia.

    Messaggi da inviare

    Selezionare gli eventi per i quali si desidera che Sophos Anti-Virus visualizzi i messaggi sul desktop.

    Messaggio definito dall'utente

    In questa casella di testo è possibile digitare un messaggio che sarà aggiunto alla fine del messaggio standard.

    Nota: I messaggi definiti dall'utente non vengono visualizzati in Windows 8 e versioni successive.
Argomento precedente: Informazioni sulla disinfezione
Argomento successivo: Configurazione di allarmi antivirus tramite e-mail


Configurazione di allarmi antivirus tramite e-mail

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Per consentire a Sophos Anti-Virus di inviare degli allarmi e-mail quando viene rilevata una minaccia o quando si verifica un errore, procedere nel modo seguente. Questa procedura è valida per la scansione in accesso, per la scansione su richiesta e per la scansione dal menu del tasto destro del mouse.

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Allarmi > Messaggistica.
  2. Nella finestra di dialogo Messaggistica, cliccare sulla scheda Allarmi e-mail. Impostare le opzioni come descritto di seguito.

    Abilita allarmi e-mail

    Selezionare questa opzione per consentire a Sophos Anti-Virus di inviare degli allarmi e-mail.

    Messaggi da inviare

    Selezionare gli eventi per i quali si desidera che Sophos Anti-Virus invii degli allarmi e-mail. Gli Errori di scansione sono gli errori che si verificano quando Sophos Anti-Virus non riesce ad accedere a un oggetto che vuole esaminare.

    Sophos Anti-Virus non invia allarmi e-mail relativi alla minacce rilevate dalla scansione delle pagine web perché tali minacce non vengono scaricate nel computer. Non è quindi necessaria alcuna azione.

    Destinatari

    Cliccare su Aggiungi o Rimuovi per aggiungere o rimuovere, rispettivamente, gli indirizzi e-mail ai quali devono essere inviati gli allarmi e-mail. Cliccare su Modifica per modificare un indirizzo e-mail che è stato aggiunto.

    Configura SMTP

    Cliccare su questa opzione per modificare le impostazioni del server SMTP e la lingua degli allarmi e-mail (v. la tabella di seguito).

Configurazione delle impostazioni di SMTP
Server SMTP | Nella casella di testo, digitare il nome host o l'indirizzo IP del server SMTP. Cliccare su Prova per verificare che sia stata stabilita la connessione con il server SMTP (non viene inviata un'e-mail di prova).
Indirizzo SMTP "mittente" | Nella casella di testo, digitare un indirizzo e-mail al quale possono essere inviati bounce e messaggi di mancato recapito.
Indirizzo SMTP "rispondi a" | Poiché gli allarmi e-mail vengono inviati automaticamente dal sistema, è possibile digitare nella casella di testo un indirizzo e-mail al quale inviare gli allarmi stessi.
Lingua | Cliccare sulla freccia del menu a discesa e selezionare la lingua nella quale devono essere inviati gli allarmi e-mail.
Argomento precedente: Configurazione della messaggistica desktop relativa all'antivirus
Argomento successivo: Configurazione della messaggistica SNMP relativa all'antivirus


Configurazione della messaggistica SNMP relativa all'antivirus

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Per consentire a Sophos Anti-Virus di inviare dei messaggi SNMP quando viene rilevata una minaccia o si verifica un errore, procedere nel modo seguente. Questa procedura è valida per la scansione in accesso, per la scansione su richiesta e per la scansione dal menu del tasto destro del mouse.

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Allarmi > Messaggistica.
  2. Nella finestra di dialogo Messaggistica, cliccare sulla scheda Messaggistica SNMP. Impostare le opzioni come descritto di seguito.

    Abilita messaggistica SNMP

    Selezionare questa opzione per consentire a Sophos Anti-Virus di inviare dei messaggi SNMP.

    Messaggi da inviare

    Selezionare gli eventi per i quali si desidera che Sophos Anti-Virus invii messaggi SNMP. Gli Errori di scansione sono gli errori che si verificano quando Sophos Anti-Virus non riesce ad accedere a un oggetto che vuole esaminare.

    Sophos Anti-Virus non invia messaggi SNMP relativi alla minacce rilevate dalla scansione delle pagine web perché tali minacce non vengono scaricate nel computer. Non è quindi necessaria alcuna azione.

    Destinazione trap SNMP

    Nella casella di testo, digitare l'indirizzo IP o il nome del computer al quale vengono inviati gli allarmi.

    Nome comunità SNMP

    Nella casella di testo, digitare il nome della comunità SNMP.

    Prova

    Cliccare su questo pulsante per inviare un messaggio SNMP di prova alla destinazione del trap SNMP specificata.

Argomento precedente: Configurazione di allarmi antivirus tramite e-mail
Argomento successivo: Configurazione del log eventi dell'antivirus


Configurazione del log eventi dell'antivirus

Per consentire a Sophos Anti-Virus di aggiungere gli allarmi al log degli eventi di Windows quando viene rilevata una minaccia o si verifica un errore, procedere nel modo seguente. Questa procedura è valida per la scansione in accesso, per la scansione su richiesta e per la scansione dal menu del tasto destro del mouse.

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > Allarmi > Messaggistica.
  2. Nella finestra di dialogo Messaggistica, cliccare sulla scheda Log eventi. Impostare le opzioni come descritto di seguito.

    Abilita log eventi

    Selezionare questa opzione per consentire a Sophos Anti-Virus di inviare i messaggi al log degli eventi di Windows.

    Messaggi da inviare

    Selezionare gli eventi per i quali si desidera che Sophos Anti-Virus invii i messaggi. Gli Errori di scansione sono gli errori che si verificano quando Sophos Anti-Virus non riesce ad accedere a un oggetto che vuole esaminare.

    Sophos Anti-Virus non invia messaggi relativi alla minacce rilevate dalla scansione delle pagine web perché tali minacce non vengono scaricate nel computer. Non è quindi necessaria alcuna azione.

Argomento precedente: Configurazione della messaggistica SNMP relativa all'antivirus
Argomento successivo: Configurazione del log di scansione


Configurazione del log di scansione

Il log della scansione del computer si trova nei seguenti percorsi:

Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10, Windows Server 2008, Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2: | C:\ProgramData\Sophos\Sophos Anti-Virus\logs\SAV.txt
Altre piattaforme Windows | C:\Documents and Settings\All Users\Dati applicazioni\Sophos\Sophos Anti-Virus\logs\SAV.txt
  1. Cliccare su Home > Antivirus e HIPS > Visualizza log antivirus e HIPS > Configura log.
  2. Nella finestra di dialogo Configura log del computer, impostare le opzioni come descritto sotto.

    Livello di log

    Per evitare che venga creato il log, cliccare su Nessuno. Per registrare le informazioni di riepilogo, i messaggi di errore e così via, cliccare su Normale. Per registrare la maggior parte delle informazioni, inclusi i file esaminati, le fasi principali di una scansione e così via, cliccare su Dettagliato.

    Archiviazione del log

    Affinché il file di log venga archiviato ogni mese, selezionare Consenti archiviazione. I file di archivio sono memorizzati nella stessa cartella del file di log. Selezionare il Numero dei file di archivio da memorizzare prima di cancellare il meno recente. Selezionare Comprimi log per ridurre le dimensioni del file di log.

Argomento precedente: Configurazione del log eventi dell'antivirus
Argomento successivo: Visualizzazione del log della scansione


Visualizzazione del log della scansione

Nella Pagina iniziale, sotto Antivirus ed HIPS, cliccare su Visualizza log antivirus e HIPS.
Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
Dalla pagina log, è possibile copiare il log negli appunti, oppure inviarlo per e-mail o stamparlo.

Per trovare un testo specifico all'interno del log, cliccare su Trova e inserire il testo desiderato.

Argomento precedente: Configurazione del log di scansione
Argomento successivo: Scansione per la ricerca di applicazioni controllate


Scansione per la ricerca di applicazioni controllate

Un'applicazione controllata è un'applicazione la cui esecuzione nel computer è impedita dai criteri di sicurezza aziendali.

La scansione alla ricerca di applicazioni controllate viene attivata o disattivata da una console di gestione come parte del criterio di controllo applicazioni e della scansione in accesso.

Per informazioni sulla scansione in accesso, consultare la sezione Scansione in accesso e su richiesta.

Argomento precedente: Visualizzazione del log della scansione
Argomento successivo: Disabilitazione della scansione alla ricerca di applicazioni controllate


Disabilitazione della scansione alla ricerca di applicazioni controllate

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se si attiva la scansione per la ricerca di applicazioni controllate, questa potrebbe impedire la disinstallazione di alcune applicazioni. Se si appartiene al gruppo SophosAdministrator, è possibile disabilitare temporaneamente la scansione alla ricerca di applicazioni controllate nel computer in questione.

Per disabilitare la scansione alla ricerca di applicazioni controllate:

  1. Nel menu Configura, cliccare su Controllo applicazioni.
  2. Deselezionare la casella Abilita scansione in accesso.
Argomento precedente: Scansione per la ricerca di applicazioni controllate
Argomento successivo: Controllo dispositivi nel computer


Controllo dispositivi nel computer

Se non viene utilizzata la console di gestione per amministrare Sophos Endpoint Security and Control nel computer, la funzionalità del controllo dispositivi non sarà inclusa.

Il controllo dispositivi viene abilitato o disabilitato dalla console di gestione. Se il controllo dispositivi è abilitato, impedirà la connessione di un dispositivo al computer anche se eseguito per motivi di manutenzione o per la risoluzione di alcuni problemi. Se questo è il caso, in tale computer è possibile disabilitare temporaneamente il controllo dispositivi. Per informazioni, consultare la sessione Disabilitare temporaneamente il controllo dispositivi.

Argomento precedente: Disabilitazione della scansione alla ricerca di applicazioni controllate
Argomento successivo: Tipi di dispositivi che possono essere controllati


Tipi di dispositivi che possono essere controllati

Il Controllo dispositivi blocca o autorizza i seguenti tipi di dispositivi sul computer: memorizzazione, rete, short range e media.

Memorizzazione

  • Dispositivo di memoria rimovibile (per esempio unità flash USB, lettori di schede per PC, unità hard disk esterne)
  • Unità disco ottico (unità CD-ROM/DVD/Blu-ray)
  • Unità floppy disk
  • Dispositivi di memorizzazione rimovibili sicuri (per esempio unità flash USB a cifratura basata su hardware)

Rete

  • Modem
  • Wireless (interfaccia Wi-Fi, 802.11 standard)

Il criterio del controllo dei dispositivi relativo al computer può essere in modalità Blocca bridging, in questo caso le schede di rete wireless o modem sono disabilitate quando il computer è collegato a una rete fisica (solitamente tramite connessione Ethernet). Quando il computer non è collegato alla rete fisica, le schede di rete wireless o modem vengono riabilitate direttamente.

Short range

  • Interfacce Bluetooth
  • Infrarossi (Interfaccia infrarossi IrDA)

Supporti

  • MTP/PTP

    Sono inclusi telefoni cellulari, tablet, fotocamere digitali, lettori multimediali ed altri dispositivi che possono essere collegati a computer tramite Media Transfer Protocol (MTP) o Picture Transfer Protocol (PTP).

Argomento precedente: Controllo dispositivi nel computer
Argomento successivo: Disabilitazione temporanea del controllo dispositivi


Disabilitazione temporanea del controllo dispositivi

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se si appartiene al gruppo Sophos Administrator e si desidera connettere un dispositivo al computer per motivi di manutenzione o per la risoluzione di alcuni problemi (per es. per installare un software da CD), è possibile disattivare temporaneamente il controllo dei dispositivi.

Per disabilitare il controllo dei dispositivi nel computer:

  1. Nel menu Configura, cliccare su Controllo dispositivi.
  2. Deselezionare la casella di spunta Abilita Sophos Device Control.
Argomento precedente: Tipi di dispositivi che possono essere controllati
Argomento successivo: Configurazione del log del controllo dispositivi


Configurazione del log del controllo dispositivi

  1. Nel menu Configura, cliccare su Controllo dispositivi.
  2. Sotto Livello di log, selezionare una delle opzioni:
    • Cliccare su Nessuno per impedire che venga creato il log.
    • Per registrare le informazioni di riepilogo, i messaggi di errore e così via, cliccare su Normale.
    • Cliccare su Dettagliato per ottenere informazioni relative a molte più attività del normale. Utilizzare questa impostazione solo quando è richiesto un log dettagliato per la risoluzione dei problemi, dal momento che le dimensioni del log cresceranno rapidamente.
  3. Sotto Archiviazione log, seguire le istruzioni a schermo.
Argomento precedente: Disabilitazione temporanea del controllo dispositivi
Argomento successivo: Visualizzazione del log del controllo dispositivi


Visualizzazione del log del controllo dispositivi

Nella Home page, sotto Controllo dispositivi, cliccare su Visualizzare log controllo dispositivi.
Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
Dalla pagina log, è possibile copiare il log negli appunti, oppure inviarlo per e-mail o stamparlo.

Per trovare un testo specifico all'interno del log, cliccare su Trova e inserire il testo desiderato.

Argomento precedente: Configurazione del log del controllo dispositivi
Argomento successivo: Controllo dati nel computer


Controllo dati nel computer

Se non viene utilizzata la console di gestione per amministrare Sophos Endpoint Security and Control nel computer, la funzionalità del controllo dati non sarà inclusa.

Il controllo dati viene abilitato o disabilitato da un criterio rilasciato da una console di gestione. Tuttavia, se si appartiene al gruppo SophosAdministrator, è possibile disabilitare temporaneamente il controllo dati nel computer per motivi di manutenzione o per la risoluzione di alcuni problemi: Per informazioni, consultare la sessione Disabilitazione temporanea del controllo dati.

Argomento precedente: Visualizzazione del log del controllo dispositivi
Argomento successivo: Disabilitazione temporanea del controllo dati


Disabilitazione temporanea del controllo dati

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se si appartiene al gruppo SophosAdministrator, è possibile disabilitare temporaneamente il controllo dati nel computer per motivi di manutenzione o per la risoluzione di alcuni problemi.

  1. Nel menu Configura, cliccare su Controllo dati.
  2. Deselezionare la casella di spunta Abilita Sophos Data Control.
Argomento precedente: Controllo dati nel computer
Argomento successivo: Aggiunta di un file a un dispositivo di memorizzazione


Aggiunta di un file a un dispositivo di memorizzazione

Se in questo computer è abilitato il controllo dati, il criterio di controllo dati potrebbe bloccare qualsiasi tentativo di aggiunta di un file a un dispositivo di memorizzazione monitorato utilizzando i seguenti metodi:

  • Salvataggio di dati all'interno di un programma
  • Utilizzo del comando DOS copia
  • Creazione di un nuovo file nel dispositivo che esegue Windows Explorer

Se si vede un allarme desktop in merito, è opportuno salvare il file sul disco rigido o su un'unità di rete e quindi utilizzare Esplora risorse per copiarlo sul dispositivo di memorizzazione.

Argomento precedente: Disabilitazione temporanea del controllo dati
Argomento successivo: Configurazione del log del controllo dati


Configurazione del log del controllo dati

  1. Nel menu Configura, cliccare su Controllo dati.
  2. Sotto Livello di log, selezionare una delle opzioni:
    • Cliccare su Nessuno per impedire che venga creato il log.
    • Per registrare le informazioni di riepilogo, i messaggi di errore e così via, cliccare su Normale.
    • Cliccare su Dettagliato per ottenere informazioni relative a molte più attività del normale. Utilizzare questa impostazione solo se si devono testare nuove regole del controllo dati, dal momento che le dimensioni del log cresceranno rapidamente.
  3. Sotto Archiviazione log, seguire le istruzioni a schermo.
Argomento precedente: Aggiunta di un file a un dispositivo di memorizzazione
Argomento successivo: Visualizzazione del log del controllo dati


Visualizzazione del log del controllo dati

Nella Home page, sotto Controllo dati, cliccare su Visualizza log controllo dati.
Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
Dalla pagina log, è possibile copiare il log negli appunti, oppure inviarlo per e-mail o stamparlo.

Per trovare un testo specifico all'interno del log, cliccare su Trova e inserire il testo desiderato.

Argomento precedente: Configurazione del log del controllo dati
Argomento successivo: Controllo web nel computer


Controllo web nel computer

Sophos Web Control consente di fornire protezione e controllo, oltre a rilevare i computer situati al di fuori della rete aziendale o in roaming.

Nota: Questa funzione non è inclusa in tutte le licenze. Se la si desidera utilizzare potrebbe essere necessario cambiare la propria licenza.

Se non viene utilizzata la console di gestione per amministrare Sophos Endpoint Security and Control nel computer, la funzionalità del controllo web non sarà inclusa.

Il controllo web viene abilitato o disabilitato da un criterio rilasciato da una console di gestione. Se membri del gruppo SophosAdministrator, è possibile disabilitare temporaneamente il controllo web nel computer. Per informazioni su come svolgere questa operazione, consultare la sezione Disabilitazione temporanea del controllo web.

Argomento precedente: Visualizzazione del log del controllo dati
Argomento successivo: Disabilitazione temporanea del controllo web


Disabilitazione temporanea del controllo web

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se si fa parte del gruppo SophosAdministrator, può presentarsi la necessità di disabilitare temporaneamente il controllo web per motivi di manutenzione o per la risoluzione di alcuni problemi e successivamente di riabilitarla.

Per disabilitare il controllo web nel computer:

  1. Nel menu Configura, cliccare su Controllo web.
  2. Deselezionare la casella Abilita scansione web.
Argomento precedente: Controllo web nel computer
Argomento successivo: Come inizializzare il firewall


Come inizializzare il firewall

Quando il firewall viene installato per la prima volta, può essere necessario configurarlo. Se sia necessario farlo o meno dipende dal modo in cui è stato installato. Sono disponibili due tipi di installazione:

  • Installato in un computer in rete e gestito da una console di gestione
  • Installato in un computer autonomo e gestito dal computer

Firewall gestito da una console di gestione

Se il firewall è installato e gestito da una console di gestione, consente o blocca applicazioni e traffico secondo le regole impostate dal criterio.

A meno che il criterio non abbia posto il firewall in modalità interattiva (v. sotto), l'utente non riceverà alcun messaggio e non dovrà configurare il firewall in alcun modo.

Firewall gestito dal computer

Se il firewall è gestito nel computer, si consiglia di cominciare creando regole che consentano l'accesso alla rete per applicazioni e servizi comuni, quali browser web e client di posta elettronica.

Per informazioni sulla creazione delle regole, consultare la sezione Configurazione del firewall.

Inizialmente il firewall sarà in modalità interattiva (v. sotto). Lasciarlo in tale modalità per un periodo di tempo sufficiente a consentire o bloccare altri servizi e applicazioni in uso.

Una volta configurato il firewall e assicuratisi che riconosca le applicazioni comunemente utilizzate, si consiglia di passare a una delle modalità non interattive.

Per informazioni , consultare la sezione Passaggio alla modalità non interattiva.

Modalità interattiva

Quando in modalità interattiva, il firewall chiede di consentire o bloccare le applicazioni e il traffico per cui non sono state create regole.

Per informazioni su come gestire messaggi dal firewall, consultare la sezione Modalità interattiva.

In Windows 8 e versioni successive, la modalità interattiva non è disponibile. È necessario aggiungere criteri specifici per consentire o bloccare applicazioni. È altrimenti possibile utilizzare il visualizzatore eventi nella console di gestione per gestire le regole dell'applicazione in modo interattivo.

Argomento precedente: Disabilitazione temporanea del controllo web
Argomento successivo: Configurazione del firewall


Configurazione del firewall

È possibile configurare il firewall in molti modi diversi e poi abilitarlo. Sebbene nel computer venga utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, le modifiche apportate potrebbero essere ignorate.

Alcune funzioni comuni sono elencate di seguito:

  • Abilitazione della modalità interattiva
  • Filtraggio dei messaggi ICMP
  • Autorizzazione di tutto il traffico su una LAN
  • Autorizzazione del download del FTP
  • Creazione di una regola globale
  • Creazione di una regola globale
  • Autorizzazione dell'avvio di processi nascosti
  • Autorizzazione dell'utilizzo di raw socket da parte di applicazioni
  • Utilizzo di checksum per l'autenticazione di applicazioni
Argomento precedente: Come inizializzare il firewall
Argomento successivo: Disabilitazione temporanea del firewall


Disabilitazione temporanea del firewall

Se si appartiene al gruppo SophosAdministrator, può presentarsi la necessità di disabilitare temporaneamente il firewall per motivi di manutenzione o per la risoluzione di alcuni problemi e successivamente di riabilitarlo.

Sophos Endpoint Security and Control conserva le impostazioni scelte in questa pagina, anche dopo il riavvio del computer. Se si disabilita il firewall, il computer risulta non protetto finché la scansione in accesso non venga riabilitata.

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, selezionare la casella di spunta Consenti tutto il traffico di fianco al percorso primario o secondario.
Argomento precedente: Configurazione del firewall
Argomento successivo: Autorizzazione di e-mail


Autorizzazione di e-mail

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.
  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Cliccare su Aggiungi, trovare l'applicazione di posta elettronica e cliccarvi due volte.
L'applicazione di posta elettronica viene autorizzata in quanto applicazione attendibile.

Alle applicazioni attendibili viene concesso accesso alla rete pieno e incondizionato, oltre che accesso a Internet. Per una maggiore sicurezza, è possibile applicare le regole predefinite fornite da Sophos:

  1. Nell'elenco delle applicazioni consentite, cliccare sull'applicazione di posta elettronica.
  2. Cliccare sulla freccia di fianco a Applicazione personalizzata>Aggiungi regole da quelle predefinite> Client di posta elettronica.
Argomento precedente: Disabilitazione temporanea del firewall
Argomento successivo: Autorizzazione all'utilizzo di un browser web


Autorizzazione all'utilizzo di un browser web

Nota: se si consente l'utilizzo di un browser web, si consente al tempo stesso l'accesso FTP.
  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Cliccare su Aggiungi, trovare l'applicazione del browser web e cliccarvi due volte.
L'applicazione del browser web viene autorizzata in quanto applicazione attendibile.

Alle applicazioni attendibili viene concesso accesso alla rete pieno e incondizionato, oltre che accesso a Internet. Per una maggiore sicurezza, è possibile applicare le regole predefinite fornite da Sophos:

  1. Nell'elenco delle applicazioni consentite, cliccare sull'applicazione del browser web.
  2. Cliccare su Personalizza>Aggiungi regole da quelle predefinite Browser.
Argomento precedente: Autorizzazione di e-mail
Argomento successivo: Autorizzazione del download del FTP


Autorizzazione del download del FTP

Nota: se è stato concesso l'utilizzo di un browser web che può accedere ai server FTP, non è necessario autorizzare anche i download del FTP.
  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Cliccare su Aggiungi, trovare l'applicazione del FTP e cliccarvi due volte.
L'applicazione del FTP viene autorizzata in quanto applicazione attendibile.

Alle applicazioni attendibili viene concesso accesso alla rete pieno e incondizionato, oltre che accesso a Internet. Per una maggiore sicurezza, è possibile applicare le regole predefinite fornite da Sophos:

  1. Nell'elenco delle applicazioni consentite, cliccare sull'applicazione del FTP.
  2. Cliccare su Applicazione personalizzata > Aggiungi regole da quelle predefinite > Client FTP.
Argomento precedente: Autorizzazione all'utilizzo di un browser web
Argomento successivo: Autorizzazione di tutto il traffico su una LAN


Autorizzazione di tutto il traffico su una LAN

Per consentire tutto il traffico tra computer su una LAN (Area di Rete Locale):

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda LAN, svolgere una delle seguenti operazioni:
    • Cliccare su Cerca LAN per rilevare la LAN in cui si trova il computer ed aggiungerla all'elenco di indirizzi di rete.
    • Cliccare su Aggiungi. Nella finestra di dialogo Seleziona indirizzo, selezionare Formato indirizzo, digitare il nome di dominio o l'indirizzo IP e poi cliccare su Aggiungi.
      Nota: Se viene selezionata Rete locale (rilevata automaticamente), non c'è bisogno di digitare altro. Questa opzione non è disponibile in Windows 8 e versioni successive. Per informazioni sul rilevamento di una rete locale, consultare la sezione Rilevamento della rete locale.
  4. Cliccare su OK per chiudere la finestra di dialogo Seleziona indirizzo.
  5. Nell'elenco Impostazioni LAN, spuntare la casella Attendibile per una rete.

Nota

  • Se si consente tutto il traffico tra computer su una LAN, si consente anche la condivisione file e stampanti su di essa.
Argomento precedente: Autorizzazione del download del FTP
Argomento successivo: Autorizzazione Condivisione file e stampanti su una LAN


Autorizzazione Condivisione file e stampanti su una LAN

Nota: Se è già stato consentito tutto il traffico fra computer su una LAN (rete di area locale), non c'è bisogno di permettere anche la condivisione di file e di stampanti.

Per autorizzare tutte le condivisioni file e stampanti su una LAN:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda LAN, svolgere una delle seguenti operazioni:
    • Cliccare su Cerca LAN per rilevare la LAN in cui si trova il computer ed aggiungerla all'elenco di indirizzi di rete.
    • Cliccare su Aggiungi. Nella finestra di dialogo Seleziona indirizzo, selezionare Formato indirizzo, digitare il nome di dominio o l'indirizzo IP e poi cliccare su Aggiungi.
      Nota: Se viene selezionata Rete locale (rilevata automaticamente), non c'è bisogno di digitare altro. Questa opzione non è disponibile in Windows 8 e versioni successive. Per informazioni sul rilevamento di una rete locale, consultare la sezione Rilevamento della rete locale.
  4. Cliccare su OK per chiudere la finestra di dialogo Seleziona indirizzo.
  5. Nell'elenco delle Impostazioni LAN, selezionare la casella di spunta NetBIOS per consentire a una LAN la condivisione file e stampanti.
Per informazioni su come bloccare o consentire la condivisione di file e stampanti su LAN diverse da quelle contenute nella lista Impostazioni LAN, consultare le seguenti sezioni:
  • Blocco di condivisioni file e stampanti indesiderate
  • Autorizzazione del controllo flessibile di condivisione file e stampanti

Per informazione su come consentire tutto il traffico su una LAN, consultare la sezione Autorizzazione di tutto il traffico su una LAN.

Argomento precedente: Autorizzazione di tutto il traffico su una LAN
Argomento successivo: Autorizzazione del controllo flessibile di condivisione file e stampanti


Autorizzazione del controllo flessibile di condivisione file e stampanti

Se si desidera un controllo più flessibile della condivisione file e stampanti sulla propria rete (ad esempio, traffico NetBIOS unidirezionale), è sufficiente fare come segue:

  1. Autorizzare la condivisione file e stampanti in LAN (reti di area locali) diverse da quelle presenti nell'elenco Impostazioni LAN. Ciò consente il traffico NetBIOS sulle LAN sottoposte alle regole del firewall.
  2. Creare regole con elevata priorità che consentano la comunicazione a/da host tramite gli adeguati protocolli e porte NetBIOS. Si consiglia di creare delle regole che blocchino esplicitamente tutto il traffico di condivisione file e stampanti indesiderato, piuttosto che lasciarlo gestire dalla regola predefinita.

Per autorizzare la condivisione file e stampanti in LAN diverse da quelle presenti nell'elenco Impostazioni LAN:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda LAN, deselezionare la casella Blocca condivisione file e stampanti per altre reti.
Argomento precedente: Autorizzazione Condivisione file e stampanti su una LAN
Argomento successivo: Blocco di condivisioni file e stampanti indesiderate


Blocco di condivisioni file e stampanti indesiderate

Per bloccare la condivisione di file e stampanti su reti diverse da quelle specificate nell'elenco Impostazioni LAN sulla scheda LAN:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda LAN, deselezionare la casella Blocca condivisione file e stampanti per altre reti.
Argomento precedente: Autorizzazione del controllo flessibile di condivisione file e stampanti
Argomento successivo: Creazione di una regola globale


Creazione di una regola globale

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Cliccare su Aggiungi, trovare l'applicazione e cliccarvi due volte.
L'applicazione viene consentita in quanto attendibile.

Alle applicazioni attendibili viene concesso accesso alla rete pieno e incondizionato, oltre che accesso a Internet. per un maggior livello di sicurezza, è possibile applicare una o più regole dell'applicazione per specificare le condizioni in cui un'applicazione può essere eseguita.

  • Creazione di una regola dell'applicazione
  • Applicazione delle regole delle applicazioni predefinite
Argomento precedente: Blocco di condivisioni file e stampanti indesiderate
Argomento successivo: Blocco di un'applicazione


Blocco di un'applicazione

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Se l'applicazione non è inclusa nell'elenco, cliccare su Aggiungi, trovare l'applicazione e cliccarvi due volte.
  5. Selezionare l'applicazione nell'elenco e cliccare su Blocca.
Argomento precedente: Creazione di una regola globale
Argomento successivo: Blocco di IPv6


Blocco di IPv6

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. In base al sistema operativo:
    • In Windows 7 e nei sistemi operativi precedenti, nella scheda Generale, sotto Blocco , selezionare Pacchetti IPv6 bloccati.
    • Su Windows 8 e versioni successive, nella scheda Regole globali, selezionare Blocca tutto il traffico IPv6.
Argomento precedente: Blocco di un'applicazione
Argomento successivo: Attivare o disattivare i checksum


Attivare o disattivare i checksum

Se viene abilitato l'utilizzo dei checksum per l'autenticazione delle applicazioni, quando si autorizzano o bloccano applicazioni queste vengono riconosciute automaticamente in base ai loro checksum (è anche possibile aggiungere checksum manualmente). Se un'applicazione non corrisponde a nessun checksum, viene bloccata.

Se questa opzione viene disabilitata, le applicazioni verranno riconosciute in base al loro nome file.

Per attivare o disattivare l'utilizzo dei checksum per l'autenticazione delle applicazioni:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. In base al sistema operativo:
    • In Windows 7 e nei sistemi operativi precedenti, sotto Blocco, deselezionare la casella di spunta Utilizza checksum per autenticare le applicazioni.
    • Su Windows 8 e versioni successive, cliccare sulla scheda Applicazioni e deselezionare la casella di spunta Usa checksum per autenticare le applicazioni.
    Per attivare o disattivare l'utilizzo dei checksum per l'autenticazione delle applicazioni, selezionare o deselezionare la casella di spunta.
Argomento precedente: Blocco di IPv6
Argomento successivo: Attivazione e disattivazione del blocco di processi modificati


Attivazione e disattivazione del blocco di processi modificati

Nota: Questa opzione non è disponibile in Windows 8 e versioni successive, dal momento che l’operazione viene gestita automaticamente dalla tecnologia HIPS di Sophos Anti-Virus.

Il malware potrebbe tentare di aggirare il firewall modificando un processo in memoria già iniziato da un programma attendibile, e utilizzare quindi il processo modificato per accedere alla rete in sua vece.

È possibile configurare il firewall per rilevare e bloccare i processi modificati in memoria.

Per attivare e disattivare il blocco di processi modificati:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Sulla scheda Generale, sotto Blocco, deselezionare la casella Blocca processi se la memoria viene modificata da un'altra applicazione (solo sistemi operativi a 32 bit) per rimuovere il blocco dei processi modificati.
    Per attivare il blocco di processi modificati, selezionare la relativa casella.
Se il firewall rileva un processo modificato in memoria, aggiunge delle regole per impedire al processo modificato di accedere alla rete.

Note

  • Si sconsiglia di disattivare il blocco di processi modificati in maniera permanente. Disattivare il rilevamento solo quando strettamente necessario.
  • Il blocco di processi modificati non è supportato sulle versioni di Windows a 64 bit.
  • Viene bloccato solamente il processo modificato. Al programma che modifica il processo non viene impedito l'accesso alla rete.
Argomento precedente: Attivare o disattivare i checksum
Argomento successivo: Filtraggio dei messaggi ICMP


Filtraggio dei messaggi ICMP

I messaggi di Internet Control Message Protocol (ICMP) consentono ai computer in rete di condividere informazioni relative ad errori e stato. È possibile consentire o bloccare determinati tipi di messaggi ICMP in entrata o uscita.

Filtrare i messaggi ICMP solo se in possesso di una certa competenza sui protocolli di rete. Per informazioni sui tipi di messaggi ICMP, consultare la sezione Definizione dei tipi di messaggi ICMP.

Per filtrare i messaggi ICMP:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda ICMP. L'interfaccia cambia a seconda del sistema operativo in esecuzione:
    • In Windows 7 e nei sistemi operativi precedenti, selezionare la casella di spunta Ing. o Usc. per consentire i messaggi in entrata o uscita di un determinato tipo.
    • Su Windows 8 e versioni successive, i tipi di messaggi ICMP vengono suddivisi in sezioni. È possibile scegliere impostazioni comuni dall'elenco a discesa, oppure cliccare su Dati per visualizzare o modificare le impostazioni.
Argomento precedente: Attivazione e disattivazione del blocco di processi modificati
Argomento successivo: Definizione dei tipi di messaggi ICMP


Definizione dei tipi di messaggi ICMP

Reportistica sugli errori di rete

Destinazione irraggiungibile, Risposta Echo
Inviato dal router quando non riesce a recapitare un datagramma IP. Un datagramma è l'unità fondamentale di informazione, o pacchetto, passata attraverso una rete TCP/IP.
Quench sorgente
Inviato da un host o router se riceve dati troppo rapidamente per poterli gestire. Il messaggio è una richiesta di riduzione della velocità con cui la fonte trasmette datagrammi.
Tempo scaduto
Inviato da un router quando un datagramma ha raggiunto il livello massimo di router attraverso cui può passare.
Problema di parametro
Inviato da un router se si verifica un problema durante la trasmissione di un datagramma tale da non consentire il completamento del processo. Una possibile causa di tale problema è una non valida intestazione del datagramma.

Risoluzione degli errori di rete

Richiesta Echo, Risposta Echo
Utilizzato per verificare l'accessibilità e lo stato della destinazione. Un host invia una Richiesta Echo e attende la relativa Risposta Echo. Questa operazione viene solitamente svolta tramite il comando ping.

Indirizzo di rete e configurazione routing di IPv4

Reindirizza
Inviato da un router se riceve datagrammi che dovrebbero essere stati inviati a un router differente. Il messaggio contiene l'indirizzo a cui la fonte deve inviare i futuri datagrammi. Ciò consente di ottimizzare il routing del traffico della rete.
Annuncio del router, Sollecitazione del router
Consente agli host di scoprire l'esistenza di router. I router rendono noti periodicamente i loro indirizzi IP tramite messaggi di tipo Annuncio del router. Gli host possono richiedere l'indirizzo di un router inviando un messaggio Sollecitazione del router a cui il router risponderà con un Annuncio del router.
Richiesta data e ora, Risposta data e ora
Utilizzato per sincronizzare gli orologi degli host e per fare stime sulla durata del transito.
Richiesta informazioni, Risposta informazioni
Obsoleto. In passato questi messaggi venivano utilizzati dagli host per determinare i loro indirizzi inter-network; ora sono considerati obsoleti e non dovrebbero essere utilizzati.
Richiesta maschera indirizzo, Risposta maschera indirizzo
Utilizzato per trovare la maschera della sottorete (ovvero quali parti dell'indirizzo definiscono la rete). Un host invia una Richiesta maschera indirizzo a un router e riceve una Risposta maschera indirizzo.
Argomento precedente: Filtraggio dei messaggi ICMP
Argomento successivo: Ripristino delle impostazioni predefinite del firewall


Ripristino delle impostazioni predefinite del firewall

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Gestione configurazione, cliccare su Ripristina predefiniti.
Argomento precedente: Definizione dei tipi di messaggi ICMP
Argomento successivo: Modalità interattiva


Modalità interattiva

Nota: La modalità interattiva non è disponibile su Windows 8 e versioni successive. È necessario aggiungere criteri specifici per consentire o bloccare applicazioni. È altrimenti possibile utilizzare il visualizzatore eventi nella console di gestione per gestire le regole dell'applicazione in modo interattivo.

In modalità interattiva, il firewall visualizza una finestra di apprendimento ogni qual volta un'applicazione o servizio sconosciuti richiedano accesso alla rete. La finestra di apprendimento chiede se consentire o bloccarlo il traffico in quella determinata occasione o se creare una regola per quel tipo di traffico.

In modalità interattiva, verranno visualizzate le seguenti finestre di apprendimento:

  • Finestre di apprendimento sui processi nascosti
  • Finestre di apprendimento sul protocollo
  • Finestre di apprendimento sulle applicazioni
  • Finestre di apprendimento su raw socket
  • Finestre di apprendimento sui checksum
Argomento precedente: Ripristino delle impostazioni predefinite del firewall
Argomento successivo: Abilitazione della modalità interattiva


Abilitazione della modalità interattiva

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda Generale, sotto Modalità di funzionamento, cliccare su Interattiva.
Argomento precedente: Modalità interattiva
Argomento successivo: Passaggio alla modalità non interattiva


Passaggio alla modalità non interattiva

Esistono due tipi di modalità non interattiva:
  • Consenti per impostazione predefinita
  • Blocca per impostazione predefinita

Nelle modalità non interattive, il firewall gestisce il traffico della rete automaticamente utilizzando le regole impostate dall'utente. Il traffico di rete che non corrisponde ad alcuna regola può essere completamente autorizzato (se in uscita) o completamente bloccato.

Per passare alla modalità interattiva:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda Generale, sotto Modalità di funzionamento, cliccare su Consenti per impostazione predefinita o Blocca per impostazione predefinita.
Argomento precedente: Abilitazione della modalità interattiva
Argomento successivo: Finestre di apprendimento sui processi nascosti


Finestre di apprendimento sui processi nascosti

Un processo nascosto avviene quando un'applicazione ne avvia un'altra che svolga delle operazioni di accesso alla rete per lei. Applicazioni malevole a volte utilizzano questa tecnica per aggirare i firewall; possono infatti lanciare un'applicazione ritenuta affidabile per accedere alla rete invece che tentare da sole.

La finestra di apprendimento sui processi nascosti visualizza informazioni relative al processo nascosto e all'applicazione che lo ha avviato.

  • Abilitazione delle finestre di apprendimento sui processi nascosti
Argomento precedente: Passaggio alla modalità non interattiva
Argomento successivo: Abilitazione delle finestre di apprendimento sui processi nascosti


Abilitazione delle finestre di apprendimento sui processi nascosti

Se si utilizza la modalità interattiva, il firewall può visualizzare una finestra di apprendimento ogni qual volta rilevi una nuova applicazione di questo genere.

Se si utilizza la modalità interattiva e questa opzione non è selezionata, a queste nuove applicazioni viene impedito l'avvio di processi nascosti.

Per abilitare le finestre di apprendimento sui processi nascosti:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Processi.
  4. Selezionare la casella di spunta Avvisa in caso di nuove applicazioni di questo genere.
Argomento precedente: Finestre di apprendimento sui processi nascosti
Argomento successivo: Finestre di apprendimento sul protocollo


Finestre di apprendimento sul protocollo

Se il firewall rileva attività di rete da parte del sistema che non riesce a relazionarsi ad alcuna applicazione specifica, richiede la creazione di una regola di protocollo.

La finestra di dialogo sul protocollo visualizza informazioni relative all'attività di rete non riconosciuta, ovvero protocollo e indirizzo remoto.

Argomento precedente: Abilitazione delle finestre di apprendimento sui processi nascosti
Argomento successivo: Finestre di apprendimento sulle applicazioni


Finestre di apprendimento sulle applicazioni

Se il firewall rileva che un'applicazione sta tentando di accedere alla rete in una modalità non coperta da alcuna regola esistente, richiede la creazione di una regola dell'applicazione.

La finestra di apprendimento dell'applicazione visualizza informazioni relative all'attività di rete non riconosciuta, ovvero il servizio e l'indirizzo remoti.

Argomento precedente: Finestre di apprendimento sul protocollo
Argomento successivo: Finestre di apprendimento su raw socket


Finestre di apprendimento su raw socket

I raw socket consentono ai processi di controllare tutti gli aspetti dei dati che inviano in rete e possono essere utilizzati per scopi malevoli.

Se il firewall rileva che un raw socket cerca di accedere alla rete in una modalità che non è coperta da una regola esistente, richiede la creazione di una regola sui raw socket.

La finestra di apprendimento sui raw socket visualizza informazioni relative al raw socket.

  • Abilitazione delle finestre di apprendimento sui raw socket
Argomento precedente: Finestre di apprendimento sulle applicazioni
Argomento successivo: Abilitazione delle finestre di apprendimento sui raw socket


Abilitazione delle finestre di apprendimento sui raw socket

Se si utilizza la modalità interattiva, il firewall può visualizzare una finestra di apprendimento ogni qual volta rilevi un raw socket che tenta di accedere alla rete in una modalità non coperta da una regola esistente.

Se si utilizza la modalità interattiva e questa opzione non è selezionata, ai raw socket viene impedito l'accesso alla rete.

Per abilitare le finestre di apprendimento sui raw socket:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Processi.
  4. Selezionare la casella di spunta Avvisa sull'utilizzo dei raw socket.
Argomento precedente: Finestre di apprendimento su raw socket
Argomento successivo: Finestre di apprendimento sui checksum


Finestre di apprendimento sui checksum

Se il firewall rileva un'applicazione nuova o modificata, visualizza una finestra di apprendimento sui checksum.

La finestra di apprendimento relativa ai checksum viene visualizzata solo vengono utilizzati i checksum per l'autenticazione delle applicazioni. Per ulteriori informazioni, leggere la sezione Attivare o disattivare i checksum.

Se si vuole consentire all'applicazione accesso alla rete, è necessario aggiungere all'elenco di checksum riconosciuti il suo checksum (identificatore unico).

Selezionare una delle seguenti opzioni:

  • Aggiungi il checksum a quelli esistenti per questa applicazione consente versioni multiple dell'applicazione.
  • Sostituisci qualsiasi checksum esistente per questa applicazione sostituisce tutti i checksum esistenti per l'applicazione con quello che richiede l'accesso e, di conseguenza, consente l'accesso solo alla versione più recente dell'applicazione.
  • Blocca questa applicazione finché non viene riavviata in questa occasione blocca l'applicazione.
Argomento precedente: Abilitazione delle finestre di apprendimento sui raw socket
Argomento successivo: File di configurazione del firewall


File di configurazione del firewall

Sophos Client Firewall consente di esportare le impostazioni generali e le regole del firewall come file di configurazione. Utilizzare questa funzione per svolgere le seguenti operazioni:

  • Eseguire backup e ripristino di tutte le configurazioni del firewall.
  • Salvare la configurazione delle impostazioni generali ed eseguirne l'installazione in computer multipli.
  • Creare le regole per le applicazioni in un solo computer ed esportarle, per poi utilizzarle in altri computer che eseguono lo stesso set di applicazioni.
  • Utilizzare la console di gestione per unire le configurazioni create in diversi computer per poter creare un criterio unico che sia valido per tutti i computer in rete.

Argomento precedente: Finestre di apprendimento sui checksum
Argomento successivo: Esportazione di un file di configurazione del firewall


Esportazione di un file di configurazione del firewall

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Cliccare su Esporta.
  3. Attribuire al file di configurazione un nome e un percorso e poi cliccare su Salva.
Argomento precedente: File di configurazione del firewall
Argomento successivo: Importazione di un file di configurazione del firewall


Importazione di un file di configurazione del firewall

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Cliccare su Importa.
  3. Selezionare un file di configurazione e cliccare su Apri.
  4. Seguire le istruzioni sullo schermo.
Argomento precedente: Esportazione di un file di configurazione del firewall
Argomento successivo: Regole del firewall


Regole del firewall

Regole globali

Le regole globali sono applicate a tutte le comunicazioni di rete e applicazioni anche se in possesso di regole di applicazione.

Regole delle applicazioni

Un'applicazione può avere una o più regole. È possibile utilizzare sia le regole create da Sophos che creare regole personalizzate per avere pieno controllo sull'accesso consentito a un'applicazione.

Per ulteriori informazioni sulle impostazioni relative alle regole predefinite globali e delle applicazioni, consultare l'articolo http://www.sophos.com/it-it/support/knowledgebase/57757.aspx.

Argomento precedente: Importazione di un file di configurazione del firewall
Argomento successivo: Ordine di applicazione delle regole


Ordine di applicazione delle regole

Per le connessioni che utilizzano raw socket, vengono verificate solo le regole globali.

Per connessioni che non utilizzano raw socket, vengono verificate svariate regole, a seconda che la connessione sia verso un indirizzo di rete elencato nella scheda LAN o meno.

Se l'indirizzo di rete è elencato nella scheda LAN, vengono controllate le seguenti regole:

  • Se l'indirizzo è stato contrassegnato come Attendibile, viene permesso tutto il traffico su tale connessione, senza ulteriori verifiche.
  • Se l'indirizzo è stato contrassegnato come NetBIOS, viene permessa la condivisione di file e stampanti su qualsiasi connessione che rispetti i seguenti criteri:
    Connessione | Porta | Intervallo
    TCP | Remoto | 137-139 o 445
    TCP | Locale | 137-139 o 445
    UDP | Remoto | 137 o 138
    UDP | Locale | 137 o 138

Se l'indirizzo di rete non è elencato nella scheda LAN, altre regole del firewall vengono verificate nel seguente ordine:

  1. Tutto il traffico NetBIOS non consentito tramite la scheda LAN viene sottoposto alle seguenti procedure, a seconda delle impostazioni della casella di spunta Blocca condivisione file e stampanti per altre reti:
    • Se la casella è spuntata, il traffico è bloccato.
    • Se la casella non è spuntata, il traffico viene sottoposto alle restanti regole.
  2. Le regole globali ad alta priorità vengono verificate nell'ordine in cui sono elencate.
  3. Se alla connessione non sono ancora state applicate regole,vengono verificate le regole dell'applicazione.
  4. Se la connessione non è stata ancora presa in considerazione, vengono verificate le normali regole di priorità globali, secondo l'ordine in cui sono elencate.
  5. Se non è stata rilevata alcuna regola per la gestione della connessione:
    • Nella modalità Consenti per impostazione predefinita il traffico viene consentito (se si tratta di traffico in uscita).
    • Nella modalità Blocca per impostazione predefinita, viene bloccato il traffico.
    • Nella modalità Interattiva, l'utente deve decidere. Questa modalità non è disponibile su Windows 8 e versioni successive.
    Nota: Se la modalità di funzionamento non è stata modificata, il firewall sarà in modalità Blocca per impostazione predefinita.
Argomento precedente: Regole del firewall
Argomento successivo: Rilevamento della rete locale


Rilevamento della rete locale

Nota: Questa opzione non è disponibile in Windows 8 e versioni successive.

È possibile assegnare regole del firewall alla rete locale del computer.

Il firewall determina la rete locale del computer al momento del suo avvio, e monitora qualsiasi cambiamento avvenuto durante tutto il periodo in cui il computer resta acceso. Se viene rilevata una qualsiasi modifica, il firewall aggiorna le regole della rete locale con l'intervallo di indirizzi della nuova rete locale.

Avvertenza:
Si consiglia la massima cautela quando si utilizzano regole della rete locale come parte di configurazioni utilizzabili "da fuori ufficio". Per informazioni, consultare la sezione Creazione di una configurazione secondaria.
Argomento precedente: Ordine di applicazione delle regole
Argomento successivo: Creazione di una regola globale


Creazione di una regola globale

Importante: Sophos consiglia di modificare regole globali solo se in possesso di una certa competenza sui protocolli di rete.

Le regole globali vengono applicate a tutte le comunicazioni della rete e a tutte le applicazioni non ancora soggette a una regola specifica.

Per creare una regola globale:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Regole globali.
  4. Cliccare su Aggiungi.
  5. Sotto Nome della regola, digitare il nome della regola.
    Il nome della regola deve essere unico all'interno dell'elenco delle regole. Due regole globali non possono avere lo stesso nome.
  6. In Windows 8 o versioni successive, sotto Protocollo, selezionare il protocollo che si desidera utilizzare.
  7. Per applicare la regola prima delle regole dell'applicazione o del normale ordine di priorità delle regole globali, selezionare la casella di spunta Priorità più alta delle regole di applicazione.
    Per informazioni sull'ordine di priorità con cui le regole vengono applicate, consultare la sezione Ordine di applicazione delle regole.
  8. Sotto Selezionare gli eventi che saranno gestiti dalla regola, selezionare le condizioni che la connessione deve rispettare affinché la regola venga applicata.
  9. Sotto Selezionare l'azione alla quale la regola reagirà, selezionare Consenti o Blocca.
  10. Effettuare una delle seguenti operazioni:
    • Per consentire altre connessioni da e verso lo stesso indirizzo remoto mentre la connessione iniziale è ancora attiva, selezionare Connessioni concorrenti. Questa opzione è disponibile solo per le regole TCP.
    • Per consentire risposte intelligenti dal computer remoto in base alla connessione iniziale, selezionare Ispezione di stato. Questa opzione è disponibile solo per le regole UDP.
    Nota: Su Windows 8 e versioni successive, queste opzioni non sono visualizzate, poiché viene sempre utilizzata la funzione Ispezione di stato, e le Connessioni concorrenti non sono supportate.
  11. Sotto Descrizione della regola, cliccare su un valore sottolineato.
Argomento precedente: Rilevamento della rete locale
Argomento successivo: Modifica di una regola globale


Modifica di una regola globale

Importante: Sophos consiglia di modificare regole globali solo se in possesso di una certa competenza sui protocolli di rete.

Per modifica una regola globale:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Regole globali.
  4. Nell'elenco Regola, scegliere la regola che si desidera modificare.
  5. Cliccare su Modifica.
    Per informazioni sulle impostazioni delle regole globali, consultare la sezione Creazione di una regola globale.
Argomento precedente: Creazione di una regola globale
Argomento successivo: Copia di una regola globale


Copia di una regola globale

Per copiare una regola globale e aggiungerla all'elenco delle regole:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Regole globali.
  4. Nell'elenco Regola, scegliere la regola che si desidera copiare.
  5. Cliccare su Copia.
Argomento precedente: Modifica di una regola globale
Argomento successivo: Cancellazione di una regola globale


Cancellazione di una regola globale

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Regole globali.
  4. Nell'elenco Regola, scegliere la regola che si desidera cancellare.
  5. Cliccare su Rimuovi.
Argomento precedente: Copia di una regola globale
Argomento successivo: Modifica dell'ordine di applicazione delle regole globali


Modifica dell'ordine di applicazione delle regole globali

Le regole globali vengono applicate secondo l'ordine in cui appaiono nell'elenco delle regole, dall'alto verso il basso.

Per modificare l'ordine di applicazione delle regole globali:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Regole globali.
  4. Nell'elenco Regola, cliccare sulla regola che si desidera spostare in alto o in basso nell'elenco.
  5. Cliccare su Sposta su o Sposta giù.
Argomento precedente: Cancellazione di una regola globale
Argomento successivo: Applicazione delle regole delle applicazioni predefinite


Applicazione delle regole delle applicazioni predefinite

Si tratta di una serie di regole delle applicazioni create da Sophos. Per aggiungere regole predefinite all'elenco di regole per un'applicazione:
  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Selezionare l'applicazione dall'elenco e quindi cliccare sulla freccia di fianco a Personalizza.
  5. Andare a Aggiungi regole da quelle predefinite e cliccare sulla regola predefinita.
Argomento precedente: Modifica dell'ordine di applicazione delle regole globali
Argomento successivo: Creazione di una regola dell'applicazione


Creazione di una regola dell'applicazione

Per creare una regola personalizzata che rappresenti un buon meccanismo di controllo sulla concessione dell'accesso a una determinata applicazione:
  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Selezionare l'applicazione dall'elenco e cliccare su Personalizza.
    È anche possibile cliccare due volte sul nome dell'applicazione nell'elenco.
  5. Nella finestra di dialogo Regole applicazioni, cliccare su Aggiungi.
  6. Sotto Nome della regola, digitare il nome della regola.
    Il nome della regola deve essere unico all'interno dell'elenco delle regole. Due regole delle applicazioni non possono avere lo stesso nome, ma due applicazioni possono avere ciascuna una regola con lo stesso nome.
  7. In Windows 8 o versioni successive, sotto Protocollo, selezionare il protocollo che si desidera utilizzare.
  8. Sotto Selezionare gli eventi che saranno gestiti dalla regola, selezionare le condizioni che la connessione deve rispettare affinché la regola venga applicata.
  9. Sotto Selezionare l'azione alla quale la regola reagirà, selezionare Consenti o Blocca.
  10. Procedere in uno dei seguenti modi:
    • Per consentire altre connessioni da e verso lo stesso indirizzo remoto mentre la connessione iniziale è ancora attiva, selezionare Connessioni concorrenti. Questa opzione è disponibile solo per le regole TCP.
    • Per consentire risposte intelligenti dal computer remoto in base alla connessione iniziale, selezionare Ispezione di stato. Questa opzione è disponibile solo per le regole UDP.
    Nota: Su Windows 8 e versioni successive, queste opzioni non sono visualizzate, poiché viene sempre utilizzata la funzione Ispezione di stato, e le Connessioni concorrenti non sono supportate.
  11. Sotto Descrizione della regola, cliccare su un valore sottolineato.
Argomento precedente: Applicazione delle regole delle applicazioni predefinite
Argomento successivo: Modifica di una regola delle applicazioni


Modifica di una regola delle applicazioni

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Selezionare l'applicazione dall'elenco e cliccare su Personalizza.
    È anche possibile cliccare due volte sul nome dell'applicazione nell'elenco.
  5. Nella finestra di dialogo Regole applicazioni, cliccare su Modifica.
  6. Sotto Nome della regola, digitare il nome della regola.
    Il nome della regola deve essere unico all'interno dell'elenco delle regole. Due regole delle applicazioni non possono avere lo stesso nome, ma due applicazioni possono avere ciascuna una regola con lo stesso nome.
  7. In Windows 8 o versioni successive, sotto Protocollo, selezionare il protocollo che si desidera utilizzare.
  8. Sotto Selezionare gli eventi che saranno gestiti dalla regola, selezionare le condizioni che la connessione deve rispettare affinché la regola venga applicata.
  9. Sotto Selezionare l'azione alla quale la regola reagirà, selezionare Consenti o Blocca.
  10. Procedere in uno dei seguenti modi:
    • Per consentire altre connessioni da e verso lo stesso indirizzo remoto mentre la connessione iniziale è ancora attiva, selezionare Connessioni concorrenti. Questa opzione è disponibile solo per le regole TCP.
    • Per consentire risposte intelligenti dal computer remoto in base alla connessione iniziale, selezionare Ispezione di stato. Questa opzione è disponibile solo per le regole UDP.
    Nota: Su Windows 8 e versioni successive, queste opzioni non sono visualizzate, poiché viene sempre utilizzata la funzione Ispezione di stato, e le Connessioni concorrenti non sono supportate.
  11. Sotto Descrizione della regola, cliccare su un valore sottolineato.
Argomento precedente: Creazione di una regola dell'applicazione
Argomento successivo: Copia di una regola delle applicazioni


Copia di una regola delle applicazioni

Per copiare una regola delle applicazioni e aggiungerla all'elenco delle regole:
  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Selezionare l'applicazione dall'elenco e cliccare su Personalizza.
    È anche possibile cliccare due volte sul nome dell'applicazione nell'elenco.
  5. Nella finestra di dialogo Regole applicazioni, selezionare la regola che si desidera copiare e cliccare su Copia.
Argomento precedente: Modifica di una regola delle applicazioni
Argomento successivo: Cancellazione di una regola delle applicazioni


Cancellazione di una regola delle applicazioni

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Selezionare l'applicazione nell'elenco e cliccare su Personalizza.
  5. Nella finestra di dialogo Regole applicazioni, selezionare la regola che si desidera rimuovere e cliccare su Rimuovi.
Argomento precedente: Copia di una regola delle applicazioni
Argomento successivo: Modifica dell'ordine di applicazione delle regole delle applicazioni


Modifica dell'ordine di applicazione delle regole delle applicazioni

Le regole dell'applicazione vengono applicate secondo l'ordine in cui appaiono nell'elenco delle regole, dall'alto verso il basso.

Per modificare l'ordine di applicazione delle regole delle applicazioni:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Applicazioni.
  4. Selezionare l'applicazione dall'elenco e cliccare su Personalizza.
    È anche possibile cliccare due volte sul nome dell'applicazione nell'elenco.
  5. Nell'elenco Regola, cliccare sulla regola che si desidera spostare in alto o in basso nell'elenco.
  6. Cliccare su Sposta su o Sposta giù.
Argomento precedente: Cancellazione di una regola delle applicazioni
Argomento successivo: Autorizzazione dell'avvio di processi nascosti


Autorizzazione dell'avvio di processi nascosti

Nota: Questa opzione non è disponibile in Windows 8 e versioni successive, dal momento che l’operazione viene gestita automaticamente dalla tecnologia HIPS di Sophos Anti-Virus.

Un applicazione a volte ne avvia un'altra che svolga delle operazioni di accesso alla rete per lei.

Applicazioni malevole possono utilizzare questa tecnica per aggirare i firewall; possono infatti lanciare un'applicazione ritenuta affidabile per accedere alla rete invece che tentare da sole.

Il firewall invia un allarme alla console di gestione, se se ne sta utilizzando una, la prima volta che viene rilevato un processo nascosto.

Per consentire l'avvio di processi nascosti:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Processi.
  4. Nell'area in alto, cliccare sul pulsante Aggiungi.
  5. Trovare l'applicazione e cliccarvi due volte.
Se si utilizza la modalità interattiva, il firewall può visualizzare una finestra di apprendimento ogni qual volta rilevi una nuova applicazione di questo genere.
  • Abilitazione della modalità interattiva
  • Abilitazione delle finestre di apprendimento sui processi nascosti
Argomento precedente: Modifica dell'ordine di applicazione delle regole delle applicazioni
Argomento successivo: Autorizzazione dell'utilizzo di raw socket da parte di applicazioni


Autorizzazione dell'utilizzo di raw socket da parte di applicazioni

Nota: Questa opzione non è disponibile in Windows 8 e versioni successive. Il firewall tratterà i rawsocket nello stesso modo in cui vengono trattati i socket ordinari.

Alcune applicazioni possono accedere alla rete tramite raw socket che forniscono loro controllo su tutti gli aspetti relativi ai dati inviati nella rete.

Alcune applicazioni malevole possono sfruttare i raw socket contraffacendo il loro indirizzo IP o inviando messaggi volutamente corrotti.

Nel caso ne venga utilizzato uno, il firewall invia un allarme alla console di gestione la prima volta che rileva un raw socket.

Per consentire alle applicazioni di accedere alla rete tramite raw socket:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Processi.
  4. Nell'area in basso, cliccare sul pulsante Aggiungi.
  5. Trovare l'applicazione e cliccarvi due volte.
Se si utilizza la modalità interattiva, il firewall può visualizzare una finestra di apprendimento ogni qual volta rilevi un raw socket.
  • Abilitazione della modalità interattiva
  • Abilitazione delle finestre di apprendimento sui raw socket
Argomento precedente: Autorizzazione dell'avvio di processi nascosti
Argomento successivo: Utilizzo di checksum per l'autenticazione di applicazioni


Utilizzo di checksum per l'autenticazione di applicazioni

Ogni versione di un'applicazione ha un checksum unico. Il firewall può utilizzare tale checksum per decidere se un'applicazione è consentita o meno.

Per impostazione predefinita, il firewall verifica il checksum di tutte le applicazioni in esecuzione. Se il checksum non è noto o è stato modificato, il firewall lo blocca o (in modalità interattiva) chiede all'utente come procedere.

Il firewall invia anche un allarme alla console di gestione, se ne viene utilizzata una, la prima volta che rileva un'applicazione nuova o modificata.

Per aggiungere un checksum all'elenco di checksum autorizzati:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Cliccare sulla scheda Checksum.
  4. Cliccare su Aggiungi.
  5. Trovare l'applicazione e cliccarvi due volte.
Se si utilizza la modalità interattiva, il firewall può visualizzare una finestra di apprendimento ogni qual volta rilevi un'applicazione nuova o modificata.
  • Abilitazione della modalità interattiva
  • Abilitazione delle finestre di apprendimento sui processi nascosti
Argomento precedente: Autorizzazione dell'utilizzo di raw socket da parte di applicazioni
Argomento successivo: Riconoscimento della presenza in rete


Riconoscimento della presenza in rete

Il riconoscimento della presenza in rete è una funzionalità di Sophos Client Firewall che attribuisce una configurazione del firewall a ciascuna scheda di rete presente sul computer, a seconda dell'attuale posizione della scheda di rete stessa.

Lo scenario più consueto per l'utilizzo di tale funzionalità si presenta quando si è in possesso di un laptop aziendale, e si lavora dalla propria abitazione. Si utilizzano così due connessioni di rete allo stesso momento:

  • Per il lavoro, ci si connette alla rete aziendale mediante un client VPN ed una scheda di rete virtuale.

  • Per uso personale, ci si connette al proprio Internet provider tramite un cavo di rete ed una scheda di rete fisica.

In questo scenario, occorre che la configurazione lavorativa venga applicata alla connessione aziendale virtuale, e che la configurazione non lavorativa (di solito più restrittiva) venga applicata alla connessione del provider di servizi Internet non lavorativo.

Nota: La configurazione non lavorativa richiederà che siano presenti abbastanza regole per consentire alla connessione aziendale "virtuale" di essere stabilita.
Argomento precedente: Utilizzo di checksum per l'autenticazione di applicazioni
Argomento successivo: Impostazione del riconoscimento della presenza in rete


Impostazione del riconoscimento della presenza in rete

  1. Definire l'elenco di indirizzi o domini gateway MAC dei propri percorsi primari. Di norma, si tratta delle proprie reti aziendali.

  2. Creare la configurazione del firewall che verrà utilizzata per i propri percorsi primari. Di solito tale configurazione è meno restrittiva.

  3. Creare una configurazione del firewall secondaria. Di solito tale configurazione è più restrittiva.
  4. Selezionare una configurazione da applicare.

A seconda del metodo di rilevamento utilizzato, il firewall ottiene l'indirizzo DNS o gateway per ciascuna scheda di rete del computer, e le paragona all'elenco di indirizzi fornito.

  • Se si verifica una corrispondenza fra uno degli indirizzi nell'elenco e l'indirizzo di una scheda di rete, a tale scheda viene assegnata la configurazione per il percorso primario.
  • Se non si rileva alcuna corrispondenza fra gli indirizzi nell'elenco e quelli delle schede di rete, alla scheda viene assegnato il criterio per il percorso secondario.

Il percorso attivo è visualizzato nel pannello Stato della finestra Sophos Endpoint Security and Control. Se sono state applicate entrambi le configurazioni, Attivo = Entrambi.

Importante: La configurazione secondaria passa dalla modalità Interattiva a quella Blocca per impostazione predefinita quando si verificano entrambe le seguenti condizioni:
  • Entrambi i percorsi sono attivi.
  • La configurazione primaria non è interattiva.
Argomento precedente: Riconoscimento della presenza in rete
Argomento successivo: Definizione dei percorsi primari


Definizione dei percorsi primari

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Cliccare sulla scheda Rilevamento percorso.
  3. Sotto Metodo di rilevamento, cliccare su Configura di fianco al metodo che si desidera utilizzare per definire i percorsi primari:
    Opzione | Descrizione
    Identifica percorso tramite DNS | Creazione di un elenco di nomi di dominio e indirizzi IP previsti, corrispondenti ai percorsi primari.
    Identifica percorso tramite indirizzi gateway MAC | Creazione di un elenco di indirizzi gateway MAC corrispondenti ai percorsi primari.
  4. Seguire le istruzioni sullo schermo.
Argomento precedente: Impostazione del riconoscimento della presenza in rete
Argomento successivo: Creazione di una configurazione secondaria


Creazione di una configurazione secondaria

Il firewall utilizza la configurazione secondaria quando non si è connessi a un percorso primario.
  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Selezionare la casella di spunta Aggiungi configurazione per percorso secondario.

Impostare ora la configurazione per il percorso secondario. Per informazioni su come svolgere questa operazione, riferirsi a Configurazione del firewall e agli altri argomenti nella sezione Configurazione del firewall.

Avvertenza:
Se il computer è un laptop, e viene utilizzato all'esterno dell'ufficio, esiste la possibilità che si colleghi ad una rete locale sconosciuta. In tale evenienza, le regole del firewall nella configurazione secondaria che utilizzano la rete locale come indirizzo possono inavvertitamente consentire traffico sconosciuto. Per questo motivo, si consiglia vivamente di esercitare cautela quando si utilizzano le regole di rete locale come parte di configurazioni secondarie.
Argomento precedente: Definizione dei percorsi primari
Argomento successivo: Selezione di una configurazione da applicare


Selezione di una configurazione da applicare

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nella scheda Generale, sotto Percorso applicato, cliccare su una delle seguenti opzioni:
    Opzione | Descrizione
    Applica la configurazione per il percorso rilevato | Il firewall applica la configurazione primaria o secondaria a ciascuna connessione di rete, a seconda delle impostazioni di rilevamento per il riconoscimento della presenza in rete (come descritto nella sezione Impostazione del riconoscimento della presenza in rete).
    Applica la configurazione per il percorso primario | Il firewall applica la configurazione primaria a tutte le connessioni di rete.
    Applica la configurazione per il percorso secondario | Il firewall applica la configurazione secondaria a tutte le connessioni di rete.
Argomento precedente: Creazione di una configurazione secondaria
Argomento successivo: Reportistica del firewall


Reportistica del firewall

Per impostazione predefinita, i report del firewall comunicano alla console di gestione cambiamenti di stato, eventi ed errori.

Cambiamenti di stato del firewall

Il firewall considera cambiamenti di stato i cambiamenti riportati di seguito:

  • Cambiamenti delle modalità di funzionamento
  • Cambiamenti della versione del software
  • Cambiamenti della configurazione del firewall per autorizzare tutto il traffico
  • Cambiamenti della conformità del firewall al criterio

Quando si lavora in modalità interattiva, la configurazione del firewall potrebbe essere deliberatamente diversa dal criterio applicato dalla console di gestione. Se questo è il caso, è possibile decidere di non inviare alla console di gestione allarmi del tipo "diverso dal criterio", quando si apportano cambiamenti a determinate parti della configurazione del firewall.

Per informazioni, consultare la sezione Attivazione o disattivazione del rilevamento di modifiche locali.

Eventi firewall

Un evento si verifica quando un'applicazione sconosciuta nel computer, o il sistema operativo del computer, prova a comunicare con un altro computer tramite una connessione di rete.

È possibile impedire che il firewall riporti alla console di gestione gli eventi.

Per informazioni, consultare la sezione Disattivazione del rilevamento del traffico di rete sconosciuto

Argomento precedente: Selezione di una configurazione da applicare
Argomento successivo: Attivazione o disattivazione del rilevamento di modifiche locali


Attivazione o disattivazione del rilevamento di modifiche locali

Nota: Questa opzione non è disponibile in Windows 8 e versioni successive.

Se la configurazione del firewall differisce dal criterio, è possibile disattivare il rilevamento di modifiche locali.

La disattivazione del rilevamento di modifiche locali fa in modo che il firewall non invii allarmi "diverso dal criterio" alla console di gestione in relazione alle modifiche apportate a regole globali, applicazioni, processi o checksum. Scegliere questa opzione quando si lavora in modalità interattiva, dal momento che si tratta di impostazioni modificabili tramite finestre di apprendimento.

Se nel computer la configurazione del firewall deve essere conforme al criterio, si dovrà attivare il rilevamento di modifiche locali.

Per disattivare il rilevamento di modifiche locali:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda Generale, sotto Reportistica, per disattivare il rilevamento di modifiche locali, deselezionare la casella di spunta Visualizza un allarme nella console di gestione se a regole globali, applicazioni, processi o checksum sono apportate modifiche a livello locale.
    Per attivare il rilevamento di modifiche locali, selezionare la casella di spunta.
Argomento precedente: Reportistica del firewall
Argomento successivo: Disattivazione del rilevamento del traffico di rete sconosciuto


Disattivazione del rilevamento del traffico di rete sconosciuto

È possibile impedire che il firewall riporti alla console di gestione il traffico di rete sconosciuto. Il firewall considera il traffico sconosciuto se non rileva regole relative ad esso.

Per impedire che il firewall riporti alla console di gestione il traffico di rete sconosciuto:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda Generala, sotto Blocco, selezionare la casella di spunta Utilizzo di checksum per l'autenticazione delle applicazioni.
  4. Sotto Reportistica, deselezionare la casella di spunta Segnala le applicazioni sconosciute e il traffico alla console di gestione.
Argomento precedente: Attivazione o disattivazione del rilevamento di modifiche locali
Argomento successivo: Disattivazione del rilevamento degli errori del firewall


Disattivazione del rilevamento degli errori del firewall

Importante: Si sconsiglia la disattivazione permanente del rilevamento degli errori del firewall. Disattivare il rilevamento solo quando strettamente necessario.

Per impedire che il firewall riporti errori alla console di gestione:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda Generale, sotto Reportistica, deselezionare la casella di spunta Segnala errori alla console di gestione.
Argomento precedente: Disattivazione del rilevamento del traffico di rete sconosciuto
Argomento successivo: Configurazione della messaggistica desktop


Configurazione della messaggistica desktop

È possibile controllare quali messaggi il firewall visualizzi nel desktop.

Le notifiche relative ad applicazioni sconosciute e traffico non vengono mostrate in modalità interattiva dal momento che le stesse informazioni vengono visualizzate nelle finestre di apprendimento.

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Sotto Configurazioni, cliccare su Configura di fianco al percorso che si desidera configurare.
  3. Nella scheda Generale, sotto Messaggistica desktop, svolgere una delle seguenti operazioni:
    • Per visualizzare le notifiche relative ad allarmi ed errori del firewall, selezionare la casella di spunta Mostra allarmi ed errori.
    • Per visualizzare le notifiche relativi ad applicazioni sconosciute e traffico, selezionare la casella di spunta Mostra applicazioni sconosciute e traffico.
Argomento precedente: Disattivazione del rilevamento degli errori del firewall
Argomento successivo: Visualizzatore del log del firewall


Visualizzatore del log del firewall

Il visualizzatore del log di Sophos Client Firewall consente di visualizzare, filtrare e salvare dettagli relativi a:

  • Tutte le connessioni
  • Connessioni che sono state consentite o bloccate
  • Eventi firewall
  • Log di sistema
Argomento precedente: Configurazione della messaggistica desktop
Argomento successivo: Apertura del visualizzatore del log del firewall


Apertura del visualizzatore del log del firewall

Nella Home page, sotto Firewall, cliccare su Visualizza log firewall.
Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
Argomento precedente: Visualizzatore del log del firewall
Argomento successivo: Configurazione del log del firewall


Configurazione del log del firewall

Per gestire la dimensione e i contenuti del database del log eventi del firewall:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Configurazione firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Cliccare sulla scheda Log.
  3. Per gestire la dimensione del database del log eventi del firewall, selezionare una delle seguenti opzioni:
    • Per consentire al database di crescere senza alcun limite, cliccare su Mantieni tutti i record.
    • Per cancellare i vecchi record, cliccare su Elimina i record vecchi, e poi configurare le Impostazioni cancellazione log.
  4. Sotto Impostazioni cancellazione log, selezionare una o più delle seguenti opzioni:
    • Cliccare sulla casella di spunta Elimina i record dopo, e successivamente inserire o selezionare un numero nella casella Giorni.
    • Cliccare sulla casella di spunta Mantieni non più di, e successivamente inserire o selezionare un numero nella casella Record.
    • Cliccare sulla casella di spunta Mantieni dimensioni entro, e successivamente inserire o selezionare un numero nella casella MB.
Argomento precedente: Apertura del visualizzatore del log del firewall
Argomento successivo: Modifica dell'aspetto del visualizzatore del log del firewall


Modifica dell'aspetto del visualizzatore del log del firewall

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Visualizza log firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Dal menu Visualizza, cliccare su Layout.
  3. Nella finestra di dialogo Visualizza personalizzazione, selezionare gli oggetti che si desidera nascondere o visualizzare:
    • L'Albero della console viene visualizzato nel riquadro a sinistra.
    • La Barra degli strumenti viene visualizzata nella parte alta del visualizzatore del log del firewall.
    • La Barra delle descrizioni viene visualizzata sopra i dati nel riquadro a destra.
    • La Barra di stato viene visualizzata nella parte bassa del visualizzatore del log del firewall.
Argomento precedente: Configurazione del log del firewall
Argomento successivo: Personalizzazione del formato dei dati


Personalizzazione del formato dei dati

È possibile cambiare il formato utilizzato per visualizzare i seguenti oggetti relativi ai dati nei log del firewall:
  • Visualizzare le porte sotto forma di numero o nome, per es. HTTP o 80.
  • Visualizzare le applicazioni come icone, percorsi file o entrambi.
  • Specificare l'unità di misura utilizzata per visualizzare i dati relativi alla velocità del trasferimento dei dati, per es. KByte o MByte.
  • Nascondere o visualizzare griglie

Per personalizzare il formato dei dati:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Visualizza log firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Dal menu Visualizza, cliccare su Personalizza.
  3. Selezionare le opzioni desiderate.
Argomento precedente: Modifica dell'aspetto del visualizzatore del log del firewall
Argomento successivo: Mostra o nascondi colonne nel visualizzatore del log del firewall


Mostra o nascondi colonne nel visualizzatore del log del firewall

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Visualizza log firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Cliccare su un oggetto nell'albero della console che visualizzi colonne nel riquadro dei dettagli.
  3. Nel menu Visualizza, selezionare Aggiungi/rimuovi colonne.
    È anche possibile cliccare col tasto destro del mouse su tutte le intestazioni delle colonne.
  4. Nella finestra di dialogo Colonne, svolgere una delle seguenti operazioni:
    • Per nascondere una colonna, deselezionare la relativa casella di spunta.
    • Per visualizzare una colonna, selezionare la relativa casella di spunta.
Argomento precedente: Personalizzazione del formato dei dati
Argomento successivo: Riordinamento delle colonne nel visualizzatore del log del firewall


Riordinamento delle colonne nel visualizzatore del log del firewall

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Visualizza log firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Cliccare su un oggetto nell'albero della console che visualizzi colonne nel riquadro dei dettagli.
  3. Nel menu Visualizza, selezionare Aggiungi/rimuovi colonne.
    È anche possibile cliccare col tasto destro del mouse su tutte le intestazioni delle colonne.
  4. Nella finestra di dialogo Colonne, cliccare sul nome di una colonna e poi su Sposta su o Sposta giù per cambiare la posizione della colonna.

Note

  • È inoltre possibile riordinare le colonne nel riquadro dei dettagli utilizzando il mouse e trascinando l'intestazione della colonna a destra o sinistra della sua posizione originale. Quando si trascina una colonna, parti evidenziate tra le intestazioni delle colonne indicano la nuova posizione della colonna.
  • È possibile cambiare le dimensioni delle colonne utilizzando il mouse per trascinare le intestazioni delle colonne.
Argomento precedente: Mostra o nascondi colonne nel visualizzatore del log del firewall
Argomento successivo: Filtraggio dei record in un log del firewall


Filtraggio dei record in un log del firewall

È possibile classificare i record del log del firewall creando un filtro.

Per filtrare i record del log del firewall:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Visualizza log firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'albero della console, selezionare un log.
  3. Nel menu Azione, cliccare su Aggiungi filtro.
  4. Seguire le istruzioni della procedura guidata Filtro.
Il filtro appare nell'albero della console immediatamente sotto al nodo che si desiderava filtrare.
Argomento precedente: Riordinamento delle colonne nel visualizzatore del log del firewall
Argomento successivo: Esportazione di tutti i record da un log del firewall


Esportazione di tutti i record da un log del firewall

Per esportare tutti i record dal log del firewall a un file di testo o CSV:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Visualizza log firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'albero della console, selezionare un log.
  3. Cliccare col tasto destro del mouse sull'elenco dei record e poi cliccare su Esporta tutti i record.
  4. Nel campo di testo Nome file, digitare un nome per il file.
  5. Nell'elenco Salva come, cliccare sul tipo di file desiderato.
Argomento precedente: Filtraggio dei record in un log del firewall
Argomento successivo: Esportazione di record selezionati da un log del firewall


Esportazione di record selezionati da un log del firewall

Per esportare record selezionati da un log del firewall a un file di testo o CSV:

  1. Nella Pagina iniziale, sotto Firewall, cliccare su Visualizza log firewall.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nell'albero della console, selezionare un log.
  3. Selezionare i record che si desidera esportare.
    Se i record si aggiornano rapidamente, nel menu Visualizza, deselezionare la casella di spunta Aggiornamento automatico.
  4. Nel menu Azione, cliccare su Esporta record selezionati.
  5. Nel campo di testo Nome file, digitare un nome per il file.
  6. Nell'elenco Salva come, cliccare sul tipo di file desiderato.
Argomento precedente: Esportazione di tutti i record da un log del firewall
Argomento successivo: Aggiornamento immediato


Aggiornamento immediato

Per impostazione predefinita, Sophos AutoUpdate è programmato per aggiornarsi ogni 10 minuti, se costantemente collegati alla rete aziendale, o ogni 60 minuti, se costantemente collegati ad Internet.

Se si è in possesso di una connessione di tipo dial-up, Sophos AutoUpdate è impostato per eseguire gli aggiornamenti ogni qual volta ci si connetta a Internet o alla rete, e quindi ogni 60 minuti.

Per eseguire aggiornamenti immediati:

Cliccare col tasto destro del mouse sull'icona nell'area di notifica di Sophos Endpoint Security and Control e poi cliccare su Aggiorna.
Argomento precedente: Esportazione di record selezionati da un log del firewall
Argomento successivo: Pianificazione degli aggiornamenti


Pianificazione degli aggiornamenti

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

È possibile specificare la modalità o la frequenza degli aggiornamenti di Sophos AutoUpdate.

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Cliccare sulla scheda Pianificazione
  3. Selezionare Consenti aggiornamenti automatici e inserire la frequenza (in minuti) con la quale Sophos AutoUpdate eseguirà gli aggiornamenti.
    Se l'aggiornamento dei file viene scaricato dalla rete aziendale, per impostazione predefinita avverrà ogni 10 minuti.
    Se l'aggiornamento dei file viene scaricato tramite Internet dal server di Sophos, Sophos AutoUpdate può svolgere gli aggiornamenti con una frequenza massima di 60 minuti.
Argomento precedente: Aggiornamento immediato
Argomento successivo: Impostazione di una fonte per gli aggiornamenti


Impostazione di una fonte per gli aggiornamenti

Se si desidera che Sophos AutoUpdate esegua l'aggiornamento automatico, è necessario specificare la fonte da cui scaricare gli aggiornamenti.

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Cliccare sulla scheda Percorso primario.
  3. Nell'elenco Indirizzo, inserire il percorso UNC o l'indirizzo web del server di aggiornamento.

    Per scaricare gli aggiornamenti direttamente da Sophos tramite Internet, selezionare Sophos dall'elenco Indirizzo.

  4. Nella casella Nome utente, digitare il nome utente dell'account utilizzato per accedere al server di aggiornamento.
    Se il nome utente deve riportare il dominio, utilizzare la forma dominio\nome utente.
  5. Nella casella Password, digitare la password dell'account utilizzato per accedere al server di aggiornamento.
Argomento precedente: Pianificazione degli aggiornamenti
Argomento successivo: Impostazione di una fonte alternativa per gli aggiornamenti


Impostazione di una fonte alternativa per gli aggiornamenti

È possibile impostare una fonte alternativa per gli aggiornamenti. Se Sophos AutoUpdate non riesce ad eseguire gli aggiornamenti dalla fonte consueta, tenterà di farlo da quella alternativa.

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Cliccare sulla scheda Percorso secondario.
  3. Nell'elenco Indirizzo, inserire il percorso UNC o l'indirizzo web del server di aggiornamento.

    Per scaricare gli aggiornamenti direttamente da Sophos tramite Internet, selezionare Sophos dall'elenco Indirizzo.

  4. Nella casella Nome utente, digitare il nome utente dell'account utilizzato per accedere al server di aggiornamento.
    Se il nome utente deve riportare il dominio, utilizzare la forma dominio\nome utente.
  5. Nella casella Password, digitare la password dell'account utilizzato per accedere al server di aggiornamento.
Argomento precedente: Impostazione di una fonte per gli aggiornamenti
Argomento successivo: Aggiornamento tramite server proxy


Aggiornamento tramite server proxy

Se Sophos AutoUpdate esegue gli aggiornamenti via Internet, è necessario inserire i dati del server proxy utilizzato per connettersi a Internet.

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Cliccare sulla scheda Percorso primario o Percorso secondario.
  3. Cliccare su Dati proxy.
  4. Selezionare la casella di spunta Accedi al percorso tramite proxy.
  5. Inserire l'Indirizzo e il numero di Porta del server proxy.
  6. Inserire il Nome utente e la Password che danno accesso al server proxy.
    Se il nome utente deve riportare il dominio, utilizzare la forma dominio\nome utente.
Argomento precedente: Impostazione di una fonte alternativa per gli aggiornamenti
Argomento successivo: Aggiornamento tramite connessione dial-up


Aggiornamento tramite connessione dial-up

Per eseguire gli aggiornamenti tramite connessione dial-up a Internet:

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Cliccare sulla scheda Pianificazione
  3. Selezionare Verifica la disponibilità di aggiornamenti in fase di connessione.
Sophos AutoUpdate esegue l'aggiornamento ogni qual volta ci si connetta a Internet.
Argomento precedente: Aggiornamento tramite server proxy
Argomento successivo: Limitazione della larghezza di banda utilizzata per gli aggiornamenti


Limitazione della larghezza di banda utilizzata per gli aggiornamenti

Per evitare che Sophos AutoUpdate occupi tutta la larghezza di banda quando è invece necessaria per altri motivi (quali scaricare la posta elettronica), è possibile limitarne la quantità utilizzata.

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Cliccare sulla scheda Percorso primario o Percorso secondario.
  3. Cliccare su Avanzate.
  4. Selezionare la casella di spunta Limita occupazione di banda e spostare l'indicatore in modo tale da indicare la quantità di larghezza di banda che Sophos AutoUpdate potrà utilizzare.
    Nota: se si specifica una larghezza di banda superiore alla quantità disponibile, Sophos AutoUpdate utilizzerà tutta la larghezza di banda.
Argomento precedente: Aggiornamento tramite connessione dial-up
Argomento successivo: Log dell'attività di aggiornamento


Log dell'attività di aggiornamento

È possibile configurare Sophos Anti-Virus in modo tale che registri l'attività di aggiornamento in un file di log.

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Cliccare sulla scheda Log.
  3. Selezionare la casella di spunta Crea log dell'attività di Sophos AutoUpdate.
  4. Nella casella Dimensioni massime log, digitare o selezionare la dimensione massima in MB del log.
  5. Nell'elenco Livello di log, selezionare un log Normale o Dettagliato.
    Il log dettagliato fornisce informazioni su molte più attività del normale, quindi il log si riempirà più rapidamente. Utilizzare questa opzione solo quando è necessario un log dettagliato per la risoluzione dei problemi.
Argomento precedente: Limitazione della larghezza di banda utilizzata per gli aggiornamenti
Argomento successivo: Visualizzazione del file di log degli aggiornamenti


Visualizzazione del file di log degli aggiornamenti

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Cliccare sulla scheda Log.
  3. Cliccare su Visualizza file di log.
Argomento precedente: Log dell'attività di aggiornamento
Argomento successivo: Il blocco rimozione in questo computer


Il blocco rimozione in questo computer

Il blocco rimozione consente di impedire a malware noto e a utenti non autorizzati (amministratori locali e utenti con conoscenze tecniche limitate) la disinstallazione del software di sicurezza Sophos o la sua disabilitazione attraverso l'interfaccia di Sophos Endpoint Security and Control.

Nota: Il blocco rimozione non è pensato per offrire protezione contro utenti con vaste conoscenze tecniche. Non offre protezione contro malware appositamente studiato per sovvertire il funzionamento del sistema operativo in modo tale da non essere rilevato. Tale tipo di malware può essere rilevato solamente eseguendo una scansione alla ricerca di minacce e comportamenti sospetti Per ulteriori informazioni, consultare la sezione "Sophos Anti-Virus" (capitolo 4).

Cosa implica il blocco rimozione per gli utenti del computer?

SophosUsers e SophosPowerUsers

Il blocco rimozione non ha alcuna ripercussione sui gruppi SophosUsers e SophosPowerUsers. Quando il blocco rimozione è attivo, sarà comunque possibile eseguire tutte le operazioni normalmente autorizzate, senza bisogno di immettere la password del blocco rimozione.

SophosUsers o SophosPowerUsers non possono attivare o disattivare il blocco rimozione.

Per maggiori informazioni sulle operazioni che ciascun gruppo Sophos è autorizzato ad effettuare, consultare la sezione Gruppi Sophos.

SophosAdministrators

I membri del gruppo SophosAdministrator sono autorizzati ad abilitare e disabilitare il blocco rimozione.

Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, i criteri del blocco rimozione impostati nella console determinano le opzioni di configurazione e la password del blocco rimozione. Se il blocco rimozione viene abilitato dalla console, richiedere la password all'amministratore per poter eseguire una delle operazioni elencate qui di seguito.

Per poter svolgere le seguenti operazioni, i membri del gruppo SophosAdministrator dovranno essere a conoscenza della password del blocco rimozione, nel caso questo sia abilitato:

  • Riconfigurare le impostazioni della scansione in accesso o del rilevamento di comportamenti sospetti in Sophos Endpoint Security and Control. Per informazioni, consultare la sezione Inserimento della password del blocco rimozione per configurare il software.
  • Disabilitazione del blocco rimozione Per informazioni, consultare la sezione Disabilitazione del blocco rimozione.
  • Disinstallare i componenti di Sophos Endpoint Security and Control (Sophos Anti-Virus, Sophos Client Firewall, Sophos AutoUpdate, Sophos Remote Management System), utilizzando il Pannello di Controllo.
  • Disinstallare Sophos SafeGuard Disk Encryption utilizzando il Pannello di Controllo.

Nel caso in cui un membro del gruppo SophosAdministrator non conosca la password potrà eseguire tutte le operazioni, escluse quelle elencate qui sopra.

Se il blocco rimozione non è attivo, ma la password del blocco rimozione è già stata impostata, è necessario utilizzare l'opzione Autentica utente per autenticarsi prima di poter riattivare il blocco rimozione. Quando il blocco rimozione non è attivo, sono comunque abilitate tutte le altre opzioni di configurazione disponibili per il gruppo SophosAdministrators. Per ulteriori informazioni su come riattivare il blocco rimozione, consultare la sezione Riattivazione del blocco rimozione.

Argomento precedente: Visualizzazione del file di log degli aggiornamenti
Argomento successivo: Abilitazione del blocco rimozione


Abilitazione del blocco rimozione

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Alla prima installazione di Sophos Endpoint Security and Control, il blocco rimozione è disabilitato. Se si è SophosAdministrator, è possibile abilitare il blocco rimozione.

Per abilitare il blocco rimozione:

  1. Sulla Pagina iniziale, sotto Blocco rimozione, cliccare su Configura blocco rimozione.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nella finestra di dialogo Configurazione blocco rimozione, mettere la spunta nella casella Attiva blocco rimozione.
  3. Cliccare su Imposta sotto la casella Password. Immettere e confermare una nuova password nella finestra di dialogo Password del blocco rimozione.
    Suggerimento: La password deve contenere un minimo di otto caratteri, e devono essere presenti numeri e lettere maiuscole e minuscole.
Argomento precedente: Il blocco rimozione in questo computer
Argomento successivo: Disabilitazione del blocco rimozione


Disabilitazione del blocco rimozione

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

I membri del gruppo SophosAdministrator possono disabilitare il blocco rimozione.

Disabilitazione del blocco rimozione:

  1. Se non è stata ancora eseguita la procedura di autenticazione, e non è disponibile l'opzione Configura blocco rimozione nella Pagina iniziale, seguire le istruzioni riportate nella sezione Inserimento della password del blocco rimozione per configurare il software prima di passare alla fase 2.
  2. Sulla Pagina iniziale, sotto Blocco rimozione, cliccare su Configura blocco rimozione.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  3. Nella finestra di dialogo Configurazione blocco rimozione, selezionare o deselezionare la casella di spunta Attiva blocco rimozione e cliccare su OK.
Argomento precedente: Abilitazione del blocco rimozione
Argomento successivo: Riattivazione del blocco rimozione


Riattivazione del blocco rimozione

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Se si appartiene al gruppo SophosAdministrator, è possibile riattivare il blocco rimozione.

Per riattivare il blocco rimozione:

  1. Sulla Pagina iniziale, sotto Blocco rimozione, cliccare su Autenticare utente.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nella finestra di dialogo Autenticazione blocco rimozione, inserire la password del blocco rimozione e cliccare su OK.
  3. Sulla Pagina iniziale, sotto Blocco rimozione, cliccare su Configura blocco rimozione.
  4. Nella finestra di dialogo Configurazione blocco rimozione, mettere la spunta nella casella Attiva blocco rimozione.
Argomento precedente: Disabilitazione del blocco rimozione
Argomento successivo: Password del blocco rimozione


Password del blocco rimozione

Quando il blocco rimozione è attivo, è necessario immetterne la password se si desidera disattivare il blocco rimozione, o configurare la scansione in accesso e il rilevamento di comportamenti sospetti. È necessario essere membri del gruppo SophosAdministrator per fare ciò.

La password del blocco rimozione deve essere immessa solo dopo aver aperto Sophos Endpoint Security and Control. Se si chiude e poi si riapre Sophos Endpoint Security and Control, è necessario immettere nuovamente la password del blocco rimozione.

Se si desidera disinstallare uno dei componenti di Sophos Endpoint Security and Control, è necessario immettere la password del blocco rimozione prima di poter disabilitare il blocco rimozione e disinstallare il software.

Se il blocco rimozione è disattivato, ma la password del blocco rimozione è stata impostata in precedenza, è necessario inserire la password prima di riattivare il blocco rimozione.

Per abilitare il blocco rimozione è necessario immetterne la password, se:

  • In precedenza si è abilitato il blocco rimozione, creata una password per esso, e poi lo si è disabilitato.
  • Una password del blocco rimozione è stata creata nella console di gestione, ma il blocco rimozione non è attivo.
Argomento precedente: Riattivazione del blocco rimozione
Argomento successivo: Inserimento della password del blocco rimozione per configurare il software


Inserimento della password del blocco rimozione per configurare il software

Se si appartiene al gruppo SophosAdministrator, è possibile autenticarsi inserendo la password del blocco rimozione.

Per autenticarsi:

  1. Sulla Pagina iniziale, sotto Blocco rimozione, cliccare su Autenticare utente.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nella finestra di dialogo Autenticazione blocco rimozione, inserire la password del blocco rimozione e cliccare su OK.
Argomento precedente: Password del blocco rimozione
Argomento successivo: Cambiamento della password del blocco rimozione


Cambiamento della password del blocco rimozione

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

È necessario essere membri del gruppo SophosAdministrator per cambiare la password del blocco rimozione.

Per cambiare la password del blocco rimozione

  1. Se non è stata ancora eseguita la procedura di autenticazione, e non è disponibile l'opzione Configura blocco rimozione nella Pagina iniziale, seguire le istruzioni riportate nella sezione Inserimento della password del blocco rimozione per configurare il software prima di passare alla fase 2.
  2. Sulla Pagina iniziale, sotto Blocco rimozione, cliccare su Configura blocco rimozione.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  3. Nella finestra di dialogo Configurazione blocco rimozione, cliccare su Cambia sotto la casella Password.
  4. Immettere e confermare una nuova password nella finestra di dialogo Password blocco rimozione.
    Suggerimento: La password deve essere lunga almeno otto caratteri, e deve contenere numeri e lettere maiuscole e minuscole.
Argomento precedente: Inserimento della password del blocco rimozione per configurare il software
Argomento successivo: Disinstallazione del software di sicurezza Sophos


Disinstallazione del software di sicurezza Sophos

Se si appartiene al gruppo SophosAdministrator, è possibile disinstallare il software di sicurezza Sophos utilizzando il Pannello di Controllo:

  • I componenti di Sophos Endpoint Security and Control (Sophos Anti-Virus, Sophos Client Firewall, Sophos AutoUpdate, Sophos Remote Management System).
  • Sophos SafeGuard Disk Encryption

Per disinstallare il software di sicurezza Sophos quando è abilitato il blocco rimozione:

  1. Sulla Pagina iniziale, sotto Blocco rimozione, cliccare su Autenticare utente.
    Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
  2. Nella finestra di dialogo Autenticazione blocco rimozione, inserire la password del blocco rimozione e cliccare su OK.
  3. Sulla Pagina iniziale, sotto Blocco rimozione, cliccare su Configura blocco rimozione.
  4. Nella finestra di dialogo Configurazione blocco rimozione, selezionare o deselezionare la casella di spunta Attiva blocco rimozione e cliccare su OK.
    Il blocco rimozione è disattivato.
  5. Nel Pannello di controllo, aprire Installazione applicazioni, individuare il software che si desidera rimuovere e cliccare su Cambia/Rimuovi or Rimuovi. Seguire le istruzioni sullo schermo per disinstallare il software.
Argomento precedente: Cambiamento della password del blocco rimozione
Argomento successivo: Visualizzazione del log del blocco rimozione:


Visualizzazione del log del blocco rimozione:

Il log del blocco rimozione mostra due tipi di evento:

  • Per gli eventi di autenticazione del blocco rimozione riusciti, viene riportato il nome dell'utente autenticato e l'orario dell'autenticazione.
  • Nel caso si tentativi di sabotaggio falliti vengono riportati i nomi dei componenti o dei prodotti Sophos oggetto di attacco, l'orario del tentativo e i dettagli dell'utente responsabile di tale tentativo.

È necessario essere membri del gruppo SophosAdministrator per visualizzare il log del blocco rimozione.

Visualizzazione del log del blocco rimozione:

Sulla Pagina iniziale, sotto Blocco rimozione, cliccare su Visualizza log del blocco rimozione.
Per informazioni sulla Pagina iniziale, consultare la sezione Pagina iniziale.
Dalla pagina log, è possibile copiare il log negli appunti, oppure inviarlo per e-mail o stamparlo.

Per trovare un testo specifico all'interno del log, cliccare su Trova e inserire il testo desiderato.

Argomento precedente: Disinstallazione del software di sicurezza Sophos
Argomento successivo: Mancato funzionamento di un aggiornamento


Mancato funzionamento di un aggiornamento

Per ottenere maggiori dettagli sul mancato funzionamento degli aggiornamenti, controllare il log degli aggiornamenti; per ulteriori informazioni su come svolgere questa operazione, consultare la sezione Visualizzazione del file di log degli aggiornamenti.

Le sezioni seguenti spiegano la ragione per cui l'aggiornamento può non riuscire, e come modificare le impostazioni per risolvere il problema.

  • Sophos Endpoint Security and Control si collega alla fonte degli aggiornamenti sbagliata
  • Sophos Endpoint Security and Control non può utilizzare il server proxy
  • L'aggiornamento automatico non è pianificato in modo corretto
  • Il mantenimento della fonte degli aggiornamenti non viene curato
Argomento precedente: Visualizzazione del log del blocco rimozione:
Argomento successivo: Sophos Endpoint Security and Control si collega alla fonte degli aggiornamenti sbagliata


Sophos Endpoint Security and Control si collega alla fonte degli aggiornamenti sbagliata

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Nella scheda Percorso primario, verificare che i dati relativi all'indirizzo e all'account siano quelli forniti dall'amministratore.
    Per informazioni sulla configurazione del Percorso primario, consultare la sezione Impostazione di una fonte per gli aggiornamenti.
Argomento precedente: Mancato funzionamento di un aggiornamento
Argomento successivo: Sophos Endpoint Security and Control non può utilizzare il server proxy


Sophos Endpoint Security and Control non può utilizzare il server proxy

Se Sophos Endpoint Security and Control esegue l'aggiornamento via Internet, è necessario accertarsi che possa utilizzare un eventuale server proxy.

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Nella scheda Percorso primario, cliccare su Dati proxy.
  3. Verificare che l'indirizzo del server proxy, il numero della porta e i dati dell'account siano corretti.
    Per informazioni su come inserire i dati del server proxy, consultare la sezione Aggiornamento tramite server proxy.
Argomento precedente: Sophos Endpoint Security and Control si collega alla fonte degli aggiornamenti sbagliata
Argomento successivo: L'aggiornamento automatico non è pianificato in modo corretto


L'aggiornamento automatico non è pianificato in modo corretto

  1. Nel menu Configura, cliccare su Aggiornamento.
  2. Cliccare sulla scheda Pianificazione (per informazioni sulla scheda Operazione pianificata, v. Pianificazione degli aggiornamenti).
  3. Se il computer è collegato alla rete, oppure se si esegue l'aggiornamento tramite una connessione Internet a banda larga, selezionare Consenti aggiornamenti automatici e inserire la frequenza di aggiornamento. Se si esegue l'aggiornamento tramite una connessione via modem, selezionare Verifica la disponibilità di aggiornamenti in fase di connessione.
Argomento precedente: Sophos Endpoint Security and Control non può utilizzare il server proxy
Argomento successivo: Il mantenimento della fonte degli aggiornamenti non viene curato


Il mantenimento della fonte degli aggiornamenti non viene curato

La propria azienda potrebbe aver spostato la directory (sulla rete o su un server web) dalla quale si eseguono gli aggiornamenti. In alternativa, è possibile che l'azienda non curi affatto il mantenimento della directory.

Se si ritiene che sia proprio questo il caso, contattare l'amministratore di rete.

Argomento precedente: L'aggiornamento automatico non è pianificato in modo corretto
Argomento successivo: Minaccia non disinfettata


Minaccia non disinfettata

Se Sophos Anti-Virus non ha eseguito la disinfezione di una minaccia dal computer, ciò potrebbe essere dovuto a una delle seguenti cause.

Disinfezione automatica disabilitata

Se Sophos Anti-Virus non ha tentato la disinfezione, verificare che la disinfezione automatica sia stata abilitata. Per informazioni su come abilitare la disinfezione automatica, consultare le seguenti sezioni:
  • Configurazione della disinfezione in accesso
  • Configurazione della disinfezione dal menu del tasto destro del mouse
  • Configurazione della disinfezione per una scansione personalizzata

la rimozione automatica di adware e PUA non è disponibile per la scansione in accesso.

Disinfezione non riuscita

Se Sophos Anti-Virus non ha rimosso una minaccia ("Disinfezione non riuscita"), potrebbe non riuscire ad eseguire la disinfezione di quel tipo specifico di minaccia o l'utente potrebbe non essere in possesso di diritti di accesso sufficienti.

Esecuzione di una scansione completa del computer

Prima che Sophos Anti-Virus esegua la disinfezione di una minaccia multicomponente dal computer, o possa rilevare una minaccia nei file precedentemente nascosti, potrebbe essere necessario eseguire una scansione completa del computer che consenta di determinare tutti i componenti della minaccia.

  1. Per eseguire una scansione di tutte le unità disco, inclusi i settori di avvio, eseguire la Scansione del computer. Per informazioni, consultare la sezione Esecuzione della scansione completa del computer.
  2. Se la minaccia non è stata totalmente rilevata, la causa può risiedere in diritti di accesso dell'utente insufficienti o nel fatto che alcune unità o cartelle del computer, contenenti i componenti della minaccia, siano escluse dalla scansione. Per informazioni, consultare la sezione Esclusione di oggetti dalla scansione in accesso. Controllare l'elenco degli oggetti esclusi dalla scansione. Se nell'elenco compaiono degli oggetti, rimuoverli e sottoporre di nuovo il computer a scansione.

Unità rimovibile protetta da scrittura

Se si tratta di un supporto rimovibile (per esempio un floppy disk o un CD), accertarsi che non sia protetto da scrittura.

Volume NTFS protetto da scrittura

In caso di file su un volume NTFS (Windows XP o successivo), accertarsi che questo non sia protetto da scrittura.

Segnalazione di un frammento di virus o spyware

Sophos Anti-Virus non rimuove i frammenti di virus/spyware perché non trova un'esatta corrispondenza con il virus/spyware. Consultare la sezione Segnalato frammento di virus o spyware.

Argomento precedente: Il mantenimento della fonte degli aggiornamenti non viene curato
Argomento successivo: Segnalato frammento di virus o spyware


Segnalato frammento di virus o spyware

Se viene segnalato un frammento di virus o spyware, fare quanto indicato di seguito:

  1. Aggiornare immediatamente la protezione, in modo tale che Sophos Anti-Virus possieda i file di identità dei virus più recenti.
  2. Eseguire la scansione completa del computer
  • Aggiornamento immediato
  • Esecuzione della scansione completa del computer

Se vengono segnalati ancora frammenti di virus o spyware, rivolgersi al supporto tecnico di Sophos per ricevere assistenza:

  • Supporto tecnico

La segnalazione di un frammento di virus o spyware indica che parte di un file corrisponde a parte di un virus o spyware. Le cause possibili sono tre.

Variante di un virus o spyware noto

Molti virus o spyware nuovi poggiano su esemplari esistenti, quindi frammenti di codice tipici di un virus o spyware noto possono sembrare parte di un nuovo codice. Se viene segnalato un frammento di virus o spyware, è possibile che Sophos Anti-Virus abbia rilevato un nuovo virus o spyware, che potrebbe diventare attivo.

Virus danneggiato

Molti virus contengono bug nelle loro routine di replicazione che fanno sì che questi virus infettino i file in modo non corretto. Una parte inattiva del virus (anche considerevole) potrebbe apparire all'interno del file che la ospita e venire rilevata da SophosAnti-Virus. Un virus danneggiato non riesce a diffondersi.

Database contenente un virus o spyware

Quando si esegue una scansione completa del computer, Sophos Anti-Virus può segnalare la presenza di un frammento di virus o spyware all'interno di un file di database. In questo caso, non cancellare il database. Rivolgersi al supporto tecnico di Sophos per ricevere assistenza.

Per informazioni su come contattare il supporto tecnico, consultare la sezione Supporto tecnico.

Argomento precedente: Minaccia non disinfettata
Argomento successivo: Rilevo parziale di una minaccia


Rilevo parziale di una minaccia

Per eseguire la scansione di tutte le unità disco nel computer, incluso il boot sector, eseguire la scansione completa del computer.

  • Esecuzione della scansione completa del computer
Se la minaccia non è stata totalmente rilevata, la causa può risiedere nel fatto che alcune unità o cartelle del computer, contenenti i componenti della minaccia, sono escluse dalla scansione. Se alcuni di questi oggetti sono annoverati nell'elenco delle esclusioni, rimuoverli ed eseguire nuovamente la scansione del computer.
  • Esclusione di oggetti dalla scansione su richiesta

Se la minaccia non viene ancora completamente rilevata, la causa può risiedere nel fatto che l'utente non disponga di sufficienti diritti di accesso.

Sophos Anti-Virus può non essere in grado di rilevare completamente o rimuovere le minacce i cui componenti sono installati in unità di rete.

Argomento precedente: Segnalato frammento di virus o spyware
Argomento successivo: Adware o PUA scomparsi dalla quarantena


Adware o PUA scomparsi dalla quarantena

Se un adware o PUA rilevato da Sophos Anti-Virus è scomparso dal Gestore quarantena senza che sia stata prima eseguita alcuna azione su di esso, ciò può indicare che un altro utente ha autorizzato l'adware o PUA o ha eseguito la disinfezione dalla console di gestione. Controllare l'elenco degli adware e PUA autorizzati per verificare se l'applicazione è stata autorizzata. Per indicazioni su come procedere, consultare Autorizzazione di adware e PUA.

Argomento precedente: Rilevo parziale di una minaccia
Argomento successivo: Rallentamento del computer


Rallentamento del computer

Se il computer è diventato molto lento, è possibile che un'applicazione potenzialmente indesiderata (PUA) sia in esecuzione nel computer e lo stia monitorando. Se nel computer è abilitata la scansione in accesso, è possibile inoltre che compaiano molti allarmi sul desktop relativi a un'applicazione potenzialmente indesiderata (PUA). Per risolvere il problema, procedere nel modo seguente.

  1. Eseguire la Scansione del computer per rilevare tutti i componenti dell'applicazione indesiderata (PUA). Per informazioni, consultare la sezione Esecuzione della scansione completa del computer.
    Nota: Se, dopo la scansione, l'applicazione (PUA) è stata parzialmente rilevata, consultareMinaccia parzialmente rilevata, punto 2.
  2. Rimuovere l'adware o PUA dal computer. Per informazioni su come procedere, consultare Gestione di adware e PUA in quarantena.
Argomento precedente: Adware o PUA scomparsi dalla quarantena
Argomento successivo: Accesso alle unità con settore di avvio infetti


Accesso alle unità con settore di avvio infetti

Importante: Se nel computer viene utilizzata una console di gestione per amministrare Sophos Endpoint Security and Control, questa potrebbe ignorare le modifiche qui apportate.

Per impostazione predefinita, Sophos Anti-Virus impedisce l'accesso ai supporti rimovibili i cui settori di avvio sono infetti.

Per consentire l'accesso (per es. per copiare file da un floppy infetto da virus del boot sector):

  1. Cliccare su Pagina iniziale > Antivirus e HIPS > Configura antivirus e HIPS > ConfiguraScansione in accesso.
  2. Nella scheda Scansione, selezionare la casella di spunta Consenti accesso alle unità con boot sector infetti.
Importante: Appena terminato l'accesso al disco, deselezionare la casella di spunta e rimuovere il disco dal computer, in modo tale che non provi a infettare nuovamente il computer al momento del riavvio.
Argomento precedente: Rallentamento del computer
Argomento successivo: Impossibile accedere ad alcune aree di Sophos Endpoint Security and Control


Impossibile accedere ad alcune aree di Sophos Endpoint Security and Control

Se non si riescono a utilizzare o a configurare determinate aree di Sophos Endpoint Security and Control, ciò può essere dovuto al fatto che l'accesso a queste aree sia riservato ai membri di particolari gruppi di utenti Sophos.

Per ulteriori informazioni sui gruppi di utenti Sophos, consultare la sezione Gruppi Sophos.

Argomento precedente: Accesso alle unità con settore di avvio infetti
Argomento successivo: Rimozione degli effetti collaterali dei virus


Rimozione degli effetti collaterali dei virus

La rimozione degli effetti collaterali dei virus dipende dal modo in cui il virus ha infettato il computer.

Effetti collaterali del virus

Alcuni virus non provocano effetti collaterali, altri possono avere degli effetti collaterali così gravi che è necessario ripristinare l'hard disk.

Alcuni virus alterano i dati gradualmente. Questo tipo di alterazione può essere difficile da rilevare.

Cosa fare

È molto importante leggere l'analisi del virus sul sito web di Sophos e verificare con attenzione i documenti dopo aver effettuato la disinfezione. Consultare la sezione Informazioni sulla disinfezione, per sapere come visualizzare, sul sito web di Sophos, i dettagli sugli effetti collaterali dei virus.

È essenziale disporre di copie di backup attendibili. Se non si disponeva di tali copie prima dell'infezione, è necessario cominciare a crearle e conservarle in caso di future infezioni.

Talvolta è possibile recuperare i dati dai dischi danneggiati da un virus. Sophos fornisce delle utilità per la riparazione dei danni causati da alcuni virus.

Rivolgersi al supporto tecnico di Sophos per ricevere assistenza.

Per informazioni su come contattare il supporto tecnico, consultare la sezione Supporto tecnico.

Argomento precedente: Impossibile accedere ad alcune aree di Sophos Endpoint Security and Control
Argomento successivo: Rimozione degli effetti collaterali di adware e PUA


Rimozione degli effetti collaterali di adware e PUA

La rimozione di adware e PUA può provocare alcuni effetti collaterali che non possono essere eliminati durante la disinfezione.

Sistema operativo modificato

Alcuni adware e PUA modificano il sistema operativo Windows, per esempio cambiano le impostazioni della connessione Internet. Sophos Anti-Virus non riesce sempre a ripristinare tutte le impostazioni con i valori, così com'erano prima dell'installazione dell'adware/PUA. Se, per esempio, un adware o PUA ha modificato la pagina iniziale del browser, Sophos Anti-Virus non può conoscere la pagina iniziale impostata in precedenza.

Utilità non rimosse

Alcuni adware e PUA possono installare nel computer delle utilità quali file .dll o .ocx. Se un'utilità è innocua (vale a dire, se non possiede le caratteristiche di adware e PUA), per esempio una libreria della lingua, e non è integrata nell'adware o PUA, Sophos Anti-Virus puotrebbe non rilevarla come componente dell'adware o PUA. In questo caso, il file non viene rimosso dal computer neanche dopo la rimozione dell'adware o PUA che l'ha installato.

Adware o PUA facente parte di un programma necessario

Talvolta un oggetto, adware o PUA, fa parte di un programma installato intenzionalmente, ed è necessario affinché il programma funzioni correttamente. Se si rimuove l'adware o PUA, il programma potrebbe non venire più eseguito nel computer.

Cosa fare

È molto importante leggere l'analisi della minaccia pubblicata sul sito web di Sophos. Consultare Informazioni sulla disinfezione per scoprire come visualizzare, sul sito web di Sophos, i dettagli sugli effetti collateralii di adware o PUA.

Per poter ripristinare il sistema e le sue impostazioni così com'erano inizialmente, è necessario eseguire periodicamente il backup del sistema. È inoltre necessario eseguire copie di backup dei file eseguibili originali dei programmi che si desidera utilizzare.

Per ulteriori informazioni o consigli su come ovviare agli effetti collaterali di adware e PUA, rivolgersi al supporto tecnico di Sophos.

Per informazioni su come contattare il supporto tecnico, consultare la sezione Supporto tecnico.

Argomento precedente: Rimozione degli effetti collaterali dei virus
Argomento successivo: Segnalato errore della password


Segnalato errore della password

Se si cerca di pianificare una scansione personalizzata e viene visualizzato un messaggio di errore relativo alla password, assicurarsi che:

  • La password sia quella relativa all'account utente
  • La password non sia vuota

Per assicurarsi che la password sia corretta, verificare le proprietà dell'account utente in Account utente, nel Pannello di controllo.

Argomento precedente: Rimozione degli effetti collaterali di adware e PUA
Argomento successivo: Messaggio di errore "Errore nel servizio"


Messaggio di errore "Errore nel servizio"

Sintomi

Nell'area di notifica viene visualizzato uno dei seguenti messaggi di errore:
  • Antivirus e HIPS: errore del servizio
  • Firewall: errore del servizio

Cause

Si è verificato un errore in uno dei servizi di Sophos Endpoint Security and Control e il computer deve essere riavviato.

Soluzione del problema

  1. Tramite Windows, aprire Servizi.
  2. Effettuare una delle seguenti operazioni:
    • Se viene visualizzato il messaggio d'errore Antivirus e HIPS: errore del servizio , cliccare col tasto destro del mouse su Sophos Anti-Virus e quindi su Riavvia.
    • Se viene visualizzato il messaggio d'errore Firewall: errore nel servizio , cliccare col tasto destro del mouse su Sophos Client Firewall e quindi su Riavvia.

Note

  • Per aprire Servizi, cliccare su Start, successivamente su Pannello di controllo, cliccare due volte su Strumenti di amministrazione e poi due volte su Servizi.
Argomento precedente: Segnalato errore della password
Argomento successivo: Il database del log firewall è danneggiato


Il database del log firewall è danneggiato

Sintomi

Mentre si utilizza il visualizzatore di log del firewall, compare il messaggio di errore:"L'attuale log del database di Sophos Client Firewall è danneggiato".

Causa

Il database del log eventi del firewall è danneggiato, e deve essere ricreato.

Soluzione del problema

Per svolgere le seguenti operazioni, è necessario essere membri del gruppo Windows Administrators nel computer in questione.

  1. Tramite Windows, aprire Servizi.
  2. Cliccare col tasto destro del mouse su Sophos Client Firewall Manager, e quindi su Arresta.

  3. Mediante Windows Explorer, andare su C:\Documents and Settings\All Users\Application Data\Sophos\Sophos Client Firewall\logs.

    Per visualizzare questa cartella nascosta, può essere necessario impostare in Windows Explorer la visualizzazione di file e cartelle nascosti.

  4. Cancellare op_data.mdb.
  5. In "Servizi", cliccare con il tasto destro del mouse su Sophos Client Firewall Manager, e poi su Avvia.

Note

  • Per aprire Servizi, cliccare su Start, successivamente su Pannello di controllo, cliccare due volte su Strumenti di amministrazione e poi due volte su Servizi.
Argomento precedente: Messaggio di errore "Errore nel servizio"
Argomento successivo: Glossario


Glossario

adware e PUA
L'adware prevede la presentazione all'utente di messaggi pubblicitari, quali messaggi popup, che incidono sulla produttività degli utenti e sull'efficienza del sistema. Un'applicazione potenzialmente indesiderata (PUA) è un'applicazione che di per sé non è malevola, ma viene generalmente considerata inadatta per la maggior parte delle reti aziendali.
analisi del comportamento in fase di esecuzione
Analisi dinamica svolta tramite il rilevamento del comportamento sospetto e del buffer overflow.
applicazione attendibile
Applicazione a cui è concesso accesso alla rete completo e incondizionato.
applicazione controllata
Un'applicazione la cui esecuzione nel computer è impedita dai criteri di sicurezza aziendali.
applicazioni bloccate
Stato che indica la negazione dell'accesso alla rete ad applicazioni (inclusi i processi nascosti), connessioni, protocolli, messaggi ICMP ecc.
barra delle descrizioni
Barra del visualizzatore del log che si trova sopra la vista dei dati e che contiene il nome dell'elemento della vista ad albero selezionato.
blocco rimozione
Una funzione che impedisce a malware noto e utenti non autorizzati (amministratori locali e utenti con conoscenze tecniche limitate), la disinstallazione del software di sicurezza Sophos o la disabilitazione tramite interfaccia di Sophos Endpoint Security and Control.
checksum
Ogni versione di un'applicazione ha un checksum unico. Il firewall può utilizzare tale checksum per decidere se un'applicazione è consentita o meno.
configurazione primaria
La configurazione del firewall utilizzata per la rete aziendale a cui l'utente si collega per svolgere il suo lavoro giornaliero.
configurazione secondaria
La configurazione del firewall utilizzata quando gli utenti non sono connessi alla rete aziendale primaria, ma a una rete differente, quale la rete wireless di un hotel o aeroporto, oppure un'altra rete aziendale.
content Control List (CCL)
Un set di condizioni che specificano il contenuto di un file, per esempio numeri di carte di credito o debito (bancomat) o conti corrente bancari simili ad altri tipi di dati che possono portare all'identificazione personale. Esistono due tipi di Content Control List: Il Content Control List di SophosLabs e quello personalizzato.
controllo dati
Funzione che riduce il rischio di perdita di dati accidentale dalle workstation. Questa funzione entra in azione quando l'utente di una workstation tenta di trasferire un file che soddisfa i parametri stabiliti da criteri e regole di controllo dei dati. Per esempio quando un utente cerca di copiare in un dispositivo di memorizzazione removibile un foglio elettronico contenente dati relativi ai clienti o cerca di caricare un documento contrassegnato come confidenziale in un account di web mail; in questi casi la funzione di controllo dei dati, se configurata in tal senso, bloccherà il trasferimento.
controllo dispositivi
Funzione che riduce la perdita accidentale di informazioni dalle workstation e che limita l'introduzione di software esterni alla rete. Entra in azione quando l'utente di una workstation tenta di utilizzare nella propria workstation dispositivi di memorizzazione o di rete non autorizzati.
corrispondenza
Equivale al contenuto definito in un Content Control List.
criteri firewall
Impostazioni volute dalla console di gestione e che il firewall utilizza per monitorare la connessione del computer a Internet e ad altre reti.
disinfezione
La disinfezione elimina le minacce presenti nel computer rimuovendo i virus da file e boot sector, spostando o cancellando un file sospetto, o cancellando un oggetto adware o PUA. Non è disponibile per le minacce rilevate tramite la scansione della pagina web perché le minacce non vengono scaricate nel computer. Non è quindi necessaria alcuna azione.
disinfezione automatica
Disinfezione svolta senza l'intervento o il consenso dell'utente.
disinfezione manuale
Disinfezione svolta tramite utilità di disinfezione specifiche o cancellando i file manualmente.
dispositivi di memorizzazione
Dispositivi di memorizzazione rimovibili (per es. unità USB flash, lettori di schede per PC e unità hard disk USB), unità CD/DVD, unità floppy disk e dispositivi di memorizzazione rimovibili sicuri (per es. unità SanDisk Cruzer Enterprise, Kingston Data Traveller, IronKey Enterprise e IronKey Basic USB flash con cifratura dell'hardware).
errore della scansione
Errore verificatosi durante la scansione di un file, per esempio quando viene negato l'accesso.
evento firewall
Situazione che si verifica nel computer quando un'applicazione sconosciuta, o il sistema operativo, prova a comunicare con un altro computer tramite connessione di rete in una modalità non specificamente richiesta dalle applicazioni in esecuzione nel computer ricevente.
evento minaccia
Rilevamento o disinfezione di una minaccia.
file di identità del virus (IDE)
File che consente a Sophos Anti-Virus di rilevare e rimuovere un determinato virus, trojan o worm.
file sospetto
File che presenta una serie di caratteristiche comunemente, ma non esclusivamente, riscontrate in virus.
finestra di apprendimento
Una finestra di dialogo che chiede all'utente di scegliere se consentire o bloccare l'attività di rete quando un'applicazione sconosciuta richiede l'accesso alla rete. Questa funzione è applicabile solo a Sophos Client Firewall per Windows 7 e precedenti.
gestore autorizzazioni
Il modulo che consente di autorizzare adware e PUA, file sospetti, applicazioni sospette o buffer overflow.
gestore quarantena
Il modulo che consente di visualizzare e gestire gli elementi messi in quarantena.
Host Intrusion Prevention System (HIPS)
Termine generale che indica l'analisi del comportamento prima dell'esecuzione ed in fase di esecuzione.
ICMP
Acronimo di "Internet Control Message Protocol." Un protocollo del livello di rete che fornisce la correzione di errori e altre informazioni relative all'elaborazione dei pacchetti IP.
impostazioni cancellazione log
Impostazioni che controllano quando i dati vengono cancellati.
impostazioni ICMP
Le impostazioni che determinano quali tipi di comunicazione di gestione della rete sono consentiti.
impostazioni processo
Impostazioni che determinano se a processi modificati o nascosti debba essere concesso accesso alla rete.
ispezione di stato
Tecnologia firewall che consente di aggiornare la tabella relativa alle connessioni di rete TCP e UDP attive. Il firewall consentirà l'accesso solo ai pacchetti che soddisfano uno stato di connessione noto; tutti gli altri verranno rifiutati.
memoria di sistema
Memoria che funge da ponte fra le applicazioni e l'elaborazione dei dati svolta a livello di hardware. Viene utilizzata dal sistema operativo.
messaggistica istantanea
Categoria di applicazioni controllate che comprende applicazioni di messaggistica istantanea (per es. MSN).
modalità di funzionamento
Impostazione che stabilisce se il firewall agisce in base all'input da parte dell'utente (modalità interattiva) o automaticamente (modalità non interattive). In Sophos Client Firewall per Windows 8 e successivi è stata rimossa la modalità interattiva.
modalità interattiva
La modalità in cui il firewall visualizza una o più finestre di apprendimento quando viene rilevato traffico di rete per cui non esiste alcuna regola. Questa funzione è applicabile solo a Sophos Client Firewall per Windows 7 e precedenti.
modalità non interattiva
Modalità in cui il firewall consente o blocca tutto il traffico di rete per cui non è stata rilevata alcuna regola.
NetBIOS
Acronimo di "Network Basic Input/Output System." Software che fornisce un'interfaccia tra il sistema operativo, il bus di I/O e la rete. Quasi tutte le LAN basate su Windows sono basate su NetBIOS.
processo nascosto
Un'applicazione a volte ne avvia un'altra che svolga delle operazioni di accesso alla rete per lei. Applicazioni malevole possono utilizzare questa tecnica per aggirare i firewall; possono infatti lanciare un'applicazione ritenuta affidabile per accedere alla rete invece che tentare da sole.
protocollo di rete
Set di regole o standard progettati per consentire ai computer di connettersi tramite la rete e di scambiare informazioni col minor margine di errore possibile.
raw socket
I raw socket consentono ai processi di controllare tutti gli aspetti dei dati che inviano in rete e possono essere utilizzati per scopi malevoli.
regola con elevata priorità
Regola applicata prima di qualsiasi regola globale o di applicazione.
regola dei contenuti
Regola comprendente una o più Content Control List e indicante l'azione da intraprendere se l'utente cerca di trasferire in una destinazione specificata i dati che soddisfano tutte le Content Control List presenti nella regola.
regola dell'applicazione
Una regola applicabile solo a pacchetti di dati trasferiti attraverso la rete a o da una particolare applicazione.
regola di sistema
Regola applicata a tutte le applicazioni che consentirà o bloccherà le attività di rete di livello basso.
regola personalizzata
Regola creata dall'utente per indicare le circostanze in cui l'esecuzione di un'applicazione è consentita.
regole globali
Regole applicate a tutte le connessioni di rete e applicazioni non ancora in possesso di regole specifiche. Hanno priorità minore delle regole impostate nella pagina della LAN. Hanno priorità minore anche delle regole delle applicazioni (a meno che non diversamente indicato dall'utente).
reputazione del download
Reputazione dei file scaricati da Internet. La reputazione viene definita in base all'età dei file, alle loro fonti e prevalenza, oltre che a un'approfondita analisi dei contenuti e ad altre caratteristiche specifiche. È un utile supporto per stabilire se i file siano sicuri o se il loro download rappresenti un potenziale rischio per i computer.
Rilevamento del traffico malevolo
Una funzionalità che consente di rilevare le comunicazioni fra computer compromessi e server command and control degli hacker.
rilevamento di buffer overflow
Rileva attacchi di buffer overflow.
rilevamento di comportamento sospetto
Analisi dinamica del comportamento di tutti i programmi in esecuzione sul sistema al fine di rilevare e bloccare le attività che appaiono malevole.
rootkit
Trojan o tecnologia utilizzata per nascondere la presenza di un oggetto malevolo (processo, file, chiave di registro o porta di rete) all'utente del computer o all'amministratore.
scansione completa
Scansiona tutte le parti di ciascun file.
Scansione dal menu del tasto destro del mouse
Scansione di file in Windows Explorer o nel desktop eseguiti tramite menu.
scansione in accesso
Il vostro principale metodo di protezione contro virus e altre minacce.. Ogni qual volta si copia, sposta e accede a un file, oppure si avvia un programma, Sophos Anti-Virus ne esegue la scansione e ne consente l'accesso solo se tale file non costituisce una minaccia per il computer o se autorizzato per l'utilizzo.
scansione normale
Scansiona solo le parti del file con maggiori probabilità di essere infettate da virus.
scansione pianificata
Scansione del computer, o di parti di esso, eseguita ad orari fissi.
scansione su richiesta
Scansione avviata dall'utente. È possibile utilizzare la scansione su richiesta per sottoporre a scansione qualsiasi elemento, da un solo file a tutto ciò che è contenuto nel proprio computer e per cui si dispone di autorizzazione per la lettura.
Sophos Live Protection
Funzione che utilizza la tecnologia "in-the-cloud" per decidere all'istante se un file sospetto rappresenta una minaccia e intraprendere l'azione specificata nella configurazione di disinfezione di Sophos Anti-Virus.
spyware
Programma che si autoinstalla nel computer di un utente utilizzando sotterfugi o tecniche di ingegneria sociale, per poi inviare informazioni da quel computer a terzi, senza il consenso dell'utente o a sua insaputa.
tipo file true
Il tipo di file che viene verificato tramite l'analisi della sua struttura piuttosto che dell'estensione del nome. Si tratta di un metodo più affidabile.
traffico sconosciuto
Forma di accesso alla rete da parte di un'applicazione o servizio per cui il firewall non ha rilevato alcuna regola.
virus non identificato
Virus per il quale non esiste uno specifico file di identità.
vista ad albero
Vista che controlla quali dati il visualizzatore di log mostra nella propria vista dei dati.
vista dati
Vista che mostra dati diversi a seconda dell'elemento della vista ad albero selezionato.
visualizzatore del log
Visualizzazione dei dati relativi agli eventi del database quali connessioni consentite o bloccate, il log di sistema e tutti gli allarmi che sono stati generati.
voice over IP
Categoria di applicazioni controllate che comprende applicazioni di Voice over IP.
Argomento precedente: Il database del log firewall è danneggiato
Argomento successivo: Supporto tecnico


Supporto tecnico

È possibile ricevere supporto tecnico per i prodotti Sophos in uno dei seguenti modi:

  • Visitando Sophos Community su community.sophos.com/ e cercando altri utenti con lo stesso problema.
  • Visitando la knowledge base del supporto Sophos su www.sophos.com/it-it/support.aspx.
  • Scaricando la documentazione del prodotto su www.sophos.com/it-it/support/documentation.aspx.
  • Aprendo un ticket per il nostro supporto tecnico alla pagina https://secure2.sophos.com/it-it/support/contact-support/support-query.aspx.
Argomento precedente: Glossario
Argomento successivo: Note legali


Note legali

Copyright © 1989-2016 Sophos Limited. Tutti i diritti riservati. Nessuna parte di questa pubblicazione può essere riprodotta, memorizzata in un sistema di recupero informazioni, o trasmessa, in qualsiasi forma o con qualsiasi mezzo, elettronico o meccanico, inclusi le fotocopie, la registrazione e altri mezzi, salvo che da un licenziatario autorizzato a riprodurre la documentazione in conformità con i termini della licenza, oppure previa autorizzazione scritta del titolare dei diritti d'autore.

Sophos, Sophos Anti-Virus e SafeGuard sono marchi registrati di Sophos Limited, Sophos Group e Utimaco Safeware AG. Tutti gli altri nomi citati di società e prodotti sono marchi o marchi registrati dei rispettivi titolari.

Apache

The Sophos software that is described in this document may include some software programs that are licensed (or sublicensed) to the user under the Apache License. A copy of the license agreement for any such included software can be found at http://www.apache.org/licenses/LICENSE-2.0

Boost C++ Libraries

Boost Software License - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or organization obtaining a copy of the software and accompanying documentation covered by this license (the “Software”) to use, reproduce, display, distribute, execute, and transmit the Software, and to prepare derivative works of the Software, and to permit third-parties to whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement, including the above license grant, this restriction and the following disclaimer, must be included in all copies of the Software, in whole or in part, and all derivative works of the Software, unless such copies or derivative works are solely in the form of machine-executable object code generated by a source language processor.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Common Public License

Il software Sophos descritto in questo documento comprende o può comprendere programmi di software concessi in licenza (o sottolicenza) all'utente secondo i termini della Common Public License (CPL), la quale, tra gli altri diritti, permette all'utente di avere accesso al codice sorgente. La CPL richiede, per qualsiasi software concesso in licenza secondo i termini della stessa, e distribuito in formato codice oggetto, che il codice sorgente di tale software venga messo a disposizione anche degli altri utenti del formato codice oggetto. Per qualsiasi software che rientri nei termini della CPL, il codice sorgente è disponibile tramite ordine postale inviandone richiesta a Sophos; per e-mail a support@sophos.it o tramite internet su http://www.sophos.com/it-it/support/contact-support.aspx. Una copia dei termini per tali software è reperibile all'indirizzo http://opensource.org/licenses/cpl1.0.php

ConvertUTF

Copyright 2001–2004 Unicode, Inc.

This source code is provided as is by Unicode, Inc. No claims are made as to fitness for any particular purpose. No warranties of any kind are expressed or implied. The recipient agrees to determine applicability of information provided. If this file has been purchased on magnetic or optical media from Unicode, Inc., the sole remedy for any claim will be exchange of defective media within 90 days of receipt.

Unicode, Inc. hereby grants the right to freely use the information supplied in this file in the creation of products supporting the Unicode Standard, and to make copies of this file in any form for internal or external distribution as long as this notice remains attached.

crt

# $FreeBSD$
# @(#)COPYRIGHT 8.2 (Berkeley) 3/21/94

The compilation of software known as FreeBSD is distributed under the following terms:

Copyright (c) 1992-2013 The FreeBSD Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the DOCUMENTATION and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The 4.4BSD and 4.4BSD-Lite software is distributed under the following terms:

All of the documentation and software included in the 4.4BSD and 4.4BSD-Lite Releases is copyrighted by The Regents of the University of California.

Copyright 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994 The Regents of the University of California. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgement: This product includes software developed by the University of California, Berkeley and its contributors.
  4. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The Institute of Electrical and Electronics Engineers and the American National Standards Committee X3, on Information Processing Systems have given us permission to reprint portions of their documentation.

In the following statement, the phrase "this text" refers to portions of the system documentation.

Portions of this text are reprinted and reproduced in electronic form in the second BSD Networking Software Release, from IEEE Std 1003.1-1988, IEEE Standard Portable Operating System Interface for Computer Environments (POSIX), copyright C 1988 by the Institute of Electrical and Electronics Engineers, Inc. In the event of any discrepancy between these versions and the original IEEE Standard, the original IEEE Standard is the referee document.

In the following statement, the phrase "This material" refers to portions of the system documentation. This material is reproduced with permission from American National Standards Committee X3, on Information Processing Systems. Computer and Business Equipment Manufacturers Association (CBEMA), 311 First St., NW, Suite 500, Washington, DC 20001-2178. The developmental work of Programming Language C was completed by the X3J11 Technical Committee.

The views and conclusions contained in the software and documentation are those of the authors and should not be interpreted as representing official policies, either expressed or implied, of the Regents of the University of California.

NOTE: The copyright of UC Berkeley's Berkeley Software Distribution ("BSD") source has been updated. The copyright addendum may be found at fttp://ftp.cs.berkeley.edu/pub/4bsd/README.Impt.License. Change and is included below.

July 22, 1999

To All Licensees, Distributors of Any Version of BSD:

As you know, certain of the Berkeley Software Distribution ("BSD") source code files require that further distributions of products containing all or portions of the software, acknowledge within their advertising materials that such products contain software developed by UC Berkeley and its contributors.

Specifically, the provision reads:

"3. All advertising materials mentioning features or use of this software must display the following acknowledgement: This product includes software developed by the University of California, Berkeley and its contributors."

Effective immediately, licensees and distributors are no longer required to include the acknowledgement within advertising materials. Accordingly, the foregoing paragraph of those BSD Unix files containing it is hereby deleted in its entirety.

William Hoskins
Director, Office of Technology Licensing
University of California, Berkeley

dtoa.c

The author of this software is David M. Gay.

Copyright © 1991, 2000 by Lucent Technologies.

Permission to use, copy, modify, and distribute this software for any purpose without fee is hereby granted, provided that this entire notice is included in all copies of any software which is or includes a copy or modification of this software and in all copies of the supporting documentation for such software.

THIS SOFTWARE IS BEING PROVIDED "AS IS", WITHOUT ANY EXPRESS OR IMPLIED WARRANTY. IN PARTICULAR, NEITHER THE AUTHOR NOR LUCENT MAKES ANY REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.

ICU

ICU version 1.8.1 or later

COPYRIGHT AND PERMISSION NOTICE

Copyright © 1995–2008 International Business Machines Corporation and others

All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.

All trademarks and registered trademarks mentioned herein are the property of their respective owners.

IEEE Software Taggant Library

This software was developed by The Institute of Electrical and Electronics Engineers, Incorporated (IEEE), through the Industry Connections Security Group (ICSG) of its Standards Association. Portions of it include software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/), and those portions are governed by the OpenSSL Toolkit License.

IEEE License

Copyright (c) 2012 IEEE. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

    "This product includes software developed by the IEEE Industry Connections Security Group (ICSG)".

  4. The name "IEEE" must not be used to endorse or promote products derived from this software without prior written permission from the IEEE Standards Association (stds.ipr@ieee.org).
  5. Products derived from this software may not contain "IEEE" in their names without prior written permission from the IEEE Standards Association (stds.ipr@ieee.org).
  6. Redistributions of any form whatsoever must retain the following acknowledgment:

    "This product includes software developed by the IEEE Industry Connections Security Group (ICSG)".

THIS SOFTWARE IS PROVIDED "AS IS" AND "WITH ALL FAULTS." IEEE AND ITS CONTRIBUTORS EXPRESSLY DISCLAIM ALL WARRANTIES AND REPRESENTATIONS, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION: (A) THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE; (B) ANY WARRANTY OF NON-INFRINGEMENT; AND (C) ANY WARRANTY WITH RESPECT TO THE QUALITY, ACCURACY, EFFECTIVENESS, CURRENCY OR COMPLETENESS OF THE SOFTWARE.

IN NO EVENT SHALL IEEE OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES, (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE AND REGARDLESS OF WHETHER SUCH DAMAGE WAS FORESEEABLE.

THIS SOFTWARE USES STRONG CRYPTOGRAPHY, WHICH MAY BE SUBJECT TO LAWS AND REGULATIONS GOVERNING ITS USE, EXPORTATION OR IMPORTATION. YOU ARE SOLELY RESPONSIBLE FOR COMPLYING WITH ALL APPLICABLE LAWS AND REGULATIONS, INCLUDING, BUT NOT LIMITED TO, ANY THAT GOVERN YOUR USE, EXPORTATION OR IMPORTATION OF THIS SOFTWARE. IEEE AND ITS CONTRIBUTORS DISCLAIM ALL LIABILITY ARISING FROM YOUR USE OF THE SOFTWARE IN VIOLATION OF ANY APPLICABLE LAWS OR REGULATIONS.

Info-ZIP

Copyright © 1990–2007 Info-ZIP. Tutti i diritti riservati.

For the purposes of this copyright and license, “Info-ZIP” is defined as the following set of individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ed Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White

This software is provided “as is,” without warranty of any kind, express or implied. In no event shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential damages arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

  1. Redistributions of source code must retain the above copyright notice, definition, disclaimer, and this list of conditions.
  2. Redistributions in binary form (compiled executables and libraries) must reproduce the above copyright notice, definition, disclaimer, and this list of conditions in documentation and/or other materials provided with the distribution. The sole exception to this condition is redistribution of a standard UnZipSFX binary (including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this license, as long as the normal SFX banner has not been removed from the binary or disabled.
  3. Altered versions—including, but not limited to, ports to new operating systems, existing ports with new graphical interfaces, versions with modified or added functionality, and dynamic, shared, or static library versions not from Info-ZIP—must be plainly marked as such and must not be misrepresented as being the original source or, if binaries, compiled from the original source. Such altered versions also must not be misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered versions with the names "Info-ZIP" (or any variation thereof, including, but not limited to, different capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP. Such altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or the Info-ZIP URL(s), such as to imply Info-ZIP will provide support for the altered versions.
  4. Info-ZIP retains the right to use the names “Info-ZIP,” “Zip,” “UnZip,” “UnZipSFX,” “WiZ,” “Pocket UnZip,” “Pocket Zip,” and “MacZip” for its own source and binary releases.

Jansson

Copyright (c) 2009-2013 Petri Lehtinen <petri@digip.org>

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Lua

The Sophos software that is described in this document may include some software programs that are licensed (or sublicensed) to the user under the Lua License. A copy of the license agreement for any such included software can be found at http://www.lua.org/copyright.html

Microsoft software

This Sophos product may include certain Microsoft software, licensed to Sophos for inclusion and use herein.

Mersenne Twister (mt19937ar.c)

Copyright (c) 1997–2002 Makoto Matsumoto and Takuji Nishimura. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. The names of its contributors may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

OpenSSL Cryptography and SSL/TLS Toolkit

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the original SSLeay license apply to the toolkit. See below for the actual license texts. Actually both licenses are BSD-style Open Source licenses. In case of any license issues related to OpenSSL please contact openssl-core@openssl.org.

OpenSSL license

Copyright © 1998-2011 The OpenSSL Project. Tutti i diritti riservati.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

    "This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://www.openssl.org/)”

  4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from this software without prior written permission. For written permission, please contact openssl-core@openssl.org.
  5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without prior written permission of the OpenSSL Project.
  6. Redistributions of any form whatsoever must retain the following acknowledgment:

    “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)”

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT "AS IS" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay license

Copyright © 1995–1998 Eric Young (eay@cryptsoft.com) All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com). The implementation was written so as to conform with Netscape’s SSL.

This library is free for commercial and non-commercial use as long as the following conditions are adhered to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young’s, and as such any Copyright notices in the code are not to be removed. If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used. This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

    “This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)”

    The word "cryptographic" can be left out if the routines from the library being used are not cryptographic related :-).

  4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement:

    “This product includes software written by Tim Hudson (tjh@cryptsoft.com)”

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publically available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution license [including the GNU Public License.]

Protocol Buffers (libprotobuf)

Copyright 2008, Google Inc.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of Google Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Code generated by the Protocol Buffer compiler is owned by the owner of the input file used when generating it. This code is not standalone and requires a support library to be linked with it. This support library is itself covered by the above license.

pstdint

Copyright (c) 2005-2007 Paul Hsieh
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the DOCUMENTATION and/or other materials provided with the distribution.
  3. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Simple ECMAScript Engine (SEE)

Copyright © 2003, 2004, 2005, 2006, 2007 David Leonard. Tutti i diritti riservati.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of David Leonard nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

SQLCipher

Copyright © 2008-2012 Zetetic LLC

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of the ZETETIC LLC nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY ZETETIC LLC ''AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL ZETETIC LLC BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

strcasestr.c

Copyright © 1990, 1993 The Regents of the University of California. Tutti i diritti riservati.

This code is derived from software contributed to Berkeley by Chris Torek.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Udis86

Copyright (c) 2002-2009 Vivek Thampi
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The views and conclusions contained in the software and documentation are those of the authors and should not be interpreted as representing official policies, either expressed or implied, of the FreeBSD Project.

Unicode

UNICODE, INC. LICENSE AGREEMENT – DATA FILES AND SOFTWARE

Unicode Data Files include all data files under the directories http://www.unicode.org/Public/, http://www.unicode.org/reports/, and http://www.unicode.org/cldr/data/. Unicode Software includes any source code published in the Unicode Standard or under the directories http://www.unicode.org/Public/, http://www.unicode.org/reports/, and http://www.unicode.org/cldr/data/.

NOTICE TO USER: Carefully read the following legal agreement. BY DOWNLOADING, INSTALLING, COPYING OR OTHERWISE USING UNICODE INC.'S DATA FILES ("DATA FILES"), AND/OR SOFTWARE ("SOFTWARE"), YOU UNEQUIVOCALLY ACCEPT, AND AGREE TO BE BOUND BY, ALL OF THE TERMS AND CONDITIONS OF THIS AGREEMENT. IF YOU DO NOT AGREE, DO NOT DOWNLOAD, INSTALL, COPY, DISTRIBUTE OR USE THE DATA FILES OR SOFTWARE.

COPYRIGHT AND PERMISSION NOTICE

Copyright © 1991–2007 Unicode, Inc. All rights reserved. Distributed under the Terms of Use in http://www.unicode.org/copyright.html.

Permission is hereby granted, free of charge, to any person obtaining a copy of the Unicode data files and any associated documentation (the "Data Files") or Unicode software and any associated documentation (the "Software") to deal in the Data Files or Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Data Files or Software, and to permit persons to whom the Data Files or Software are furnished to do so, provided that (a) the above copyright notice(s) and this permission notice appear with all copies of the Data Files or Software, (b) both the above copyright notice(s) and this permission notice appear in associated documentation, and (c) there is clear notice in each modified Data File or in the Software as well as in the documentation associated with the Data File(s) or Software that the data or software has been modified.

THE DATA FILES AND SOFTWARE ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THE DATA FILES OR SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in these Data Files or Software without prior written authorization of the copyright holder.

UnRAR

The source code of UnRAR utility is freeware. This means:

  1. All copyrights to RAR and the utility UnRAR are exclusively owned by the author - Alexander Roshal.
  2. The UnRAR sources may be used in any software to handle RAR archives without limitations free of charge, but cannot be used to re-create the RAR compression algorithm, which is proprietary. Distribution of modified UnRAR sources in separate form or as a part of other software is permitted, provided that it is clearly stated in the documentation and source comments that the code may not be used to develop a RAR (WinRAR) compatible archiver.
  3. The UnRAR utility may be freely distributed. It is allowed to distribute UnRAR inside of other software packages.
  4. THE RAR ARCHIVER AND THE UnRAR UTILITY ARE DISTRIBUTED “AS IS”. NO WARRANTY OF ANY KIND IS EXPRESSED OR IMPLIED. YOU USE AT YOUR OWN RISK. THE AUTHOR WILL NOT BE LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND OF LOSS WHILE USING OR MISUSING THIS SOFTWARE.
  5. Installing and using the UnRAR utility signifies acceptance of these terms and conditions of the license.
  6. If you don’t agree with terms of the license you must remove UnRAR files from your storage devices and cease to use the utility.

Thank you for your interest in RAR and UnRAR.

Alexander L. Roshal

Windows Template Library (WTL)

This product may contain Windows Template Library (WTL) and/or WixToolset code, which are licensed under the Common Public License 1.0. The source code for the components is available from Sophos, upon request, by emailing TPCRequest@sophos.com

wow64ext library

This is used in Sophos Virus Removal Tool as a shared library (wow64ext.dll), which may be removed or subsituted without affecting other functionality. Its use is covered by the following license:

GNU LESSER GENERAL PUBLIC LICENSE

Version 3, 29 June 2007

Copyright (C) 2007 Free Software Foundation, Inc.

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

This version of the GNU Lesser General Public License incorporates the terms and conditions of version 3 of the GNU General Public License, supplemented by the additional permissions listed below.

  • 0. Additional Definitions.

    As used herein, "this License" refers to version 3 of the GNU Lesser General Public License, and the "GNU GPL" refers to version 3 of the GNU General Public License.

    "The Library" refers to a covered work governed by this License, other than an Application or a Combined Work as defined below.

    An "Application" is any work that makes use of an interface provided by the Library, but which is not otherwise based on the Library. Defining a subclass of a class defined by the Library is deemed a mode of using an interface provided by the Library.

    A "Combined Work" is a work produced by combining or linking an Application with the Library. The particular version of the Library with which the Combined Work was made is also called the "Linked Version".

    The "Minimal Corresponding Source" for a Combined Work means the Corresponding Source for the Combined Work, excluding any source code for portions of the Combined Work that, considered in isolation, are based on the Application, and not on the Linked Version.

    The "Corresponding Application Code" for a Combined Work means the object code and/or source code for the Application, including any data and utility programs needed for reproducing the Combined Work from the Application, but excluding the System Libraries of the Combined Work.

  1. Exception to Section 3 of the GNU GPL.

    You may convey a covered work under sections 3 and 4 of this License without being bound by section 3 of the GNU GPL.

  2. Conveying Modified Versions.

    If you modify a copy of the Library, and, in your modifications, a facility refers to a function or data to be supplied by an Application that uses the facility (other than as an argument passed when the facility is invoked), then you may convey a copy of the modified version:

    1. under this License, provided that you make a good faith effort to ensure that, in the event an Application does not supply the function or data, the facility still operates, and performs whatever part of its purpose remains meaningful, or
    2. under the GNU GPL, with none of the additional permissions of this License applicable to that copy.
  3. Object Code Incorporating Material from Library Header Files.

    The object code form of an Application may incorporate material from a header file that is part of the Library. You may convey such object code under terms of your choice, provided that, if the incorporated material is not limited to numerical parameters, data structure layouts and accessors, or small macros, inline functions and templates (ten or fewer lines in length), you do both of the following:

    1. Give prominent notice with each copy of the object code that the Library is used in it and that the Library and its use are covered by this License.
    2. Accompany the object code with a copy of the GNU GPL and this license document.
  4. Combined Works.

    You may convey a Combined Work under terms of your choice that, taken together, effectively do not restrict modification of the portions of the Library contained in the Combined Work and reverse engineering for debugging such modifications, if you also do each of the following:

    1. Give prominent notice with each copy of the Combined Work that the Library is used in it and that the Library and its use are covered by this License.
    2. Accompany the Combined Work with a copy of the GNU GPL and this license document.
    3. For a Combined Work that displays copyright notices during execution, include the copyright notice for the Library among these notices, as well as a reference directing the user to the copies of the GNU GPL and this license document.
    4. Do one of the following:

      0) Convey the Minimal Corresponding Source under the terms of this License, and the Corresponding Application Code in a form suitable for, and under terms that permit, the user to recombine or relink the Application with a modified version of the Linked Version to produce a modified Combined Work, in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source

      1) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (a) uses at run time a copy of the Library already present on the user's computer system, and (b) will operate properly with a modified version of the Library that is interface-compatible with the Linked Version.

    5. Provide Installation Information, but only if you would otherwise be required to provide such information under section 6 of the GNU GPL, and only to the extent that such information is necessary to install and execute a modified version of the Combined Work produced by recombining or relinking the Application with a modified version of the Linked Version. (If you use option 4d0, the Installation Information must accompany the Minimal Corresponding Source and Corresponding Application Code. If you use option 4d1, you must provide the Installation Information in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source.)
  5. Combined Libraries.

    You may place library facilities that are a work based on the Library side by side in a single library together with other library facilities that are not Applications and are not covered by this License, and convey such a combined library under terms of your choice, if you do both of the following:

    1. Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities, conveyed under the terms of this License.
    2. Give prominent notice with the combined library that part of it is a work based on the Library, and explaining where to find the accompanying uncombined form of the same work.
  6. Revised Versions of the GNU Lesser General Public License.

    The Free Software Foundation may publish revised and/or new versions of the GNU Lesser General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

    Each version is given a distinguishing version number. If the Library as you received it specifies that a certain numbered version of the GNU Lesser General Public License "or any later version" applies to it, you have the option of following the terms and conditions either of that published version or of any later version published by the Free Software Foundation. If the Library as you received it does not specify a version number of the GNU Lesser General Public License, you may choose any version of the GNU Lesser General Public License ever published by the Free Software Foundation.

    If the Library as you received it specifies that a proxy can decide whether future versions of the GNU Lesser General Public License shall apply, that proxy's public statement of acceptance of any version is permanent authorization for you to choose that version for the Library.

Argomento precedente: Supporto tecnico