說明

關於 Sophos Endpoint Security and Control

Sophos Endpoint Security and Control 項整合的安全防護軟體套件。

Sophos Anti-Virus 能偵測、清理病毒、特洛伊木馬、蠕蟲與間諜程式，以及廣告程式及其他可能不需要的應用程式。本公司的 HIPS (主機入侵防護系統) 技術亦可防護您的電腦免於可疑檔案與 Rootkit 侵襲。此外，偵測惡意資料流能偵測電腦和指令之間的通訊及僵屍病毒或其他惡意程式攻擊相關的控制伺服器。

Sophos 行為偵測 使用本公司的主機入侵防護系統 (HIPS) ，防護 Windows 的電腦免於不明或「零日」安全威脅與可疑行為的侵襲。

Sophos Live Protection 能增進對於最新惡意程式的偵測功能，同時能避免進行不需要的偵測動作。此項功能可即時檢查比對最新的已知惡意檔案。一旦發現最新的惡意程式，Sophos 可在頃刻之間傳送更新資訊。

Sophos 網頁防護功能，可藉由防止對於已知具有惡意軟體位置的存取動作，提供增強的防護，抵禦網頁安全威脅。網頁防護功能，可藉由即時查閱 Sophos 的線上惡意網站資料庫，防止端點存取此種安全堪慮的網站。它也會掃描已下載資料及檔案，並檢查檔案信譽。

Sophos Application Control 可對例如網際網路語音協定、即時通訊、檔案共享、遊戲軟體等未經許可的應用程式進行攔截。

Sophos Device Control 可對未經許可的外部儲存設備與無線連結技術進行攔截。

Sophos Data Control 可防止個人資料從受管理的電腦意外洩漏。

Sophos Web Control 可為位於您公司網路之外，或瀏覽於公司網路之外的電腦，提供防護、控管與通報功能。

Sophos Client Firewall 可防止蠕蟲、特洛伊木馬與 間諜程式盜取、傳佈敏感資訊，亦能避免駭客入侵。

Sophos AutoUpdate 提供您安全的更新程序，並能再透過低速網路連線進行更新時，調節頻寬。

Sophos Tamper Protection 能防止未經許可的使用者 (技術知識有限的使用者) 透過 Sophos Endpoint Security and Control 介面解除安裝或關閉 Sophos 安全防護軟體。

下一個主題: 關於首頁


關於首頁

首頁 會在您開啟 Sophos Endpoint Security and Control 視窗時，顯現在右邊窗格。首頁可讓您配置、使用軟體。

在您使用 Sophos Endpoint Security and Control 時，右邊窗格的內容將會變更。如欲回到 首頁 頁面，請點選工具列上的 首頁。

前一個主題: 關於 Sophos Endpoint Security and Control
下一個主題: 關於 Sophos 群組


關於 Sophos 群組

Sophos Endpoint Security and Control 限制某些 Sophos 群組成員存取軟體某些部件。

當 Sophos Endpoint Security and Control 安裝後，此台電腦上的各使用者，會依據其 Windows 群組，初步分配至一個 Sophos 群組。
Windows 群組 | Sophos 群組
系統管理員 | SophosAdministrator
特級使用者 | SophosPowerUser
一般使用者 | SophosUser

未指派至 Sophos 群組的使用者，包括訪客使用者，僅能進行以下操作：

  • 讀取掃描
  • 右鍵掃描

SophosUsers

SophosUsers 可進行以上工作，亦能進行以下工作：

  • 開啟 Sophos Endpoint Security and Control。
  • 設定及執行即時掃描
  • 右鍵掃描
  • 以有限的權限來管理隔離所內的項目
  • 建立、配置防火牆規則

SophosPowerUsers

SophosPowerUsers 具備與 SophosUsers 相同的權限，但亦包括以下權限：

  • 對於隔離所管理員的更多權限
  • 存取許可管理員

SophosAdministrators

SophosAdministrators 可使用或配置 Sophos Endpoint Security and Control 所有部件。
註: 一旦竄改防護功能開啟，SophosAdministrator 成員必須具備竄改防護密碼，才能進行以下操作：
  • 配置讀取掃描。
  • 配置可疑行為偵測功能。
  • 關閉竄改防護功能。

如欲瞭解更多詳情，請參閱關於本台電腦上的竄改防護功能。

前一個主題: 關於首頁
下一個主題: 新增使用者至 Sophos 群組


新增使用者至 Sophos 群組

如果您是網域系統管理員或本台電腦的 Windows Administrators 群組成員，您可變更使用者為其成員的 Sophos 群組。進行此項動作的目的，一般在於變更其對於 Sophos Endpoint Security and Control 的存取權限。

如欲新增使用者至 Sophos 群組：

  1. 使用 Windows 開啟電腦管理
  2. 在主控台樹狀目錄內，點選 使用者。
  3. 按右鍵點選使用者帳號，然後點選 內容。
  4. 請在 成員隸屬 標籤內，點選 新增。
  5. 在 輸入物件名稱選擇 內，輸入一項 Sophos 群組名稱：
    • SophosAdministrator
    • SophosPowerUser
    • SophosUser
  6. 如果您要驗證 Sophos 群組名稱，請點選 檢查名稱。
當使用者再度登入至 Windows 後，便會發現其對於 Sophos Endpoint Security and Control 的存取權限已經改變。

注意事項

  • 如欲開啟電腦管理，點選 開始，然後點選 控制台。按兩下 管理工具，然後按兩下 電腦管理。
  • 如欲從 Sophos 使用者群組移除使用者，請在 成員隸屬 標籤內，選取 成員隸屬 內的群組，然後點選 移除。
前一個主題: 關於 Sophos 群組
下一個主題: 配置隔離所管理員的使用者權限


配置隔離所管理員的使用者權限

如果您是 SophosAdministrator 群組的成員，您可配置隔離所管理員的使用者權限。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 隔離所管理員的使用者權限。
  2. 選取可進行各項類型動作的使用者類型。
    註: 除 許可 選項之外，在此所設定的權限只適用於 隔離所管理員。
    選項 | 敘述
    清理磁區 | 使用者能清理軟碟片開機磁區。
    清理檔案 | 使用者能清理文件與程式。
    刪除檔案 | 使用者能刪除感染病毒的檔案。
    移動檔案 | 使用者能將受感染病毒的檔案移至其他資料夾。
    許可 使用者能許可可疑項目、廣告程式，以及可能不需要的應用程式，使其得以在電腦上執行。

    此項設定適用於 許可管理員 與 隔離所管理員。
前一個主題: 新增使用者至 Sophos 群組
下一個主題: 關於讀取掃描與即時掃描


關於讀取掃描與即時掃描

讀取掃描

讀取掃描，亦即您抵禦病毒與其他安全威脅的主要防護方法。

在您存取 (複製、儲存、移動或開啟) 檔案時，Sophos Anti-Virus 會對該檔案進行掃描，並唯有在其並未對您電腦造成威脅，或已經獲得許可使用的情況下，才允許對其進行存取。

如欲瞭解更多相關資訊，請參閱 配置讀取掃描。

即時掃描

即時掃描提供更進一步的防護。如同名稱所示，您啟動即時掃描。您可掃描任何項目，包括個別檔案到整台電腦。

如欲瞭解更多相關資訊，請參閱 即時掃描類型。

前一個主題: 配置隔離所管理員的使用者權限
下一個主題: 關於讀取掃描最佳實踐方案


關於讀取掃描最佳實踐方案

本節內容包含的建議事項可協助您充分利用讀取掃描的優勢。

本公司建議您使用預設讀取掃描設定，因為其可讓您在防護您電腦免於安全威脅侵襲與整體系統效能之間取得最佳平衡。如欲瞭解讀取掃描建議設定相關資訊，請參閱 Sophos 技術支援知識庫文章第 114345號 (http://www.sophos.com/en-us/support/knowledgebase/114345.aspx)(英文)。

前一個主題: 關於讀取掃描與即時掃描
下一個主題: 配置讀取掃描


配置讀取掃描

注意:
如果已安裝特定加密軟體，讀取掃描可能無法偵測到病毒。變更安裝程序，確保在讀取掃描開始進行時，檔案已解密。如欲瞭解如何使用具有加密軟體的防病毒與 HIPS 策略的更多詳情，請參閱 Sophos 知識庫文章第 12790 號 http://www.sophos.com/en-us/support/knowledgebase/12790.aspx (英文)。
重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。
根據預設值，Sophos Anti-Virus 會在進行右鍵掃描時，偵測、清理以下安全威脅：
  • 病毒
  • 特洛伊木馬
  • 蠕蟲
  • 間諜程式

如欲配置右鍵掃描功能：

  1. 點選 首頁防病毒與 HIPS配置防病毒與 HIPS配置讀取掃描。
  2. 如欲變更讀取掃描進行的時間，請在 檢查檔案 下，依照以下描述設定選項。
    選項 | 描述
    讀檔時 | 在複製、移動或開啟檔案時，對該檔案進行掃描。
    重新命名 | 在檔案重新命名時，對其進行掃描。
    寫入檔案時 | 在儲存或建立檔案時，對其進行掃描。
  3. 在 掃掃 內，依照以下步驟設定選項。
    選項 | 描述
    廣告程式與可能不需要的應用程式 廣告程式會顯示例如快顯訊息的廣告活動，可能會影響使用者生產力與系統效能。

    PUA (可能不需要的應用程式) 本質並非惡意，但一般視為不適合企業環境使用的應用程式。
    可疑檔案 | 可疑檔案會展現通常在病毒內 (但並非僅限在病毒內發現) ，所發現的綜合特性的檔案。
  4. 在 其他掃描選項內，依照以下步驟設定選項。
    選項 | 描述
    允許存取開機區受感染的磁碟 關閉此選項，便能允許存取受感染可開機的卸除式媒體或設備，例如開機光碟、軟碟或 USB 快閃記憶碟。

    您只應在 Sophos 技術支援人員的指導下使用本選項。

    請參閱 排疑解難 主題 允許存取開機區受感染的磁碟。
    掃描所有檔案 | 本公司建議您關閉此選項，因為該選項會讓掃描速度大為減低。只能在每周?描期??描所有文件。
    掃描壓縮檔內部 開啟此選項，掃描檔案或壓縮檔內容。只有當下載和散發此類文件而未擷取內容時需要執行此操作。

    本公司建議您關閉此選項，因為該選項會讓掃描速度大為減低。

    您仍將受到防護，免於壓縮檔內任何安全威脅的侵襲，因為所有可能是惡意程式的元件，皆會受到讀取掃描攔截。

    • 當您開啟從壓縮檔解壓縮的檔案時，解壓縮的檔案便會受到掃描。
    • 使用例如 PKLite、LZEXE 與 Diet 等動態壓縮公用程式壓縮的檔案，皆會受到掃描。
    掃描系統記憶體 請開啟此選項，自動執行每小時背景掃描，來偵測隱藏於電腦系統記憶體內的惡意程式 (操作系統使用的記憶體)。
    註: 此選項僅在 32 位作業系統上有效。
前一個主題: 關於讀取掃描最佳實踐方案
下一個主題: 暫時關閉讀取掃描


暫時關閉讀取掃描

如果您是 SophosAdministrator 群組成員，您可暫時關閉本台電腦上的讀取掃描，以進行維護或故障排除：如果您關閉讀取掃描，您仍可以執行您的電腦上的即時掃描。

Sophos Endpoint Security and Control 會保留您在此所做的設定，甚至在您重新開機之後依然保留。如果您關閉讀取掃描，在您重新將其開啟之前，您的電腦將不會受到防護。

  1. 點選 首頁防病毒與 HIPS配置防病毒與 HIPS配置讀取掃描。
  2. 取消勾選 啟用本台電腦的讀取掃描 勾選方塊。
前一個主題: 配置讀取掃描
下一個主題: 配置讀取清理


配置讀取清理

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。
如欲配置右鍵清理功能：
  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 讀取掃描。
  2. 點選 清理 標籤。
  3. 如欲自動清理感染病毒的項目，請在 病毒/間諜程式 下，選取 自動清理包含病毒/間諜程式 勾選方塊。
    註: 如果您開啟此選項，清理某些病毒/間諜程式將會啟動完整系統掃描，此掃描會試圖清理您電腦上所有的病毒。如此將耗費許多時間。
  4. 如果您已經關閉自動清理，或者自動清理失敗，請在 病毒/間諜程式 下，選取一項 Sophos Anti-Virus 操作來處理受感染的項目。
    選項 描述
    僅拒絕存取 Sophos Anti-Virus 會在繼續操作之前，詢問您要進行的操作。

    這是預設設定。
    刪除

    拒絕存取並移至

                 您只應在 Sophos 技術支援人員的指導下使用這些設定。

    否則，請使用隔離所管理員來清理 Sophos Anti-Virus 在您電腦上所發現的病毒/間諜程式。參閱 處理隔離所內的病毒/間諜程式。
  5. 在 可疑檔案 下，選取當發現包含惡意程式中常用程式碼的檔案時，Sophos Anti-Virus 應採取的行動。
    選項 描述
    拒絕存取 Sophos Anti-Virus 會在繼續操作之前，詢問您要進行的操作。

    這是預設設定。
    刪除

    拒絕存取並移至

                 您只應在 Sophos 技術支援人員的指導下使用這些設定。

    否則，請使用隔離所管理員來清理 Sophos Anti-Virus 在您電腦中所發現的可疑檔案。參閱 處理隔離所內的可疑檔案。
前一個主題: 暫時關閉讀取掃描
下一個主題: 重設掃描檔案總和檢查


重設掃描檔案總和檢查

當進行 Sophos Anti-Virus 更新或重新啟動電腦時，便會重設掃描檔案總和檢查的清單。該項清單便會重新建立，內含 Sophos Anti-Virus 掃描檔案的新資料。

如果您不想重新啟動電腦，可在 Sophos Endpoint Security and Control 內重新設定掃描檔案總和檢查的清單。

如欲重新設定掃描檔案總和檢查：

  1. 點選 首頁防病毒與 HIPS配置防病毒與 HIPS配置讀取掃描。
  2. 請在 掃描 標籤內，點選 清理快取記憶體。
前一個主題: 配置讀取清理
下一個主題: 指定讀取掃描檔案附檔名


指定讀取掃描檔案附檔名

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

您可指定讀取檔案進行時，要掃描的檔案附檔名。

  1. 點選 首頁防病毒與 HIPS配置防病毒與 HIPS配置讀取掃描。
  2. 點選 附檔名 標籤，依以下描述設定選項。

    掃描所有檔案

    點選此處啟用掃描所有檔案功能，無論檔案的附檔名為何。

    允許精確控制掃描的項目

    點選此處便可將掃描的檔案限定在具有特定附檔名的檔案，這些附檔名詳列在附檔名清單之中。

    注意:
    該附檔名清單包含本公司建議掃描的檔案型態。若要變更清單內容，請按照以下步驟小心進行。

    若要新增附檔名至清單中，請點選 新增。您可使用萬用字元「?」來比對任何單一字元。

    如要將附檔名從清單中移除，請選擇附檔名並點選 移除。

    如要變更清單中的附檔名，請選擇附檔名並點選 編輯。

    當您選取 允許精確控制掃描的項目時，根據預設值 掃描不具有附檔名的檔案 亦會同時選取。若要關閉掃描不具有附檔名的檔案功能，請取消勾選 掃描不具有附檔名的檔案。

前一個主題: 重設掃描檔案總和檢查
下一個主題: 即時掃描類型


即時掃描類型

右鍵掃描

在任何時刻以 Windows Explorer 掃描 檔案、資料夾及磁碟機。

  • 執行右鍵掃描

自訂掃描

掃描特定檔案或資料夾。您可手動執行自訂掃描，或將其排程為自動執行。

  • 執行自訂掃描
  • 排程自訂掃描

完整電腦掃描

在任何時刻掃描您整台電腦，包括開機區與系統記憶體。

  • 執行一項完整電腦掃描
前一個主題: 指定讀取掃描檔案附檔名
下一個主題: 指定即時掃描檔案附檔名


指定即時掃描檔案附檔名

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

您可指定即時檔案進行時，要掃描的檔案附檔名。

  1. 在 配置 功能表內，點選 即時掃描附檔名與排除項目。
  2. 點選 附檔名 標籤，依以下描述設定選項。

    掃描所有檔案

    點選此處啟用掃描所有檔案功能，無論檔案的附檔名為何。

    允許精確控制掃描的項目

    點選此處便可將掃描的檔案限定在具有特定附檔名的檔案，這些附檔名詳列在附檔名清單之中。

    注意:
    該附檔名清單包含本公司建議掃描的檔案型態。若要變更清單內容，請按照以下步驟小心進行。

    若要新增附檔名至清單中，請點選 新增。您可使用萬用字元「?」來比對任何單一字元。

    如要將附檔名從清單中移除，請選擇附檔名並點選 移除。

    如要變更清單中的附檔名，請選擇附檔名並點選 編輯。

    當您選取 允許精確控制掃描的項目時，根據預設值 掃描不具有附檔名的檔案 亦會同時選取。若要關閉掃描不具有附檔名的檔案功能，請取消勾選 掃描不具有附檔名的檔案。

前一個主題: 即時掃描類型
下一個主題: 右鍵掃描


右鍵掃描

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，將會覆蓋您進行的任何變更。
根據預設值，Sophos Anti-Virus 會在進行右鍵掃描時，偵測、清理以下安全威脅：
  • 病毒
  • 特洛伊木馬
  • 蠕蟲
  • 間諜程式
  • 廣告程式以及可能不需要的應用程式 (PUA)

如欲配置右鍵掃描

  1. 點選 首頁防病毒與 HIPS配置防病毒與 HIPS配置右鍵掃描。
  2. 在 掃描 內，依照以下步驟設定選項。
    選項 | 描述
    廣告程式與可能不需要的應用程式 廣告程式會顯示例如快顯訊息的廣告活動，可能會影響使用者生產力與系統效能。

    PUA (可能不需要的應用程式) 本質並非惡意，但一般視為不適合企業環境使用的應用程式。
    可疑檔案 | 可疑檔案會展現通常在病毒內 (但並非僅限在病毒內發現) ，所發現的綜合特性的檔案。
  3. 在 其他掃描選項內，依照以下步驟設定選項。
    選項 | 描述
    掃描所有檔案 | 本公司建議您關閉此選項，因為該選項會讓掃描速度大為減低。只能在每周?描期??描所有文件。
    掃描壓縮檔內部 開啟此選項，掃描檔案或壓縮檔內容。只有當下載和散發此類文件而未擷取內容時需要執行此操作。

    本公司建議您關閉此選項，因為該選項會讓掃描速度大為減低。

    您仍將受到防護，免於壓縮檔內任何安全威脅的侵襲，因為所有可能是惡意程式的元件，皆會受到讀取掃描攔截。

    • 當您開啟從壓縮檔解壓縮的檔案時，解壓縮的檔案便會受到掃描。
    • 使用例如 PKLite、LZEXE 與 Diet 等動態壓縮公用程式壓縮的檔案，皆會受到掃描。
前一個主題: 指定即時掃描檔案附檔名
下一個主題: 配置右鍵清理功能


配置右鍵清理功能

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。
如欲配置右鍵清理功能
  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 右鍵掃描。
  2. 點選 清理 標籤。
  3. 如欲自動清理感染病毒的項目，請在 病毒/間諜程式 下，選取 自動清理包含病毒/間諜程式 勾選方塊。
  4. 如果您未開啟自動清理，或者自動清理失敗，請選取一項 Sophos Anti-Virus 操作，來處理受感染的項目。
    選項 描述
    僅紀錄 除了在掃描紀錄中紀錄受感染的項目外，Sophos Anti-Virus 不會採取其他任何行動。參閱 檢視掃描日誌紀錄。

    這是預設設定。
    刪除

    移至

                 您只應在 Sophos 技術支援人員的指導下使用這些設定。

    否則，請使用隔離所管理員來清理 Sophos Anti-Virus 在您電腦上所發現的病毒/間諜程式。參閱 處理隔離所內的病毒/間諜程式。

  5. 在 可疑檔案 下，選取當發現包含惡意程式中常用程式碼的檔案時，Sophos Anti-Virus 應採取的行動。
    選項 描述
    僅紀錄 除了在掃描紀錄中紀錄受感染的項目外，Sophos Anti-Virus 不會採取其他任何行動。

    這是預設設定。
    刪除

    移至

                 您只應在 Sophos 技術支援人員的指導下使用這些設定。

    否則，請使用隔離所管理員來清理 Sophos Anti-Virus 在您電腦上所發現的病毒/間諜程式。參閱 處理隔離所內的可疑檔案。
  6. 如欲移除電腦上所有使用者的廣告程式與可能不需要的應用程式的已知元件，請在 廣告程式與可能不需要的應用程式 下，選取 自動清理廣告程式與可能不需要的應用程式 勾選方塊。
    使用清理動作無法修復或變更已經進行的廣告程式或可能不需要的應用程式。
    • 如欲瞭解 Sophos 網站上關於廣告程式與可能不需要的應用程式的檢視詳情，請參閱 取得清理資訊。
    • 如欲瞭解如何使用隔離所管理員，來清理您電腦上的廣告程式與可能不需要的應用程式的相關資訊，請參閱 處理隔離所內的廣告程式與可能不需要的應用程式。
前一個主題: 右鍵掃描
下一個主題: 執行右鍵掃描


執行右鍵掃描

您可藉由執行右鍵掃描，使用 Windows Explorer 或桌面掃描檔案、資料夾與磁碟機。

  1. 使用 Windows Explorer 或從桌面選取您要掃描的檔案、資料夾或磁碟機。
    您可選取多項檔案與資料夾。
  2. 按右鍵點選選取項目後，便會顯現一個功能表，請點選 以 Sophos Anti-Virus 掃描。

一旦發現到任何安全威脅或受控管的應用程式，請點選 更多，並參閱本說明檔的 管理隔離項目 章節內容。

前一個主題: 配置右鍵清理功能
下一個主題: 建立自訂掃描


建立自訂掃描

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 掃描。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 點選 設定新掃描。
  3. 在 掃描名稱文字方塊內，請輸入一個掃描名稱。
  4. 在 要掃描的項目 面板中，請選擇您想要掃描的磁碟機。若要進行此項動作，請點選每個磁碟機或資料夾左方的勾選方塊。若要瞭解更多顯現在勾選方塊內的圖示，請參閱 掃描項目標示。
    註: 無法聯繫的磁碟或資料夾 (因為沒有連上線或已從清單中刪除) 會以畫線刪除名稱的方式來顯現。如果這些磁碟或資料夾被取消選取，或其母磁碟機或母資料夾的選取項目已經過變更，便會從 要掃描的項目 面板移除。
  5. 若要進一步配置掃描，請點選 配置此項掃描。(請參閱 配置自訂掃描 取得更多資訊。)
  6. 若要排程此項掃描，請點選 排程此項掃描。(請參閱 排程自訂掃描 取得更多資訊。)
  7. 點選 儲存 來儲存掃描或者 儲存並啟用 來儲存或執行掃描。
前一個主題: 執行右鍵掃描
下一個主題: 掃描項目標示


掃描項目標示

在 要掃描的項目 面板面板中，依據將掃描的項目，不同的圖示會顯現在每個項目旁的勾選方塊內。這些圖示顯現如下，並附註解釋。
圖示 | 解釋
 | 該項目與其所有的子項目 不會 被選取掃描。
 | 該項目與其所有的子項目 會 被選取掃描。
 | 該項目被部分選取：該項目沒有被選取，但某些子項目被選取掃描。
 | 該項目與其所有子項目被排除此項特定掃描。
 | 該項目被部分排除：該項目被選取，但某些子項目被排除特定掃描。
 | 該項目與其子項目已排除即時掃描，因為已經設定了一項即時掃描 排除項目。如欲瞭解更多詳情，請參閱排除讀取掃描項目。
前一個主題: 建立自訂掃描
下一個主題: 配置自訂掃描


配置自訂掃描

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。
根據預設值，Sophos Anti-Virus 會再進行自訂掃描時，偵測、清理以下安全威脅：
  • 病毒
  • 特洛伊木馬
  • 蠕蟲
  • 間諜程式
  • 廣告程式以及可能不需要的應用程式 (PUA)
  • Rootkit

如欲配置自訂掃描

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 掃描。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 請在 可用的掃描 清單內，選取您想要編輯的掃描，然後點選 編輯。
  3. 點選 配置此項掃描。
  4. 在 掃描 內，依照以下步驟設定選項。
    選項 | 描述
    廣告程式與可能不需要的應用程式 廣告程式會顯示例如快顯訊息的廣告活動，可能會影響使用者生產力與系統效能。

    PUA (可能不需要的應用程式) 本質並非惡意，但一般視為不適合企業環境使用的應用程式。
    可疑檔案 | 可疑檔案會展現通常在病毒內 (但並非僅限在病毒內發現) ，所發現的綜合特性的檔案。
    Rootkit 如果您隸屬於 SophosAdministrator 群組成員，在您執行完整電腦掃描時，每次都會掃描 Rootkit。

    您亦可掃描 Rootkit，作為自訂掃描。

  5. 在 其他掃描選項內，依照以下步驟設定選項。
    選項 | 描述
    掃描所有檔案 | 本公司建議您僅在每週掃描時掃描所有檔案，因為掃描所有檔案會影響電腦效能。
    掃描壓縮檔內部 開啟此選項，掃描檔案或壓縮檔內容。只有當下載和散發此類文件而未擷取內容時需要執行此操作。

    本公司建議您關閉此選項，因為該選項會讓掃描速度大為減低。

    您仍將受到防護，免於壓縮檔內任何安全威脅的侵襲，因為所有可能是惡意程式的元件，皆會受到讀取掃描攔截。

    • 當您開啟從壓縮檔解壓縮的檔案時，解壓縮的檔案便會受到掃描。
    • 使用例如 PKLite、LZEXE 與 Diet 等動態壓縮公用程式壓縮的檔案，皆會受到掃描。
    掃描系統記憶體 請開啟此選項，自動執行每小時背景掃描，來偵測隱藏於電腦系統記憶體內的惡意程式 (作業系統使用的記憶體)。
    註: 此選項僅在 32 位作業系統上有效。
    以較低優先權執行掃描 | 在 Windows Vista 以上的系統內，使用較低優先權執行自訂掃描，使其對使用者的影響降至最低。
前一個主題: 掃描項目標示
下一個主題: 配置自訂掃描的清理操作


配置自訂掃描的清理操作

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。
如欲配置自訂掃描的清理操作：
  1. 在 首頁 頁面上的 防病毒與 HIPS 下點選 掃描。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 請在 可用的掃描 清單內，選取您想要編輯的掃描，然後點選 編輯。
  3. 點選 配置此項掃描。
  4. 點選 清理 標籤。
  5. 如欲自動清理感染病毒的檔案，請在 病毒/間諜程式 下，選取 自動清理包含病毒/間諜程式 勾選方塊。
  6. 如果您未開啟自動清理，或者自動清理失敗，請選取一項 Sophos Anti-Virus 操作，來處理受感染的項目。
    選項 描述
    僅紀錄 除了在自訂掃描紀錄中紀錄受感染的項目外，Sophos Anti-Virus 不會採取其他任何行動。參閱 自訂掃描的日誌紀錄。

    這是預設設定。
    刪除

    移至

                 您只應在 Sophos 技術支援人員的指導下使用這些設定。

    否則，請使用隔離所管理員來清理 Sophos Anti-Virus 在您電腦上所發現的病毒/間諜程式。參閱 處理隔離所內的病毒/間諜程式。
  7. 在 可疑檔案 下，選取當發現包含惡意程式中常用程式碼的檔案時，Sophos Anti-Virus 應採取的行動。
    選項 描述
    僅紀錄 除了在掃描紀錄中紀錄受感染的項目外，Sophos Anti-Virus 不會採取其他任何行動。

    這是預設設定。
    刪除

    移至

    您只應在 Sophos 技術支援人員的指導下使用這些設定。

    否則，請使用隔離所管理員來清理 Sophos Anti-Virus 在您電腦上所發現的病毒/間諜程式。參閱 處理隔離所內的可疑檔案。
  8. 如欲移除電腦上所有使用者的廣告程式與可能不需要的應用程式的已知元件，請在 廣告程式與可能不需要的應用程式 下，選取 自動清理廣告程式與可能不需要的應用程式 勾選方塊。
    使用清理動作無法修復或變更已經進行的廣告程式或可能不需要的應用程式。
    • 如欲瞭解 Sophos 網站上關於廣告程式與可能不需要的應用程式的檢視詳情，請參閱 取得清理資訊。
    • 如欲瞭解如何使用隔離所管理員，來清理您電腦上的廣告程式與可能不需要的應用程式的相關資訊，請參閱 處理隔離所內的廣告程式與可能不需要的應用程式。
前一個主題: 配置自訂掃描
下一個主題: 排程自訂掃描


排程自訂掃描

如果您是 SophosAdministrator 群組的成員，您即可排程自訂掃描、或檢視、編輯其他使用者建立的排程掃描。

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 掃描。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 請在 可用的掃描 清單內，選取您想要編輯的掃描，然後點選 編輯。
  3. 點選 排程此項掃描。
  4. 在 排程掃描 對話方塊中，請選取 啟用排程。

    請選取掃描應執行的日程。

    若要新增掃描的時間，請點選 新增。

    倘若有需要，請分別點選 移除 或 編輯來移除或編輯某個時間。

  5. 請輸入 使用者名稱 與 密碼。請確認已在密碼欄輸入密碼。
    所排程的掃描是以該使用者的使用者權限執行。
註: 如果掃描在記憶體內偵測到安全威脅元件，且您未設定掃描的自動清理病毒/間諜程式功能，掃描將停止。這是因為進一步掃描動作將會使得安全威脅擴散。您必須在再次執行掃描時，清理安全威脅。
前一個主題: 配置自訂掃描的清理操作
下一個主題: 執行自訂掃描


執行自訂掃描

註: 您無法以手動方式執行排程的自訂掃描。已排程的掃描會以時鐘圖形顯示在 可用的掃描 清單中。
  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 掃描。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 請在 可用的掃描 清單內，選取您想要執行的掃描，然後點選 開始。
    一個進度對話方塊會顯現出來，活動摘要 也會顯現在 Sophos Endpoint Security and Control 視窗上。
註: 如果掃描在記憶體內偵測到安全威脅元件，且您未設定掃描的自動清理病毒/間諜程式功能，掃描將停止。這是因為進一步掃描動作將會使得安全威脅擴散。您必須在再次執行掃描時，清理安全威脅。

一旦發現到任何安全威脅或受控管的應用程式，請點選 更多，並參閱 管理隔離項目。

前一個主題: 排程自訂掃描
下一個主題: 重新命名自訂掃描


重新命名自訂掃描

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 掃描。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 請在 可用的掃描 清單內，選取您想要編輯的掃描，然後點選 編輯。
  3. 在 掃描名稱 方塊內，請輸入一項新掃描名稱。
前一個主題: 執行自訂掃描
下一個主題: 檢視自訂掃描的日誌紀錄


檢視自訂掃描的日誌紀錄

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 掃描。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 可用的掃描 清單內，點選自訂掃描的 摘要。
  3. 在 摘要 對話方塊中，點選最下方的連結。
您可從日誌紀錄頁面中，將日誌紀錄複製到剪貼簿、電子郵件內，或將其列印出來。

若要尋找日誌紀錄中的特定文字，請點選 尋找 並輸入您欲搜尋的文字。

前一個主題: 重新命名自訂掃描
下一個主題: 檢視自訂掃描摘要


檢視自訂掃描摘要

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 掃描。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 可用的掃描 清單內，點選自訂掃描的 摘要。
前一個主題: 檢視自訂掃描的日誌紀錄
下一個主題: 刪除自訂掃描


刪除自訂掃描

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 掃描。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 請在 可用的掃描 清單內，選取您想要編輯的掃描，然後點選 刪除。
前一個主題: 檢視自訂掃描摘要
下一個主題: 執行一項完整電腦掃描


執行一項完整電腦掃描

如欲在任何時刻掃描您整台電腦，包括開機區與系統記憶體：

在 首頁 頁面內的 防病毒與 HIPS，點選 掃描我的電腦。
如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。

一個進度對話方塊會顯現出來，活動摘要 也會顯現在 Sophos Endpoint Security and Control 視窗上。

註: 如果掃描在記憶體內偵測到安全威脅元件，掃描將停止。這是因為進一步掃描動作將會使得安全威脅擴散。您必須在再次執行掃描時，清理安全威脅。

一旦發現到任何安全威脅或受控管的應用程式，請點選 更多，並參閱 管理隔離項目 章節部分。

前一個主題: 刪除自訂掃描
下一個主題: 排除讀取掃描項目


排除讀取掃描項目

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如欲編輯排除讀取掃描之外的檔案、資料夾與磁碟機清單：

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 讀取掃描。
  2. 點選 排除項目 標籤，然後選取以下其中一項選項。
    • 如欲指定應排除讀取掃描的檔案、資料夾或磁碟機，請點選 新增。
    • 如欲刪除排除項目，請點選 移除。
    • 如欲變更排除項目，請點選 編輯。
  3. 如欲新增或編輯排除項目，請在 排除項目 對話方塊內，選取 項目類型。
    所有遠端檔案 項目類型用於排除未儲存於本機磁碟上的檔案。如果您想要增加存取該檔案的速度，且您信任可用的遠端檔案位置，您可選取此選項。
  4. 使用 瀏覽 按鍵指定 項目名稱，或在文字方塊中輸入名稱。
    註: 如果您是在 64 位元的平台上操作，瀏覽 按鍵將無法在 排除項目 對話中出現。

    如欲取得更多關於指定項目名稱的詳細資訊，請參閱 指定掃描排除項目。

前一個主題: 執行一項完整電腦掃描
下一個主題: 排除即時掃描項目


排除即時掃描項目

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

以下步驟適用於所有即時掃描。如欲瞭解關於排除特定項目自訂掃描的相關資訊，請參閱 建立自訂掃描。

如欲編輯排除及時掃描之外的檔案、資料夾與磁碟機清單：

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 即時掃描附檔名與排除項目。
  2. 點選 排除項目 標籤，然後選取以下其中一項選項。
    • 如欲指定應排除及時掃描的檔案、資料夾或磁碟機，請點選 新增。
    • 如欲刪除排除項目，請點選 移除。
    • 如欲變更排除項目，請點選 編輯。
  3. 如欲新增或編輯排除項目，請在 排除項目 對話方塊內，選取 項目類型。
  4. 使用 瀏覽 按鍵指定 項目名稱，或在文字方塊中輸入名稱。
    註: 如果您是在 64 位元的平台上操作，瀏覽 按鍵將無法在 排除項目 對話中出現。

    如欲取得更多關於指定項目名稱的詳細資訊，請參閱 指定掃描排除項目。

前一個主題: 排除讀取掃描項目
下一個主題: 指定掃描排除項目


指定掃描排除項目

標準命名準則

Sophos Anti-Virus 會使用標準 Windows 命名標準，來驗證掃描排除項目的路徑與檔案名稱。例如，資料夾名稱可包含空白，但不能 僅 包含空白。

多重檔案附檔名

具有多重附檔名的檔案，最後一個附檔名會被視為附檔名，其他的附檔名會被視為檔案名稱的一部份。

MySample.txt.doc = 檔案名稱 MySample.txt + 附檔名 .doc。

排除特定檔案、資料夾、程式或磁碟機

排除項目類型 | 描述 | 範例 | 註釋
特定檔案 | 指定路徑與檔案名稱來排除特定檔案。路徑包括磁碟機字母或網路共享名稱。 | C:\Documents\CV.doc \\Server\Users\?Documents\CV.doc \\Server\Users\Documents\CV.doc | 如欲確保排除項目每次都正確套用，請新增長與短檔案與資料夾名稱： C:\Program Files\Sophos\Sophos Anti-Virus C:\Progra~1\Sophos\Sophos~1 如欲瞭解更多詳情，請參閱知識庫文章 13045 號。
特定程式 | 指定路徑與檔案名稱來排除特定的可執行檔案（程式）。 | C:\Windows\notepad.exe | 您必須指定完整路徑。
使用相同名稱的所有檔案 | 不使用路徑來指定檔案名稱以排除具有該名稱的所有檔案，無論其位於檔案系統內何處。 | spacer.gif |
磁碟上或網路共享內的所有項目 | 指定磁碟字母或網路共享名稱，以排除在該磁碟或網路共享上的所有項目。 | C: \\Server\<sharename>\ | 指定網路共享時，應將末尾斜杠包括在內。
特定資料夾 | 指定包括磁碟字母或網路共享名稱的資料夾路徑，以排除在該資料夾內及其以下的所有項目。 | D:\Tools\logs\ | 包括資料夾名稱後的末尾斜杠。
使用相同名稱的所有資料夾 | 指定一項不含磁碟機字母或共享的資料夾路徑，排除 所有 磁碟或網路共享上的資料夾內及其以下的所有項目： | \Tools\logs\ （排除以下資料夾：C:\Tools\logs\, \\Server\Tools\logs\) | 您必須將完整路徑指定於磁碟字母或網路共享名稱。在此範例中，如果僅指定 \logs\，則無法排除任何檔案。

萬用字元

您可以使用此表中顯示的萬用字元。

註: 僅 * 和 ? 可在 Windows Server 2003 上使用。
權杖 | 符合 | 註釋
*（星號） 除 \ 或 / 以外的零個或多個字元。 例如：

c:\*\*.txt 會排除 C:\ 頂級資料夾中名稱為 *.txt 的所有檔案。

註: * 無法與 be 資料夾一起使用。
**（雙星號） 當被 \ 或 / 字符括起或用於排除項目的開頭和結尾時，包括 \ 和 / 在內的零個或多個任意字元。

** 的任意其他使用被視為單一 *，並匹配除 \ 或 / 以外的零個或多個字元。

 例如：
  • c:\foo\**\bar 匹配：c:\foo\bar、c:\foo\more\bar、c:\foo\even\more\bar
  • **\bar 匹配 c:\foo\bar
  • c:\foo\** 匹配 c:\foo\more\bar
  • c:\foo**bar 匹配 c:\foomorebar，而不是 c:\foo\more\bar
\（反斜線） | \ 或 /。
/（斜線） | / 或 \。
？（問號） | 一個單一字元，除非在可匹配零字元的字串結尾。
.（句號） 檔名結尾的句號或空字串，如果模式以句號結束並且檔名沒有副檔名。 請注意：
  • *.* 匹配所有檔案
  • *. 匹配所有無副檔名的檔案
  • "foo." 匹配 "foo" 和 " "foo."

範例

以下是使用萬用字元的一些範例。

表示式 | 解釋為 | 描述
foo | **\foo | 排除名稱為 foo 的所有檔案（在任何位置）。
foo\bar | **\foo\bar | 排除名稱為 foo 的資料夾中名稱為 bar 的所有檔案（在任何位置）。
*.txt | **\*.txt | 排除名稱為 *txt 的所有檔案（在任何位置）。
C: | C: | 從掃描排除磁碟機 C:（包括磁碟機的主開機紀錄）。
C:\ | C:\ | 從掃描排除磁碟機 C: 上的所有檔案（但掃描磁碟機的主開機紀錄）。
C:\foo\ | C:\foo\ | C:\foo 下的所有檔案和資料夾，包括 C:\foo 本身。
C:\foo\*.txt | C:\foo\*.txt | C:\foo 中包含的名稱為 *.txt 的所有資料夾。

排除項目變數

在設定掃描排除項目時可使用變數。

下表顯示了在每項作業系統上掃描排除項目對應位置的變數與範例。

變數 | Windows 7 以上、Windows Server 2008 以上 | Windows Server 2003、Windows XP、Windows Vista
%allusersprofile%\ | C:\ProgramData\ | C:\Documents and Settings\All Users\
%appdata%\ | C:\Users\*\AppData\Roaming\ | C:\Documents and Settings\*\Application Data\
%commonprogramfiles%\ | C:\Program Files\Common Files\ | C:\Program Files\Common Files\
%commonprogramfiles(x86)%\ | C:\Program Files (x86)\Common Files\ | C:\Program Files (x86)\Common Files\
%localappdata%\ | C:\Users\*\AppData\Local\ | C:\Documents and Settings\*\Local Settings\Application Data\
%programdata%\ | C:\ProgramData\ | C:\Documents and Settings\All Users\Application Data\
%programfiles%\ | C:\Program Files\ | C:\Program Files\
%programfiles(x86)%\ | C:\Program Files (x86)\ | C:\Program Files (x86)\
%systemdrive%\ | C: | C:
%systemroot%\ | C:\Windows\ | C:\Windows\
%temp%\ 或 %tmp%\ | C:\Users\*\AppData\Local\Temp\ | C:\Documents and Settings\*\Local Settings\Temp\
%userprofile%\ | C:\Users\*\ | C:\Documents and Settings\*\
%windir%\ | C:\Windows\ | C:\Windows\
前一個主題: 排除即時掃描項目
下一個主題: 關於行為偵測


關於行為偵測

Sophos 行為偵測係讀取掃描的一部份，可防護 Windows 的電腦，免於不明或「零日」安全威脅與可疑行為的侵襲。

執行階段偵測可攔截在執行前無法偵測到的安全威脅。行為偵測使用以下執行階段偵測方法來攔截安全威脅：
  • 惡意與可疑行為偵測
  • 緩衝區溢位偵測

惡意與可疑行為偵測

可疑行為偵測功能使用 Sophos 的主機入侵防護系統 (HIPS)，來動態分析在電腦上執行的所有程式，以偵測、攔截看似可疑的行為。可疑行為，可能包括對登錄所進行的變更，該項變更可使電腦重新啟動時，允許一項目病毒自動執行。

可疑行為偵測會偵查所有系統處理程序是否有惡意程式運作的跡象，例如對於登錄的寫入操作或檔案複製動作。該功能可設為警告系統管理員與/或攔截進程。

「惡意行為偵測」功能會動態分析運行於電腦上所有程式的行為，以偵測、攔截視為惡意的行為。

緩衝區溢位偵測

緩衝區溢位偵測對於處理零日安全漏洞相當重要。

緩衝區溢位偵測會動態分析在系統上運行的程式行為，以便偵測使用緩衝區溢位偵測技術來利用運行中處理程序的動作。緩衝區溢位偵測會獵捕針對作業系統軟體與應用程式安全漏洞的攻擊行為。

前一個主題: 指定掃描排除項目
下一個主題: 啟用行為偵測


啟用行為偵測

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您隸屬 SophosAdministrator 群組，您可開啟行為偵測功能。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 行為偵測。
  2. 在 配置行為偵測 對話方塊內，選取 開啟行為偵測 勾選方塊。
前一個主題: 關於行為偵測
下一個主題: 攔截惡意行為


攔截惡意行為

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

「惡意行為偵測」功能會動態分析運行於系統上所有程式的行為，以偵測、攔截視為惡意的行為。

如果您是 SophosAdministrator 群組的成員，您可變更偵測與通報惡意行為的設定。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 行為偵測。
  2. 在 配置行為偵測 對話方塊內，選取 開啟行為偵測 勾選方塊。
  3. 如欲警告系統管理員並攔截可疑進程，請選取 偵測惡意行為 勾選方塊。
前一個主題: 啟用行為偵測
下一個主題: 防止偵測可疑行為


防止偵測可疑行為

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

可疑行為偵測會偵查所有系統進程是否有惡意程式運作的跡象，例如對於註冊表的寫入操作或檔案複製動作。該功能可設為警告系統管理員與/或攔截進程。

如果您是 SophosAdministrator 群組的成員，您可變更偵測與通報可疑行為的設定。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 行為偵測。
  2. 在 配置行為偵測 對話方塊內，選取 開啟行為偵測 勾選方塊。
  3. 選取 偵測惡意行為 勾選方塊。
  4. 如欲警告系統管理員並攔截可疑進程，請選取 偵測可疑行為 勾選方塊。
  5. 如欲警告系統管理員，但不要攔截可疑進程，請選取 僅警示，勿攔截可疑行為 勾選方塊。

為取得最佳的防護，本公司建議您掃描可疑檔案。如欲瞭解更多詳情，請參閱以下主題：

  • 配置讀取掃描
  • 右鍵掃描
  • 配置自訂掃描
前一個主題: 攔截惡意行為
下一個主題: 防止緩衝區溢位


防止緩衝區溢位

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

緩衝區溢位偵測會動態分析在系統上運行的程式行為，以便偵測使用緩衝區溢位偵測技術來利用運行中進程的動作。

如果您是 SophosAdministrator 群組的成員，您可變更偵測與通報緩衝區溢位管理員的設定。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 行為偵測。
  2. 在 配置行為偵測 對話方塊內，選取 開啟行為偵測 勾選方塊。
  3. 如欲警告系統管理員並攔截緩衝區溢位偵測，請選取 偵測緩衝區溢位 勾選方塊。
  4. 如欲警告系統管理員，但不要攔截緩衝區溢位偵測，請選取 僅警示，勿攔截 勾選方塊。
前一個主題: 防止偵測可疑行為
下一個主題: 關於 Sophos Live Protection


關於 Sophos Live Protection

Sophos Live Protection 可判定某項檔案是否為安全威脅，如果判定為安全威脅，便會立即採取於 Sophos anti-Virus 清理配置內指定的行動。

Sophos Live Protection 能增進對於最新惡意程式的偵測功能，同時能避免進行不需要的偵測動作。此項功能可即時檢查比對最新的已知惡意檔案。一旦發現最新的惡意程式，Sophos 可在頃刻之間傳送更新資訊。

Sophos Live Protection 使用以下的選項。

  • 開啟即時雲端防護

    如果端點電腦上的防病毒掃描發現某項可疑檔案，但無法根據儲存於電腦上的安全威脅識別檔案 (IDE)，進一步判定其為安全檔案或惡意檔案，便會將某些檔案的特性 (例如其總和檢查與屬性) 傳送至 Sophos，以便進行更深入的分析。

    最先進的遠端網路檢查技術，會在 SophosLabs 資料庫內搜尋比對惡意檔案。如果該檔案被視為安全檔案或惡意檔案，該項判斷便會回傳至電腦，檔案的狀態便會自動更新。

  • 將樣本檔案自動傳送回 Sophos

    如果某項檔案被視為可疑檔案，但無法僅依據檔案資料，識別為真正的可疑檔案，您可允許 Sophos 要求取得檔案的樣本。如果已開啟此選項，且 Sophos 尚未具有檔案樣本，便會自動傳送該檔案。

    傳送樣本檔案給 Sophos，可協助本公司不斷增進對於惡意程式的偵測能力，有效減低誤報率。

前一個主題: 防止緩衝區溢位
下一個主題: 開啟或關閉 Sophos Live Protection


開啟或關閉 Sophos Live Protection

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您是 SophosAdministrator 群組成員之一，您可開啟或關閉 Sophos Live Protection：

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > Sophos Live Protection。
  2. 在 Sophos Live Protection 對話方塊內：
    • 如欲開啟或關閉 Sophos Live Protection，請選取或取消勾選 開啟即時雲端防護 勾選方塊。

    • 如欲開啟或關閉傳送樣本檔案至 Sophos，請選取或取消勾選 自動傳送檔案樣本至 Sophos 勾選方塊。

      唯有在您已經選取 開啟即時雲端掃描 的情況下，才能使用此選項。

注意事項

在將檔案樣本寄送至 Sophos 時，檔案資料會與樣本一起傳送。

前一個主題: 關於 Sophos Live Protection
下一個主題: 檢視 Sophos 即時雲端防護日誌


檢視 Sophos 即時雲端防護日誌

傳送至 Sophos 進行線上掃描的檔案資料，以及掃描完成後的檔案狀態更新，紀錄於本台電腦的掃描日誌紀錄內。

如果已經開啟 Sophos 線上防護功能，日誌紀錄將顯示：

  • 每項檔案傳送資料至 Sophos 的路徑。
  • 傳送資料的時間。
  • 如果傳送資料失敗，造成失敗的原因 (若已知原因)。
  • 檔案的現況 (例如，如果檔案被辨識為惡意檔案，則為 「病毒/間諜程式」)。

如欲檢視掃描日誌紀錄

  • 在 首頁 頁面內的 防病毒與 HIPS，點選 檢視防病毒與 HIPS 日誌紀錄。

    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。

您可從日誌紀錄頁面中，將日誌紀錄複製到剪貼簿、電子郵件內，或將其列印出來。

若要尋找日誌紀錄中的特定文字，請點選 尋找 並輸入您欲搜尋的文字。

前一個主題: 開啟或關閉 Sophos Live Protection
下一個主題: 關於 Sophos Web Protection


關於 Sophos Web Protection

Sophos Web Protection 提供您增強的防護功能，有效抵禦網頁安全威脅。網頁防護包括以下功能：

  • 即時 URL 過濾
  • 掃描已下載內容
  • 查看已下載檔案的信譽

即時 URL 過濾

及時 URL 過濾，可攔截存取已知含有惡意程式的網站。此項功能及時檢索 Sophos 線上資料庫，比對感染病毒的網站。

一旦惡意程式網站受到攔截，該事件會紀錄於掃描日誌紀錄內。如欲瞭解關於檢視掃描日誌紀錄的相關訊息，請參閱 檢視掃描日誌紀錄。

內容掃描

內容掃描可掃描透過網際網路（或內部網路）下載的資料與檔案，積極偵測惡意內容。此項功能可掃描所有位置內的內容，包括感染病毒網站資料庫內未包含的內容。

下載信譽

根據檔案年齡、來源、散佈程度、深度內容分析及其他特徵，計算下載信譽。

註: 下載信譽僅能在 Windows 7 以上系統獲得支援。

根據預設值，如果下載低信譽或未知信譽的檔案，一項警示便會顯現。本公司建議您不要下載此類檔案。如果您信任此檔案的來源及發佈者，您可選擇下載此檔案。您的動作及檔案 URL 將記錄於掃描日誌紀錄中。

註: 根據 SophosLabs 雲端資料庫中的資料計算下載信譽，並需要開啟 Sophos Live Protection，以便進行查詢並取得資料。（Sophos Live Protection 功能預設為開啟。）

如欲瞭解關於下載信譽的更多資訊，請參閱知識庫文章 121319。

網頁防護配置設定

網頁防護功能預設為開啟：對於惡意網站的存取動作受到攔截，下載內容受到掃描，對已下載檔案的信譽進行檢查。

如欲瞭解關於網頁防護設定及如何如何變更它們的更多資訊，請參閱配置 Sophos Web Protection。

支援的網頁瀏覽器

以下網頁瀏覽器支援網頁防護：

  • Internet Explorer
  • Edge
  • Google Chrome
  • Firefox（除了下載信譽）
  • Safari（除了下載信譽）
  • Opera

透過未支援瀏覽器進行存取的網頁內容，不會受到過濾，亦不會受到攔截。

前一個主題: 檢視 Sophos 即時雲端防護日誌
下一個主題: 配置 Sophos Web Protection


配置 Sophos Web Protection

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

若要變更 Sophos Web Protection 設定：

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 網頁防護 。
  2. 若要攔截或取消攔截存取惡意網站，在攔截存取惡意網站旁選取開啟或關閉。此選項預設為開啟。
    如欲瞭解如何許可歸類為惡意的網站，請參閱 許可網站以供使用。
  3. 若要開啟或關閉掃描已下載資料及檔案，在內容掃描旁選取讀取掃描時為開啟或關閉。
    根據預設值，讀取掃描時已選取，亦即，已使用讀取掃描同時關閉或開啟內容掃描。
  4. 若要變更下載低信譽或未知信譽檔案時的資訊，在下載信譽的動作旁選取提示使用者（預設值）或僅紀錄。
    • 如果您選取提示使用者，每次下載低信譽檔案時，一項警示便會顯現，通知此資訊並要求您確認是否攔截或允許下載。本公司建議您不要下載此類檔案。如果您信任此檔案的來源及發佈者，您可選擇下載此檔案。攔截或允許下載的選擇及檔案 URL 將記錄於掃描日誌紀錄中。
    • 如果您選取僅記錄，警示將不會顯現；下載將被允許並記錄於掃描日誌紀錄中。
  5. 若要選擇您要的信譽掃描嚴格程度，在門檻旁選取建議（預設值）或嚴格。
    • 如果您選取建議，一項警示便會顯現，並/或在每次下載低信譽或未知信譽的檔案時創建日誌紀錄。
    • 如果您選取嚴格，一項警示便會顯現，並/或在每次下載低信譽、未知信譽或中級信譽的檔案時創建日誌紀錄。

如欲瞭解關於下載信譽的更多資訊，請參閱知識庫文章 121319。

如欲瞭解關於檢視掃描日誌紀錄的相關訊息，請參閱 檢視掃描日誌紀錄。

前一個主題: 關於 Sophos Web Protection
下一個主題: 許可廣告程式與可能不需要的應用程式


許可廣告程式與可能不需要的應用程式

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您要執行 Sophos Anti-Virus 分類為可能不需要的廣告程式或應用程式，請依照以下步驟對其進行存取。

如欲許可廣告程式與可能不需要的應用程式：

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 許可。
  2. 在 廣告程式或 可能不需要的應用程式 標籤內的 已知廣告程式或 可能不需要的應用程式 清單內，選取 廣告程式或 可能不需要的應用程式。
  3. 點擊 新增。
廣告程式或可能不需要的應用程式即會顯現在 許可廣告程式或可能不需要的應用程式 清單內。
註: 您亦可在隔離所管理員內許可廣告程式與可能不需要的應用程式。如欲瞭解如何進行此項操作，請參閱 處理隔離所內的廣告程式與可能不需要的應用程式。
前一個主題: 配置 Sophos Web Protection
下一個主題: 攔截許可的廣告程式與可能不需要的應用程式


攔截許可的廣告程式與可能不需要的應用程式

如欲防止廣告程式與可能不需要的應用程式在您的電腦上運行：

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 許可。
  2. 在 廣告程式或 可能不需要的應用程式 標籤內的 已知廣告程式或 可能不需要的應用程式 清單內，選取要攔截的廣告程式或可能不需要的應用程式。
  3. 點選 移除。
前一個主題: 許可廣告程式與可能不需要的應用程式
下一個主題: 許可可疑項目


許可可疑項目

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您要許可一項被 Sophos Anti-Virus 歸類為可疑的項目，您應該使用以下方式對其進行許可。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 許可。
  2. 點選偵測到項目類型的標籤 (例如 緩衝區溢位)。
  3. 在 已知項目 清單內，選取可疑項目。
  4. 點擊 新增。
可疑項目會顯現在 已許可 清單內。
註: 您亦能許可隔離所管理員內的可疑項目。如欲瞭解如何進行此項操作的相關資訊，請參閱以下主題：
  • 處理隔離所內的可疑檔案
  • 處理隔離所內的可疑行為
前一個主題: 攔截許可的廣告程式與可能不需要的應用程式
下一個主題: 預先許可可疑項目


預先許可可疑項目

如果您要許可 Sophos Endpoint Security and Control 尚未 歸類為可疑的項目，您可對其進行預先許可。

如欲預先許可可疑項目：

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 許可。
  2. 點選偵測到項目類型的標籤 (例如 緩衝區溢位)。
  3. 點選 新項目。
  4. 找出可疑項目，然後按兩下該應用程式。
可疑項目會顯現在 已許可 清單內。
前一個主題: 許可可疑項目
下一個主題: 許可網站以供使用


許可網站以供使用

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您要解除封鎖 Sophos 歸類為惡意網站的網站，您可將其新增至許可的網站清單內。對某個網站進行許可動作，將使該網站的網址無法受到 Sophos 線上網頁過濾服務檢驗。

注意:
如果您對被歸類為惡意的網站進行許可動作，可能會使您曝露於安全威脅的風險之中，因此，請在許可網站之前，確保該網站安全無虞。

許可網站以供使用：

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 配置 > 許可。
  2. 點選 網站 標籤。
  3. 點擊 新增。
  4. 輸入網頁名稱或 IP 位址。
該網站將顯現於 許可的網站 清單。
前一個主題: 預先許可可疑項目
下一個主題: 關於隔離所管理員


關於隔離所管理員

隔離所管理員可讓您處理掃描所發現的項目，該安全威脅並未在掃描執行時被自動刪除。放置於此處的每個項目，是基於以下原因置於此處。

  • 並沒有任何消除病毒的選項 (包括消除病毒、刪除、移動) 受到選取。
  • 已選取了該掃描種類的一個清理選項，但操作該選項失敗。
  • 該項目受到多重感染，仍然含有其他的安全威脅。
  • 只部分偵測到安全威脅，需要進行完整電腦掃描對其進行完整偵測。如欲瞭解如何進行此項操作，請參閱 執行一項完整電腦掃描。
  • 該項目展現可疑行為。
  • 該項目為一項受控管應用程式。
註: 在讀取掃描期間，所偵測到的廣告程式、可能不需要的應用程式與多重元件感染，都會列在隔離所管理員內。讀取掃描不具備自動清理廣告程式、可能不需要的應用程式功能。

一個消除病毒的選項，會因為不具備足夠的存取權限而失效。假使您有更大的權限，您可使用隔離所管理員處理項目。

您以網頁掃描方式偵測到安全威脅，並不會顯現在隔離所管理員內，因為安全威脅並未下載至您的電腦上。因此，您無須採取任何動作。

前一個主題: 許可網站以供使用
下一個主題: 隔離所管理員版面


隔離所管理員版面

隔離所管理員會列出所有掃描偵測到的項目，並可讓您對其採取行動。隔離所管理員 視窗的各個部件描述如下。

點選 顯示 清單，過濾要顯示的項目。
項目的身份，包括 Sophos 網站與其相關的分析的連結。
項目的檔案名稱與位置。

如果項目與 Rootkit 相關，便會顯示為 隱藏。

如果一項 更多 連結顯現在檔案名稱旁邊，這表示此項目受到多元件感染。點選連結，來檢視屬於感染部分的其他元件清單。如果某些元件與某項 Rootkit 相關，此項對話方塊便會顯示某些元件已經隱藏。
您可使用隔離所管理員處理項目的動作。

除非項目已經隱藏，否則能進行的項目有以下三種：清理、刪除 與 移動。

如果您點選其中一項動作，便會在進行確認之後，對於該項目進行此項動作。隱藏檔僅能清除。
偵測到項目的清單。

如欲排列項目，請點選適當的欄位標題。
點選 全選，對這些項目進行動作。

如欲取消選取項目，請取消勾選 類型 欄位內的勾選方塊。
如果您已選取所有項目，並欲清除選項，請點選 取消選取全部。

如欲選取項目，請點選 類型 欄位內的勾選方塊。
點選 從清單移除，從清單中移除選取的項目，而不對其採取任何行動。

此項動作並不會將項目從磁碟移除。
點選 採取行動，來顯示一項您可對於選取項目所採取的一項行動清單。
前一個主題: 關於隔離所管理員
下一個主題: 處理隔離所內的病毒/間諜程式


處理隔離所內的病毒/間諜程式

註: 病毒 在此處指任何病毒蠕蟲、特洛伊木馬或其他惡意軟體。
  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 管理隔離項目。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 顯示 清單內，點選 病毒/間諜程式。

關於每項項目的資訊都會顯現在欄位內。

名稱 顯示 Sophos Anti-Virus 偵測到的身分。如欲瞭解更多病毒/間諜程式的相關資訊，請點選該身份名稱， Sophos Anti-Virus 會將您連結至Sophos 網站上的病毒/間諜程式分析。

詳細資訊 會顯示項目的名稱與位置。如果項目與 Rootkit 相關，便會顯示為「隱藏」。如果一項 更多 連結顯現在檔案名稱旁邊，這表示此項目受到多元件感染。點選連結，來檢視屬於感染部分的其他元件清單。如果任何其他的元件與某項 Rootkit 相關，此項對話方塊便會顯示某些元件已經隱藏。

可採取的行動 會顯示您能對項目採取的行動。除非項目已經隱藏，否則能進行的項目有以下三種：清理、刪除以及移動，茲描述如下。如果您點選其中一項動作，便會在進行確認之後，對於該項目進行此項動作。隱藏檔僅能清除。

處理感染的項目

如欲處理病毒/間諜程式，請使用以下所描述的按鍵。

全選/取消全選

點選這些按鍵來選取或取消選取所有項目。如此可以使您對一群項目實施相同的動作。如欲選取或取消選取一項特定物件，請選取項目類型左邊的勾選方塊。

從清單消除

如果您確定項目並未包含病毒或間諜程式，請點選此選項，來移除清單內的項目。然而，此項動作並不會將項目從磁碟移除。

執行動作

點選此處，來顯示一項您可對於選取項目所採取的一項行動清單。

  • 點選 清理 來移除選取項目的病毒或間諜程式項目。清理文件無法修復文件內病毒所造成的副作用。
    註: 如欲完全清理您電腦上，某些包含數項元件的病毒/間諜程式，或清理隱藏檔案，您需要重新啟動電腦。如此，您會被要求選擇立即或稍後重新啟動電腦。最後的清理步驟將在電腦重新啟動後進行。
    註: 清理某些病毒會造使完整掃描執行，試圖清理 所有 病毒。如此將耗費許多時間。可用的操作會變為 清理，直到掃描結束。
  • 點選 刪除 來刪除您電腦上的選取項目。請小心使用本功能。
  • 點選 移動 來將選取的項目移至其他的資料夾。當清理功能設定完成後，項目會被移至指定的資料夾內。移動一個可執行檔案，會降低該檔案被執行的可能性。請小心使用本功能。
注意:
有時候，如果您刪除或移動感染病毒的檔案，您的電腦可能無法正常運作，因為您的電腦無法找到該檔案。再者，一項感染的檔案可能僅是一項多重感染的一部份，如果情況如此，刪除或移動此項特定檔案，將無法清理您電腦的感染。如果情況如此，請聯繫 Sophos 技術支援部門，來取得關於處理項目的協助。

如欲瞭解關於聯繫技術支援部門的相關資訊，請參閱 技術支援。

如欲配置您可執行的動作，請參閱 配置隔離所管理員的使用者權限。

前一個主題: 隔離所管理員版面
下一個主題: 處理隔離所內的廣告程式與可能不需要的應用程式


處理隔離所內的廣告程式與可能不需要的應用程式

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 管理隔離項目。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 顯示 清單內，點選 廣告程式或可能不需要的應用程式。

關於每項項目的資訊都會顯現在欄位內。

名稱 顯示 Sophos Anti-Virus 偵測到的身分。如欲瞭解更多廣告程式或可能不需要的應用程式的相關資訊，請點選該身份名稱，Sophos Anti-Virus 會將您連結至 Sophos 網站上的廣告程式或可能不需要的應用程式分析。

詳細資訊 會顯示廣告程式或可能不需要的應用程式的子類型。如果項目與 Rootkit 相關，便會顯示為「隱藏」。如果一項 更多 連結顯現在子類型旁邊，這表示此項目是廣告程式或可能不需要應用程式的多件項目。點選連結，來檢視屬於廣告程式或可能不需要的應用程式的其他元件清單。如果任何其他的元件與某項 Rootkit 相關，此項對話方塊便會顯示某些元件已經隱藏。

可採取的行動 會顯示您能對項目採取的行動。可採取的動作有兩種：「許可」以及「清理」，茲描述如下。如果您點選其中一項動作，便會在進行確認之後，對於該項目進行此項動作。

處理廣告程式與可能不需要的應用程式

若要處理廣告程式與可能不需要的應用程式，請使用以下所描述的按鍵。

全選/取消全選

點選這些按鍵來選取或取消選取所有項目。如此可以使您對一群項目實施相同的動作。如欲選取或取消選取一項特定物件，請選取項目類型左邊的勾選方塊。

從清單消除

如果您信任某個項目，請點選此按鍵來從清單內移除選取的項目。然而，此項動作並不會將項目從磁碟移除。

執行動作

點選此處，來顯示一項您可對於選取項目所採取的一項行動清單。

  • 點選 許可 來許可電腦上的選取項目，如果您信任這些項目。如此便可新增項目至許可的廣告程式與可能不需要的應用程式清單內，如此可讓 Sophos Anti-Virus 不會阻礙其在您的電腦上執行。
  • 點選 清理，來為所有的使用者移除所有項目的已知元件。如欲清理電腦上的廣告程式與可能不需要的應用程式，您必須同時為 Windows Administrators 與 SophosAdministrator 群組的成員。
註: 如欲完全清理您電腦上，某些包含數項元件的病毒與 可能不需要的應用程式，或清理隱藏檔案，您需要重新啟動電腦。如此，您會被要求選擇立即或稍後重新啟動電腦。最後的清理步驟將在電腦重新啟動後進行。

如要配置您可採取的行動，請參閱 配置隔離所管理員的使用者權限。

如欲檢視已知與許可的廣告程式與可能不需要的應用程式清單，請點選 配置許可。

前一個主題: 處理隔離所內的病毒/間諜程式
下一個主題: 處理隔離所內的可疑檔案


處理隔離所內的可疑檔案

所謂 可疑檔案，亦即會展現通常在病毒內 (但並非僅限在病毒內發現) ，所發現的綜合特性的檔案。

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 管理隔離項目。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 顯示 清單內，點選 可疑檔案。

關於每項項目的資訊都會顯現在欄位內。

名稱 顯示 Sophos Anti-Virus 偵測到的身分。如欲瞭解更多可疑檔案的相關資訊，請點選該身份名稱，Sophos Anti-Virus 會將您連結至 Sophos 網站上的可疑檔案分析。

詳細資訊 會顯示項目的名稱與位置。如果項目與 Rootkit 相關，便會顯示為「隱藏」。

可採取的行動 會顯示您能對項目採取的行動。除非項目已經隱藏，否則能進行的項目有以下三種：清理、刪除以及移動，茲描述如下。如果您點選其中一項動作，便會在進行確認之後，對於該項目進行此項動作。您僅能對隱藏檔進行許可。

處理可疑檔案

若要處理可疑檔案，請使用以下所描述的按鍵。

全選/取消全選

點選這些按鍵來選取或取消選取所有項目。如此可以使您對一群項目實施相同的動作。如欲選取或取消選取一項特定物件，請選取項目類型左邊的勾選方塊。

從清單消除

如果您信任某個項目，請點選此按鍵來從清單內移除選取的項目。然而，此項動作並不會將項目從磁碟移除。

執行動作

點選此處，來顯示一項您可對於選取項目所採取的一項行動清單。

  • 點選 許可 來許可電腦上的選取項目，如果您信任這些項目。如此便可新增項目至許可的可疑項目清單內，如此可讓 Sophos Anti-Virus 阻礙其受到存取。
  • 點選 刪除 來刪除您電腦上的選取項目。請小心使用本功能。
  • 點選 移動 來將選取的項目移至其他的資料夾。當清理功能設定完成後，項目會被移至指定的資料夾內。移動一個可執行檔案，會降低該檔案被執行的可能性。請小心使用本功能。
注意:
有時候，如果您刪除或移動感染病毒的檔案，您的電腦可能無法正常運作，因為您的電腦無法找到該檔案。

如要配置您可採取的行動，請參閱 配置隔離所管理員的使用者權限。

如欲檢視許可可疑檔案的清單，請點選 配置許可。

前一個主題: 處理隔離所內的廣告程式與可能不需要的應用程式
下一個主題: 處理隔離所內的可疑行為


處理隔離所內的可疑行為

可疑行為 即為看似惡意的行為。

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 管理隔離項目。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 顯示 清單內，點選 可疑行為。

關於每項項目的資訊都會顯現在欄位內。

名稱 顯示 Sophos Anti-Virus 偵測到的身分。如欲瞭解更多該行為的相關資訊，請點選該身份名稱，Sophos Anti-Virus 會將您連結至 Sophos 網站上的行為分析。

詳細資訊 會顯示項目的名稱與位置。

可採取的行動 會顯示您能對項目採取的行動。如果您已經啟用對於可疑行為的攔截行為，您可進行一項動作：許可，茲描述如下。如果您點選其中一項動作，便會在進行確認之後，對於該項目進行此項動作。

處理可疑行為

若要處理可疑項目，請使用以下按鍵。

全選/取消全選

點選這些按鍵來選取或取消選取所有項目。如此可以使您對一群項目實施相同的動作。如欲選取或取消選取一項特定物件，請選取項目類型左邊的勾選方塊。

從清單消除

如果您信任某個項目，請點選此按鍵來從清單內移除選取的項目。然而，此項動作並不會將項目從磁碟移除。

執行動作

點選此處，來顯示一項您可對於選取項目所採取的一項行動清單。

  • 點選 許可 來許可電腦上的選取項目，如果您信任這些項目。如此便可新增項目至許可的可疑項目清單內，如此可讓 Sophos Anti-Virus 不會阻礙其行為。

如要配置您可採取的行動，請參閱 配置隔離所管理員的使用者權限。

如欲檢視許可可疑行為的清單，請點選 配置許可。

前一個主題: 處理隔離所內的可疑檔案
下一個主題: 處理隔離所內的受控管應用程式


處理隔離所內的受控管應用程式

受控管應用程式，即貴機構安全策略不允許在您電腦上執行的應用程式。

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 管理隔離項目。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 顯示 清單內，點選 受控管應用程式。

關於每項項目的資訊都會顯現在欄位內。

名稱 顯示 Sophos Anti-Virus 偵測到的身分。欲瞭解更多受控管應用程式的相關資訊，請點選該身份名稱，Sophos Anti-Virus 會將您連結至 Sophos 網站上的受控管應用程式分析。

詳細資訊 會顯示受控管應用程式的子類型。如果一項 更多 連結顯現在子類型名稱旁邊，請點選連結檢視一項受控管應用程式一部份的其他元件清單。

可採取的行動 會顯示您能對項目採取的行動。然而，除將受控管的應用程式從清單移除之外，您無法對其進行任何動作，茲描述如下。

處理受控管的應用程式

如欲處理受控管的應用程式，請使用以下按鍵操作。

全選/取消全選

點選這些按鍵來選取或取消選取所有項目。如此可以使您對一群項目實施相同的動作。如欲選取或取消選取一項特定物件，請選取項目類型左邊的勾選方塊。

從清單消除

點選此按鍵，從清單中移除選取的項目。然而，此項動作並不會將項目從磁碟移除。在您使用受控管的應用程式之前，必須先經過中央主控台的許可。

前一個主題: 處理隔離所內的可疑行為
下一個主題: 關於清理


關於清理

清理動作能藉由進行以下其中一項操作，刪除您電腦上的安全威脅：

  • 移除軟碟開機區、文件、程式以及任何選擇進行掃描之處內的病毒/間諜程式。
  • 移動或刪除可疑檔案
  • 刪除廣告程式或可能不需要的應用程式項目

當 Sophos Anti-Virus 自動清理內含病毒/間諜程式內的項目時，將會刪除純粹為惡意程式的所有項目，並將試圖對受感染的項目進行消除感染的動作。這些已消除感染的檔案應視為永久損毀，因為病毒掃描功能無從知曉檔案損害之前，包含的項目為何。

清理文件

清理文件無法修復文件內病毒/間諜程式所造成的副作用。請參閱 取得清理資訊，來瞭解如何查閱 Sophos 網站上關於病毒/間諜程式副作用的詳細資料。

清理程式

清理程式只應該作為一種暫時的手段。接下來，您應該隨即從原來的磁片或無毒的備份中，替換已進行清理動作的程式。

清理網頁安全威脅

當您以網頁掃描方式偵測到安全威脅時，無須使用清理功能，因為安全威脅並未下載至您的電腦上。

註: 清理安全威脅可能無法恢復安全威脅已在此電腦上執行的所有動作。例如，如果安全威脅更改一項設定值，清理處理程序可能不會知道原始的設定值。您可能需要確認電腦的組態設定。清理受感染的文件無法修復安全威脅對該文件所進行的變更。
前一個主題: 處理隔離所內的受控管應用程式
下一個主題: 取得清理資訊


取得清理資訊

一旦在您的電腦上發現一項安全威脅，請至 Sophos 網站上查閱安全威脅分析，以取得安全威脅與清理的相關資訊，這項動作相當重要。您可從以下各處進行此項操作：

  • 桌面警示 (讀取掃描)
  • 掃描進度對話方塊 (自訂掃描與右鍵掃描)
  • 隔離所管理員 (所有掃描類型)

透過桌面警示取得資訊

如果您電腦上的讀取掃描已開啟，Sophos Anti-Virus 一旦發現任何安全威脅，即會顯現一項桌面警示。

請在訊息方塊內，點選您要瞭解的安全威脅名稱。Sophos Anti-Virus 會將您連結至Sophos 網站上的安全威脅分析。

經由掃描進度對話方塊取得資訊

若要使用自訂或右鍵掃描，請在掃描進度對話方塊 (或掃描對話方塊，掃描完畢後即會顯現) 內點選您想要瞭解的安全威脅名稱。

Sophos Anti-Virus 會將您連結至Sophos 網站上的安全威脅分析。

透過隔離所管理員取得資訊

  1. 在 首頁 頁面內的 防病毒與 HIPS，點選 管理隔離項目。如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 名稱 欄位內，點選您要瞭解的安全威脅名稱。

Sophos Anti-Virus 會將您連結至Sophos 網站上的安全威脅分析。

前一個主題: 關於清理
下一個主題: 配置防病毒桌面發送訊息


配置防病毒桌面發送訊息

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如欲在 Sophos Anti-Virus 在發現安全威脅時顯示桌面訊息，請依照以下步驟操作。只有讀取掃描才具備此種功能。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 發送警示 > 發送訊息。
  2. 在 發送訊息 對話方塊內，點選 桌面發送訊息 標籤。請依照以下描述設定選項。

    開啟桌面發送訊息

    選取該選項來讓 Sophos Anti-Virus 在發現安全威脅時顯示桌面訊息。

    想要發送的訊息

    選取您要 Sophos Anti-Virus 顯示桌面訊息的事件。

    使用者定義訊息

    在此項文字方塊內，您可以輸入一項將新增至標準訊息結尾的訊息。

    註: 使用者自訂訊息不會顯示在 Windows 8 或更高版本的電腦上。
前一個主題: 取得清理資訊
下一個主題: 配置防病毒電子郵件警示


配置防病毒電子郵件警示

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

若要使 Sophos Anti-Virus 在發現安全威脅或發生錯誤時顯示電子郵件警示，請依照以下指示進行。此項步驟適用於讀取掃描、即時掃描與右鍵掃描。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 發送警示 > 發送訊息。
  2. 在 發送訊息 對話方塊內，點選 電子郵件警示 標籤。請依照以下描述設定選項。

    啟用電子郵件警示功能

    點選此處，便可使 Sophos Anti-Virus 發送電子郵件警示。

    想要發送的訊息

    請點選您想要 Sophos Anti-Virus 寄送電子郵件警示的事件。掃描錯誤 的情形包括當 Sophos Anti-Virus 試圖要掃描一個項目時，遭到拒絕存取該項目。

    當您以網頁掃描方式偵測到安全威脅時，Sophos Anti-Virus 不會傳送訊息，因為安全威脅並未下載至您的電腦上。因此，您無須採取任何動作。

    接收者

    請點選 新增 或 移除， 來新增或移除電子郵件應該送達的郵件地址。請點選 編輯 來變更您新增的電子郵件地址。

    配置 SMTP

    點選此處來變更 SMTP 伺服器設定以及電子郵件警示的語言。(參閱下表。)

配置 SMTP 設定
SMTP 伺服器 | 在文字框中，輸入主機名稱或 SMTP 伺服器的 IP 位址。請點選 測試 來測試是否可以連結上 SMTP 伺服器。(如此將 不會 傳送測試郵件。)
SMTP「寄件者」位址 | 在文字方塊中，請輸入一個彈回郵件及無法寄送郵件可以送達的郵件住址。
SMTP「回覆」位址 | 電子郵件警示是從一個無人信箱發出，您可在文字框中輸入一個回覆電子郵件警示可送達的郵件住址。
語言 | 點選下拉箭頭，選取電子郵件警示發送時應使用的語言。
前一個主題: 配置防病毒桌面發送訊息
下一個主題: 配置防病毒 SNMP 發送訊息


配置防病毒 SNMP 發送訊息

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

若要使 Sophos Anti-Virus 在發現安全威脅或發生錯誤時傳送 SNMP 訊息，請依照以下指示進行。此項步驟適用於讀取掃描、即時掃描與右鍵掃描。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 發送警示 > 發送訊息。
  2. 在 發送訊息 對話方塊內，點選 SNMP 發送訊息 標籤。請依照以下描述設定選項。

    啟用 SNMP 發送訊息

    選取該選項來讓 Sophos Anti-Virus 傳送 SNMP 訊息。

    想要發送的訊息

    請點選您想要 Sophos Anti-Virus 寄送 SNMP 訊息的事件。掃描錯誤 的情形包括當 Sophos Anti-Virus 試圖要掃描一個項目時，遭到拒絕存取該項目。

    當您以網頁掃描方式偵測到安全威脅時，Sophos Anti-Virus 不會傳送 SNMP 訊息，因為安全威脅並未下載至您的電腦上。因此，您無須採取任何動作。

    SNMP 陷阱目的地

    請在文字方塊中輸入 IP 位址或警示欲送達的電腦。

    SNMP 社群名稱

    在文字方塊中，輸入 SNMP 社群名稱。

    測試

    點選此處，便能將一個測試 SNMP 訊息寄送至您所指定的 SNMP 陷阱目的地。

前一個主題: 配置防病毒電子郵件警示
下一個主題: 配置防病毒電子郵件警示


配置防病毒電子郵件警示

若要使 Sophos Anti-Virus 在發現安全威脅或發生錯誤時，新增警示至 Windows 事件日誌中，請依照以下指示進行。此項步驟適用於讀取掃描、即時掃描與右鍵掃描。

  1. 點選 首頁 > 防病毒與 HIPS > 配置防病毒與 HIPS > 發送警示 > 發送訊息。
  2. 在 發送訊息 對話方塊內，點選 事件日誌 標籤。請依照以下描述設定選項。

    開啟事件日誌紀錄

    選取此選項，來讓 Sophos Anti-Virus 發送訊息至 Windows 事件日誌。

    想要發送的訊息

    請點選您想要 Sophos Anti-Virus 寄送電子郵件警示的事件。掃描錯誤 的情形包括當 Sophos Anti-Virus 試圖要掃描一個項目時，遭到拒絕存取該項目。

    當您以網頁掃描方式偵測到安全威脅時，Sophos Anti-Virus 不會傳送訊息，因為安全威脅並未下載至您的電腦上。因此，您無須採取任何動作。

前一個主題: 配置防病毒 SNMP 發送訊息
下一個主題: 配置掃描日誌紀錄


配置掃描日誌紀錄

此台電腦的掃描日誌紀錄儲存於以下位置。

Windows Vista、Windows 7、Windows 8、Windows 8.1、Windows 10、Windows Server 2008、Windows Server 2008 R2、Windows Server 2012、Windows Server 2012 R2： | C:\ProgramData\Sophos\Sophos Anti-Virus\logs\SAV.txt
其他 Windows 平台 | C:\Documents and Settings\All Users\Application Data\Sophos\Sophos Anti-Virus\logs\SAV.txt
  1. 點選 首頁 > 防病毒與 HIPS > 檢視防病毒與 HIPS 日誌紀錄 > 配置日誌。
  2. 在 配置本電腦的日誌紀錄層級 對話方塊內，依照以下步驟設定選項。

    日誌紀錄層級

    若要停止日誌紀錄，請點選 停止紀錄。若要紀錄摘要資訊、錯誤訊息等，請點選 一般紀錄。若要紀錄最多資訊，包括所掃描的檔案、掃描的主要步驟等，請點選 詳細紀錄。

    日誌紀錄備份

    若要每個月備份日誌紀錄檔案，請點選 啟用壓縮功能。壓縮檔與紀錄檔儲存於相同的資料夾內。在最早的備份檔案刪除前，選擇要儲存的 壓縮日誌紀錄檔案數目。選擇 壓縮日誌紀錄 來減低日誌壓縮檔的大小。

前一個主題: 配置防病毒電子郵件警示
下一個主題: 檢視掃描日誌紀錄


檢視掃描日誌紀錄

在 首頁 頁面內的 防病毒與 HIPS，點選 檢視防病毒與 HIPS 日誌紀錄。
如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
您可從日誌紀錄頁面中，將日誌紀錄複製到剪貼簿、電子郵件內，或將其列印出來。

若要尋找日誌紀錄中的特定文字，請點選 尋找 並輸入您欲搜尋的文字。

前一個主題: 配置掃描日誌紀錄
下一個主題: 掃描受控管的應用程式


掃描受控管的應用程式

受控管應用程式，即貴機構安全策略不允許在您電腦上執行的應用程式。

掃描受控管應用程式功能的開啟或關閉，係由一項管理主控台控制，屬於應用程式控管策略一部份，包括在讀取掃描內。

如欲瞭解關於讀取掃描相關資訊，請參閱 關於讀取掃描與即時掃描。

前一個主題: 檢視掃描日誌紀錄
下一個主題: 關閉掃描受控管應用程式


關閉掃描受控管應用程式

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您開啟對於受控管應用程式的掃描，此項功能可能讓您無法解除安裝某些應用程式。如果您是 SophosAdministrator 群組成員，您可暫時關閉掃描本台電腦上的受控管應用程式。

掃描受控管應用程式

  1. 在 配置 功能表內，點選 應用程式控管。
  2. 取消勾選 開啟讀取掃描 勾選方塊。
前一個主題: 掃描受控管的應用程式
下一個主題: 關於本台電腦的設備控管


關於本台電腦的設備控管

如果未在此台電腦上使用主控台來管理 ，則 Sophos Endpoint Security and Control 不 包括設備控管功能。

管理主控台已開啟或關閉設備控管。如果您開啟設備控管功能，可能會使您無法連結設備至此台電腦，以進行維修或故障排除。如果情況如此，您可暫時關閉此台電腦的設備控管。如欲瞭解更多詳情，請參閱 暫時關閉設備控管。

前一個主題: 關閉掃描受控管應用程式
下一個主題: 什麼種類的設備能受控管？


什麼種類的設備能受控管？

設備控管功能可讓您攔截以下類型的設備：儲存設備、網路設備、短距無線傳輸設備和媒體設備。

儲存

  • 卸除式儲存裝置 (例如可攜式快閃記憶碟、PC 讀卡機，以及外接硬碟)
  • 光碟機 (CD-ROM/DVD/Blu-ray 光碟機)
  • 軟碟片磁碟機
  • 安全的卸除式儲存設備 (例如硬體加密的可攜式快閃記憶碟)

網路

  • 數據機
  • 無線裝置 (Wi-Fi 介面、802.11 標準)

此項電腦的設備控管策略可能處於 攔截橋接 模式，此項模式會在電腦連接至實體網路時，關閉無線或數據機網路卡 (一般透過乙太網路連接)。一旦電腦斷開實體網路連線，無線或數據機網路卡便會重新開啟。

短距無線傳輸

  • 藍芽介面
  • 紅外線裝置 (IrDA IrDA 紅外線介面)

媒體

  • MTP/PTP

    這包括行動電話、平板電腦、數位相機、媒體播放程式以及其他使用媒體傳輸通訊協定 (MTP) 或圖片傳輸通訊協定 (PTP) 連接到電腦的設備。

前一個主題: 關於本台電腦的設備控管
下一個主題: 暫時關閉資料控管


暫時關閉資料控管

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您的身分是 Sophos Administrator 群組 成員之一，且您欲將一項設備裝置連上電腦，以便進行維護或故障排除 (例如使用光碟安裝軟體)，您可暫時 關閉對設備控管。

如欲關閉本台電腦的設備控管：

  1. 在 配置 功能表內，點選 設備控管。
  2. 取消勾選 開啟 Sophos 設備控管 勾選方塊。
前一個主題: 什麼種類的設備能受控管？
下一個主題: 配置設備控管日誌紀錄


配置設備控管日誌紀錄

  1. 在 配置 功能表內，點選 設備控管。
  2. 在 日誌紀錄層級 內，選取以下選項之一：
    • 若要停止日誌紀錄，請點選 無紀錄。
    • 若要紀錄摘要資訊、錯誤訊息等，請點選 一般紀錄。
    • 點選 詳細紀錄，來提供較一般更多活動的相關資訊。請唯有在您需要故障排除詳細日誌紀錄的情況下，使用此項設定，因為日誌紀錄大小增長的速度極為迅速。
  3. 在 日誌紀錄壓縮 下，遵循螢幕上的指示操作。
前一個主題: 暫時關閉資料控管
下一個主題: 檢視資料控管日誌紀錄


檢視資料控管日誌紀錄

在 首頁 頁面內的 資料控管 ，點選 檢視資料控管日誌。
如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
您可從日誌紀錄頁面中，將日誌紀錄複製到剪貼簿、電子郵件內，或將其列印出來。

若要尋找日誌紀錄中的特定文字，請點選 尋找 並輸入您欲搜尋的文字。

前一個主題: 配置設備控管日誌紀錄
下一個主題: 關於本台電腦的資料控管


關於本台電腦的資料控管

如果未在此台電腦上使用主控台來管理 ，則 Sophos Endpoint Security and Control 不 包括資料控管功能。

來自管理主控台的策略，能開啟或關閉資料控管功能。然而，如果您是 SophosAdministrator 群組成員，您可暫時關閉本台電腦上的資料控管，以進行維護或故障排除：如欲瞭解更多詳情，請參閱 暫時關閉資料控管。

前一個主題: 檢視資料控管日誌紀錄
下一個主題: 暫時關閉資料控管


暫時關閉資料控管

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您是 SophosAdministrator 群組成員，您可暫時關閉本台電腦上的資料控管，以進行維護或故障排除：

  1. 在 配置 功能表內，點選 資料控管。
  2. 取消勾選 開啟 Sophos 資料控管 勾選方塊。
前一個主題: 關於本台電腦的資料控管
下一個主題: 如何將檔案新增至儲存設備？


如何將檔案新增至儲存設備？

如果本台電腦上資料控管功能已開啟，資料控管策略會使用以下方式，攔截任何試圖將檔案新增至受偵測儲存設備的操作：

  • 從程式內儲存資料
  • 使用 DOS 複製指令
  • 使用 Windows Explorer 在設備內建立新檔案

如果您見到一項桌面警示，警告您此項意圖，您應該將檔案儲存至您的硬碟或網路磁碟機內，然後使用 Windows Explorer 將其複製到儲存設備內。

前一個主題: 暫時關閉資料控管
下一個主題: 配置資料控管日誌紀錄


配置資料控管日誌紀錄

  1. 在 配置 功能表內，點選 資料控管。
  2. 在 日誌紀錄層級 內，選取以下選項之一：
    • 若要停止日誌紀錄，請點選 無紀錄。
    • 若要紀錄摘要資訊、錯誤訊息等，請點選 一般紀錄。
    • 點選 詳細紀錄，來提供較一般更多活動的相關資訊。請唯有在您需要測試新資料控管規則的情況下，使用此項設定，因為日誌紀錄增長的速度極為迅速。
  3. 在 日誌紀錄壓縮 下，遵循螢幕上的指示操作。
前一個主題: 如何將檔案新增至儲存設備？
下一個主題: 檢視資料控管日誌紀錄


檢視資料控管日誌紀錄

在 首頁 頁面內的 資料控管 ，點選 檢視資料控管日誌。
如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
您可從日誌紀錄頁面中，將日誌紀錄複製到剪貼簿、電子郵件內，或將其列印出來。

若要尋找日誌紀錄中的特定文字，請點選 尋找 並輸入您欲搜尋的文字。

前一個主題: 配置資料控管日誌紀錄
下一個主題: 關於本台電腦的網頁控管


關於本台電腦的網頁控管

Sophos Web Control 可為位於您公司網路之外，或瀏覽於公司網路之外的電腦，提供防護、控管與通報功能。

註: 此項功能並未包括於所有許可權內。如果您要使用此項功能，您可能需要變更您的許可權。

如果未在此台電腦上使用主控台來管理 ，則 Sophos Endpoint Security and Control 不 包括網頁控管功能。

來自管理主控台的策略，能開啟或關閉網頁控管功能。然而，如果您是 SophosAdministrator 群組成員，您可暫時關閉本台電腦上的網頁控管功能。如欲了解如何進行此項操作，請參閱 暫時關閉網頁控管。

前一個主題: 檢視資料控管日誌紀錄
下一個主題: 暫時關閉網頁控管


暫時關閉網頁控管

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您是 SophosAdministrator 群組成員，您可暫時關閉本台電腦上的，以進網頁控管功能，進行維護或故障排除：

如欲關閉本台電腦的網頁控管：

  1. 在 配置 功能表內，點選 網頁控管。
  2. 取消勾選 開啟網頁控管 勾選方塊。
前一個主題: 關於本台電腦的網頁控管
下一個主題: 防火牆入門


防火牆入門

在您首次安裝防火牆時，您可能需要對其進行配置。您是否需要進行此項操作，取決於您防火牆的安裝方式。安裝類型包括以下兩種：

  • 安裝於網路電腦上，透過管理主控台進行管理
  • 安裝於獨立電腦上，透過電腦進行管理

透過管理主控台管理的防火牆

如果防火牆是透過管理主控台安裝、管理，便可根據策略設定的規則，許可或攔截應用程式。

除非策略已將防火牆置轉為互動模式 (請見以下)，否則您將不會見到提醒訊息，且無須使用任何方式配置防火牆。

透過此項電腦管理的防火牆

如果防火牆係在本台電腦上管理，Sophos 建議您先建立規則來允許一般應用程式與服務的網路存取，例如網頁瀏覽器與電子郵件用戶端。

如欲瞭解更多建立規則的相關資訊，請參閱 關於配置防火牆。

防火牆一開始亦使用互動模式 (參見以下內容)。請讓防火牆保持互動模式一段時間，使您能許可或攔截其他您使用的應用程式或服務。

一旦您配置防火牆完成，且防火牆辨識您一般使用的應用程式，Sophos 建議您變更為其中一項非互動模式。

如欲瞭解更多詳情，請參閱 轉換為非互動模式。

什麼是互動模式？

使用互動模式，防火牆即會詢問您是否要許可或攔截不具有規則的應用程式與資料流。

如欲瞭解如何處理防火牆發出的訊息，請參閱 互動模式。

互動模式不適用於 Windows 8 或更高版本的電腦。您必須新增特定的策略規則以許可或攔截應用程式。或者您可使用管理主控台內的事件檢視器，以互動方式管理應用程式規則。

前一個主題: 暫時關閉網頁控管
下一個主題: 關於配置防火牆


關於配置防火牆

您可使用多種不同方式配置防火牆，然後將其開啟。然而，如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

以下列出部分一般功能：

  • 開啟互動模式
  • 篩選 ICMP 訊息
  • 允許區域網的所有資料流
  • 許可 FTP 下載
  • 建立全域規則
  • 許可應用程式
  • 允許應用程式啟動隱藏進程
  • 允許應用程式使用原始通訊端
  • 使用總和檢查驗證應用程式
前一個主題: 防火牆入門
下一個主題: 暫時停用防火牆


暫時停用防火牆

如果您是 SophosAdministrator 群組成員，您可暫時關閉本台電腦上的防火牆，以進行維護或故障排除：

Sophos Endpoint Security and Control 會保留您在此所做的設定，甚至在您重新開機之後依然保留。如果您關閉防火牆，在您重新將其開啟之前，您的電腦將不會受到防護。

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，選取主要位置或次要位置旁的 許可所有資料流 勾選方塊。
前一個主題: 關於配置防火牆
下一個主題: 許可電子郵件


許可電子郵件

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。
  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 點選 新增，找出電子郵件應用程式，然後按兩下該應用程式。
電子郵件應用程式便已受到許可，成為「信任」的應用程式。

信任的應用程式允許具備完全與無條件的存取規則，包括存取網際網路。如欲取得更佳的安全防護，您可套用 Sophos 提供的預設規則。

  1. 在許可應用程式的清單內，點選電子郵件應用程式。
  2. 按一下自? >新增????> 電子郵件用?旁的箭頭。
前一個主題: 暫時停用防火牆
下一個主題: 許可使用網頁瀏覽器


許可使用網頁瀏覽器

註: 如果您要允許使用網頁瀏覽器，您亦可允許 FTP 存取。
  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 點選 新增，找出網頁瀏覽器應用程式，然後按兩下該應用程式。
網頁瀏覽應用程式便已受到「信任」。

信任的應用程式允許具備完全與無條件的存取規則，包括存取網際網路。如欲取得更佳的安全防護，您可套用 Sophos 提供的預設規則。

  1. 在許可應用程式的清單內，點選網頁瀏覽器應用程式。
  2. 點選 自訂從預設值新增規則 瀏覽器。
前一個主題: 許可電子郵件
下一個主題: 許可 FTP 下載


許可 FTP 下載

註: 如果您允許使用能存取 FTP 伺服器的網頁瀏覽器，您亦不需要許可 FTP 下載。
  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 點選 新增，找出 FTP 應用程式，然後按兩下該應用程式。
FTP 應用程式便已受到許可，成為「信任」的應用程式。

信任的應用程式允許具備完全與無條件的存取規則，包括存取網際網路。如欲取得更佳的安全防護，您可套用 Sophos 提供的預設規則。

  1. 在許可應用程式的清單內，點選 FTP 應用程式。
  2. 點選 自訂 > 從預設值新增規則 > FTP 用戶端。
前一個主題: 許可使用網頁瀏覽器
下一個主題: 允許區域網的所有資料流


允許區域網的所有資料流

如欲許可區域網電腦間的所有資料流：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 區域網 標籤內，進行以下其中一項操作：
    • 點選 偵測區域網，來偵測您電腦所在的區域網，並將其新增至網路位址清單。
    • 點擊 新增。在 選取位址 對話方塊內，選取 位址形式，輸入網域名稱或 IP 位址，然後點選 新增。
      註: 如果您選取 本機網路 (自動偵測)，您無須輸入任何項目。此選項目前不適用於 Windows 8 或更高版本的電腦。如欲參閱本機網路偵測的相關資訊，請參閱 關於本機網路偵測。
  4. 點選 確定，關閉 選取位址 對話方塊。
  5. 在 區域網設定 清單內，為網路選取 信任 勾選方塊。

注意事項

  • 如果您許可區域網上電腦間的所有的資料流，您亦同時許可區域往上的檔案與印表機共用。
前一個主題: 許可 FTP 下載
下一個主題: 許可區域網上的檔案與印表機共用


許可區域網上的檔案與印表機共用

註: 如果您已經許可區域網上電腦間的所有資料流，您亦無須許可檔案與印表機共用資料流。

如欲許可區域網上的檔案與印表機共用：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 區域網 標籤內，進行以下其中一項操作：
    • 點選 偵測區域網，來偵測您電腦所在的區域網，並將其新增至網路位址清單。
    • 點選 新增。在 選取位址 對話方塊內，選取 位址形式，輸入網域名稱或 IP 位址，然後點選 新增。
      註: 如果您選取 本機網路 (自動偵測)，您無須輸入任何項目。此選項目前不適用於 Windows 8 或更高版本的電腦。如欲參閱本機網路偵測的相關資訊，請參閱 關於本機網路偵測。
  4. 點選 確定，關閉 選取位址 對話方塊。
  5. 在 區域網設定 清單內，選取區域網的 NetBIOS 勾選方塊，來許可區域網上的檔案與印表機共用。
如欲瞭解如何在其他區域網 (區域網路) 而非 區域網設定 清單上的區域網上許可檔案與印表機共用，請參閱以下主題：
  • 攔截不需要的檔案與印表機共用
  • 可讓您對檔案與印表機共用的控管更具彈性

如欲瞭解如何許可區域網上所有的資料流，請參閱 許可區域網的所有資料流。

前一個主題: 允許區域網的所有資料流
下一個主題: 可讓您對檔案與印表機共用的控管更具彈性


可讓您對檔案與印表機共用的控管更具彈性

如果您要對檔案與印表機共用的控管更具彈性 (例如單向 NetBIOS 資料流)，您可進行以下操作：

  1. 在其他區域網 (區域網路) 而非 區域網設定 清單上的區域網上許可檔案與印表機共用。此項操作可讓那些區域網上的 NetBIOS 資料流受防火牆規則處理。
  2. 建立可使用適當 NetBIOS 通訊埠與通訊協定，許可流向、流出主機通訊的全域規則。本公司建議您建立全域規則，明確攔截所有不需要的檔案與印表機共用資料流，而非使其受預設規則處理。

如欲在其他區域網 (區域網路) 而非 區域網設定 清單上的區域網上許可檔案與印表機共用：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 區域網標籤內，取消勾選 攔截其他網路的檔案與印表機共用 勾選方塊。
前一個主題: 許可區域網上的檔案與印表機共用
下一個主題: 攔截不需要的檔案與印表機共用


攔截不需要的檔案與印表機共用

如欲攔截在 區域網 標籤內 區域網設定 清單以外的檔案與印表機共用：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 請在 區域網 標籤內，選取 攔截其他網路的檔案與列印共享 勾選方塊。
前一個主題: 可讓您對檔案與印表機共用的控管更具彈性
下一個主題: 許可應用程式


許可應用程式

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 點選 新增，找出應用程式，然後按兩下該應用程式。
如此，應用程式便已受到「信任」。

信任的應用程式允許具備完全與無條件的存取規則，包括存取網際網路。如欲擁有更佳的安全防護，您可套用一項或多項 應用程式規則，來指定允許應用程式執行的條件。

  • 建立應用程式規則
  • 套用預設應用程式規則
前一個主題: 攔截不需要的檔案與印表機共用
下一個主題: 攔截應用程式


攔截應用程式

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 如果應用程式未在清單內，請點選 新增，找出應用程式，然後點選該應用程式。
  5. 請在清單內選取該應用程式，然後點選 攔截。
前一個主題: 許可應用程式
下一個主題: 攔截 IPv6


攔截 IPv6

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 根據作業系統，進行不同操作：
    • 若使用 Windows 7 及較舊的作業系統，在 一般 標籤內的 攔截 中，選取 攔截 IPv6 封包。
    • 若您使用 Windows 8 或更高版本，請在 全域規則 標籤上選取 攔截所有 IPv6 資料流。
前一個主題: 攔截應用程式
下一個主題: 開啟或關閉總和檢查的使用


開啟或關閉總和檢查的使用

如果您開啟使用總和檢查功能以驗證應用程式，您會根據應用程式經識別的總和檢查碼自動信任或攔截該應用程式 (您也可手動新增總和檢查碼)。如果應用程式不符合總和檢查碼，則其會遭攔截。

如果您關閉此選項，則應用程式會以其檔名識別。

如欲開啟或關閉總和檢查的使用：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 根據作業系統，進行不同操作：
    • 若使用 Windows 7 及較舊的作業系統，在 攔截 下，取消勾選 使用總和檢查驗證應用程式 勾選方塊。
    • 若您使用 Windows 8 或更高版本的電腦，請點選 應用程式 標籤並取消勾選 使用總和檢查來驗證應用程式 勾選方塊。
    如欲開啟總和檢查的使用，請選取勾選方塊。
前一個主題: 攔截 IPv6
下一個主題: 開啟或關閉對於受修改進程的攔截功能


開啟或關閉對於受修改進程的攔截功能

註: 此選項不適用於 Windows 8 或更高版本的電腦，因為其自動受 Sophos Anti-Virus HIPS 技術處理。

惡意程式會藉由修改記憶體內經由信任的程式啟動的進程，試圖避開防火牆偵測，然後代替其使用受修改的進程存取網路。

您可配置防火牆來偵測、攔截記憶體內受到修改的處理程序。

如欲開啟或關閉對於受修改進程的攔截功能：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 一般 標籤的 攔截 內，取消選取 若記憶體受到其他應用程式修改，則攔截該進程 勾選方塊，來關閉對於受修改進程的攔截功能。
    如欲開啟對於受修改程式的攔截功能，請選取該勾選方塊。
如果防火牆偵測到記憶體內的進程已經修改，便會新增規則，防止受修改的進程存取網路。

注意事項

  • 不建議永久關閉對於受修改進程的攔截功能。請唯有在有必要的情況下，才關閉通報功能。
  • 64 位元版本的 Windows 不支援攔截受修改的處理程序的功能。
  • 唯有受修改的處理程序，才會受到攔截。受修改進程被攔截，禁止存取網絡。
前一個主題: 開啟或關閉總和檢查的使用
下一個主題: 篩選 ICMP 訊息


篩選 ICMP 訊息

網際網路控管訊息通訊協定 (ICMP) 訊息，能允許網路中的電腦分享錯誤與狀態資訊。您可許可或攔截特定類型的內送或外送 ICMP 訊息。

您應唯有在熟悉網路通訊協定的情況下，才變更 ICMP 訊息。如欲瞭解 ICMP 訊息的相關說明，請參閱 ICMP 訊息類型說明。

如欲過濾 ICMP 訊息：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 ICMP 標籤。此介面會根據作業系統而有所不同：
    • 若您使用 Windows 7 或較舊的作業系統，選取 流入 或 流出 勾選方塊，來允許特定類型的傳入或傳出訊息。
    • 在 Windows 8 或更高版本的電腦上，ICMP 訊息類型被歸類至不同區塊。您可從下拉式清單中選取一般設定，或點擊 詳細資訊 檢視或編輯設定。
前一個主題: 開啟或關閉對於受修改進程的攔截功能
下一個主題: ICMP 訊息類型說明


ICMP 訊息類型說明

網路錯誤通報

無法送達目的地、回應回覆
當路由器無法傳送 IP 資料包時，便會發出此項訊息。所謂資料包，即是資料或封包單位，係透過 TCP/IP 網路進行傳送。
來源抑制
如果主機接收資料時，傳送的速度過於迅速，導致無法處理，便會發出此訊息。此項訊息係一項請求，要求傳送來源減低傳送資料包的速度。
超出時間
如果資料包超過能透過路由器傳遞的上限，路由器便會發出此項訊息。
參數問題
如果在資料包傳遞的過程中發生問題，導致無法完成傳遞過程，路由器便會發出此項訊息。此項問題的原因之一，可能是資料包標題無效。

網路排疑解難

回應要求、回應回覆
用來測試目的地的存取性及其狀態。主機會傳送 回波要求，並聽取相應的 回應回覆。此項操作最常使用 ping 指令。

IPv4 網路位址及路由配置

重新導向
如果路由器接收到應該傳送至其他伺服器的資料包，路由器便會傳送此項訊息。此訊息包含來源未來應傳送資料包目的地的位址。此項訊息係用於優化網路資料流的路由器。
路由廣播、路由請求
能許可主機尋找路由器。路由器會透過 路由廣播 訊息，定期廣播其 IP 位址。主機亦可藉由廣播 路由請求 訊息，請求路由器將使用 路由廣播 回應的路由器位址。
時間標籤要求、時間標籤回覆
用於同步處理主機之間的時鐘，以及估測傳輸時間。
資訊要求、資訊回覆
已廢棄不用。之前主機使用者些訊息判定其跨網路位址，但現在被視為過時，不應使用。
位址遮罩要求、位址遮罩回覆
用於尋找子網路遮罩 (亦即位址的哪個部分定義網路)。主機會傳送 位址遮罩請求 至路由器，並接收傳回的 位址遮罩回覆。
前一個主題: 篩選 ICMP 訊息
下一個主題: 恢復預設防火牆設定


恢復預設防火牆設定

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 管理配置 內，點選 恢復預設值。
前一個主題: ICMP 訊息類型說明
下一個主題: 互動模式


互動模式

註: 互動模式不適用於 Windows 8 或更高版本的電腦。您必須新增特定的策略規則以許可或攔截應用程式。或者您可使用管理主控台內的事件檢視器，以互動方式管理應用程式規則。

如果使用互動模式，防火牆會在每次未知應用程式或服務要求網路存取時，顯示 學習對話。學習模式對話會詢問您是否要許可此次資料流、攔截此次資料流，或者為該類型的資料流建立規則。

如果使用互動模式，您將見到以下類型的學習對話：

  • 隱藏進程學習對話
  • 通訊協定學習對話
  • 應用程式學習對話
  • Rawsocket 學習對話
  • 總和檢查學習對話
前一個主題: 恢復預設防火牆設定
下一個主題: 開啟互動模式


開啟互動模式

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 一般 標籤的 工作模式 內，點選 互動。
前一個主題: 互動模式
下一個主題: 轉換為非互動模式


轉換為非互動模式

非互動模式有兩種：
  • 預設為許可
  • 預設為攔截

在非互動模式中，防火牆使用您的規則自動處理網路資料流。不具有符合規則的網路資料流 (若為輸出)，將全部受到許可或攔截。

如欲變更為非互動模式：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 一般 標籤的 工作模式 下，點選 預設為許可 或 預設為攔截。
前一個主題: 開啟互動模式
下一個主題: 隱藏進程學習對話


隱藏進程學習對話

隱藏進程，即某項應用程式啟動其他的應用程式，以進行為其網路存取。惡意應用程式有時可使用此項技巧避開防火牆：惡意程式會啟動信任的應用程式來存取網路，而非自行存取網路。

隱藏進程學習對話，能顯示隱藏進程以及啟動該隱藏進程的應用程式的相關資訊。

  • 開啟總和檢查學習對話
前一個主題: 轉換為非互動模式
下一個主題: 開啟總和檢查學習對話


開啟總和檢查學習對話

如果您使用互動模式，防火牆會在偵測到新啟動程式時，顯示學習模式。

如果您使用學習模式，且未選取此選項，新的啟動程式會受到攔截，無法啟動隱藏進程。

如欲隱藏進程學習對話：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 進程 標籤。
  4. 選取 警告新的啟動程式 勾選方塊。
前一個主題: 隱藏進程學習對話
下一個主題: 通訊協定學習對話


通訊協定學習對話

如果防火牆偵測到無法與特定應用程式相關的系統所進行的活動，便會要求您建立通訊協定規則。

通訊協定學習對話會顯示關於不明網路活動的相關資訊，亦即通訊協定與遠端位址。

前一個主題: 開啟總和檢查學習對話
下一個主題: 應用程式學習對話


應用程式學習對話

如果防火牆偵測到某項應用程式試圖使用任何現存規則未涵蓋的方式存取網路時，便會要求建立一項應用程式規則。

應用程式學習對話會顯示關於不明網路活動的相關資訊，亦即遠端服務與遠端位址。

前一個主題: 通訊協定學習對話
下一個主題: Rawsocket 學習對話


Rawsocket 學習對話

Rawsocket 能允許進程控管其在網路上傳送資料的所有部分，可用於惡意用途。

如果防火牆偵測到某項 Rawsocket 試圖使用任何現存規則未涵蓋的方式存取網路時，便會要求建立一項 Rawsocket 規則。

Rawsocket 學習對話會顯示 Rawsocket 的相關資訊。

  • 開啟 Rawsocket 學習對話
前一個主題: 應用程式學習對話
下一個主題: 開啟 Rawsocket 學習對話


開啟 Rawsocket 學習對話

如果您使用互動模式，防火牆可在偵測到 Rawsocket 試圖使用任何現存規則未涵蓋的方式存取網路時，顯示一項學習對話。

如果您使用學習模式，且未選取此選項，Rawsocket 會受到攔截，無法存取網路。

如欲開啟 Rawsocket 學習對話：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 進程 標籤。
  4. 選取 警告使用 Rawsocket 勾選方塊。
前一個主題: Rawsocket 學習對話
下一個主題: 總和檢查學習對話


總和檢查學習對話

如果防火牆偵測到新的或受修改的應用程式，便會顯現一項總和檢查學習對話。

總和檢查學習對話只會在您使用總和檢查驗證應用程式時顯示。如欲瞭解更多詳情，請參閱 開啟或關閉總和檢查的使用。

如果您要允許應用程式存取網路，您必須將其總和檢查 (一項獨一而二的識別符) 至已知總和檢查的清單內。

請選取以下選項：

  • 為此項應用程式新增總和檢查至現有的總和檢查 能許可本應用程式的多項版本。
  • 取代此項應用程式任何總和檢查 會取代具有要求存取總和檢查的應用程式的所有現有總和檢查，如此便能僅許可此項應用程式的最新版本。
  • 攔截此項應用程式，直到其重新啟動為止 選項，可攔截此次應用程式。
前一個主題: 開啟 Rawsocket 學習對話
下一個主題: 關於防火牆配置檔案


關於防火牆配置檔案

Sophos Client Firewall 可讓您將防火牆一般設定與規則，作為配置檔匯出。您可進行以下操作，使用以下功能：

  • 備份並恢復您整個防火牆配置。
  • 儲存一般設定配置，並將其安裝在多台電腦上。
  • 在電腦上建立應用程式的規則，並將其匯出，使其能在其他執行相同應用程式的電腦上使用。
  • 使用管理主控台合併在數個電腦上建立的配置，來建立能在網路上所有電腦上使用的策略。

前一個主題: 總和檢查學習對話
下一個主題: 匯出防火牆配置檔案


匯出防火牆配置檔案

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 點選 匯出。
  3. 請賦予您的配置檔案名稱與位置，然後點選 儲存。
前一個主題: 關於防火牆配置檔案
下一個主題: 匯出防火牆配置檔案


匯出防火牆配置檔案

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 點選 匯入。
  3. 選取配置檔，然後點選 開啟。
  4. 依照螢幕上的指示操作。
前一個主題: 匯出防火牆配置檔案
下一個主題: 關於防火牆規則


關於防火牆規則

全域規則

全域規則可套用於所有網路通訊以及應用程式，即使其已經具備應用程式規則。

應用程式規則

一項應用程式能具有一項或多項規則。您可使用 Sophos 建立的預先設定規則，或建立自訂規則，賦予您更多對於應用程式存取的控管能力。

有關默認全域和應用規則設置的資訊，請參見 http://www.sophos.com/en-us/support/knowledgebase/57757.aspx。

前一個主題: 匯出防火牆配置檔案
下一個主題: 關於套用規則的順序


關於套用規則的順序

對於使用 Rawsocket 的連線，僅有全域規則會受到檢查。

對於 未 使用 rawsocket 的連線，其多項規則會取決於其連線是否連向列於 區域網 標籤內的網路位址，而受到檢查。

如果網路位址列於 區域網 標籤，以下規則便會受到檢查：

  • 如果位址被標示為 信任，該連結的所有資料流皆會受允許，不會受到進一步檢查。
  • 如果位址標示為 NetBIOS，符合以下條件的任何連結的檔案與印表機共用，皆會受到允許：
    連結 | 連接埠 | 範圍
    TCP | 遠端 | 137-139 或 445
    TCP | 本機 | 137-139 或 445
    UDP | 遠端 | 137 或 138
    UDP | 本機 | 137 或 138

如果網路位址 未 列於 區域網 標籤內，其他的防火牆規則將依照以下順序受到檢查：

  1. 所有未受許可使用 區域網 的 NetBIOS 資料流，會根據 攔截其他網路的檔案與列印設定 勾選方塊內的設定進行處置。
    • 如果選取該勾選方塊，資料流便會受到攔截。
    • 如果取消勾選該勾選方塊，資料流將受其餘規則處理。
  2. 高優先權全域規則，係使用其列出的順序對其進行檢查。
  3. 如果連線尚未套用規則應用程式規則將受到檢查。
  4. 如果連線尚未處理，將依據其列出的順序，套用一般優先全域規則。
  5. 如果未發現處理連線的規則：
    • 使用 預設為許可 模式將允許資料流 (如果資料流為外流)。
    • 使用 預設為攔截 模式時，將攔截資料流。
    • 使用 互動 模式時，使用者將被要求進行決定。此模式不適用於 Windows 8 或更高版本的電腦。
    註: 如果您未變更工作模式，防火牆將處於 預設為攔截 模式。
前一個主題: 關於防火牆規則
下一個主題: 關於本機網路偵測


關於本機網路偵測

註: 此選項目前不適用於 Windows 8 或更高版本的電腦。

您可將本電腦的本機網路指派至防火牆規則。

防火牆會在電腦啟動時，判定其本機網路，然後會在執行時偵測任何變更。如果偵測到任何變更，防火牆將使用最新的本機網路位址範圍更新任何所有本機網路規則。

注意:
在您使用本機網路規則作為可能用於「辦公環境」以外位置，作為其中一項配置時，本公司強烈建議您謹慎進行操作時。如欲瞭解更多詳情，請參閱 建立次要配置。
前一個主題: 關於套用規則的順序
下一個主題: 建立全域規則


建立全域規則

重要: 本公司建議您唯有在熟悉網路通訊協定的情況下，才變更全域規則。

全域規則套用於所有尚未具有規則的網路連線與應用程式。

如欲建立全域規則：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 全域規則 標籤。
  4. 點選 新增。
  5. 在 規則名稱下，輸入該規則的名稱。
    清單內的規則名稱不得重複。全域規則的名稱不得重複。
  6. 若您使用 Windows 8 或更高版本的電腦，請在 通訊協定 下選取您欲使用的通訊協定。
  7. 如欲在任何應用程式規則或一般優先全域規則之前，優先套用規則，請選取 高於應用程式規則的優先權 勾選方塊。
    如欲瞭解套用規則的優先順序，請參閱 關於套用規則的順序。
  8. 在 選取規則將處理的事件 內，選取套用規則時，連線必須符合的條件。
  9. 在 選取規則將回應的行動 內，選取 許可 或 攔截。
  10. 請進行以下任何一項步驟：
    • 如欲在首次連線存在時，許可其他連結至或來自相同遠端位址的連線，請選取 同時連結。此選項僅適用於 TCP 規則。
    • 如欲依據初步連線允許來自遠端電腦的回覆，請選取 狀態偵測。此選項僅適用於 UDP 規則。
    註: Windows 8 或更高版本的電腦不會顯示這些選項，因為 狀態偵測 總是被使用且 同時連結 不受支援。
  11. 在 規則描述 內，點選劃底線的數值。
前一個主題: 關於本機網路偵測
下一個主題: 編輯全域規則


編輯全域規則

重要: 本公司建議您唯有在熟悉網路通訊協定的情況下，才變更全域規則。

如欲編輯全域規則：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 全域規則 標籤。
  4. 請在 規則 清單內，選取您要編輯的規則。
  5. 點選 編輯。
    如欲瞭解全域規則設定的相關資訊，請參閱 建立全域規則。
前一個主題: 建立全域規則
下一個主題: 複製全域規則


複製全域規則

如欲複製全域規則，並將其新增至規則清單最下方：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 全域規則 標籤。
  4. 請在 規則 清單內，選取您要複製的規則。
  5. 點選 複製。
前一個主題: 編輯全域規則
下一個主題: 刪除全域規則


刪除全域規則

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 全域規則 標籤。
  4. 請在 規則 清單內，選取您要刪除的規則。
  5. 點選 移除。
前一個主題: 複製全域規則
下一個主題: 變更套用全域規則的順序


變更套用全域規則的順序

套用全域規則的順序，係依據規則清單內規則由上往下順序進行套用。

如欲變更套用全域規則的順序：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 全域規則 標籤。
  4. 在 規則 清單內，點選您需要的規則，在清單內上下移動。
  5. 點選 上移 或 下移。
前一個主題: 刪除全域規則
下一個主題: 套用預設應用程式規則


套用預設應用程式規則

預設規則，即是由 Sophos 建立的一組應用程式規則。如欲將預設規則新增至一項應用程式規則清單後：
  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 在清單內選取應用程式，然後點選 自訂 旁的箭頭。
  5. 指向 從預設值新增規則，然後點選預設規則。
前一個主題: 變更套用全域規則的順序
下一個主題: 建立應用程式規則


建立應用程式規則

如欲建立可讓您對應用程式進行進一步控管的自訂規則：
  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 請在清單內選取該應用程式，然後點選 自訂。
    您亦可雙擊清單內的應用程式。
  5. 在 配置掃描 對話方塊內，點選 許可。
  6. 在 規則名稱下，輸入該規則的名稱。
    清單內的規則名稱不得重複。應用程式的名稱必須獨一無二，不得有重複情形，但可以具有相同名稱的規則。
  7. 若您使用 Windows 8 或更高版本的電腦，請在 通訊協定 下選取您欲使用的通訊協定。
  8. 在 選取規則將處理的事件 內，選取套用規則時，連線必須符合的條件。
  9. 在 選取規則將回應的行動 內，選取 許可 或 攔截。
  10. 請進行以下任何一項步驟：
    • 如欲在首次連線存在時，許可其他連結至或來自相同遠端位址的連線，請選取 同時連結。此選項僅適用於 TCP 規則。
    • 如欲依據初步連線允許來自遠端電腦的回覆，請選取 狀態偵測。此選項僅適用於 UDP 規則。
    註: Windows 8 或更高版本的電腦不會顯示這些選項，因為 狀態偵測 總是被使用且 同時連結 不受支援。
  11. 在 規則描述 內，點選劃底線的數值。
前一個主題: 套用預設應用程式規則
下一個主題: 編輯應用程式規則


編輯應用程式規則

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 請在清單內選取該應用程式，然後點選 自訂。
    您亦可雙擊清單內的應用程式。
  5. 在 應用程式規則 對話方塊內，點選 編輯。
  6. 在 規則名稱下，輸入該規則的名稱。
    清單內的規則名稱不得重複。應用程式的名稱必須獨一無二，不得有重複情形，但可以具有相同名稱的規則。
  7. 若您使用 Windows 8 或更高版本的電腦，請在 通訊協定 下選取您欲使用的通訊協定。
  8. 在 選取規則將處理的事件 內，選取套用規則時，連線必須符合的條件。
  9. 在 選取規則將回應的行動 內，選取 許可 或 攔截。
  10. 請進行以下任何一項步驟：
    • 如欲在首次連線存在時，許可其他連結至或來自相同遠端位址的連線，請選取 同時連結。此選項僅適用於 TCP 規則。
    • 如欲依據初步連線允許來自遠端電腦的回覆，請選取 狀態偵測。此選項僅適用於 UDP 規則。
    註: Windows 8 或更高版本的電腦不會顯示這些選項，因為 狀態偵測 總是被使用且 同時連結 不受支援。
  11. 在 規則描述 內，點選劃底線的數值。
前一個主題: 建立應用程式規則
下一個主題: 複製應用程式規則


複製應用程式規則

如欲複製應用程式規則，並將其新增至規則清單最下方：
  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 請在清單內選取該應用程式，然後點選 自訂。
    您亦可雙擊清單內的應用程式。
  5. 在 應用程式規則 對話方塊內，選取您要排程的報告，並點選 排程。
前一個主題: 編輯應用程式規則
下一個主題: 刪除應用程式規則


刪除應用程式規則

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 請在清單內選取該應用程式，然後點選 自訂。
  5. 在 應用程式規則對話方塊內，選擇希望刪除的規則，按一下刪除。
前一個主題: 複製應用程式規則
下一個主題: 變更套用應用程式規則的順序


變更套用應用程式規則的順序

套用應用程式規則的順序，係依據規則清單內規則由上往下順序進行套用。

如欲變更套用應用程式規則的順序：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 應用程式 標籤。
  4. 請在清單內選取該應用程式，然後點選 自訂。
    您亦可雙擊清單內的應用程式。
  5. 在 規則 清單內，點選您需要的規則，在清單內上下移動。
  6. 點選 上移 或 下移。
前一個主題: 刪除應用程式規則
下一個主題: 允許應用程式啟動隱藏進程


允許應用程式啟動隱藏進程

註: 此選項不適用於 Windows 8 或更高版本的電腦，因為其自動受 Sophos Anti-Virus HIPS 技術處理。

應用程式有時可啟動其他的隱藏進程，為其進行某些網路存取。

惡意應用程式可使用此項技巧避開防火牆：惡意程式會啟動信任的應用程式來存取網路，而非自行存取網路。

防火牆會在首次偵測到隱藏進程時，傳送警示至管理主控台 (如果已經使用管理主控台)。

如欲允許應用程式啟動隱藏進程：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 進程 標籤。
  4. 在上方區域內，點選 新增 按鍵。
  5. 找出應用程式，然後按兩下該應用程式。
如果您使用互動模式，防火牆會在偵測到新啟動程式時，顯示學習模式。
  • 開啟互動模式
  • 開啟總和檢查學習對話
前一個主題: 變更套用應用程式規則的順序
下一個主題: 允許應用程式使用原始通訊端


允許應用程式使用原始通訊端

註: 此選項目前不適用於 Windows 8 或更高版本的電腦。防火牆會以處理一般通訊端的方式處理原始通訊端。

某些應用程式可透過原始通訊端存取網路，能使其控管其在網路上傳送資料的所有部件。

惡意應用程式能藉由偽裝其 IP 位址或故意傳送損毀的訊息，濫用原始通訊端。

防火牆會在首次偵測到 Rawsocket 時，傳送警示至管理主控台 (如果已經使用管理主控台)。

如欲透過 Rawsocket 許可應用程式存取網路：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 進程 標籤。
  4. 在上方區域內，點選 新增 按鍵。
  5. 找出應用程式，然後按兩下該應用程式。
如果您使用互動模式，防火牆會在偵測到 Rawsocket 時，顯示學習模式。
  • 開啟互動模式
  • 開啟 Rawsocket 學習對話
前一個主題: 允許應用程式啟動隱藏進程
下一個主題: 使用總和檢查驗證應用程式


使用總和檢查驗證應用程式

每項版本的應用程式，皆具有一項獨有的總和檢查。防火牆可使用此項總和檢查，決定是否許可應用程式。

根據預設值，防火牆會檢查每項執行應用程式的總和檢查。如果總和檢查未知或已經變更，防火牆將對其進行攔截，或 (使用互動模式) 詢問使用者要採取何項操作。

防火牆亦會在首次偵測到新的或受修改的應用程式時，傳送警示至管理主控台 (如果已經使用管理主控台)。

若要新增總和檢查至清單內：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 點選 總和檢查 標籤。
  4. 點選 新增。
  5. 找出應用程式，然後按兩下該應用程式。
如果您使用互動模式，防火牆會在偵測到新的或受到修改的應用程式時，顯示學習模式。
  • 開啟互動模式
  • 開啟總和檢查學習對話
前一個主題: 允許應用程式使用原始通訊端
下一個主題: 關於位置感知功能


關於位置感知功能

位置感知為 Sophos Client Firewall 的功能，可依據網路卡的目前位置，指派防火牆配置至您的電腦上的所有網路卡。

使用此項功能最常見的情況，即是使用公司筆記型電腦，且在家工作。同時使用兩項網路連線。

  • 辦公網路連線，透過 VPN 用戶端以及 虛擬網路卡 連上辦公室網路。

  • 私人網路使用，透過網路線以及 ISP 實體網路卡 連上 ISP。

在此種情況下，您需要將辦公配置套用於虛擬辦公連線，以及將一般來說限制較多的非辦公連線套用於非辦公 ISP 連線。

註: 非辦公環境的配置將需要充分的規則，來允許建立「虛擬」辦公連線。
前一個主題: 使用總和檢查驗證應用程式
下一個主題: 設定位置感知


設定位置感知

  1. 定義您主要位置內的閘道 MAC 位址收件者或網域名稱清單。一般來說，這些清單為您的辦公網路。

  2. 建立將用於您主要位置的防火牆配置。一般來說，這些配置限制較少。

  3. 建立次要防火牆配置。一般來說，這些配置限制較多。
  4. 選取要套用的配置。

取決於您使用的偵測方式，防火牆會為您電腦網路卡取得 DNS 或閘道位址，然後將其與您的收件人清單進行比對。

  • 如果您清單內的任何收件人符合網路卡的位址，網路卡便會被賦予 主要位置 的配置。
  • 如果您清單內的收件人不符合任何網路卡的位址，網路卡便會被賦予 次要位置。

現用位置會顯示於 Sophos Endpoint Security and Control 視窗內的 狀態 面板內。如果套用兩項配置，現用 = 兩者。

重要: 如果符合以下條件，則次要配置會從 互動 模式轉換為 預設攔截模式：
  • 兩項位置皆為使用中。
  • 主要配置 非 互動模式。
前一個主題: 關於位置感知功能
下一個主題: 定義您的主要位置


定義您的主要位置

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 點選 位置偵測 標籤。
  3. 在 偵測方式 下，點選您要用來定義您主要路徑方法旁的 配置：
    選項 | 敘述
    以 DNS 辨識位置 | 建立與您主要位置相應的網域名稱清單與 IP 位址。
    以閘道 MAC 位址辨識位址 | 建立與您主要位置相應的閘道 MAC 位址清單。
  4. 依照螢幕上的指示操作。
前一個主題: 設定位置感知
下一個主題: 建立次要配置


建立次要配置

防火牆會在偵測到您為連結到主要位置時，使用您的次要配置。
  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 選取 為次要位置新增配置 勾選方塊。

現在請為您的次要位置設定配置。如欲瞭解如何進行此項操作，請在 配置防火牆 章節 參閱 關於配置防火牆 以及其他主題。

注意:
如果此項電腦為筆記型電腦，且在辦公室以外的環境使用，可能會連上未知的本機網路。如果發生此種情況，使用本機網路為位址的次要配置內的防火牆規則，可能會無意間允許未知的資料流。為避免此種情形發生，當您使用本機網路規則為次要配置時，本公司強烈建議您審慎進行操作。
前一個主題: 定義您的主要位置
下一個主題: 選取要套用的配置


選取要套用的配置

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 請在 套用位置 下的 一般 標籤內，點選以下選項：
    選項 | 描述
    套用偵測位置的配置 | 防火牆會根據位置感知的偵測設定，將主要或次要配置套用於每項網路連結 (內容描述於 設定位置感知)。
    為主要位置套用配置 | 防火牆會套用主要配置至所有的網路連結。
    為次要位置套用配置 | 防火牆會套用次要配置至所有的網路連結。
前一個主題: 建立次要配置
下一個主題: 關於防火牆通報


關於防火牆通報

根據預設值，防火牆能向管理主控台通報狀態變更、事件、以及錯誤。

防火牆狀態變更

防火牆會將以下情形視為狀態變更：

  • 工作模式變更
  • 軟體版本變更
  • 是否配置防火牆許可所有資料流的變更
  • 防火牆是否遵循策略的變更

如果您使用互動模式，您的防火牆配置可能會刻意與管理主控台套用的策略相異。如果情況如此，您可在變更您防火牆配置的某些部分時，選擇 不要 傳送「與策略相異」警示至管理主控台。

如欲瞭解更多詳情，請參閱 開啟或關閉通報本機變更。

防火牆事件

所謂 事件，即您電腦上的應用程式或作業系統，試圖透過網路連結與其他電腦進行通訊。

您可防火牆向管理伺服器通報事件。

如欲瞭解更多詳情，請參閱 關閉通報未知網路資料流錯誤

前一個主題: 選取要套用的配置
下一個主題: 開啟或關閉通報本機變更


開啟或關閉通報本機變更

註: 此選項目前不適用於 Windows 8 或更高版本的電腦。

如果您的防火牆配置與策略相異，您可 關閉通報本機變更。

關閉通報本機變更，可讓防火牆停止傳送關於對全域規則、應用程式、進程或總和檢查進行的變更的「與策略相異」警示至管理主控台。您可能想要進行此項操作，例如，如果您使用互動模式進行工作，因為您可使用學習對話變更這些設定。

如果本台電腦的防火牆配置要遵循策略，您應該 開啟通報本機變更。

如欲關閉通報本機變更：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 一般 標籤的 通報 內，如果對本機全域規則、應用程式、進程或總和檢查進行變更，則在管理主控台顯示一項警示 勾選方塊，來關閉通報本機變更。
    如欲開啟通報本機變更，請選取該勾選方塊。
前一個主題: 關於防火牆通報
下一個主題: 關閉通報未知網路資料流


關閉通報未知網路資料流

您可避免防火牆向管理伺服器通報未知網路資料流。如果資料流不具備規則，防火牆會將該資料流視為未知。

如欲避免防火牆向管理伺服器通報未知資料流：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 一般 標籤內的 攔截 內，選取 使用總和檢查來驗證應用程式 勾選方塊。
  4. 在 通報 內，取消選取 向管理主控台通報錯誤 勾選方塊。
前一個主題: 開啟或關閉通報本機變更
下一個主題: 關閉通報防火牆錯誤


關閉通報防火牆錯誤

重要: Sophos 不建議您永遠關閉防火牆錯誤通報。請唯有在必要的情況下，才關閉通報功能。

如欲避免防火牆向管理伺服器通報錯誤：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 一般 標籤內的 通報 內，取消選取 向管理主控台通報錯誤 勾選方塊。
前一個主題: 關閉通報未知網路資料流
下一個主題: 配置桌面發送訊息


配置桌面發送訊息

您可控管防火牆在桌面要顯示的訊息。

未知的應用程式與資料流通知，不會顯現於互動模式，因為相同的資訊會顯現在學習對話內。

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 配置 下，點選您要配置位置的 配置。
  3. 在 一般 標籤的 桌面發送訊息 內，進行以下操作：
    • 如欲顯示防火牆警示與錯誤通知，請選取 顯示警示與錯誤 勾選方塊。
    • 如欲顯示未知應用程式與資料流的通知，請選取 顯示未知應用程式與資料流 勾選方塊。
前一個主題: 關閉通報防火牆錯誤
下一個主題: 關於防火牆日誌檢視器


關於防火牆日誌檢視器

Sophos Client Firewall 日誌檢視器可讓您檢視、篩選並儲存以下詳細資訊：

  • 所有連結
  • 許可或攔截的連結
  • 防火牆事件
  • 系統日誌紀錄
前一個主題: 配置桌面發送訊息
下一個主題: 開啟防火牆日誌檢視器


開啟防火牆日誌檢視器

在 首頁 頁面內的 防火牆，點選 檢使防火牆日誌。
如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
前一個主題: 關於防火牆日誌檢視器
下一個主題: 配置防火牆日誌紀錄


配置防火牆日誌紀錄

如欲管理防火牆事件日誌資料庫的大小與內容：

  1. 在 首頁 頁面內的 防火牆，點選 配置防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 點選 日誌 標籤。
  3. 如欲管理防火牆事件日誌資料庫的大小與內容，請進行以下操作：
    • 如欲讓資料庫無限制增長，請點選 保持所有紀錄。
    • 如欲清除舊有紀錄，請點選 刪除舊有紀錄，然後配置 紀錄清理設定。
  4. 在 日誌清理設定 內，選取一項或多項以下選項：
    • 點選 幾天後刪除紀錄 勾選方塊，然後在 天 方塊內，輸入或選取數字。
    • 點選 紀錄數目維持在 勾選方塊，然後在 紀錄 方塊內，輸入或選取數字。
    • 點選 紀錄大小維持在 勾選方塊，然後在 MB 方塊內，輸入或選取數字。
前一個主題: 開啟防火牆日誌檢視器
下一個主題: 變更防火牆日誌檢視器外觀


變更防火牆日誌檢視器外觀

  1. 在 首頁 頁面內的 防火牆，點選 檢使防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 請在 檢視 功能表內，點選 格式。
  3. 在 自訂檢視 對話方塊內，顯示要隱藏或顯示的項目：
    • 主控台樹狀目錄 將顯示於左邊窗格。
    • 工具列 會顯現於防火牆日誌顯示器最上方。
    • 描述列 會顯示於右邊窗格的資料上方。
    • 狀態列 會顯示於防火牆日誌紀錄檢視器最下方。
前一個主題: 配置防火牆日誌紀錄
下一個主題: 自訂資料格式


自訂資料格式

您可在以下防火牆日誌紀錄內，變更顯示以下資料項目的使用格式：
  • 以號碼或名稱顯示埠號，例如 HTTP 或 80。
  • 以圖示、檔案路徑或兩者顯示應用程式。
  • 指定用以顯示資料傳輸速率的單位大小，例如 KBytes 或 MBytes。
  • 隱藏或顯示格線。

如欲自定資料格式：

  1. 在 首頁 頁面內的 防火牆，點選 檢使防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 請在 檢視 功能表內，點選 自訂。
  3. 選取您需要的選項。
前一個主題: 變更防火牆日誌檢視器外觀
下一個主題: 隱藏或顯示防火牆日誌紀錄內的欄位


隱藏或顯示防火牆日誌紀錄內的欄位

  1. 在 首頁 頁面內的 防火牆，點選 檢使防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 點選主控台樹狀目錄內，能在詳細資訊窗格內顯示欄位的項目。
  3. 在 檢視 功能表內，選取 新增/移除欄位。
    您亦可按右鍵點選欄位標題。
  4. 在 欄位 對話方塊內，進行以下操作：
    • 如欲隱藏欄位，請取消勾選其勾選方塊。
    • 如欲顯示欄位，請選取其勾選方塊。
前一個主題: 自訂資料格式
下一個主題: 防火牆日誌紀錄內的紀錄欄位


防火牆日誌紀錄內的紀錄欄位

  1. 在 首頁 頁面內的 防火牆，點選 檢使防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 點選主控台樹狀目錄內，能在詳細資訊窗格內顯示欄位的項目。
  3. 在 檢視 功能表內，選取 新增/移除欄位。
    您亦可按右鍵點選欄位標題。
  4. 在 欄位 對話方塊內，點選欄位名稱，然後點選 上移 或 下移 來變更欄位的位置。

注意事項

  • 您亦可藉由使用滑鼠，將欄位標題拖曳至其原先位置的左方或右方，紀錄詳細資訊窗格內的欄位。再您拖曳欄位時，在欄位標題之間反白選取，指示欄位的新位置。
  • 您可藉由使用滑鼠拖曳欄位標題，來改變欄位的大小。
前一個主題: 隱藏或顯示防火牆日誌紀錄內的欄位
下一個主題: 篩選防火牆日誌內的紀錄


篩選防火牆日誌內的紀錄

您可藉由建立篩選條件，來排列防火牆日誌紀錄。

如欲篩選防火牆日誌紀錄：

  1. 在 首頁 頁面內的 防火牆，點選 檢使防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在主控台樹狀目錄內，選取一項日誌。
  3. 在 動作 功能表內，點選 新增篩選條件。
  4. 依照 篩選條件 精靈的指示操作。
篩選條件即會顯示在您要篩選日誌的節點下方的主控台樹狀目錄內。
前一個主題: 防火牆日誌紀錄內的紀錄欄位
下一個主題: 從防火牆日誌匯出所有的紀錄


從防火牆日誌匯出所有的紀錄

從防火牆日誌匯出所有的紀錄至文字或 CSV 檔案：

  1. 在 首頁 頁面內的 防火牆，點選 檢使防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在主控台樹狀目錄內，選取一項日誌。
  3. 按右鍵點選紀錄清單，然後點選 匯出所有紀錄。
  4. 在 掃描名稱 方塊內，輸入一項檔案名稱。
  5. 在 另存類型 清單內，點選您要的檔案類型。
前一個主題: 篩選防火牆日誌內的紀錄
下一個主題: 從防火牆日誌匯出選取的紀錄


從防火牆日誌匯出選取的紀錄

從防火牆日誌匯出選取的紀錄至文字或 CSV 檔案：

  1. 在 首頁 頁面內的 防火牆，點選 檢使防火牆日誌。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在主控台樹狀目錄內，選取一項日誌。
  3. 請選取您要匯出的紀錄。
    如果紀錄迅速更新，請在 檢視 功能表，請清除 自動刷新 勾選方塊。
  4. 在 動作 功能表內，點選 匯出選取的紀錄。
  5. 在 掃描名稱 方塊內，輸入一項檔案名稱。
  6. 在 另存類型 清單內，點選您要的檔案類型。
前一個主題: 從防火牆日誌匯出所有的紀錄
下一個主題: 立即更新


立即更新

根據預設值，如果您總是連上貴公司網路，Sophos AutoUpdate 便會排程為每 10 分鐘進行更新，或者，如果您總是連上網際網路，則更新便會排成為每 60 分鐘進行。

如果您使用撥接連線，Sophos AutoUpdate 會排程為在您連上網際網路或您的網路時進行更新，之後每 60 分鐘進行更新。

如欲立即進行更新：

按右鍵點選 Sophos Endpoint Security and Control 系統狀態列圖示，然後點選 立即更新。
前一個主題: 從防火牆日誌匯出選取的紀錄
下一個主題: 排程更新


排程更新

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

您可指定 Sophos AutoUpdate 進行更新的時間與頻率。

  1. 在 配置 功能表內，點選 更新。
  2. 點選 排程 標籤。
  3. 選取 開啟自動更新，然後輸入 Sophos AutoUpdate 將進行更新的頻率 (以分鐘為單位)。
    如果更新檔案係透過貴公司網站下載，根據預設值，將於每 10 分鐘進行更新。
    如果更新檔案係透過 Sophos 伺服器下載，Sophos AutoUpdate 的更新頻率無法高於每 60 分鐘一次。
前一個主題: 立即更新
下一個主題: 設定更新來源


設定更新來源

如果您想要 Sophos AutoUpdate 進行自動更新，您必須要指定要從何處下載更新。

  1. 在 配置 功能表內，點選 更新。
  2. 點選 主伺服器 標籤。
  3. 在 主要位置 清單內，輸入更新伺服器的 UNC 路徑或網頁位址。

    如欲透過網際網路從 Sophos 下載更新，請選取 位址 清單內的 Sophos。

  4. 請在 使用者名稱 欄位內，輸入將用於存取更新來源的使用者名稱。
    假使需要限定使用者名稱，來指示網域名稱，請使用 網域\使用者名稱 格式。
  5. 請在 密碼 欄位內，輸入將用於存取更新來源的密碼。
前一個主題: 排程更新
下一個主題: 設定另外的更新來源


設定另外的更新來源

您可設定一個另外的更新來源。如果 Sophos AutoUpdate 透過慣常來源進行更新，便會試圖從此項替代來源上更新。

  1. 在 配置 功能表內，點選 更新。
  2. 點選 次伺服器 標籤。
  3. 在 主要位置 清單內，輸入更新伺服器的 UNC 路徑或網頁位址。

    如欲透過網際網路從 Sophos 下載更新，請選取 位址 清單內的 Sophos。

  4. 請在 使用者名稱 欄位內，輸入將用於存取更新來源的使用者名稱。
    假使需要限定使用者名稱，來指示網域名稱，請使用 網域\使用者名稱 格式。
  5. 請在 密碼 欄位內，輸入將用於存取更新來源的密碼。
前一個主題: 設定更新來源
下一個主題: 透過 Proxy 伺服器更新


透過 Proxy 伺服器更新

如果 Sophos AutoUpdate 是透過網際網路取得更新，您必須輸入連上網際網路所需的 Proxy 詳細資訊。

  1. 在 配置 功能表內，點選 更新。
  2. 點選 主要位置 或 次要位置 標籤。
  3. 點選 Proxy 詳細資訊。
  4. 選取 透過 Proxy 存取網際網路 勾選方塊。
  5. 輸入代理伺服器 位址 以及 埠 號碼。
  6. 輸入一組可存取 Proxy 的 使用者名稱 以及 密碼 。
    假使需要限定使用者名稱，來指示網域名稱，請使用 網域\使用者名稱 格式。
前一個主題: 設定另外的更新來源
下一個主題: 透過撥接上網進行更新


透過撥接上網進行更新

如欲透過撥接方式連結至網際網路進行更新：

  1. 在 配置 功能表內，點選 更新。
  2. 點選 排程 標籤。
  3. 請選取 檢查是否在撥接連線時可取得下載軟體。
Sophos AutoUpdate 將在您每次連上網際網路時，試圖進行更新。
前一個主題: 透過 Proxy 伺服器更新
下一個主題: 限定更新時所使用的頻寬


限定更新時所使用的頻寬

如欲避免 Sophos AutoUpdate 在您需要頻寬時，使用所有的頻寬 (例如下載您的電子郵件)，您可限制其使用的頻寬量。

  1. 在 配置 功能表內，點選 更新。
  2. 點選 主要位置 或 次要位置 標籤。
  3. 點選 進階。
  4. 選取 限制使用的頻寬量 勾選方塊，然後捲軸指定 Sophos AutoUpdate 使用的頻寬量。
    註: 如果您指定的頻寬量超過能使用的頻寬，Sophos AutoUpdate 會使用所有的頻寬。
前一個主題: 透過撥接上網進行更新
下一個主題: 日誌更新活動


日誌更新活動

您可配置 Sophos AutoUpdate，將更新活動紀錄在日誌紀錄檔案中。

  1. 在 配置 功能表內，點選 更新。
  2. 點選 日誌紀錄 標籤。
  3. 選取 紀錄 Sophos AutoUpdate 活動 勾選方塊。
  4. 在 最大日誌紀錄大小 方塊內，以 MB 為單位輸入或選取日誌的最大大小。
  5. 在 紀錄層級 清單內，選取 一般 或 詳細 日誌紀錄。
    詳細日誌紀錄提供的訊息較往常更多，因此日誌紀錄的大小會增長得較快。請唯有在您需要詳細日誌紀錄進行故障排除的情況下，才使用此選項。
前一個主題: 限定更新時所使用的頻寬
下一個主題: 檢視更新日誌檔案


檢視更新日誌檔案

  1. 在 配置 功能表內，點選 更新。
  2. 點選 日誌紀錄 標籤。
  3. 點選 檢視日誌紀錄檔。
前一個主題: 日誌更新活動
下一個主題: 關於本台電腦上的竄改防護功能


關於本台電腦上的竄改防護功能

竄改防護功能，可讓您防止未受許可的惡意程式與未經許可的使用者 (技術知識有限的版機管理員與使用者) 透過 Sophos Endpoint Security and Control 介面解除安裝或關閉 Sophos 安全防護軟體。

註: 竄改防護功能，無法防範具有廣泛技術知識的使用者。本功能無法抵禦特別設計用來破壞作業系統操作，以躲避偵測的惡意程式。如欲偵測此種類型的惡意程式，您必須對安全威脅與可疑行為進行掃描。如欲瞭解更多詳情，請參閱第四章「Sophos Anti-Virus」。

竄改防護功能對於此項電腦使用者有何影響？

SophosUsers and SophosPowerUsers

竄改防護功能不會影響 SophosUser 與 SophosPowerUser 群組成員。一旦竄改防護功能啟動，這些群組成員將可進行任何平常許可的操作，無須輸入竄改防護密碼。

SophosUsers 或 SophosPowerUsers 無法開啟或關閉竄改防護功能。

如欲瞭解每項 Sophos 群組能進行操作的更多詳情，請參閱 關於 Sophos 群組。

SophosAdministrators

SophosAdministrator 群組成員可開啟或關閉竄改防護功能。

如果您使用管理主控台來管理本台電腦上的 Sophos Endpoint Security and Control，設定於主控台內的竄改防護策略，將決定竄改防護配置與密碼。如果竄改防護係透過主控台開啟，而您要進行上述工作，請要求您的主控台系統管理員提供密碼。

如果您隸屬 SophosAdministrator 群組成員，且竄改防護功能已開啟，您必須具備竄改防護密碼，來進行以下工作：

  • 預先配置讀取掃描或可疑行為偵測設定。如欲瞭解更多詳情，請參閱 輸入竄改防護密碼來配置軟體。
  • 關閉竄改防護功能。如欲瞭解更多詳情，請參閱 重新開啟竄改防護。
  • 透過控制台解除安裝 Sophos Endpoint Security and Control 元件 (Sophos Anti-Virus、Sophos Client Firewall、Sophos AutoUpdate、Sophos Remote Management System)。
  • 使用控制台解除安裝 Sophos SafeGuard Disk Encryption。

不具有密碼的 SophosAdministrator 成員，能進行除以上提及操作以外的所有操作。

如果竄改防護功能關閉，但其密碼已事先設定，您必須使用 驗證使用者 選項，在您重新啟動竄改防護功能之前，對您自身進行驗證。如果竄改防護功能關閉，所有您 SophosAdministrators 群組使用者能使用的其他配置選項均會開啟。如欲瞭解更多關於重新開啟竄改防護功能的更多資訊，請參閱 關閉竄改防護。

前一個主題: 檢視更新日誌檔案
下一個主題: 開啟竄改防護


開啟竄改防護

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

首次安裝 Sophos Endpoint Security and Control 時，竄改防護會開啟。如果您是 SophosAdministrator 成員，您可開啟竄改防護功能。

如欲開啟竄改防護功能：

  1. 在 首頁 頁面的 竄改防護 功能內，點選 配置竄改防護。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 竄改防護配置 對話方塊內，選取 開啟竄改防護 勾選方塊。
  3. 點選 密碼 方塊內的 設定。在 竄改防護密碼 對話方塊內，輸入並確認密碼。
    提示: 密碼必須至少 8 個字元，同時必須包括號碼與大小寫字母。
前一個主題: 關於本台電腦上的竄改防護功能
下一個主題: 關閉竄改防護


關閉竄改防護

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您隸屬 SophosAdministrator 群組，您可關閉竄改防護功能。

如欲關閉竄改防護

  1. 如果您尚未自行驗證，且 首頁 頁面內的 配置竄改防護，且無法使用，請在進行步驟 2 之前，進行 輸入竄改防護密碼來配置軟體 內的操作。
  2. 在 首頁 頁面的 竄改防護 功能內，點選 配置竄改防護。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  3. 在 竄改防護配置 對話方塊內，取消勾選 開啟竄改防護 勾選方塊，然後點選 確定。
前一個主題: 開啟竄改防護
下一個主題: 重新開啟竄改防護


重新開啟竄改防護

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

如果您隸屬 SophosAdministrator 群組，您可重新開啟竄改防護功能。

如欲重新開啟竄改防護功能：

  1. 在 首頁 頁面內的 竄改防護 內，點選 驗證使用者。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 竄改防護驗證 對話方塊內，輸入竄改防護密碼，然後點選 確定。
  3. 在 首頁 頁面的 竄改防護 功能內，點選 配置竄改防護。
  4. 在 竄改防護配置 對話方塊內，選取 開啟竄改防護 勾選方塊。
前一個主題: 關閉竄改防護
下一個主題: 關於竄改防護密碼


關於竄改防護密碼

一旦啟動竄改防護功能，如果您要配置讀取掃描、配置可疑行為偵測或關閉竄改防護功能，您必須輸入竄改防護密碼。您必須隸屬 SophosAdministrator 群組成員，才能進行此項操作。

在您開啟 Sophos Endpoint Security and Control 後，您僅需輸入竄改防護一次。如果您關閉 Sophos Endpoint Security and Control 之後，然後再度將其開啟，您將需要再次輸入密碼。

如果您要解除安裝任何 Sophos Endpoint Security and Control 元件，您必須在關閉竄改防護功能之前，輸入竄改防護密碼，才能解除安裝防護軟體。

如果竄改防護功能關閉，但其密碼已事先設定，您必須先輸入密碼，才能重新啟動竄改防護。

在下列情況下，您需要輸入竄改防護密碼：

  • 您先前已開啟竄改防護、建立竄改防護密碼、然後關閉竄改防護功能。
  • 已在管理主控台內建立竄改防護密碼，但竄改防護功能尚未開啟。
前一個主題: 重新開啟竄改防護
下一個主題: 輸入竄改防護密碼來配置軟體


輸入竄改防護密碼來配置軟體

如果您為 SophosAdministrator 群組成員，您可藉由輸入竄改防護密碼，來驗明身分。

如欲驗證自行身分：

  1. 在 首頁 頁面內的 竄改防護 內，點選 驗證使用者。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 竄改防護驗證 對話方塊內，輸入竄改防護密碼，然後點選 確定。
前一個主題: 關於竄改防護密碼
下一個主題: 變更竄改防護密碼


變更竄改防護密碼

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

您必須為 SophosAdministrator 群組成員，才能變更竄改防護密碼。

如欲變更竄改防護密碼：

  1. 如果您尚未自行驗證，且 首頁 頁面內的 配置竄改防護，且無法使用，請在進行步驟 2 之前，進行 輸入竄改防護密碼來配置軟體 內的操作。
  2. 在 首頁 頁面的 竄改防護 功能內，點選 配置竄改防護。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  3. 在 竄改防護配置 對話方塊內，點選 密碼 方塊內的 變更。
  4. 在 竄改防護密碼 對話方塊內，輸入並確認新密碼。
    提示: 密碼應該至少要有 8 個字元長，同時包含數字與大小寫字母。
前一個主題: 輸入竄改防護密碼來配置軟體
下一個主題: 解除安裝 Sophos 安全防護軟體


解除安裝 Sophos 安全防護軟體

如果您隸屬於 SophosAdministrator 群組成員，您可使用主控台解除安裝 Sophos 安全防護軟體：

  • 透過控制台解除安裝 Sophos Endpoint Security and Control 元件 (Sophos Anti-Virus、Sophos Client Firewall、Sophos AutoUpdate、Sophos Remote Management System)。
  • Sophos SafeGuard Disk Encryption

如欲在關閉竄改防護功能之前，解除安裝 Sophos 安全防護軟體：

  1. 在 首頁 頁面內的 竄改防護 內，點選 驗證使用者。
    如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
  2. 在 竄改防護驗證 對話方塊內，輸入竄改防護密碼，然後點選 確定。
  3. 在 首頁 頁面的 竄改防護 功能內，點選 配置竄改防護。
  4. 在 竄改防護配置 對話方塊內，取消勾選 開啟竄改防護 勾選方塊，然後點選 確定。
    竄改防護功能便會關閉。
  5. 在 控制台 內，開啟 新增/移除程式 找出您要移除的軟體，然後點選 變更/移除 或 移除。依照螢幕上的相關指示，來解除安裝軟體。
前一個主題: 變更竄改防護密碼
下一個主題: 檢視竄改防護日誌紀錄


檢視竄改防護日誌紀錄

竄改防護日誌紀錄會顯示兩種事件：

  • 成功的竄改防護驗證事件，會顯示驗證使用者名稱以及驗證時間。
  • 失敗的竄改防護驗證事件，顯示針對的 Sophos 產品或元件，竄改動作時間，以及進行竄改動作的使用者。

您必須為 SophosAdministrator 群組成員，才能檢視竄改防護日誌紀錄。

如欲檢視竄改防護日誌紀錄：

在 首頁 頁面的 竄改防護 內，點選 檢視竄改防護日誌紀錄。
如欲瞭解關於 首頁 的相關訊息，請參閱 關於首頁。
您可從日誌紀錄頁面中，將日誌紀錄複製到剪貼簿、電子郵件內，或將其列印出來。

若要尋找日誌紀錄中的特定文字，請點選 尋找 並輸入您欲搜尋的文字。

前一個主題: 解除安裝 Sophos 安全防護軟體
下一個主題: 關於更新失敗


關於更新失敗

如欲瞭解關於更新失敗的相關資訊，請檢視更新日誌：如欲瞭解如何進行此項操作的細節，請參閱 檢視更新日誌檔案。

以下的章節解釋為何更新會失敗，以及您要如何變更設定來修正問題。

  • Sophos Endpoint Security and Control 聯繫錯誤的更新資源
  • Sophos Endpoint Security and Control 無法每次恢復所有設定
  • 自動更新還未正確安排妥當
  • 更新的來源未受到維護
前一個主題: 檢視竄改防護日誌紀錄
下一個主題: Sophos Endpoint Security and Control 聯繫錯誤的更新資源


Sophos Endpoint Security and Control 聯繫錯誤的更新資源

  1. 在 配置 功能表內，點選 更新。
  2. 請在 主要位置 標籤內，檢查您的位址與帳戶詳細資訊是由您的管理員所提供。
    如欲瞭解關於配置 主要位置 標籤的相關資訊，請參閱 設定更新來源。
前一個主題: 關於更新失敗
下一個主題: Sophos Endpoint Security and Control 無法每次恢復所有設定


Sophos Endpoint Security and Control 無法每次恢復所有設定

假使 Sophos Endpoint Security and Control 是經由網際網路更新，您必須確認它可以使用您的 Proxy (假使有的話)。

  1. 在 配置 功能表內，點選 更新。
  2. 在 主要位置 標籤，點選 Proxy 詳細資訊。
  3. 請確保 Proxy 伺服器位址、埠號與帳號詳細資訊正確無誤。
    如欲瞭解如何輸入 Proxy 的相關資訊，請參閱 透過 Proxy 伺服器更新。
前一個主題: Sophos Endpoint Security and Control 聯繫錯誤的更新資源
下一個主題: 自動更新還未正確安排妥當


自動更新還未正確安排妥當

  1. 在 配置 功能表內，點選 更新。
  2. 點選 排程 標籤。(如欲瞭解關於 排程 標籤的相關資訊，請參閱 排程更新。)
  3. 如果您的電腦已連上網路，或者您是經由寬頻網路連線，請選取 啟用自動更新，並輸入更新的頻率。假使您是經由撥號方式連上網網路，請點選 撥號時檢查更新 。
前一個主題: Sophos Endpoint Security and Control 無法每次恢復所有設定
下一個主題: 更新的來源未受到維護


更新的來源未受到維護

您的公司可能已將您應從該處更新的目錄 (該目錄位於網路或網路伺服器上) 移開。或者是因為沒有維持該目錄。

如果您認為可能發生此種情形，請聯繫您的網路管理員。

前一個主題: 自動更新還未正確安排妥當
下一個主題: 安全威脅尚未清除


安全威脅尚未清除

如果 Sophos Anti-Virus 尚未清除您電腦上的安全威脅，可能是由於以下因素。

自動清理已關閉

如果 Sophos Anti-Virus 並未試圖進行清理，請檢查已經啟動自動清理。如欲瞭解開啟自動清理，請參閱以下主題：
  • 配置讀取清理
  • 配置右鍵清理功能
  • 配置自訂掃描的清理操作

讀取掃描不具備自動清理廣告程式與可能不需要的應用程式功能。

清理失敗

如果 Sophos Anti-Virus 無法清理一項安全威脅("清理失敗")，可能是因為無法清理該類型的安全威脅，或您不具備足夠的存取權限。

需要進行完整的電腦掃描

在 Sophos Anti-Virus 能夠從您電腦上清除安全威脅之前，您可能需要執行一項完整掃描，來判定多元件安全威脅的所有元件，或偵測先前隱藏於檔案內的安全威脅。

  1. 若要掃描包括開機區的所有磁碟機，請執行 掃描我的電腦 掃描。如欲瞭解更多詳情，請參閱執行一項完整電腦掃描。
  2. 如果仍然沒有完全偵測到安全威脅，可能是因為您不具備足夠的使用者權限，或者電腦上的某些磁碟或資料夾內包含安全威脅的元件，已經受到排除掃描。如欲瞭解更多詳情，請參閱排除讀取掃描項目。檢查排除掃描的項目清單。如果某些項目位於清單內，請將其從清單移除，並再次掃描您的電腦。

可卸除媒體為防寫

如果正在處理一項可卸除媒體 (例如磁碟片或 CD)，請確保該媒體並非防寫。

NTFS 磁區為防寫

假使正在處理一個 NTFS 磁區 (Windows XP 以上系統) 上的檔案，請確保其不具防寫功能。

報告出病毒/間諜程式碎片

Sophos Anti-Virus 無法清除病毒/間諜程式碎片，因為病毒/間諜程式碎片無法作病毒比對。請參閱 報告出病毒/間諜程式碎片。

前一個主題: 更新的來源未受到維護
下一個主題: 報告出病毒/間諜程式碎片


報告出病毒/間諜程式碎片

如果通報出病毒/間諜程式，請進行以下操作：

  1. 立即更新您的安全防護，讓 Sophos Anti-Virus 具有最新的病毒辨識檔。
  2. 執行一項完整電腦掃描。
  • 立即更新
  • 執行一項完整電腦掃描

假使仍舊報告出病毒/間諜程式碎片，請聯繫 Sophos 技術支援部門取得相關建議。

  • 技術支援

如有病毒/間諜程式碎片報告出來，則顯示檔案的該部分符合病毒或間諜程式的一部份。有三種可能的原因：

已知病毒或間諜程式項目的變種

許多新病毒或間諜程式是基於現有項目所產生，因此已知病毒或間諜程式的典型程式碼碎片，便會顯示為新型項目的一部份。假使有病毒/間諜程式碎片報告出來，有可能是因為 Sophos Anti-Virus 已經偵測出一項新病毒，有可能會變得活躍。

損毀的病毒

許多病毒在其替代路徑中，含有會使其不正確感染目標檔案的錯誤。病毒不積極活動的部分 (可能是一大部份 ) 有可能會出現在主檔案中，是由 Sophos Anti-Virus 偵測出。損毀的病毒並不會散佈。

資料庫內含一項病毒或間諜程式項目

當執行完全電腦掃描時，Sophos Anti-Virus 會報告出在資料庫檔案中有一個病毒/間諜程式碎片。如果情況如此，請勿刪除資料庫。請聯繫 Sophos 技術支援部門取得相關建議。

如欲瞭解關於聯繫技術支援部門的相關資訊，請參閱 技術支援。

前一個主題: 安全威脅尚未清除
下一個主題: 部分偵測到安全威脅


部分偵測到安全威脅

若要掃描包括開機區的所有磁碟機，請對電腦執行完整電腦掃描。

  • 執行一項完整電腦掃描
如果仍然沒有完全偵測到安全威脅，可能是因為電腦上的某些磁碟或資料夾內包含安全威脅的元件，已經受到排除掃描。如果某些項目位於排除清單內，請將其從清單移除，並再次掃描您的電腦。
  • 排除即時掃描項目

如果仍未完全偵測到安全威脅，可能是因為您不具備足夠的存取權限。

Sophos Anti-Virus 可能無法完全偵測或移除元件安裝於網路磁碟上的安全威脅。

前一個主題: 報告出病毒/間諜程式碎片
下一個主題: 從隔離所內消失的廣告程式或可能不需要的應用程式


從隔離所內消失的廣告程式或可能不需要的應用程式

如果一項 Sophos Anti-Virus 偵測到的廣告程式或可能不需要的應用程式，您沒有對其進行任何動作，卻從隔離所管理員內消失，該廣告程式或可能不需要的應用程式可能是受到管理主控台或其他使用者許可或清理。檢查許可的廣告程式與可能不需要的應用程式清單，來檢視應用程式是否受到許可。如欲瞭解如何進行此項操作，請參閱 許可廣告程式與可能不需要的應用程式。

前一個主題: 部分偵測到安全威脅
下一個主題: 電腦運行速度降低


電腦運行速度降低

如果您的電腦運行速度大為降低，可能是因為一項可能不需要的應用程式正在執行並監控您的電腦。如果您已經開啟讀取掃描，您也可能見到許多關於可能不需要的應用程式的桌面警示。如欲解決此項問題，請依以下說明操作。

  1. 執行 掃描我的電腦 來進行掃描，偵測可能不需要應用程式的所有元件。如欲瞭解更多詳情，請參閱執行一項完整電腦掃描。
    註: 如果掃描後偵測到部分可能不需要的應用程式，請參閱 偵測到部分可能不需要的應用程式，步驟 2。
  2. 清除您電腦上的廣告程式或可能不需要的應用程式。如欲瞭解如何進行此項操作，請參閱 處理隔離所內的廣告程式與可能不需要的應用程式。
前一個主題: 從隔離所內消失的廣告程式或可能不需要的應用程式
下一個主題: 允許存取開機區受感染的磁碟


允許存取開機區受感染的磁碟

重要: 如果您在此台電腦上，使用管理主控台來管理 Sophos Endpoint Security and Control，可能會覆蓋您進行的任何變更。

根據預設值，Sophos Anti-Virus 會避免存取開機區遭病毒感染的可移動式硬碟。

若想許可存取的動作，(比如說，從一個開機區感染病毒的磁片複製檔案)， 請依照以下步驟進行：

  1. 點選 首頁防病毒與 HIPS配置防病毒與 HIPS配置讀取掃描。
  2. 在 掃描 標籤內，選取 允許存取啟動區感染病毒的磁碟機 勾選方塊。
重要: 一旦您完成存取磁碟，請清除該勾選方塊，然後從電腦移除磁碟，使其無法在從新啟動時，試圖重新感染電腦。
前一個主題: 電腦運行速度降低
下一個主題: 無法存取 Sophos Endpoint Security and Control 區域


無法存取 Sophos Endpoint Security and Control 區域

如果您無法使用或配置 Sophos Endpoint Security and Control 的特定區域，可能是因為對於這些區域的存取，僅限於特定 Sophos 使用者群組成員。

如欲瞭解更多 Sophos 使用者群組的相關資訊，請參閱 關於 Sophos 群組。

前一個主題: 允許存取開機區受感染的磁碟
下一個主題: 從病毒的副作用恢復


從病毒的副作用恢復

從病毒副作用中回復的程度，取決於病毒如何感染電腦。

病毒：副作用

有些病毒不會留下副作用，有些病毒則會留下極為嚴重的副作用，使您必須要重新恢復硬碟才能回復。

有些病毒會逐漸改變資料。這種損害不容易偵測。

如何進行

閱讀 Sophos 網站上的安全威脅分析，以及在清理後檢查文件相當重要。請參閱 取得清理資訊，來瞭解如何查閱 Sophos 網站上關於病毒副作用的詳細資料。

完善的備份相當重要。如果您在感染前並未進行備分，請即開始進行備份，已備將來感染時不時之需。

有時您能夠從受病毒損害的磁碟中恢復。Sophos 能提供修復一些病毒所造成的損害所需的公用程式。

請聯繫 Sophos 技術支援部門取得相關建議。

如欲瞭解關於聯繫技術支援部門的相關資訊，請參閱 技術支援。

前一個主題: 無法存取 Sophos Endpoint Security and Control 區域
下一個主題: 從廣告程式與可能不需要的應用程式的副作用恢復


從廣告程式與可能不需要的應用程式的副作用恢復

移除廣告程式與可能不需要的應用程式，可能會產生某些無法在清理過程中移除的副作用。

作業系統已被修改

有些廣告程式與可能不需要的應用程式會修改 Windows 作業系統，例如，變更您網際網路連結設定。Sophos Anti-Virus 無法每次皆能將設定恢復至安裝廣告程式或可能不需要的應用程式前的設定。比方說，如果一項廣告程式或可能不需要的應用程式變更瀏覽器首頁設定，Sophos Anti-Virus 無法知悉之前的首頁設定為何。

公用程式無法清除

某些廣告程式與可能不需要的應用程式會在您的電腦上安裝公用程式，例如 .dll 或 .ocx 檔案。如果一項公用程式無害 (意即，不具備廣告程式與可能不需要的應用程式的特性)，例如一項語言程式庫，且並未整合於廣告程式/可能不需要的應用程式， Sophos Anti-Virus 可能無法偵測其為廣告程式或可能不需要的應用程式的一部份。如此，檔案將無法從您的電腦上移除，即使安裝在電腦上的廣告程式或可能不需要的應用程已經清除。

廣告程式或可能不需要的應用程式是您需要程式的一部份

有時候，某些廣告程式或可能不需要的應用程式是您刻意要安裝程式的一部份，需要予以保留，以便執行程式。一旦您移除廣告程式或可能不需要的應用程式，程式將會停止在您的電腦上執行。

如何進行

閱讀 Sophos 網站上的安全威脅相當重要。請參閱 取得清理資訊 來瞭解如何檢視 Sophos 網站上廣告程式或可能不需要的應用程式副作用的詳細資訊。

為了能夠將您的系統與設定恢復至先前的狀態，您應該為您的系統進行經常性備份。同時，您也應該為想要使用程式的原始可執行檔製作備份。

欲瞭解更多從廣告程式與可能不需要的應用程副作用恢復的相關訊息，請聯繫 Sophos 技術支援部門。

如欲瞭解關於聯繫技術支援部門的相關資訊，請參閱 技術支援。

前一個主題: 從病毒的副作用恢復
下一個主題: 密碼錯誤通報


密碼錯誤通報

如果您試圖排程自訂掃描，且一項關於密碼的錯誤訊息顯現，請確保以下事項：

  • 帳戶的密碼正確無誤
  • 密碼欄並未空白

如欲確保密碼正確無誤，請檢查 控制面板 內的 使用者帳號 內的使用者帳號內容。

前一個主題: 從廣告程式與可能不需要的應用程式的副作用恢復
下一個主題: 「服務失敗」錯誤訊息


「服務失敗」錯誤訊息

症狀

您可在通知區域見到以下錯誤訊息：
  • Anti-virus 與 HIPS：服務失敗
  • 防火牆：服務失敗

原因

您電腦上的其中一項 Sophos Endpoint Security and Contro 服務失敗，需要重新啟動。

解決問題

  1. 使用 Windows，開啟服務。
  2. 請進行以下任何一項步驟：
    • 如果您見到 Anti-virus 與 HIPS：服務失敗 錯誤訊息，請按右鍵點選 Sophos Anti-Virus，然後點選 重新啟動。
    • 如果您見到 防火牆：服務失敗 錯誤訊息，請按右鍵點選 Sophos Client Firewall，然後點選 重新啟動。

注意事項

  • 如欲開啟服務，請點選 開始，點選 控制台，按兩下 管理工具，然後按兩下 服務。
前一個主題: 密碼錯誤通報
下一個主題: 防火牆資料庫損毀


防火牆資料庫損毀

症狀

在使用防火牆日誌檢視器時，您見到「目前 Sophos Client Firewall 日誌紀錄資料庫已損毀」錯誤訊息。

原因

防火牆的日誌紀錄資料庫已經損毀，需要重新建立。

解決問題

您必須身為 Windows Administrators 的群組成員，才能進行此項操作。

  1. 使用 Windows，開啟服務。
  2. 按右鍵點選 Sophos Client Firewall Manager，然後點選 停止。

  3. 使用檔案總管，瀏覽至 C:\Documents and Settings\All Users\Application Data\Sophos\Sophos Client Firewall\logs。

    如欲檢視此項隱藏資料夾，您需要顯示檔案總管內的隱藏檔與資料夾。

  4. 刪除 op_data.mdb。
  5. 在服務內，按右鍵點選 Sophos Client Firewall Manager，然後點選 開始。

注意事項

  • 如欲開啟服務，請點選 開始，點選 控制台，按兩下 管理工具，然後按兩下 服務。
前一個主題: 「服務失敗」錯誤訊息
下一個主題: 術語彙編


術語彙編

廣告程式與可能不需要的應用程式
廣告程式會顯示例如快顯訊息的廣告活動，會影響使用者生產力與系統效能。可能不需要的應用程式 (PUA)，即為本身並非惡意程式，但一般視為不適用大部分的企業網路。
應用程式規則
本規則僅適用於在網路上傳輸的資料的流向或流出特定應用程式的資料包。
許可管理員
可讓您許可廣告程式與 可能不需要的應用程式、可疑檔案與呈現出可疑行為與緩衝區溢位的模組。
自動清理
在使用者不介入或接受的情況下，自動進行清理。
受到攔截
係一項狀態，顯示網路存取遭受拒絕的應用程式 (包括隱藏進程)、連線、通訊協定 ICMP 訊息等。
緩衝區溢位偵測
偵測緩衝區溢位攻擊。
總和檢查
每項版本的應用程式，皆具有一項獨有的總和檢查。防火牆可使用此項總和檢查，決定是否許可應用程式。
清理
清理動作可藉由移除檔案或開機區中的病毒，移動或刪除可疑檔案，或刪除廣告程式或可能不需要的應用程式，移除您電腦上的安全威脅。當您以網頁掃描方式偵測到安全威脅時，清理功能無法使用，因為安全威脅並未下載至您的電腦上。因此，您無須採取任何動作。
內容控管清單 (Content Control List) (CCL)
指定檔案內容的一組條件，例如信用卡或金融卡號碼，或銀行帳號詳細資訊，以及類似的個人辨識資訊。內容控管清單的類型有兩種：SophosLabs Content Control List (SophosLabs 內容控管清單) 與自訂 Content Control List (自訂內容控管清單)。
內容規則
包含一項或一項以上內容控管清單的規則，並在使用者試圖轉移與規則內與所有內容控管清單相符的資料至指定的路徑時，指定要採取的動作。
受控管應用程式
受控管應用程式，即貴機構安全策略不允許在您電腦上執行的應用程式。
自訂規則
使用者建立的規則，指定許可某項應用程式與否的情況。
資料控管
本功能可減低由工作站意外洩漏資料的風險。當工作站使用者試圖轉移符合在資料控管策略與規則內定義的評量標準的檔案時，便會採取動作。例如，當使用者試圖將包含客戶清單資料的清單複製到卸除式存放裝置，或將標示為機密的文件上載至網路郵件帳號，資料控管將會攔截傳輸動作 (倘若配置為進行攔截)。
資料檢視
取決於在樹狀檢視選取的項目，此項檢視會顯示不同的資料。
描述列
日誌檢視內的狀態列，顯示於資料檢視上方，內含目前在樹狀檢視內選取的項目名稱。
設備控管
係一項功能，可降低資料從工作站上意外流失的風險，並限制從公司網路外部引入軟體。當工作站使用者試圖在工作站上使用未經許可的儲存裝置或網路裝置時，此項功能便會採取行動。
下載信譽
從網際網路上下載檔案之信譽。根據檔案年齡、來源、散佈程度、深度內容分析及其他特徵，計算信譽。這有助於確定檔案是否安全，是否是潛在的安全威脅並在下載後損害使用者的電腦。
全面掃描
掃描每項檔案的每個部分。
防火牆事件
當電腦上的未知應用程式，或作業系統試圖與其他電腦進行通訊時，使用的方式並非該電腦特別指定的方式時，所出現的情形。
防火牆策略
係一項系統管理員的設定，在此項設定中，防火牆使用該項設定偵測對於網際網路與其他網路的連線。
全域規則
此項規則套用於所有尚未具有規則的網路連線與應用程式。這些規則的優先權低於在區域網頁面內設定的規則。這些規則的優先權亦低於應用程程式規則 (除非使用者另外指定)。
隱藏進程
應用程式有時會啟動其他隱藏進程，為其進行某些網路存取。惡意應用程式可使用此項技巧避開防火牆：惡意程式會啟動信任的應用程式來存取網路，而非自行存取網路。
高優先權全域規則
比其他全域規則或應用程式規則優先套用的規則。
主機入侵防護系統 (HIPS)
預先執行行為分析與執行時間行為分析的一般術語。
ICMP
「網際網路控管訊息通訊協定」(Internet Control Message Protocol) 的簡稱。係網際網路層級的的網際網路通訊協定，提供錯誤修正與其他與 IP 資料包處理相關的資訊。
ICMP 設定
指定何種網路管理通訊類型能獲得許可。
即時通訊
一種受控管應用程式的類別，包括即時通訊用戶端應用程式 (例如 MSN)。
互動模式
此項模式中，防火牆會在偵測到不具有規則的網路資料流時，顯示一項或多項學習對話。此功能只適用於運行於 Windows 7 以上系統電腦的 Sophos Client Firewall。
學習對話
此種對話方塊會在不明的應用程式要求網路存取時，要求使用者選取一項網路資料流類型。此功能只適用於運行於 Windows 7 以上系統電腦的 Sophos Client Firewall。
日誌清理設定
此項設定可控管紀錄何時刪除。
日誌檢視
係一項表格，使用者可藉此表格檢視來自事件資料庫的詳細資訊，例如受到許可或攔截的連線，系統日誌以及所有產生的警示。
偵測惡意資料流
一種偵測受到破壞的電腦及攻擊者指令和控制伺服器之間通訊的功能。
手動清理
藉由使用特定病毒消除工具或公用程式，或者藉由手動刪除檔案的方式，進行清理動作。
相符
與定義於 Content Control List 內的內容相符。
NetBIOS
「網路基本輸入/輸出系統」的縮寫。此項軟體可提供作業系統、輸入/輸出匯流排與網路之間的介面。幾乎所有基於 Windows 的區域網，皆基於 NetBIOS。
網路通訊協定
即設計用來讓網路中電腦相互連結，並以儘可能少錯誤交換資訊的規則或標準套組。
非互動式模式
此項模式中，防火牆會攔截或許可所有不具有規則的網路資料流。
一般掃描
本掃描僅會掃描每項檔案可能感染病毒的部分。
讀取掃描
您防禦安全威脅的主要方法。在您複製、移動、開啟檔案或啟動程式時，Sophos Anti-Virus 會對該檔案進行掃描，並唯有在其並未對您電腦造成威脅，或已經獲得許可使用的情況下，才允許對其進行存取。
即時掃描
由您啟動的掃描。您可使用即時掃描功能，來掃描小至單個檔案，乃至您電腦上所有您具備讀取權限的所有項目。
主要配置
用於公司網路使用者連結其每日營運的防火牆配置。
進程設定
此項設定可指定是否允許受到修改的進程或隱藏進程進行網路存取。
隔離所管理員
係一項可讓您檢視並處理隔離項目的模組。
Rawsocket
Rawsocket 能允許進程控管其在網路上傳送資料的所有部分，可用於惡意用途。
右鍵掃描
此項掃描可使用 Windows Explorer 或捷徑功能表在桌面上掃描檔案。
Rootkit
係一項特洛伊木馬或技術，用於隱藏惡意物件 (進程、檔案、登錄機碼或網路通訊埠)，讓使用者或管理員無法偵測。
執行時間行為分析
可疑行為偵測與緩衝區溢位偵測所進行的動態分析。
掃描錯誤
對檔案進行掃描時所發生的錯誤，例如存取遭拒。
排程掃描
對於您電腦或電腦某部分所進行的掃描，在設定的時間內進行。
次要配置
此項防火牆配置，用於使用者未連結至主要公司網路，但連結至其他例如旅館或機場無線網路或其他公司網路的情況。
間諜程式
亦即以隱密、詭詐欺瞞、社交工程等手段，將自身安裝於使用者電腦內，並在未經使用者允許、知曉的情況下，擅自將該電腦的資訊傳送于第三者的程式。
Sophos Live Protection
此項功能使用最新的遠端網路偵測技術 - 雲端技術，即時判別某項檔案是否為安全威脅，然後採取指定於 Sophos Anti-Virus 清理配置內的操作。
狀態偵測
此項防火牆技術，能紀錄使用中的 TCP 與 UDP 網路連線表格。僅有符合已知連線狀態的資料包，才會受防火牆允許，其他的資料包會被拒絕。
儲存設備
卸除式存放裝置 (例如可攜式快閃記憶碟、PC 讀卡機與外接硬碟)、CD/DVD 磁碟機、軟碟機與安全的可攜式儲存設備 (例如 SanDisk Cruzer Enterprise、Kingston Data Traveller、IronKey Enterprise 與加密的 IronKey Basic 可攜式快閃記憶碟)。
可疑行為偵測
此功能可動態分析執行於系統上所有程式的行為，以偵並攔截看似可疑的行為。
可疑檔案
亦即會展現通常在病毒內 (但並非僅限在病毒內發現) ，所發現的綜合特性的檔案。
系統記憶
系統記憶系應用程式與硬體層級實際資料處理的橋樑。系統記憶用於作業系統。
系統規則
此規則可套用於所有應用程式，將可允許或攔截低階系統網路活動。
竄改防護
竄改防護功能，可讓您防止未經許可的使用者 (技術知識有限的版機管理員與使用者) 與已知的惡意程式透過 Sophos Endpoint Security and Control 介面解除安裝或關閉 Sophos 安全防護軟體。
安全威脅事件
對於安全威脅的偵測或消除動作。
樹狀檢視
此項檢視可控管日誌檢視器在其資料檢視內所顯示的資料。
真實檔案類型
經由分析檔案結構，所證實的真實檔案類型，相對於檔案名稱副檔名。此項方法較為可靠。
信任的應用程式
允許完整、無條件存取網際網路的應用程式。
不明病毒
不具有特定身份的檔案。
未知的資料流
防火牆不具備規則的應用程式或服務的網路存取形式。
病毒辨識檔 (IDE)
此檔案可讓 Sophos Anti-Virus 對特定的病毒、特洛伊木馬或蠕蟲項目進行偵測以及刪除等動作。
網際網路語音協定
一種受控管應用程式的類別，包括網際網路語音協定應用程式。
工作模式
此項設定決定防火牆是否套用使用者進行的動作 (互動模式) 或自動進行 (非互動模式)。Windows 8 以上的 Sophos Client Firewall 中的互動模式已移除。
前一個主題: 防火牆資料庫損毀
下一個主題: 技術支援


技術支援

您可使用以下其中一項方法，取得 Sophos 產品技術支援服務：

  • 造訪 community.sophos.com/ 內的 Sophos Community 社群，尋找其他遭遇到相同問題的使用者。
  • 造訪 www.sophos.com/en-us/support.aspx 內的 Sophos 技術支援資料庫。
  • 在 www.sophos.com/en-us/support/documentation.aspx 內下載產品英文版本說明文件，如欲取得中文版本，請郵寄需求至。
  • 於 https://secure2.sophos.com/support/contact-support/support-query.aspx 開啟我們的支援團隊票證。
前一個主題: 術語彙編
下一個主題: 法律聲明


法律聲明

版權所有 © 1989-2016 Sophos Limited。All rights reserved.本出版品任何部分不得以電子、機械、複印、錄影等方式複製、儲存於任何儲存媒體或傳佈，除非您具備有效的許可權，得依據許可權條款之規定複製文件手冊，或者以書面方式告知版權所有人，並獲得其授權許可，方能進行複製。

Sophos、Sophos Anti-Virus 與 SafeGuard 皆為 Sophos Limited 的註冊商標，Sophos Group、Utimaco Safeware AG 則視情況而定。本出版品所提及的所有其他產品與公司名稱，均為其各自所有人之商標或註冊商標。

Apache

The Sophos software that is described in this document may include some software programs that are licensed (or sublicensed) to the user under the Apache License.A copy of the license agreement for any such included software can be found at http://www.apache.org/licenses/LICENSE-2.0

Boost C++ Libraries

Boost Software License - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or organization obtaining a copy of the software and accompanying documentation covered by this license (the “Software”) to use, reproduce, display, distribute, execute, and transmit the Software, and to prepare derivative works of the Software, and to permit third-parties to whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement, including the above license grant, this restriction and the following disclaimer, must be included in all copies of the Software, in whole or in part, and all derivative works of the Software, unless such copies or derivative works are solely in the form of machine-executable object code generated by a source language processor.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT.IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Common Public License

The Sophos software that is described in this document includes or may include some software programs that are licensed (or sublicensed) to the user under the Common Public License (CPL), which, among other rights, permits the user to have access to the source code.The CPL requires for any software licensed under the terms of the CPL, which is distributed in object code form, that the source code for such software also be made available to the users of the object code form.For any such software covered under the CPL, the source code is available via mail order by submitting a request to Sophos; via email to supportasia@sophos.com or via the web at http://www.sophos.com/en-us/support/contact-support.aspx.A copy of the license agreement for any such included software can be found at http://opensource.org/licenses/cpl1.0.php

ConvertUTF

Copyright 2001–2004 Unicode, Inc.

This source code is provided as is by Unicode, Inc. No claims are made as to fitness for any particular purpose.No warranties of any kind are expressed or implied.The recipient agrees to determine applicability of information provided.If this file has been purchased on magnetic or optical media from Unicode, Inc., the sole remedy for any claim will be exchange of defective media within 90 days of receipt.

Unicode, Inc. hereby grants the right to freely use the information supplied in this file in the creation of products supporting the Unicode Standard, and to make copies of this file in any form for internal or external distribution as long as this notice remains attached.

crt

# $FreeBSD$
# @(#)COPYRIGHT 8.2 (Berkeley) 3/21/94

The compilation of software known as FreeBSD is distributed under the following terms:

Copyright (c) 1992-2013 The FreeBSD Project.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the DOCUMENTATION and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The 4.4BSD and 4.4BSD-Lite software is distributed under the following terms:

All of the documentation and software included in the 4.4BSD and 4.4BSD-Lite Releases is copyrighted by The Regents of the University of California.

Copyright 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994 The Regents of the University of California.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgement: This product includes software developed by the University of California, Berkeley and its contributors.
  4. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The Institute of Electrical and Electronics Engineers and the American National Standards Committee X3, on Information Processing Systems have given us permission to reprint portions of their documentation.

In the following statement, the phrase "this text" refers to portions of the system documentation.

Portions of this text are reprinted and reproduced in electronic form in the second BSD Networking Software Release, from IEEE Std 1003.1-1988, IEEE Standard Portable Operating System Interface for Computer Environments (POSIX), copyright C 1988 by the Institute of Electrical and Electronics Engineers, Inc. In the event of any discrepancy between these versions and the original IEEE Standard, the original IEEE Standard is the referee document.

In the following statement, the phrase "This material" refers to portions of the system documentation.This material is reproduced with permission from American National Standards Committee X3, on Information Processing Systems.Computer and Business Equipment Manufacturers Association (CBEMA), 311 First St., NW, Suite 500, Washington, DC 20001-2178.The developmental work of Programming Language C was completed by the X3J11 Technical Committee.

The views and conclusions contained in the software and documentation are those of the authors and should not be interpreted as representing official policies, either expressed or implied, of the Regents of the University of California.

NOTE: The copyright of UC Berkeley's Berkeley Software Distribution ("BSD") source has been updated.The copyright addendum may be found at fttp://ftp.cs.berkeley.edu/pub/4bsd/README.Impt.License.Change and is included below.

1999年7月22日

To All Licensees, Distributors of Any Version of BSD:

As you know, certain of the Berkeley Software Distribution ("BSD") source code files require that further distributions of products containing all or portions of the software, acknowledge within their advertising materials that such products contain software developed by UC Berkeley and its contributors.

Specifically, the provision reads:

"3.All advertising materials mentioning features or use of this software must display the following acknowledgement: This product includes software developed by the University of California, Berkeley and its contributors."

Effective immediately, licensees and distributors are no longer required to include the acknowledgement within advertising materials.Accordingly, the foregoing paragraph of those BSD Unix files containing it is hereby deleted in its entirety.

William Hoskins
Director, Office of Technology Licensing
University of California, Berkeley

dtoa.c

The author of this software is David M. Gay.

Copyright © 1991, 2000 by Lucent Technologies.

Permission to use, copy, modify, and distribute this software for any purpose without fee is hereby granted, provided that this entire notice is included in all copies of any software which is or includes a copy or modification of this software and in all copies of the supporting documentation for such software.

THIS SOFTWARE IS BEING PROVIDED "AS IS", WITHOUT ANY EXPRESS OR IMPLIED WARRANTY.IN PARTICULAR, NEITHER THE AUTHOR NOR LUCENT MAKES ANY REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.

ICU

ICU version 1.8.1 or later

COPYRIGHT AND PERMISSION NOTICE

Copyright © 1995–2008 International Business Machines Corporation and others

All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS.IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.

All trademarks and registered trademarks mentioned herein are the property of their respective owners.

IEEE Software Taggant Library

This software was developed by The Institute of Electrical and Electronics Engineers, Incorporated (IEEE), through the Industry Connections Security Group (ICSG) of its Standards Association.Portions of it include software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/), and those portions are governed by the OpenSSL Toolkit License.

IEEE License

Copyright (c) 2012 IEEE.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

    "This product includes software developed by the IEEE Industry Connections Security Group (ICSG)".

  4. The name "IEEE" must not be used to endorse or promote products derived from this software without prior written permission from the IEEE Standards Association (stds.ipr@ieee.org).
  5. Products derived from this software may not contain "IEEE" in their names without prior written permission from the IEEE Standards Association (stds.ipr@ieee.org).
  6. Redistributions of any form whatsoever must retain the following acknowledgment:

    "This product includes software developed by the IEEE Industry Connections Security Group (ICSG)".

THIS SOFTWARE IS PROVIDED "AS IS" AND "WITH ALL FAULTS."IEEE AND ITS CONTRIBUTORS EXPRESSLY DISCLAIM ALL WARRANTIES AND REPRESENTATIONS, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION: (A) THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE; (B) ANY WARRANTY OF NON-INFRINGEMENT; AND (C) ANY WARRANTY WITH RESPECT TO THE QUALITY, ACCURACY, EFFECTIVENESS, CURRENCY OR COMPLETENESS OF THE SOFTWARE.

IN NO EVENT SHALL IEEE OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES, (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE AND REGARDLESS OF WHETHER SUCH DAMAGE WAS FORESEEABLE.

THIS SOFTWARE USES STRONG CRYPTOGRAPHY, WHICH MAY BE SUBJECT TO LAWS AND REGULATIONS GOVERNING ITS USE, EXPORTATION OR IMPORTATION.YOU ARE SOLELY RESPONSIBLE FOR COMPLYING WITH ALL APPLICABLE LAWS AND REGULATIONS, INCLUDING, BUT NOT LIMITED TO, ANY THAT GOVERN YOUR USE, EXPORTATION OR IMPORTATION OF THIS SOFTWARE.IEEE AND ITS CONTRIBUTORS DISCLAIM ALL LIABILITY ARISING FROM YOUR USE OF THE SOFTWARE IN VIOLATION OF ANY APPLICABLE LAWS OR REGULATIONS.

Info-ZIP

Copyright © 1990–2007 Info-ZIP.All rights reserved.

For the purposes of this copyright and license, “Info-ZIP” is defined as the following set of individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ed Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White

This software is provided “as is,” without warranty of any kind, express or implied.In no event shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential damages arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

  1. Redistributions of source code must retain the above copyright notice, definition, disclaimer, and this list of conditions.
  2. Redistributions in binary form (compiled executables and libraries) must reproduce the above copyright notice, definition, disclaimer, and this list of conditions in documentation and/or other materials provided with the distribution.The sole exception to this condition is redistribution of a standard UnZipSFX binary (including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this license, as long as the normal SFX banner has not been removed from the binary or disabled.
  3. Altered versions—including, but not limited to, ports to new operating systems, existing ports with new graphical interfaces, versions with modified or added functionality, and dynamic, shared, or static library versions not from Info-ZIP—must be plainly marked as such and must not be misrepresented as being the original source or, if binaries, compiled from the original source.Such altered versions also must not be misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered versions with the names "Info-ZIP" (or any variation thereof, including, but not limited to, different capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP.Such altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or the Info-ZIP URL(s), such as to imply Info-ZIP will provide support for the altered versions.
  4. Info-ZIP retains the right to use the names “Info-ZIP,” “Zip,” “UnZip,” “UnZipSFX,” “WiZ,” “Pocket UnZip,” “Pocket Zip,” and “MacZip” for its own source and binary releases.

Jansson

Copyright (c) 2009-2013 Petri Lehtinen <petri@digip.org>

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Lua

The Sophos software that is described in this document may include some software programs that are licensed (or sublicensed) to the user under the Lua License.A copy of the license agreement for any such included software can be found at http://www.lua.org/copyright.html

Microsoft 軟體

本 Sophos 產品可能包括特定的 Microsoft 軟體，授權給 Sophos 列入本文並在此處使用。

Mersenne Twister (mt19937ar.c)

Copyright (c) 1997–2002 Makoto Matsumoto and Takuji Nishimura.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. The names of its contributors may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

OpenSSL Cryptography and SSL/TLS Toolkit

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the original SSLeay license apply to the toolkit.See below for the actual license texts.Actually both licenses are BSD-style Open Source licenses.In case of any license issues related to OpenSSL please contact openssl-core@openssl.org.

OpenSSL License

Copyright © 1998-2011 The OpenSSL Project.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

    “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)”(http://www.openssl.org/)”

  4. The names “OpenSSL Toolkit” and “OpenSSL Project” must not be used to endorse or promote products derived from this software without prior written permission.For written permission, please contact openssl-core@openssl.org.
  5. Products derived from this software may not be called “OpenSSL” nor may “OpenSSL” appear in their names without prior written permission of the OpenSSL Project.
  6. Redistributions of any form whatsoever must retain the following acknowledgment:

    “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)”

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS’’ AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).This product includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay License

Copyright © 1995–1998 Eric Young (eay@cryptsoft.com) All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following conditions are aheared to.The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code.The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young’s, and as such any Copyright notices in the code are not to be removed.If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used.This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

    “This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)”

    The word ‘cryptographic’ can be left out if the rouines from the library being used are not cryptographic related :-).

  4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement:

    “This product includes software written by Tim Hudson (tjh@cryptsoft.com)”

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG ``AS IS’’ AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publically available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution license [including the GNU Public License.]

Protocol Buffers (libprotobuf)

Copyright 2008, Google Inc.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of Google Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Code generated by the Protocol Buffer compiler is owned by the owner of the input file used when generating it.This code is not standalone and requires a support library to be linked with it.This support library is itself covered by the above license.

pstdint

Copyright (c) 2005-2007 Paul Hsieh
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the DOCUMENTATION and/or other materials provided with the distribution.
  3. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Simple ECMAScript Engine (SEE)

Copyright © 2003, 2004, 2005, 2006, 2007 David Leonard.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of David Leonard nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

SQLCipher

Copyright © 2008-2012 Zetetic LLC

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of the ZETETIC LLC nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY ZETETIC LLC ''AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL ZETETIC LLC BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

strcasestr.c

Copyright © 1990, 1993 The Regents of the University of California.All rights reserved.

This code is derived from software contributed to Berkeley by Chris Torek.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Udis86

Copyright (c) 2002-2009 Vivek Thampi
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The views and conclusions contained in the software and documentation are those of the authors and should not be interpreted as representing official policies, either expressed or implied, of the FreeBSD Project.

Unicode

UNICODE, INC.LICENSE AGREEMENT – DATA FILES AND SOFTWARE

Unicode Data Files include all data files under the directories http://www.unicode.org/Public/, http://www.unicode.org/reports/, and http://www.unicode.org/cldr/data/.Unicode Software includes any source code published in the Unicode Standard or under the directories http://www.unicode.org/Public/, http://www.unicode.org/reports/, and http://www.unicode.org/cldr/data/.

NOTICE TO USER: Carefully read the following legal agreement.BY DOWNLOADING, INSTALLING, COPYING OR OTHERWISE USING UNICODE INC.'S DATA FILES ("DATA FILES"), AND/OR SOFTWARE ("SOFTWARE"), YOU UNEQUIVOCALLY ACCEPT, AND AGREE TO BE BOUND BY, ALL OF THE TERMS AND CONDITIONS OF THIS AGREEMENT.IF YOU DO NOT AGREE, DO NOT DOWNLOAD, INSTALL, COPY, DISTRIBUTE OR USE THE DATA FILES OR SOFTWARE.

COPYRIGHT AND PERMISSION NOTICE

Copyright © 1991–2007 Unicode, Inc. All rights reserved.Distributed under the Terms of Use in http://www.unicode.org/copyright.html.

Permission is hereby granted, free of charge, to any person obtaining a copy of the Unicode data files and any associated documentation (the "Data Files") or Unicode software and any associated documentation (the "Software") to deal in the Data Files or Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Data Files or Software, and to permit persons to whom the Data Files or Software are furnished to do so, provided that (a) the above copyright notice(s) and this permission notice appear with all copies of the Data Files or Software, (b) both the above copyright notice(s) and this permission notice appear in associated documentation, and (c) there is clear notice in each modified Data File or in the Software as well as in the documentation associated with the Data File(s) or Software that the data or software has been modified.

THE DATA FILES AND SOFTWARE ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS.IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THE DATA FILES OR SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in these Data Files or Software without prior written authorization of the copyright holder.

UnRAR

The source code of UnRAR utility is freeware.This means:

  1. All copyrights to RAR and the utility UnRAR are exclusively owned by the author - Alexander Roshal.
  2. The UnRAR sources may be used in any software to handle RAR archives without limitations free of charge, but cannot be used to re-create the RAR compression algorithm, which is proprietary.Distribution of modified UnRAR sources in separate form or as a part of other software is permitted, provided that it is clearly stated in the documentation and source comments that the code may not be used to develop a RAR (WinRAR) compatible archiver.
  3. The UnRAR utility may be freely distributed.It is allowed to distribute UnRAR inside of other software packages.
  4. THE RAR ARCHIVER AND THE UnRAR UTILITY ARE DISTRIBUTED “AS IS”.NO WARRANTY OF ANY KIND IS EXPRESSED OR IMPLIED.YOU USE AT YOUR OWN RISK.THE AUTHOR WILL NOT BE LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND OF LOSS WHILE USING OR MISUSING THIS SOFTWARE.
  5. Installing and using the UnRAR utility signifies acceptance of these terms and conditions of the license.
  6. If you don’t agree with terms of the license you must remove UnRAR files from your storage devices and cease to use the utility.

Thank you for your interest in RAR and UnRAR.

Alexander L. Roshal

Windows Template Library (WTL)

This product may contain Windows Template Library (WTL) and/or WixToolset code, which are licensed under the Common Public License 1.0.The source code for the components is available from Sophos, upon request, by emailing TPCRequest@sophos.com

wow64ext library

This is used in Sophos Virus Removal Tool as a shared library (wow64ext.dll), which may be removed or subsituted without affecting other functionality.Its use is covered by the following license:

GNU LESSER GENERAL PUBLIC LICENSE

Version 3, 29 June 2007

Copyright (C) 2007 Free Software Foundation, Inc.

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

This version of the GNU Lesser General Public License incorporates the terms and conditions of version 3 of the GNU General Public License, supplemented by the additional permissions listed below.

  • 0.Additional Definitions.

    As used herein, "this License" refers to version 3 of the GNU Lesser General Public License, and the "GNU GPL" refers to version 3 of the GNU General Public License.

    "The Library" refers to a covered work governed by this License, other than an Application or a Combined Work as defined below.

    An "Application" is any work that makes use of an interface provided by the Library, but which is not otherwise based on the Library.Defining a subclass of a class defined by the Library is deemed a mode of using an interface provided by the Library.

    A "Combined Work" is a work produced by combining or linking an Application with the Library.The particular version of the Library with which the Combined Work was made is also called the "Linked Version".

    The "Minimal Corresponding Source" for a Combined Work means the Corresponding Source for the Combined Work, excluding any source code for portions of the Combined Work that, considered in isolation, are based on the Application, and not on the Linked Version.

    The "Corresponding Application Code" for a Combined Work means the object code and/or source code for the Application, including any data and utility programs needed for reproducing the Combined Work from the Application, but excluding the System Libraries of the Combined Work.

  1. Exception to Section 3 of the GNU GPL.

    You may convey a covered work under sections 3 and 4 of this License without being bound by section 3 of the GNU GPL.

  2. Conveying Modified Versions.

    If you modify a copy of the Library, and, in your modifications, a facility refers to a function or data to be supplied by an Application that uses the facility (other than as an argument passed when the facility is invoked), then you may convey a copy of the modified version:

    1. under this License, provided that you make a good faith effort to ensure that, in the event an Application does not supply the function or data, the facility still operates, and performs whatever part of its purpose remains meaningful, or
    2. under the GNU GPL, with none of the additional permissions of this License applicable to that copy.
  3. Object Code Incorporating Material from Library Header Files.

    The object code form of an Application may incorporate material from a header file that is part of the Library.You may convey such object code under terms of your choice, provided that, if the incorporated material is not limited to numerical parameters, data structure layouts and accessors, or small macros, inline functions and templates (ten or fewer lines in length), you do both of the following:

    1. Give prominent notice with each copy of the object code that the Library is used in it and that the Library and its use are covered by this License.
    2. Accompany the object code with a copy of the GNU GPL and this license document.
  4. Combined Works.

    You may convey a Combined Work under terms of your choice that, taken together, effectively do not restrict modification of the portions of the Library contained in the Combined Work and reverse engineering for debugging such modifications, if you also do each of the following:

    1. Give prominent notice with each copy of the Combined Work that the Library is used in it and that the Library and its use are covered by this License.
    2. Accompany the Combined Work with a copy of the GNU GPL and this license document.
    3. For a Combined Work that displays copyright notices during execution, include the copyright notice for the Library among these notices, as well as a reference directing the user to the copies of the GNU GPL and this license document.
    4. 請進行以下任何一項步驟：

      0) Convey the Minimal Corresponding Source under the terms of this License, and the Corresponding Application Code in a form suitable for, and under terms that permit, the user to recombine or relink the Application with a modified version of the Linked Version to produce a modified Combined Work, in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source

      1) Use a suitable shared library mechanism for linking with the Library.A suitable mechanism is one that (a) uses at run time a copy of the Library already present on the user's computer system, and (b) will operate properly with a modified version of the Library that is interface-compatible with the Linked Version.

    5. Provide Installation Information, but only if you would otherwise be required to provide such information under section 6 of the GNU GPL, and only to the extent that such information is necessary to install and execute a modified version of the Combined Work produced by recombining or relinking the Application with a modified version of the Linked Version.(If you use option 4d0, the Installation Information must accompany the Minimal Corresponding Source and Corresponding Application Code.If you use option 4d1, you must provide the Installation Information in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source.)
  5. Combined Libraries.

    You may place library facilities that are a work based on the Library side by side in a single library together with other library facilities that are not Applications and are not covered by this License, and convey such a combined library under terms of your choice, if you do both of the following:

    1. Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities, conveyed under the terms of this License.
    2. Give prominent notice with the combined library that part of it is a work based on the Library, and explaining where to find the accompanying uncombined form of the same work.
  6. Revised Versions of the GNU Lesser General Public License.

    The Free Software Foundation may publish revised and/or new versions of the GNU Lesser General Public License from time to time.Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

    Each version is given a distinguishing version number.If the Library as you received it specifies that a certain numbered version of the GNU Lesser General Public License "or any later version" applies to it, you have the option of following the terms and conditions either of that published version or of any later version published by the Free Software Foundation.If the Library as you received it does not specify a version number of the GNU Lesser General Public License, you may choose any version of the GNU Lesser General Public License ever published by the Free Software Foundation.

    If the Library as you received it specifies that a proxy can decide whether future versions of the GNU Lesser General Public License shall apply, that proxy's public statement of acceptance of any version is permanent authorization for you to choose that version for the Library.

前一個主題: 技術支援