帮助

关于 Sophos Endpoint Security and Control

Sophos Endpoint Security and Control 是集成式的安全软件套件。

Sophos Anti-Virus 会检测和清除病毒，特洛伊木马，蠕虫，以及间谍软件，还有广告软件和其它可能不想安装的应用程序。我们的 HIPS (Host Intrusion Prevention System，主机入侵防范系统) 技术还可以保护您的计算机不受可疑文件和 Rootkit 的侵害。此外，恶意数据流检测程序还可以检测僵尸网络或其他恶意软件攻击中涉及的计算机和命令与控制服务器之间的通信。

Sophos Behavior Monitoring 使用我们的 HIPS 技术保护 Windows 及以后的计算机免遭未被识别的或尚未有补丁的安全隐患，以及可疑行为的威胁。

Sophos Live Protection 可以显著提高对新出现的恶意软件的检出率，同时也不会做无谓的检测活动。能够做到这一点，是因为能够随时比对最新的已知的恶意软件。一旦确认了新的恶意软件，Sophos 即可立即发出更新文件。

Sophos Web Protection 通过防止访问已知的带有恶意软件的网站，提供增强的防范网页安全隐患的保护措施。通过实时对比 Sophos 的在线恶意网站数据库，它会阻断终结点计算机访问恶意网站。它还会扫描下载的数据和文件，并检查文件信誉。

Sophos Application Control 会阻断未经批准的应用程序，诸如，语音 IP，即时通讯，文件共享，以及游戏软件等。

Sophos Device Control 会阻断未经批准的外接存储设备，以及无线连接技术。

Sophos Data Control 会防止从受管理的计算机中意外泄漏个人识别信息。

Sophos Web Control 为在您的公司网络中，网络外，以及漫游的终结点计算机提供保护，控制，和报告。

Sophos Client Firewall 会防范蠕虫，特洛伊木马，以及间谍软件偷窃和敏感信息，并且还会防范黑客入侵。

Sophos AutoUpdate 提供安全可靠的更新，并且能够在低速网络连接中更新时，克制使用带宽。

Sophos Tamper Protection 可以防范已知的恶意软件，以及防止未经授权的用户通过 Sophos Endpoint Security and Control 用户界面，卸载或禁用 Sophos 安全软件。

下一个题目： 关于主页


关于主页

当您打开 Sophos Endpoint Security and Control 窗口时，主页 会出现在右手边的窗格板中。它使您能够配置和使用此软件。

当您使用 Sophos Endpoint Security and Control 时，右手边的窗格板中的内容会改变。要返回 主页 页面，单击工具栏上的 主页 按钮。

上一个题目： 关于 Sophos Endpoint Security and Control
下一个题目： 关于 Sophos 组


关于 Sophos 组

Sophos Endpoint Security and Control 会限制某些 Sophos 组的成员访问软件的特定部分。

当 Sophos Endpoint Security and Control 安装后，计算机上的各个用户会根据它们所在 Windows 组被指派到 Sophos 组中。
Windows 组 | Sophos 组
Administrators | SophosAdministrator
Power Users | SophosPowerUser
用户 | SophosUser

没有被指派到 Sophos 组的用户，包括来宾用户，只能执行以下任务：

  • 读写扫描
  • 单击右键扫描

SophosUsers

SophosUsers 只能执行以上任务，以及执行以下任务：

  • 打开 Sophos Endpoint Security and Control。
  • 设置和运行即时扫描
  • 配置单击右键扫描
  • 管理（只有限定的权限的）隔离项目
  • 创建和配置防火墙规则

SophosPowerUsers

SophosPowerUsers 具备与 SophosUsers 相同的权限，并具有以下更多的权限：

  • 更高的隔离区管理器的权限
  • 访问批准管理器的权限

SophosAdministrators

SophosAdministrators 可以使用和配置 Sophos Endpoint Security and Control 中的任何部分。
注： 如果启用了介入防范，那么，SophosAdministrator 组的成员必须知道介入防范密码，才能执行以下任务：
  • 配置读写扫描。
  • 配置可疑行为检测。
  • 禁用介入防范。

要了解更多信息，请参见 关于此计算机上的介入防范。

上一个题目： 关于主页
下一个题目： 添加用户到 Sophos 组中


添加用户到 Sophos 组中

如果您是计算机上的域管理员或 Windows Administrators 组中的成员，那么，您可以更改用户作为成员所在的 Sophos 组。您这样做，尤其是为了更改它们访问 Sophos Endpoint Security and Control 的权限。

要添加用户到 Sophos 组中：

  1. 使用 Windows，打开计算机管理。
  2. 在控制台树中，单击 用户。
  3. 右击用户帐户，然后单击 属性。
  4. 在 隶属于 标签页中，单击 添加。
  5. 在 输入供选择的对象名称，输入一个 Sophos 组的名称：
    • SophosAdministrator
    • SophosPowerUser
    • SophosUser
  6. 如果您想要验证 Sophos 组名，请单击 检查名称。
当用户下一次登录到计算机时，他们会发现访问 Sophos Endpoint Security and Control 的权限已被更改。

注意

  • 要打开“计算机管理”，请单击 开始，然后，单击 控制面板。双击 管理工具，然后，双击 计算机管理。
  • 要从 Sophos 用户组删除用户，请在 隶属于 标签页中，选择用户隶属于的组，然后，单击 删除。
上一个题目： 关于 Sophos 组
下一个题目： 配置用户使用隔离区管理器的权限


配置用户使用隔离区管理器的权限

如果您是 SophosAdministrator 组的成员，您可以配置用户使用隔离区管理器的权限。

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 用户使用隔离区管理器的权限。
  2. 选择执行各种类型的措施的用户类型。
    注： 除了 批准 选项之外，您在此设置的权限仅应用于 隔离区管理器。
    选项 | 描述
    清除扇区 | 用户可以清除软盘引导区。
    清除文件 | 用户可以清除文档和程序。
    删除文件 | 用户可以删除感染的文件。
    移动文件 | 用户可以移动受感染的文件到其它文件夹。
    批准 用户可以批准可疑项目，广告软件，以及可能不想安装的应用程序，以便它们能够在计算机上运行。

    此选项应用于 批准管理器 和 隔离区管理器。
上一个题目： 添加用户到 Sophos 组中
下一个题目： 关于读写扫描和即时扫描


关于读写扫描和即时扫描

读写扫描

读写扫描是您防范病毒和其他安全隐患的主要方法。

当您复制，移动，或打开某个文件时，Sophos Anti-Virus 会扫描该文件，确保访问它不会对您的计算机造成安全隐患，或者，它已被批准使用。

要了解更多的信息，请参见 配置读写扫描。

即时扫描

即时扫描可以提供附加的保护。正如扫描的名称所示，您可以即时启动扫描。您可以扫描单一文件到整个计算机上的任何内容。

要了解更多信息，请参见 即时扫描类型。

上一个题目： 配置用户使用隔离区管理器的权限
下一个题目： 关于读写扫描的最佳使用方法


关于读写扫描的最佳使用方法

本节中提供的建议将帮助您获得读写扫描的最佳效果。

我们建议您使用默认的读写扫描设置，因为它在保护您的计算机免遭安全隐患的威胁与不影响整个计算机系统之间取得了最佳的平衡。要了解有关调整默认的读写扫描设置的详细建议，请参见 Sophos 技术支持知识库文章 114345 (http://www.sophos.com/en-us/support/knowledgebase/114345.aspx)（英文）。

上一个题目： 关于读写扫描和即时扫描
下一个题目： 配置读写扫描


配置读写扫描

警告：
如果安装了某些加密软件，那么，读写扫描可能会检测不到病毒。更改启动进程，确保在读写扫描开始时，加密的文件已被解密。要了解更多有关怎样针对加密软件使用防病毒和 HIPS 策略的信息，请参见 Sophos 技术支持知识库文章 12790 http://www.sophos.com/en-us/support/knowledgebase/12790.aspx（英文）。
重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。
依照默认值，Sophos Anti-Virus 会在进行读写扫描时，检测和删除以下的安全隐患：
  • 病毒
  • 特洛伊木马
  • 蠕虫
  • 间谍软件

要配置读写扫描：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 读写扫描。
  2. 要更改进行读写扫描的时机，请在 检查文件的时机 中，按照以下说明设置选项。
    选项 | 描述
    读文件时 | 当文件被复制，移动，或打开时， 扫描文件。
    Rename | 当文件被重新命名时，扫描文件。
    写文件时 | 当保存，或创建文件时，扫描文件。
  3. 在 扫描 下，按照以下说明设置选项。
    选项 | 描述
    广告软件和可能不想安装的应用程序 广告软件显示广告活动（例如：弹出消息），它会影响用户的工作效率和系统的运行效率。

    可能不想安装的应用程序 (PUA) 不是恶意软件，但是通常被认为不适合在公司网络中使用。
    可疑文件 | 可疑文件是在文件中出现了病毒中普遍具有，但又不仅是病毒中才具有的一系列特征的一种文件。
  4. 在 其它扫描选项 下，按照以下说明设置选项。
    选项 | 描述
    允许访问引导区受到感染的驱动器 开启此选项，可以允许访问被感染的，可以用于启动的移动介质，如：CD 启动盘，软盘，或者，USB 闪存。

    只在 Sophos 技术支持的建议下才使用此选项。

    请同时参见“排疑解难”主题中的 允许访问引导区受到感染的驱动器。
    扫描所有文件 | 我们建议您关闭此选项，因为，它会显著增加扫描的时间。只能在每周扫描期间扫描所有文件。
    扫描打包文件内部 打开此选项，扫描档案或压缩档的内容。只有当下载和分配此类文件而未选取内容时需要执行此操作。

    我们建议您关闭此选项，因为，它会显著增加扫描的时间。

    您将仍然受到保护，免遭打包文件或压缩文件中的任何安全隐患的威胁，因为，打包文件或压缩文件中的任何可能是恶意软件的组件，都会被读写扫描阻断：

    • 当您打开解压缩自打包文件的文件时，该解压缩的文件会被扫描。
    • 使用动态压缩工具，如：PKLite，LZEXE，以及 Diet 压缩的文件都会被扫描。
    扫描系统内存 打开此选项，可以每小时自动运行一次后台扫描，检测隐藏在计算机系统内存（操作系统所使用的内存）中的恶意软件。
    注： 此选项仅在 32 位操作系统上有效。
上一个题目： 关于读写扫描的最佳使用方法
下一个题目： 暂时禁用读写扫描


暂时禁用读写扫描

如果您是 SophosAdministrator 组的成员，您可以为了进行维护或排错，而暂时禁用读写扫描，以后在重新启用它。您可以禁用读写扫描保护，同时，仍然在您的计算机上运行即时扫描。

即使您重新启动计算机，Sophos Endpoint Security and Control 还是会将您在此所作的设置保留。如果您禁用读写扫描，您的计算机将处于非保护状态，直到您重新启用它。

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 读写扫描。
  2. 取消勾选 在本计算机上启用读写扫描 勾选框。
上一个题目： 配置读写扫描
下一个题目： 配置读写扫描的清除


配置读写扫描的清除

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。
要配置读写扫描的清除：
  1. 单击主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 读写扫描。
  2. 单击清除选项卡。
  3. 要自动清除感染的项目，请在病毒/间谍软件下选中自动清除包含病毒/间谍软件的项目复选框。
    注： 如果开启此选项，清除某些病毒/间谍软件时将会触发完整系统扫描，它会试图清除计算机上的所有病毒。这可能会耗费较长时间。
  4. 如果已禁用自动清除，或自动清除失败，请在病毒/间谍软件下，选择要让 Sophos Anti-Virus 对感染项目执行的操作：
    选项 描述
    仅拒绝访问 在继续之前，Sophos Anti-Virus 会询问您要做什么。

    这是默认的设置。
    删除

    拒绝访问并移至

                 只在 Sophos 技术支持的建议下才使用这些设置。

    否则，请使用“隔离区管理器”清除 Sophos Anti-Virus 在计算机中发现的病毒/间谍软件。请参阅处置隔离区中的病毒/间谍软件。
  5. 在可疑文件下，请选中某个 Sophos Anti-Virus 措施，当文件中发现通常在恶意软件中使用的代码时，采用该措施：
    选项 描述
    拒绝访问 在继续之前，Sophos Anti-Virus 会询问您要做什么。

    这是默认的设置。
    删除

    拒绝访问并移至

                 只在 Sophos 技术支持的建议下才使用这些设置。

    否则，请使用“隔离区管理器”清除 Sophos Anti-Virus 在您的计算机中发现的可疑文件。请参阅处置隔离区中的可疑文件。
上一个题目： 暂时禁用读写扫描
下一个题目： 重置已扫描文件的检查和


重置已扫描文件的检查和

当 Sophos Anti-Virus 更新时，或者，当您重新启动计算机时，已扫描文件的检查和的列表会被重置。当文件被 Sophos Anti-Virus 扫描后，该列表会被使用新的数据重建。

如果不想重新启动计算机，您可以从 Sophos Endpoint Security and Control 中重置已扫描文件的检查和的列表。

要重置已扫描文件的检查和：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 读写扫描。
  2. 在 扫描 标签页中，单击 清空缓存。
上一个题目： 配置读写扫描的清除
下一个题目： 指定读写扫描文件扩展名


指定读写扫描文件扩展名

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

您可以指定进行读写扫描时，扫描的文件扩展名。

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 读写扫描。
  2. 单击 扩展名 标签页，按照以下说明设置选项。

    扫描所有文件

    单击该选择，以启用扫描所有文件，该扫描忽略文件的扩展名。

    允许精确控制扫描的项目

    单击该选择，以限制扫描仅针对那些在文件扩展名列表中所指定的，带有特定扩展名的文件。

    警告：
    扩展名列表中包括了我们建议扫描的所有文件类型。如果您要更改该列表，请按照以下的说明仔细地做。

    要添加文件扩展名到该列表中，请单击 添加。您可以使用通配符 ? 替代任何单一的字符。

    要从列表中删除文件扩展名，请选择该扩展名，然后，单击 删除。

    要从列表中更改文件扩展名，请选择该扩展名，然后，单击 编辑。

    当您选择 允许精确控制扫描的项目 选项时，扫描没有扩展名的文件 选项会成为默认选项。要禁用扫描不带文件扩展名的文件，请取消勾选 扫描不带文件扩展名的文件。

上一个题目： 重置已扫描文件的检查和
下一个题目： 即时扫描类型


即时扫描类型

单击右键扫描

随时扫描资源管理器中的文件，文件夹，或驱动器。

  • 运行单击右键扫描

自定义扫描

扫描特定的文件或文件夹集合。您既可以手动运行自定义扫描，也可以计划运行自定义扫描。

  • 运行自定义扫描
  • 计划自定义扫描

完全的计算机扫描

随时扫描您的整个计算机，包括引导区和系统内存。

  • 运行完全的计算机扫描
上一个题目： 指定读写扫描文件扩展名
下一个题目： 指定即时扫描文件扩展名


指定即时扫描文件扩展名

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

您可以指定进行即时扫描时，扫描的文件扩展名。

  1. 在 配置 菜单中，单击 即时扫描文件扩展名和排除文件。
  2. 单击 扩展名 标签页，按照以下说明设置选项。

    扫描所有文件

    单击该选择，以启用扫描所有文件，该扫描忽略文件的扩展名。

    允许精确控制扫描的项目

    单击该选择，以限制扫描仅针对那些在文件扩展名列表中所指定的，带有特定扩展名的文件。

    警告：
    扩展名列表中包括了我们建议扫描的所有文件类型。如果您要更改该列表，请按照以下的说明仔细地做。

    要添加文件扩展名到该列表中，请单击 添加。您可以使用通配符 ? 替代任何单一的字符。

    要从列表中删除文件扩展名，请选择该扩展名，然后，单击 删除。

    要从列表中更改文件扩展名，请选择该扩展名，然后，单击 编辑。

    当您选择 允许精确控制扫描的项目 选项时，扫描没有扩展名的文件 选项会成为默认选项。要禁用扫描不带文件扩展名的文件，请取消勾选 扫描不带文件扩展名的文件。

上一个题目： 即时扫描类型
下一个题目： 配置单击右键扫描


配置单击右键扫描

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它将不会覆盖您在此所作的任何更改。
依照默认值，Sophos Anti-Virus 会在进行单击右键扫描时，检测和删除以下的安全隐患：
  • 病毒
  • 特洛伊木马
  • 蠕虫
  • 间谍软件
  • 广告软件和其它可能不想安装的应用程序 (PUA)

要配置单击右键扫描：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 单击右键扫描。
  2. 在 扫描 下，按照以下说明设置选项。
    选项 | 描述
    广告软件和可能不想安装的应用程序 广告软件显示广告活动（例如：弹出消息），它会影响用户的工作效率和系统的运行效率。

    可能不想安装的应用程序 (PUA) 不是恶意软件，但是通常被认为不适合在公司网络中使用。
    可疑文件 | 可疑文件是在文件中出现了病毒中普遍具有，但又不仅是病毒中才具有的一系列特征的一种文件。
  3. 在 其它扫描选项 下，按照以下说明设置选项。
    选项 | 描述
    扫描所有文件 | 我们建议您关闭此选项，因为，它会显著增加扫描的时间。只能在每周扫描期间扫描所有文件。
    扫描打包文件内部 打开此选项，扫描档案或压缩档的内容。只有当下载和分配此类文件而未选取内容时需要执行此操作。

    我们建议您关闭此选项，因为，它会显著增加扫描的时间。

    您将仍然受到保护，免遭打包文件或压缩文件中的任何安全隐患的威胁，因为，打包文件或压缩文件中的任何可能是恶意软件的组件，都会被读写扫描阻断：

    • 当您打开解压缩自打包文件的文件时，该解压缩的文件会被扫描。
    • 使用动态压缩工具，如：PKLite，LZEXE，以及 Diet 压缩的文件都会被扫描。
上一个题目： 指定即时扫描文件扩展名
下一个题目： 配置单击右键扫描的清除


配置单击右键扫描的清除

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。
要配置单击右键扫描的清除：
  1. 单击主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 右键单击扫描。
  2. 单击清除选项卡。
  3. 要自动清除感染的项目，请在病毒/间谍软件下选中自动清除包含病毒/间谍软件的项目复选框。
  4. 如果尚未启用自动清除，或自动清除失败，请选择要让 Sophos Anti-Virus 对感染项目执行的操作：
    选项 描述
    仅记录 Sophos Anti-Virus 不采取任何措施，只是将感染的项目记录到扫描日志中。请参阅查看扫描日志。

    这是默认的设置。
    删除

    移至

                 只在 Sophos 技术支持的建议下才使用这些设置。

    否则，请使用“隔离区管理器”清除 Sophos Anti-Virus 在计算机中发现的病毒/间谍软件。请参阅处置隔离区中的病毒/间谍软件。

  5. 在可疑文件下，请选中某个 Sophos Anti-Virus 措施，当文件中发现通常在恶意软件中使用的代码时，采用该措施：
    选项 描述
    仅记录 Sophos Anti-Virus 不采取任何措施，只是将感染的项目记录到扫描日志中。

    这是默认的设置。
    删除

    移至

                 只在 Sophos 技术支持的建议下才使用这些设置。

    否则，请使用“隔离区管理器”清除 Sophos Anti-Virus 在计算机中发现的病毒/间谍软件。请参阅处置隔离区中的可疑文件。
  6. 要删除所有用户的计算机上的广告软件/可能不需要的应用程序 (PUA) 的所有组件，请在广告软件和 PUA 下，选中自动清除广告软件/PUA 复选框。
    对此所作的清除，并不会修复广告软件或可能不需要的应用程序，已经对计算机所做的任何改变。
    • 要了解在 Sophos 网站详细查看广告软件或 PUA 造成损害的信息，请参阅获得清除信息。
    • 要了解有关通过隔离区管理器，清除计算机中的广告软件和可能不需要的应用程序的信息，请参阅处置隔离区中的广告软件和可能不需要的应用程序。
上一个题目： 配置单击右键扫描
下一个题目： 运行单击右键扫描


运行单击右键扫描

您可以通过单击右键扫描，从“资源管理器”或桌面扫描文件，文件夹和驱动器。

  1. 通过“资源管理器”，或者，在桌面上，选择您想要文件，文件夹，或磁盘驱动器。
    您可以选择多个文件和文件夹。
  2. 右击该选项，然后，选择 用 Sophos Anti-Virus 扫描。

如果发现了任何安全隐患或受控程序，请单击 更多，然后，参见此帮助文件中的 管理隔离项目 部分。

上一个题目： 配置单击右键扫描的清除
下一个题目： 创建自定义扫描


创建自定义扫描

  1. 在 主页 中的 防病毒和 HIPS 下，单击 扫描。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 单击 设置新扫描。
  3. 在 扫描名称 文本框中，输入扫描的名称。
  4. 在 扫描项目 面板中，选择您想要扫描的驱动器和文件夹。勾选各驱动器或文件左边的勾选框，可以进行选择。要了解出现在勾选框中的各种图标的含义，请参见扫描项目的示意图标。
    注： 在显示不可用的驱动器或文件夹（因为它们是离线的，或者已被删除）时，会有删除线。如果它们被取消了勾选，或者，如果更改了对它们的父驱动器或父文件夹的选择，它们会被从 扫描项目 窗格板中删除。
  5. 要进一步配置选项，单击 配置本扫描。（请参见 配置自定义扫描 获取更多的信息。）
  6. 要计划本扫描，单击 计划本扫描。（请参见 计划自定义扫描 获取更多的信息。）
  7. 单击 存盘 保存本扫描，或者，单击 存盘并启动，保存并运行该扫描。
上一个题目： 运行单击右键扫描
下一个题目： 扫描项目的示意图标


扫描项目的示意图标

在 扫描项目 窗格板中，各种不同的图标会出现在每个项目（驱动器或文件夹）的勾选框中，图标的不同取决于要扫描的项目。对这些图标的说明如下。
图标 | 释意
 | 该项目及其所有子项目都没有被选择为扫描对象。
 | 该项目及其所有子项目都已被选择为扫描对象。
 | 部分地被选择的项目：该项目本身没有被选择，但是，该项目的一些子项目被选择进行扫描。
 | 该项目及其所有子项目会被从特定的扫描中排除。
 | 部分地排除的项目：该项目本身被选择，但是，该项目的一些子项目被从该特定的扫描中排除。
 | 该项目及其所有子项目都已被从所有即时扫描中排除，因为已经设定了一个即时扫描的排除列表。有关详细信息，请参阅从读写扫描中排除项目。
上一个题目： 创建自定义扫描
下一个题目： 配置自定义扫描


配置自定义扫描

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。
依照默认值，Sophos Anti-Virus 会在进行自定义扫描时，检测和删除以下的安全隐患：
  • 病毒
  • 特洛伊木马
  • 蠕虫
  • 间谍软件
  • 广告软件和其它可能不想安装的应用程序 (PUA)
  • rootkit

要配置自定义扫描：

  1. 在 主页 中的 防病毒和 HIPS 下，单击 扫描。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 可用的扫描 列表中，选择您想要编辑的扫描，然后，单击 编辑。
  3. 单击 配置此扫描。
  4. 在 扫描 下，按照以下说明设置选项。
    选项 | 描述
    广告软件和可能不想安装的应用程序 广告软件显示广告活动（例如：弹出消息），它会影响用户的工作效率和系统的运行效率。

    可能不想安装的应用程序 (PUA) 不是恶意软件，但是通常被认为不适合在公司网络中使用。
    可疑文件 | 可疑文件是在文件中出现了病毒中普遍具有，但又不仅是病毒中才具有的一系列特征的一种文件。
    Rootkit 如果您是 SophosAdministrator 组的成员，那么，在您运行完整计算机扫描时，总是会扫描 rootkit。

    您也可以将扫描 rootkit，作为自定义扫描的一部分。

  5. 在 其它扫描选项 下，按照以下说明设置选项。
    选项 | 描述
    扫描所有文件 | 我们建议您只每周进行一次扫描所有文件，因为，扫描所有文件会降低计算机系统的运行效率。
    扫描打包文件内部 打开此选项，扫描档案或压缩档的内容。只有当下载和分配此类文件而未选取内容时需要执行此操作。

    我们建议您关闭此选项，因为，它会显著增加扫描的时间。

    您将仍然受到保护，免遭打包文件或压缩文件中的任何安全隐患的威胁，因为，打包文件或压缩文件中的任何可能是恶意软件的组件，都会被读写扫描阻断：

    • 当您打开解压缩自打包文件的文件时，该解压缩的文件会被扫描。
    • 使用动态压缩工具，如：PKLite，LZEXE，以及 Diet 压缩的文件都会被扫描。
    扫描系统内存 打开此选项，可以每小时自动运行一次后台扫描，检测隐藏在计算机系统内存（操作系统所使用的内存）中的恶意软件。
    注： 此选项仅在 32 位操作系统上有效。
    以较低的优先级运行扫描 | 在 Windows Vista 及以上的操作系统中，以较低的优先级运行自定义扫描，以便最大限度地降低对用户应用程序运行效率的影响。
上一个题目： 扫描项目的示意图标
下一个题目： 配置自定义扫描的清除


配置自定义扫描的清除

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。
要配置自定义扫描的清除：
  1. 在主页页面上的防病毒和 HIPS 下，单击扫描。
    有关主页页面的信息，请参阅关于主页。
  2. 在可用的扫描列表中，选择要编辑的扫描，然后单击编辑。
  3. 单击配置此扫描。
  4. 单击清除选项卡。
  5. 要自动清除感染的文件，请在病毒/间谍软件下选中自动清除包含病毒/间谍软件的文件复选框。
  6. 如果尚未启用自动清除，或自动清除失败，请选择要让 Sophos Anti-Virus 对感染项目执行的操作：
    选项 描述
    仅记录 Sophos Anti-Virus 不采取任何措施，只是将感染的项目记录到自定义扫描的日志中。请参阅查看自定义扫描日志。

    这是默认的设置。
    删除

    移至

                 只在 Sophos 技术支持的建议下才使用这些设置。

    否则，请使用“隔离区管理器”清除 Sophos Anti-Virus 在计算机中发现的病毒/间谍软件。请参阅处置隔离区中的病毒/间谍软件。
  7. 在可疑文件下，请选中某个 Sophos Anti-Virus 措施，当文件中发现通常在恶意软件中使用的代码时，采用该措施：
    选项 描述
    仅记录 Sophos Anti-Virus 不采取任何措施，只是将感染的项目记录到扫描日志中。

    这是默认的设置。
    删除

    移至

    只在 Sophos 技术支持的建议下才使用这些设置。

    否则，请使用“隔离区管理器”清除 Sophos Anti-Virus 在计算机中发现的病毒/间谍软件。请参阅处置隔离区中的可疑文件。
  8. 要删除所有用户的计算机上的广告软件/可能不需要的应用程序 (PUA) 的所有组件，请在广告软件和 PUA 下，选中自动清除广告软件/PUA 复选框。
    对此所作的清除，并不会修复广告软件或可能不需要的应用程序，已经对计算机所做的任何改变。
    • 要了解在 Sophos 网站详细查看广告软件或 PUA 造成损害的信息，请参阅获得清除信息。
    • 要了解有关通过隔离区管理器，清除计算机中的广告软件和可能不需要的应用程序的信息，请参阅处置隔离区中的广告软件和可能不需要的应用程序。
上一个题目： 配置自定义扫描
下一个题目： 计划自定义扫描


计划自定义扫描

如果您是 SophosAdministrator 组的成员，您可以计划自定义扫描，或者，查看和编辑其它用户已创建的计划扫描。

  1. 在 主页 中的 防病毒和 HIPS 下，单击 扫描。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 可用的扫描 列表中，选择您想要编辑的扫描，然后，单击 编辑。
  3. 单击 计划本扫描。
  4. 在 计划扫描 对话框中，选择 启用计划。

    选择扫描应该运行的时间。

    单击 添加 可添加时间。

    如果需要，选择时间，然后分别单击 删除 或 编辑，可以删除或编辑该时间。

  5. 输入 用户名 和 密码。请确保密码不为空白。
    该计划扫描将依据该用户的访问权限运行。
注： 如果扫描检测到内存中有安全隐患的组件，并且您尚未设置为扫描发现的病毒/间谍软件进行自动清除，那么，扫描会中止。这是因为继续扫描，有可能会扩散安全隐患。您必须在清除该安全隐患之后，再运行扫描。
上一个题目： 配置自定义扫描的清除
下一个题目： 运行自定义扫描


运行自定义扫描

注： 您不能手动运行计划的自定义扫描。计划了的扫描会显示在 可用的扫描 列表中，并带有一个时钟图标。
  1. 在 主页 中的 防病毒和 HIPS 下，单击 扫描。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 可用的扫描 列表中，选择您想要运行的扫描，然后，单击 启动。
    这时会有一个扫描进程对话框出现，同时 活动摘要 面板会出现在 Sophos Endpoint Security and Contro 窗口中。
注： 如果扫描检测到内存中有安全隐患的组件，并且您尚未设置为扫描发现的病毒/间谍软件进行自动清除，那么，扫描会中止。这是因为继续扫描，有可能会扩散安全隐患。您必须在清除该安全隐患之后，再运行扫描。

如果发现了安全隐患或受控程序，单击 更多信息，并参见“管理隔离区项目”。

上一个题目： 计划自定义扫描
下一个题目： 重新命名自定义扫描


重新命名自定义扫描

  1. 在 主页 中的 防病毒和 HIPS 下，单击 扫描。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 可用的扫描 列表中，选择您想要编辑的扫描，然后，单击 编辑。
  3. 在 扫描名称 文本框中，为扫描输入新的名称。
上一个题目： 运行自定义扫描
下一个题目： 查看自定义扫描日志


查看自定义扫描日志

  1. 在 主页 中的 防病毒和 HIPS 下，单击 扫描。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 可用的扫描 列表中，单击自定义扫描的 摘要。
  3. 在 摘要 对话框中，单击底部的链接文字。
您可以从日志记录页中，复制日志记录到剪贴板，也可以用电子邮件发送日志记录，或者，直接打印日志记录。

要在日志记录中查找特定的文本，单击 查找 并输入您想查找的文本内容。

上一个题目： 重新命名自定义扫描
下一个题目： 查看自定义扫描摘要


查看自定义扫描摘要

  1. 在 主页 中的 防病毒和 HIPS 下，单击 扫描。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 可用的扫描 列表中，单击自定义扫描的 摘要。
上一个题目： 查看自定义扫描日志
下一个题目： 删除自定义扫描


删除自定义扫描

  1. 在 主页 中的 防病毒和 HIPS 下，单击 扫描。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 可用的扫描 列表中，选择您想要删除的扫描，然后，单击 删除。
上一个题目： 查看自定义扫描摘要
下一个题目： 运行完全的计算机扫描


运行完全的计算机扫描

要扫描整个计算机系统，包括引导区和系统内存：

在 主页 页面下的 防病毒和 HIPS 中，单击 扫描我的电脑。
要了解有关 主页 页面的信息，请参见 关于主页。

这时会有一个扫描进程对话框出现，同时 活动摘要 会出现在 Sophos Endpoint Security and Contro 窗口中。

注： 如果扫描检测到内存中有安全隐患的组件，那么，扫描会中止。这是因为继续扫描，有可能会扩散安全隐患。您必须在清除该安全隐患之后，再运行扫描。

如果发现了安全隐患或受控程序，单击 更多信息，并参见管理隔离项目 部分。

上一个题目： 删除自定义扫描
下一个题目： 从读写扫描中排除项目


从读写扫描中排除项目

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

要编辑从读写扫描中排除的文件，文件夹，和驱动器的列表：

  1. 单击主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 读写扫描。
  2. 单击排除项目选项卡，然后选择以下选项之一。
    • 要指定需要从读写扫描中排除的文件、文件夹或驱动器，请单击添加。
    • 要删除某个排除项目，请单击删除。
    • 要更改某个排除项目，请单击编辑。
  3. 要添加或编辑某个已排除的项目，请在排除项目对话框中，选择项目类型。
    所有远程文件选项用于排除未存储在本地磁盘上的文件。如果您想要加快访问此类文件的速度，并且您信任所提供的远程文件的来源，您可以勾选此选项。
  4. 使用浏览按钮，或在文本框中输入，指定项目名称。
    注： 如果您使用的是 64 位的操作系统，浏览按钮在排除项目对话框中将不可见。

    有关指定项目名称的详细信息，请参阅指定扫描排除。

上一个题目： 运行完全的计算机扫描
下一个题目： 从即时扫描中排除项目


从即时扫描中排除项目

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

下述过程适用于所有即时扫描。要了解有关从自定义扫描中排除特定项目的信息，请参阅创建自定义扫描。

要编辑从即时扫描中排除的文件，文件夹，和驱动器的列表：

  1. 单击主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 即时扫描文件扩展名和排除文件。
  2. 单击排除项目选项卡，然后选择以下选项之一。
    • 要指定需要从读写扫描中排除的文件、文件夹或驱动器，请单击添加。
    • 要删除某个排除项目，请单击删除。
    • 要更改某个排除项目，请单击编辑。
  3. 要添加或编辑某个已排除的项目，请在排除项目对话框中，选择项目类型。
  4. 使用浏览按钮，或在文本框中输入，指定项目名称。
    注： 如果您使用的是 64 位的操作系统，浏览按钮在排除项目对话框中将不可见。

    有关指定项目名称的详细信息，请参阅指定扫描排除。

上一个题目： 从读写扫描中排除项目
下一个题目： 指定扫描排除


指定扫描排除

标准命名协定

Sophos Anti-Virus 会根据标准的 Windows 命名协定，校验扫描排除项目的文件名和路径。例如，某个文件夹名可以使用空格，但是不能仅仅是空格。

多重文件扩展名

在带有多个扩展名的文件名中，最后一个扩展名被视为扩展名，其余部分被视为文件名。

MySample.txt.doc = 文件名 MySample.txt + 扩展名 .doc。

排除特定的文件、文件夹、进程或驱动器

排除类型 | 描述 | 示例 | 注释
特定的文件 | 同时指定文件名和路径，才能排除特定的文件。路径中可以包含驱动器盘符或网络共享名。 | C:\Documents\CV.doc \\Server\Users\?Documents\CV.doc \\Server\Users\Documents\CV.doc | 要确保排除项目能够正确地找到，请添加长文件名或文件夹名，以及 8.3 文件名和文件夹名(8.3-compliant file and folder names)： C:\Program Files\Sophos\Sophos Anti-Virus C:\Progra~1\Sophos\Sophos~1 要了解更多信息，请参见知识库文章 13045。
特定的进程 | 同时指定路径和文件名，以排除特定的可执行文件（进程）。 | C:\Windows\notepad.exe | 必须指定完整路径。
名称相同的所有文件 | 指定不带路径的文件名，可以排除文件系统中所有路径中以该名字命名的所有文件。 | spacer.gif |
驱动器或网络共享中的所有文件 | 指定驱动器盘符，或网络共享，可以排除驱动器或网络共享上的所有文件。 | C: \\Server\<sharename>\ | 指定网络共享时，请在共享名后包括末尾的斜杠。
特定的文件夹 | 指定的文件夹的路径中包含驱动器盘符，或网络共享名，可以排除该文件夹，及其所有子文件夹中的所有文件。 | D:\Tools\logs\ | 在文件夹名称后包括末尾的斜杠。
名称相同的所有文件夹 | 指定的文件夹的路径中不包含驱动器盘符，或网络共享名，可以排除任何驱动器或网络共享中的该文件夹，及其所有子文件夹中的所有文件。 | \Tools\logs\ (排除以下文件夹：C:\Tools\logs\, \\Server\Tools\logs\) | 您必须指定包括驱动器盘符或网络共享名的完整路径。在此示例中，指定 \logs\ 将不会排除任何文件。

通配符

您可以使用此表格中所示的通配符。

注： 在 Windows Server 2003 中只能使用 * 和 ?。
令牌 | 匹配 | 注释
*（星号） 零个或多个除 \ 或 / 以外的任意字符。 例如：

c:\*\*.txt 排除 C:\ 顶层文件夹中所有名称为 *.txt 的文件。

注： * 不能用于表示文件夹
**（两个星号） 由 \ 或 / 字符括起来时，或用在排除的开始或结束位置时，表示包括 \ 和 / 在内的零个或多个任意字符。

** 的所有其他用法均处理为单个 *，匹配零个或多个除 \ 或 / 以外的任意字符。

 例如：
  • c:\foo\**\bar 匹配：c:\foo\bar、c:\foo\more\bar、c:\foo\even\more\bar
  • **\bar 匹配：c:\foo\bar
  • c:\foo\** 匹配：c:\foo\more\bar
  • c:\foo**bar 匹配：c:\foomorebar 但不匹配 c:\foo\more\bar
\（反斜杠） | \ 或 /。
/（斜杠） | / 或 \。
? （问号） | 单个字符，在字符串末尾可匹配零个字符。
.（句点） 句点，或文件名末尾的空字符串（如果匹配模式以句点结束且文件名没有扩展名）。 请注意：
  • *.* 匹配所有文件
  • *. 匹配所有没有扩展名的文件
  • "foo." 匹配 "foo" 和 " "foo."

示例

下面是一些使用通配符的示例。

表达式 | 解释为 | 描述
foo | **\foo | 排除所有名称中包含 foo（在任意位置）的文件。
foo\bar | **\foo\bar | 排除所有文件名称中包含 bar 且文件夹名称中包含 foo（在任意位置）的文件。
*.txt | **\*.txt | 排除所有名称中包含 *txt（在任意位置）的文件。
C: | C: | 从扫描中排除驱动器 C:（包括驱动器的主启动记录）。
C:\ | C:\ | 从扫描中排除驱动器 C: 上的所有文件（但扫描驱动器的主启动记录）。
C:\foo\ | C:\foo\ | C:\foo 下的所有文件和文件夹，包括 C:\foo 本身。
C:\foo\*.txt | C:\foo\*.txt | C:\foo 中包含的所有名称为 *.txt 的文件。

用于排除的变量

设置扫描排除时，可以使用变量。

下表显示了这些变量，以及与每个操作系统对应的位置示例。

变量 | Windows 7 或更高版本，Windows Server 2008 或更高版本 | Windows Server 2003、Windows XP、Windows Vista
%allusersprofile%\ | C:\ProgramData\ | C:\Documents and Settings\All Users\
%appdata%\ | C:\Users\*\AppData\Roaming\ | C:\Documents and Settings\*\Application Data\
%commonprogramfiles%\ | C:\Program Files\Common Files\ | C:\Program Files\Common Files\
%commonprogramfiles(x86)%\ | C:\Program Files (x86)\Common Files\ | C:\Program Files (x86)\Common Files\
%localappdata%\ | C:\Users\*\AppData\Local\ | C:\Documents and Settings\*\Local Settings\Application Data\
%programdata%\ | C:\ProgramData\ | C:\Documents and Settings\All Users\Application Data\
%programfiles%\ | C:\Program Files\ | C:\Program Files\
%programfiles(x86)%\ | C:\Program Files (x86)\ | C:\Program Files (x86)\
%systemdrive%\ | C: | C:
%systemroot%\ | C:\Windows\ | C:\Windows\
%temp%\ 或 %tmp%\ | C:\Users\*\AppData\Local\Temp\ | C:\Documents and Settings\*\Local Settings\Temp\
%userprofile%\ | C:\Users\*\ | C:\Documents and Settings\*\
%windir%\ | C:\Windows\ | C:\Windows\
上一个题目： 从即时扫描中排除项目
下一个题目： 关于行为监控


关于行为监控

作为读写扫描的一部分，Sophos Behavior Monitoring 保护 Windows 计算机免遭未被识别的或“零天”安全隐患，以及可疑行为的威胁。

运行时检测可以中止那些在执行前无法检测到的安全隐患。行为监控使用以下的运行时检测的方法中止安全隐患：
  • 恶意和可疑行为检测
  • 缓冲区溢出检测

恶意和可疑行为检测

可疑行为检测，通过 Sophos 的主机入侵防范系统 (HIPS)，动态地分析所有在计算机上运行的程序，以检测并阻断可能带有恶意的程序活动。可疑行为，包括更改注册表，使得在计算机启动时，病毒会自动运行。

可疑行为检测会监测所有系统进程中恶意软件的活动迹象，如：可疑的注册表写入操作，或文件复制操作等。可以设置提醒管理员和/或阻断进程。

恶意行为检测，可以对所有运行在计算机上的程序进行动态分析，以检测并阻断已知的恶意行为。

缓冲区溢出检测

缓冲区溢出检测对于处理当天最新出现的安全隐患很重要。

它可以动态地分析正在系统中运行的程序的行为，以便及时检测到使用缓冲区溢出手段利用正在运行的进程的企图。它可以捕捉针对操作系统软件和应用程序软件中的安全漏洞发起的攻击。

上一个题目： 指定扫描排除
下一个题目： 启用行为监控


启用行为监控

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您是 SophosAdministrator 组的成员，您可以启用行为监控。

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 行为监控。
  2. 在 配置行为监控 对话框中，选择 启用行为监控 勾选框。
上一个题目： 关于行为监控
下一个题目： 阻断恶意行为


阻断恶意行为

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

恶意行为检测，是对所有运行在计算机上的程序进行动态分析，以检测并阻断已知的恶意行为。

如果您是 SophosAdministrator 组的成员，您可以更改检测和报告恶意行为的设置：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 行为监控。
  2. 在 配置行为监控 对话框中，选择 启用行为监控 勾选框。
  3. 要提醒管理员，并阻断恶意行为，请勾选 检测恶意行为 勾选框。
上一个题目： 启用行为监控
下一个题目： 阻止可疑行为


阻止可疑行为

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

可疑行为检测会监测所有系统进程中恶意软件的活动迹象，如：可疑的注册表写入操作，或文件复制操作等。可以设置提醒管理员和/或阻断进程。

如果您是 SophosAdministrator 组的成员，您可以更改检测和报告可疑行为的设置：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 行为监控。
  2. 在 配置行为监控 对话框中，选择 启用行为监控 勾选框。
  3. 勾选 检测恶意行为 勾选框。
  4. 要提醒管理员，并阻断可疑进程，请勾选 检测可疑行为 勾选框。
  5. 要提醒管理员，但并不阻断可疑进程，请勾选 仅限警告，不阻断可疑行为 勾选框。

为了获得最可靠的保护，我们建议您扫描可疑文件。要了解更多信息，请参见以下主题：

  • 配置读写扫描
  • 配置单击右键扫描
  • 配置自定义扫描
上一个题目： 阻断恶意行为
下一个题目： 防止缓冲区溢出


防止缓冲区溢出

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

缓冲区溢出检测可以动态地分析正在系统中运行的程序的行为，以便及时检测到使用缓冲区溢出手段利用正在运行的进程的企图。

如果您是 SophosAdministrator 组的成员，您可以更改检测和报告缓冲区溢出的设置：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 行为监控。
  2. 在 配置行为监控 对话框中，选择 启用行为监控 勾选框。
  3. 要提醒管理员，并阻断缓冲区溢出，请勾选 检测缓冲区溢出 勾选框。
  4. 要提醒管理员，但并不阻断缓冲区溢出，请勾选 仅限警告，不阻断 勾选框。
上一个题目： 阻止可疑行为
下一个题目： 关于 Sophos Live Protection


关于 Sophos Live Protection

Sophos Live Protection 可以判断可疑文件是否成为安全隐患，并且，如果是安全隐患，便可以立即采取在 Sophos Anti-Virus 清除配置中指定的措施。

Sophos Live Protection 可以显著提高对新出现的恶意软件的检出率，同时也不会做无谓的检测活动。能够做到这一点，是因为能够随时比对最新的已知的恶意软件。一旦确认了新的恶意软件，Sophos 即可立即发出更新文件。

Sophos Live Protection 使用以下选项：

  • 启用 Live Protection

    如果终结点计算机上的防病毒扫描发现某个文件可疑，但是又无法根据存储在计算机上的安全隐患识别文件 (IDE) 进一步确认该文件中是否有恶意代码，那么，某些文件数据（如：文件的检查和，以及其它属性）会被发送给 Sophos 以便做进一步的分析。

    云计算检查会在 SophosLabs 数据库中迅速查看可疑文件。如果文件被确认为是正常的，或者是带有恶意代码的，确认意见会被寄给该计算机，并且该文件的状态会被自动更新。

  • 自动发送文件样本给 Sophos

    如果某文件可疑，但是却又不能仅仅根据其文件数据就肯定地确认它具有恶意代码，那么，您可以允许 Sophos 要求此文件的样本。如果此选项已启用，并且 Sophos 尚未具有该文件的样本，那么，该文件会被自动提交。

    提交文件样本，有助于 Sophos 不断增强检测恶意软件的能力，并且降低误报的几率。

上一个题目： 防止缓冲区溢出
下一个题目： 开启或关闭 Sophos Live Protection 选项


开启或关闭 Sophos Live Protection 选项

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您是 SophosAdministrator 组的成员，您将可以开启或关闭 Sophos Live Protection。

  1. 单击 主页 > 防病毒 HIPS > 配置防病毒和 HIPS > 配置 > Sophos Live Protection。
  2. 在 Sophos Live Protection 对话框中：
    • 要开启或关闭向 Sophos 发送文件数据，请勾选或取消勾选 启用 Live Protection 勾选框。

    • 要开启或关闭向 Sophos 发送文件样本，请勾选或取消勾选 自动发送文件样本给 Sophos 勾选框。

      只有在您已经选择了 启用 Live Protection 后，此选项才可用。

注意

当向 Sophos 寄送文件样本进行在线扫描时，总是将文件数据同样本一同寄送。

上一个题目： 关于 Sophos Live Protection
下一个题目： 查看 Sophos Live Protection 日志记录


查看 Sophos Live Protection 日志记录

为进行 Sophos 在线扫描而发送的文件数据，以及在扫描完成后更新的文件状态的信息，都记录在此计算机的扫描日志记录中。

如果 Sophos Live Protection 已启用，那么，日志记录会显示：

  • 数据发送给了 Sophos 的文件所在的路径。
  • 数据发送的时间。
  • 如果数据发送失败了，失败的原因（除非原因不明）。
  • 文件的当前状态（例如，“病毒/间谍软件”，如果该文件被确定为带有恶意代码）。

要查看扫描日志记录：

  • 在 主页 页面的 防病毒和 HIPS 下，单击 查看防病毒和 HIPS 日志。

    要了解有关 主页 页面的信息，请参见 关于主页。

您可以从日志记录页中，复制日志记录到剪贴板，也可以用电子邮件发送日志记录，或者，直接打印日志记录。

要在日志记录中查找特定的文本，单击 查找 并输入您想查找的文本内容。

上一个题目： 开启或关闭 Sophos Live Protection 选项
下一个题目： 关于 Sophos Web Protection


关于 Sophos Web Protection

Sophos Web Protection 能加强对网页中的安全隐患的防范。它有以下功能：

  • 实时 URL 筛选
  • 扫描下载的内容
  • 检查下载文件的信誉

实时 URL 筛选

实时 URL 筛选可以阻断对已知的带有恶意软件的网站的访问。此功能通过实时比对 Sophos 的感染网站在线数据库来实现。

当访问恶意网站被阻断时，此事件会被记录到扫描日志中。要了解有关查看扫描日志的信息，请参见 查看扫描日志。

内容扫描

内容扫描可以扫描从因特网（或内部网）下载的数据和文件，并预先检测恶意内容。此功能可以扫描来自所有网站的内容，包括那些并没有在感染网站在线数据库的列表中的网站的内容。

下载信誉

下载信誉按文件的时间、来源、普遍性、深度内容分析和其他特征进行计算。

注： 下载信誉仅在 Windows 7 及更高版本上得到支持。

默认情况下，下载低信誉或未知信誉的文件时将显示警报。我们建议您不要下载此类文件。如果您信任文件的来源和发布者，您可以选择下载该文件。您的操作和文件的 URL 将记录在扫描日志中。

注： 下载信誉是根据 SophosLabs 的云端数据库中的数据进行计算的，需要启用 Sophos Live Protection 才能执行查找和获得该数据。（默认情况下，Sophos Live Protection 处于启用状态。）

有关下载信誉的详细信息，请参阅知识库文章 121319。

Web 保护配置设置

默认情况下，Web 保护处于启用状态：会阻止对恶意网站的访问、扫描下载内容并检查下载文件的信誉。

有关 Web 保护设置及其更改方法的详细信息，请参阅配置 Sophos Web Protection。

支持的 Web 浏览器

网页防范功能支持以下的网页浏览器：

  • IE
  • Edge
  • Google Chrome
  • Firefox（除下载信誉外）
  • Safari（除下载信誉外）
  • Opera

通过不受支持的网页浏览器访问的网页内容不会被过滤，也不会被阻断。

上一个题目： 查看 Sophos Live Protection 日志记录
下一个题目： 配置 Sophos Web Protection


配置 Sophos Web Protection

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

要更改 Sophos Web Protection 的设置：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 网页保护。
  2. 要阻断或取消阻断对恶意网站的访问，请在阻断访问恶意网站旁边，选择开或关。此选项在默认情况下是启用的。
    要了解有关怎样批准已被归类为恶意网站的某个网站，请参见 批准使用网站。
  3. 要启用或禁用对下载数据和文件的扫描，请在内容扫描旁边，选择在读写扫描时、开或关。
    默认情况下，在读写文件时是选中的，下载扫描的禁用或启用是与读写扫描同步改变的。
  4. 要更改下载低信誉或未知信誉的文件时的操作，请在下载信誉下的操作旁边，选择提示用户（默认）或仅记录。
    • 如果您选择提示用户，每次下载低信誉文件时，将会显示警报告知您这种情况，并让您确定是阻止还是允许下载。我们建议您不要下载此类文件。如果您信任文件的来源和发布者，您可以选择下载该文件。对阻止或允许下载的选择，以及文件的 URL 将记录在扫描日志中。
    • 如果您选择只记录，将不会显示任何警报，下载将被允许并记录在扫描日志中。
  5. 要选择信誉扫描的严格程度，请在阈值旁边，选择推荐（默认）或严格。
    • 如果您选择推荐，每次下载低信誉或未知信誉的文件时，将显示警报并/或创建日志记录。
    • 如果您选择严格，每次下载低信誉、未知信誉或中等信誉的文件时，将显示警报并/或创建日志记录。

有关下载信誉的详细信息，请参阅知识库文章 121319。

要了解有关查看扫描日志的信息，请参见 查看扫描日志。

上一个题目： 关于 Sophos Web Protection
下一个题目： 批准广告软件和可能不想安装的应用程序


批准广告软件和可能不想安装的应用程序

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您想运行被 Sophos Anti-Virus 归类为可能不想安装的应用程序的某个广告软件或应用程序，您可以按照以下说明批准它。

要批准广告软件和可能不想安装的应用程序：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 批准。
  2. 在 广告软件/可能不想安装的应用程序 标签页中的 已知的广告软件/可能不想安装的应用程序 列表中，选择广告软件/可能不想安装的应用程序。
  3. 单击 添加。
广告软件或可能不想安装的应用程序会出现在 已批准的广告软件/可能不想安装的应用程序 列表中。
注： 您也可以在隔离区管理器中批准广告软件和可能不想安装的应用程序。要了解有关怎样做的信息，请参见 处置隔离区中的广告软件和可能不想安装的应用程序。
上一个题目： 配置 Sophos Web Protection
下一个题目： 阻断已批准的广告软件和可能不想安装的应用程序


阻断已批准的广告软件和可能不想安装的应用程序

要避免当前批准的广告软件和可能不想安装的在您的计算机上运行：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 批准。
  2. 在 广告软件/可能不想安装的应用程序 标签页中的 批准的广告软件/可能不想安装的应用程序 列表中，选择您想要阻断的广告软件/可能不想安装的应用程序。
  3. 单击 删除。
上一个题目： 批准广告软件和可能不想安装的应用程序
下一个题目： 批准可疑项目


批准可疑项目

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您想运行被 Sophos Anti-Virus 归类为可疑项目的项目，您可以按照以下说明预批准它。

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 批准。
  2. 单击已检测到的项目类型的标签页（例如，缓冲溢出）。
  3. 在 已知的 列表中，选择可疑项目。
  4. 单击 添加。
可疑项目会出现在 批准 列表中。
注： 您还可以在隔离管理器中批准可疑项目。要了解有关怎样做的信息，请参见以下主题：
  • 处置隔离区中的可疑文件
  • 处置隔离区中的可疑行为
上一个题目： 阻断已批准的广告软件和可能不想安装的应用程序
下一个题目： 预批准可疑项目


预批准可疑项目

如果您想运行被 Sophos Endpoint Security and Control 归类为可疑项目的项目，您可以预批准它。

要预批准某个可疑项目：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 批准。
  2. 单击已检测到的项目类型的标签页（例如，缓冲溢出）。
  3. 单击 新项目。
  4. 找到该可疑项目，然后双击它。
可疑项目会出现在 批准 列表中。
上一个题目： 批准可疑项目
下一个题目： 批准使用网站


批准使用网站

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您不想阻断已被 Sophos 归类为恶意网站的某个网站，那么，您可以将它添加到已批准的网站的列表中。批准某个网站，将会使该网站的 URL 避免 Sophos 扫描网站过滤服务的验证。

警告：
批准已被归类为恶意网站的网站，会使您处于安全隐患之中。因此，请在批准网站之前，确保访问该网站是安全的。

要批准使用网站：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 批准。
  2. 单击 网站 标签页。
  3. 单击 添加。
  4. 键入域名或 IP 地址。
网站会出现在 批准的网站 列表中。
上一个题目： 预批准可疑项目
下一个题目： 关于隔离区管理器


关于隔离区管理器

隔离区管理器使您能够处置，在运行扫描时发现的，并且没有自动清除的项目。隔离区中的每个项目，都是由于以下之一的某个原因，而被隔离的。

  • 在发现该项目的那个扫描类型的设置中，没有选择清除选项（清除, 删除, 移动）。
  • 在发现该项目的那个扫描类型的设置中，已经选择了清除选项，但是该选项不起作用。
  • 该项目受到多重感染，并且仍然含有其它的安全隐患。
  • 该安全隐患只是部分地被检测到，需要进行完整的计算机扫描，才能彻底检测该安全隐患。要了解具体怎样做，请参见 运行完整的计算机扫描。
  • 具有可疑行为的项目。
  • 受控程序项目。
注： 在读写扫描中检测到的，广告软件，可能不想安装的应用程序和多组件感染，会在隔离区管理器中列表显示。在读写扫描中，不能对广告软件，可能不想安装的应用程序和多组件感染进行自动清除。

清除选项不起作用，因为没有足够的访问权限。如果您拥有更大的权限，您可以使用隔离区管理器处置项目。

在扫描网页时检测到的安全隐患，不会在隔离区管理器中列出，因为所检测到的安全隐患并没有下载到您的计算机上。因此，不必采取任何操作。

上一个题目： 批准使用网站
下一个题目： 隔离区管理器的布局


隔离区管理器的布局

隔离区管理器中会列示在扫描中检测到的所有项目，并且使您能够处置这些项目。隔离区管理器 窗口的组成部分，显示如下：

单击 显示 列表，可以筛选显示的项目类型。
项目识别，以及 Sophos 网站对其分析的链接。
文件名和项目所在的路径。

如果该项目与某个 rootkit 相关联，它会显示为 隐藏。

如果有 更多信息 链接出现在文件名旁，这说明该项目是多组件感染。单击该链接，可以查看其它的感染组件的列表。如果某些组件是与某个 rootkit 相关联的，那么，在对话框中会指明这些组件已被隐藏。
您可以用于处置此项目的措施。

除非该项目是隐藏的，否则，有三种措施：清除，删除，以及 移动。

如果您单击其中某个措施，该措施会立即在该项目上执行，并会给与确认信息。隐藏文件只能被清除。
已检测到的项目的列表。

要对项目排序，请单击栏标之一。
单击 全选，可以在所有项目上执行同一个措施。

要取消勾选某个项目，请取消勾选 类型 栏目中的勾选框。
如果您已选择了所有的项目，但想要取消此选择，请单击 取消全选。

要选择某个项目，请单击 类型 栏目中的勾选框。
单击 从列表中清除，可以从列表中删除所选的项目，而不处置它们。

此操作不会从磁盘中删除该项目。
单击 执行措施，可以显示您能在所选的项目上执行的措施的列表。
上一个题目： 关于隔离区管理器
下一个题目： 处置隔离区中的病毒/间谍软件


处置隔离区中的病毒/间谍软件

注： 这里所称的 病毒 是指任何病毒，蠕虫，特洛伊木马，或者其他恶意软件。
  1. 在 主页 页面下的 防病毒和 HIPS，单击 管理隔离项目。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 显示 列表中，单击 病毒/间谍软件。

有关每个项目的信息都显示在此栏中。

名称 显示 Sophos Anti-Virus 检测到的项目名称。要了解更多关于该病毒／间谍软件的信息，单击该名称，然后 Sophos Anti-Virus 会将您连接到 Sophos 网站的病毒／间谍软件分析部分。

详情 显示项目的名称和路径。如果该项目与某个 rootkit 相关联，它会显示为“隐藏”。如果有 更多信息 链接出现在文件名旁，这说明该项目是多组件感染。单击该链接，可以查看其它的感染组件的列表。如果任一该组件的与某个 rootkit 相关联，对话框会表明某些组件被隐藏。

可用措施 显示您可以针对该项目所采取的措施。除非该项目是隐藏的，否则，有三种措施：清除，删除，移动。具体描述如下。如果您单击其中一个措施，该措施会在该项目上执行，并会给与确认信息。隐藏文件只能被清除。

处置感染项目

要处置病毒/间谍软件，请使用以下说明的按钮。

全选/取消全选

单击这两个按钮可以全选，或者取消全选所有的项目。这使您能够针对一组项目，同时施行相同的措施。要勾选或者取消勾选特定的项目，请勾选项目类型左边的勾选框。

从列表中清除

单击它，可以将所选的项目从列表中清除，如果您确信这些项目中不含有病毒/间谍软件。不过，这并不会从磁盘中删除该项目。

执行操作

单击它，可以显示您可以针对所选项目而执行的操作的列表。

  • 单击 清除，可以删除所选项目中的病毒或间谍软件。清除文档，并不会修复病毒已对文档造成的损害。
    注： 要从您的计算机中彻底清除某些涉及数个组件的病毒／间谍软件，或者，要清除隐藏的文件，您需要重新启动计算机。如果出现这种情况，会有选项出现，您可以选择立即重新启动计算机，或者稍后重新启动计算机。在计算机重新启动之后，会进行清除的最终步骤。
    注： 清除某些病毒时，会导致进行完整系统扫描，以清除所有病毒。这可能会耗费较长时间。当扫描完成时，可用的措施会更改为 清除。
  • 单击 删除 可以从您的计算机中删除所选项目。请谨慎使用此功能。
  • 单击 移至 可以将所选的项目移至其它文件夹。这些项目所移至的文件夹，是在设置清除时，所指定的那个文件夹。移走可执行文件，可以减少它们被运行的机会。请谨慎使用此功能。
警告：
有些时候，如果您删除或者移除了某个被感染的文件，您的计算机系统可能会工作不正常，因为无法找到该文件。还有，某个被感染的文件可能仅仅只是多重感染的一部分。在这种情况下，删除或移除某个特定的文件，并不能彻底清除计算机中的感染。出现这种情况时，请联系Sophos 技术支持寻求处置该项目的帮助。

要了解有关联系技术支持的信息，请参见 技术支持。

要配置您可以执行何种措施，请参见 配置用户使用隔离区管理器的权限。

上一个题目： 隔离区管理器的布局
下一个题目： 处置隔离区中的广告软件和可能不想安装的应用程序


处置隔离区中的广告软件和可能不想安装的应用程序

  1. 在 主页 页面下的 防病毒和 HIPS，单击 管理隔离项目。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 显示 列表中，单击 广告软件或可能不想安装的应用程序。

有关每个项目的信息都显示在此栏中。

名称 显示 Sophos Anti-Virus 检测到的项目名称。要了解更多关于该广告软件或可能不想安装的应用程序的信息，单击该名称，然后 Sophos Anti-Virus 会将您连接到 Sophos 网站的广告软件或可能不想安装的应用程序分析部分。

详情 显示广告软件或可能不想安装的应用程序的子类型。如果该项目与某个 rootkit 相关联，它会显示为“隐藏”。如果有 更多信息 链接出现在子类型旁，这说明该项目是多组件的广告软件／可能不想安装的应用程序。单击该链接，可以查看其它的广告软件或可能不想安装的应用程序组件的列表。如果任一该组件的与某个 rootkit 相关联，对话框会表明某些组件被隐藏。

可用措施 显示您可以针对该项目所采取的措施。有两种措施可以采用：批准和清除，说明如下。如果您单击其中一个措施，该措施会在该项目上执行，并会给与确认信息。

处置广告软件和可能不想安装的应用程序

要处置广告软件和可能不想安装的应用程序，请使用以下说明的按钮。

全选/取消全选

单击这两个按钮可以全选，或者取消全选所有的项目。这使您能够针对一组项目，同时施行相同的措施。要勾选或者取消勾选特定的项目，请勾选项目类型左边的勾选框。

从列表中清除

如果您信任该项目，单击该按钮，可以将所选择的项目从列表中清除。不过，这并不会从磁盘中删除该项目。

执行操作

单击它，可以显示您可以针对所选项目而执行的操作的列表。

  • 单击 批准 以批准所选项目在计算机上运行，如果您信任这些项目。这会将项目添加到已批准的广告软件和可能不想安装的应用程序的列表中，这样 Sophos Anti-Virus 将不会阻止该项目在您的计算机上运行。
  • 单击 清除 以从所有用户的计算机上删除所选项目的所有已知组件。要从计算机中清除广告软件和可能不想安装的应用程序，用户必须同时是 Windows Administrators 和 SophosAdministrator 组的成员。
注： 要从您的计算机中彻底清除某些涉及数个组件的广告软件和可能不想安装的应用程序，或者，要清除隐藏的文件，您需要重新启动计算机。如果出现这种情况，会有选项出现，您可以选择立即重新启动计算机，或者稍后重新启动计算机。在计算机重新启动之后，会进行清除的最终步骤。

要配置您可以执行何种措施，请参见 配置用户使用隔离区管理器的权限。

要查看已知的和已批准的广告软件和可能不想安装的应用程序，请单击 配置批准。

上一个题目： 处置隔离区中的病毒/间谍软件
下一个题目： 处置隔离区中的可疑文件


处置隔离区中的可疑文件

可疑文件 是指具有通常，但不只是，在病毒中发现的各种特征的文件。

  1. 在 主页 页面下的 防病毒和 HIPS，单击 管理隔离项目。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 显示 列表中，单击 显示文件。

有关每个项目的信息都显示在此栏中。

名称 显示 Sophos Anti-Virus 检测到的项目名称。要了解更多关于该可疑文件的信息，单击该名称，然后 Sophos Anti-Virus 会将您连接到 Sophos 网站的可疑文件分析部分。

详情 显示项目的名称和路径。如果该项目与某个 rootkit 相关联，它会显示为“隐藏”。

可用措施 显示您可以针对该项目所采取的措施。除非该项目是隐藏的，否则，有三种措施：清除，删除，移动。具体描述如下。如果您单击其中一个措施，该措施会在该项目上执行，并会给与确认信息。隐藏文件只能被批准。

处置可疑文件

要处置可疑文件，请使用以下说明的按钮。

全选/取消全选

单击这两个按钮可以全选，或者取消全选所有的项目。这使您能够针对一组项目，同时施行相同的措施。要勾选或者取消勾选特定的项目，请勾选项目类型左边的勾选框。

从列表中清除

如果您信任该项目，单击该按钮，可以将所选择的项目从列表中清除。不过，这并不会从磁盘中删除该项目。

执行操作

单击它，可以显示您可以针对所选项目而执行的操作的列表。

  • 单击 批准 以批准所选项目在计算机上运行，如果您信任这些项目。这会将项目添加到已批准的可疑项目的列表中，这样 Sophos Anti-Virus 将不会阻止对这些文件的访问。
  • 单击 删除 可以从您的计算机中删除所选项目。请谨慎使用此功能。
  • 单击 移至 可以将所选的项目移至其它文件夹。这些项目所移至的文件夹，是在设置清除时，所指定的那个文件夹。移走可执行文件，可以减少它们被运行的机会。请谨慎使用此功能。
警告：
有些时候，如果您删除或者移除了某个被感染的文件，您的计算机系统可能会工作不正常，因为无法找到该文件。

要配置您可以执行何种措施，请参见 配置用户使用隔离区管理器的权限。

要查看已批准的可疑文件，请单击 配置批准。

上一个题目： 处置隔离区中的广告软件和可能不想安装的应用程序
下一个题目： 处置隔离区中的可疑行为


处置隔离区中的可疑行为

可疑行为 是看起来带有恶意的程序活动。

  1. 在 主页 页面下的 防病毒和 HIPS，单击 管理隔离项目。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 显示 列表中，单击 可疑行为。

有关每个项目的信息都显示在此栏中。

名称 显示 Sophos Anti-Virus 检测到的项目名称。要了解更多关于该可疑行为的信息，单击该名称，然后 Sophos Anti-Virus 会将您连接到 Sophos 网站的可疑行为分析部分。

详情 显示项目的名称和路径。

可用措施 显示您可以针对该项目所采取的措施。如果您已启用了阻断可疑行为，可采用的措施为：批准，说明如下。如果您单击该措施，该措施会在该项目上执行，并会给与确认信息。

处置可疑行为

要处置可疑行为，请使用以下说明的按钮。

全选/取消全选

单击这两个按钮可以全选，或者取消全选所有的项目。这使您能够针对一组项目，同时施行相同的措施。要勾选或者取消勾选特定的项目，请勾选项目类型左边的勾选框。

从列表中清除

如果您信任该项目，单击该按钮，可以将所选择的项目从列表中清除。不过，这并不会从磁盘中删除该项目。

执行操作

单击它，可以显示您可以针对所选项目而执行的操作的列表。

  • 单击 批准 以批准所选项目在计算机上运行，如果您信任这些项目。这会将项目添加到已批准的可疑项目的列表中，这样 Sophos Anti-Virus 将不会阻止该行为。

要配置您可以执行何种措施，请参见 配置用户使用隔离区管理器的权限。

要查看已批准的可疑行为，请单击 配置批准。

上一个题目： 处置隔离区中的可疑文件
下一个题目： 处置隔离区中的受控程序


处置隔离区中的受控程序

受控程序，是公司的安全策略不允许在您的计算机上运行的应用程序。

  1. 在 主页 页面下的 防病毒和 HIPS，单击 管理隔离项目。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 显示 列表中，单击 受控程序。

有关每个项目的信息都显示在此栏中。

名称 显示 Sophos Anti-Virus 检测到的项目名称。要了解更多关于该受控程序的信息，单击该名称，然后 Sophos Anti-Virus 会将您连接到 Sophos 网站的受控程序分析部分。

详情 显示受控程序的子类型。如果 更多信息 的链接出现在子类型旁，单击它可以查看受控程序的其它组件的列表。

可用措施 显示您可以针对该项目所采取的措施。不过，除了以下说明的，从列表中清空该项目之外，没有措施可以用于受控程序。

处置受控程序

要处置受控程序，请使用以下说明的按钮。

全选/取消全选

单击这两个按钮可以全选，或者取消全选所有的项目。这使您能够针对一组项目，同时施行相同的措施。要勾选或者取消勾选特定的项目，请勾选项目类型左边的勾选框。

从列表中清除

单击该按钮，可以从列表中删除所选择的项目。不过，这并不会从磁盘中删除该项目。受控程序必须通过中央控制台批准之后，才能使用。

上一个题目： 处置隔离区中的可疑行为
下一个题目： 关于清除


关于清除

清除可以通过以下方式，消除您计算机上的安全隐患：

  • 删除软盘引导区，文档，程序，以及任何被扫描的项目中的病毒/间谍软件。
  • 移动或删除该可疑文件
  • 删除广告软件或可能不想安装的应用程序

当 Sophos Anti-Virus 自动清除带有病毒/间谍软件的项目时，会删除纯粹是恶意软件的项目，并且会清除其它项目中感染的病毒。这些病毒感染被清除之后的文件，应被视为已发生不可逆的损坏，因为病毒扫描程序并不知道文件在感染病毒之前所包含的内容。

清除文档

清除文档，并不会修复病毒/间谍软件已对文档造成的损害。请参见 获取清除信息 以了解怎样从 Sophos 网站中查看有关病毒/间谍软件的破坏作用的详情。

清除程序

清除程序，应该只是作为一种临时的措施。您应该接着就用原盘或者无病毒的备份，重新替换被清除过的程序。

清除网页安全隐患

对于扫描网页时检测到的安全隐患，则无需清除，因为所检测到的安全隐患并没有下载到您的计算机上。

注： 清理威胁可能无法撤销威胁对计算机做出的所有更改。例如，如果威胁更改了设定值，清理进程可能不知道原始设置。您可能需要验证计算机的配置。清除感染文档，并不会修复病毒已对文档所作的任何改变。
上一个题目： 处置隔离区中的受控程序
下一个题目： 获取清除信息


获取清除信息

当您的计算机中发现了安全隐患时，查看 Sophos 网站中的安全隐患分析，获取该安全隐患的相关信息，及其清除建议，是非常重要的。您可以从以下位置进行此任务：

  • 桌面消息警报（读写扫描）
  • 扫描进程对话框（自定义扫描和单击右键扫描）
  • 隔离区管理器（所有扫描类型）

通过桌面消息警报获取信息

如果您的计算机中启用了读写扫描，Sophos Anti-Virus 会在发现安全隐患时，出现桌面消息警报。

在消息框中，单击您想要获取相关信息的安全隐患的名称。Sophos Anti-Virus 会将您连接到 Sophos 网站的安全隐患分析部分。

通过扫描进程对话框获取信息

对于自定义扫描和单击右键扫描，请在扫描进程对话框（或者，在扫描结束后，出现的扫描摘要对话框）中的日志记录里，单击您想要了解的安全隐患的名称。

Sophos Anti-Virus 会将您连接到 Sophos 网站的安全隐患分析部分。

通过隔离区管理器获取信息

  1. 在 主页 页面下的 防病毒和 HIPS，单击 管理隔离项目。要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 名称 栏中，单击您想要了解的安全隐患的名称。

Sophos Anti-Virus 会将您连接到 Sophos 网站的安全隐患分析部分。

上一个题目： 关于清除
下一个题目： 配置防病毒桌面消息发送


配置防病毒桌面消息发送

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

要使 Sophos Anti-Virus 在发现安全隐患时，显示桌面消息，请按照以下说明做。这仅仅应用于读写扫描。

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 警报 > 消息发送。
  2. 在 消息发送 对话框中，单击 桌面消息发送 标签。请按以下说明设置选项。

    启用桌面消息发送

    选择该项，启用 Sophos Anti-Virus 在发现安全隐患时，显示桌面消息。

    要发送的消息

    选择您想要 Sophos Anti-Virus 发送桌面消息的事件。

    用户定义的消息

    在此文本框中，您可以输入一段消息文字，它会被添加到标准的消息文字之后。

    注： Windows 8 和以后版本中不会显示用户定义消息。
上一个题目： 获取清除信息
下一个题目： 配置防病毒电子邮件警报


配置防病毒电子邮件警报

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

要启用 Sophos Anti-Virus 在发现安全隐患，或出现错误时，发送电子邮件警报，请按以下说明做。这应用于读写扫描，即时扫描和单击右键扫描。

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 警报 > 消息发送。
  2. 在 消息发送 对话框中，单击 电子邮件警报 标签。请按以下说明设置选项。

    启用电子邮件警报发送

    选择该项，以启用 Sophos Anti-Virus 发送电子邮件警报。

    要发送的消息

    选择您想要 Sophos Anti-Virus 发送电子邮件警报的事件。扫描错误 中包括 Sophos Anti-Virus 被拒绝访问试图扫描的项目的情况。

    Sophos Anti-Virus 不会就扫描网页时检测到的安全隐患发出电子邮件警报，因为所检测到的安全隐患并没有下载到您的计算机上。因此，不必采取任何操作。

    收件人

    单击 添加 或 删除 分别添加或删除电子邮件警报的寄往地址。单击 编辑 更改您所添加的电子邮件地址。

    配置 SMTP

    单击该项，更改 SMTP 服务器和电子邮件警报语言的设置。（请参见以下表格。）

配置 SMTP 设置
SMTP 服务器 | 在文本框中，输入主机名或 SMTP 服务器的 IP 地址。单击 测试 以测试到 SMTP 服务器的连接。（这不会发送测试的电子邮件。）
SMTP “寄件人”地址 | 在文本框中，输入退回邮件和未送达报告将要寄往的地址。
SMTP “回复”地址 | 由于电子邮件警报是从无人照管的邮箱发出的，您可以在文本框中，输入电子邮件警报的回复地址。
语言 | 单击下拉箭头，然后选择寄送电子邮件警报所使用的语言。
上一个题目： 配置防病毒桌面消息发送
下一个题目： 配置防病毒 SNMP 消息发送


配置防病毒 SNMP 消息发送

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

要启用 Sophos Anti-Virus 在发现安全隐患，或出现错误时，发送 SNMP 消息，请按以下说明做。这应用于读写扫描，即时扫描和单击右键扫描。

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 警报 > 消息发送。
  2. 在 消息发送 对话框中，单击 SNMP 消息发送 标签。请按以下说明设置选项。

    启用 SNMP 消息发送

    选择该项，以启用 Sophos Anti-Virus 发送 SNMP 消息。

    要发送的消息

    选择您想要 Sophos Anti-Virus 发送 SNMP 消息的事件。扫描错误 中包括 Sophos Anti-Virus 被拒绝访问试图扫描的项目的情况。

    Sophos Anti-Virus 不会就扫描网页时检测到的安全隐患发送 SNMP 消息，因为所检测到的安全隐患并没有下载到您的计算机上。因此，不必采取任何操作。

    SNMP 陷阱目标

    在文本框中，输入寄送警报的计算机的 IP 地址或名称。

    SNMP 团体名

    在文本框中，输入 SNMP 团体名。

    测试

    单击该按钮，发送 SNMP 测试消息到您所指定的 SNMP 陷阱目标。

上一个题目： 配置防病毒电子邮件警报
下一个题目： 配置防病毒事件日志记录


配置防病毒事件日志记录

要使 Sophos Anti-Virus 在发现安全隐患，或出现错误时，能够将警报添加到 Windows 的事件日志中，请按照以下说明做。这应用于读写扫描，即时扫描和单击右键扫描。

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 警报 > 消息发送。
  2. 在 消息发送 对话框中，单击 事件日志 标签。请按以下说明设置选项。

    启用事件日志记录

    选择该项，启用 Sophos Anti-Virus 向 Windows 事件日志寄送消息。

    要发送的消息

    选择您想要 Sophos Anti-Virus 发送消息的事件。扫描错误 中包括 Sophos Anti-Virus 被拒绝访问试图扫描的项目的情况。

    Sophos Anti-Virus 不会就扫描网页时检测到的安全隐患发送消息，因为所检测到的安全隐患并没有下载到您的计算机上。因此，不必采取任何操作。

上一个题目： 配置防病毒 SNMP 消息发送
下一个题目： 配置扫描日志


配置扫描日志

此计算机的扫描日志存储在以下路径中：

Windows Vista、Windows 7、Windows 8、Windows 8.1、Windows 10、Windows Server 2008、Windows Server 2008 R2、Windows Server 2012、Windows Server 2012 R2： | C:\ProgramData\Sophos\Sophos Anti-Virus\logs\SAV.txt
其它 Windows 操作平台 | C:\Documents and Settings\All Users\Application Data\Sophos\Sophos Anti-Virus\logs\SAV.txt
  1. 单击 主页 > 防病毒和 HIPS > 查看防病毒和 HIPS 日志 > 配置日志。
  2. 在 配置本计算机的日志记录 对话框中，按照以下说明设置选项。

    日志记录级别

    要停止所有日志记录，请单击 无记录。要记录摘要信息，出错消息等，单击 普通记录。要记录详细信息，包括被扫描的文件，扫描的主要阶段的情况等，单击 详尽记录。

    日志记录归档

    要启用每月归档日志文件，选择 启用归档。归档文件与日志文件存储在同一个文件夹中。选择 归档文件数 设定最旧的文件被删除前，所能存储的归档文件数。选择 压缩日志记录 以减少日志文件的大小。

上一个题目： 配置防病毒事件日志记录
下一个题目： 查看扫描日志


查看扫描日志

在 主页 页面的 防病毒和 HIPS 下，单击 查看防病毒和 HIPS 日志。
要了解有关 主页 页面的信息，请参见 关于主页。
您可以从日志记录页中，复制日志记录到剪贴板，也可以用电子邮件发送日志记录，或者，直接打印日志记录。

要在日志记录中查找特定的文本，单击 查找 并输入您想查找的文本内容。

上一个题目： 配置扫描日志
下一个题目： 关于扫描受控程序


关于扫描受控程序

受控程序，是公司的安全策略不允许在您的计算机上运行的应用程序。

扫描受控程序，属于读写扫描的一部分，可以通过管理控制台来启用或禁用，成为某应用程序控制策略的一部分。

要了解有关读写扫描的信息，请参见 关于读写扫描和即时扫描。

上一个题目： 查看扫描日志
下一个题目： 禁用扫描受控应用程序


禁用扫描受控应用程序

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果启用了扫描受控程序，则可能会使您无法卸载某些应用程序。如果您是 SophosAdministrator 组的成员，您可以暂时禁用此计算机上的受控程序。

要禁用扫描受控应用程序：

  1. 在 配置 菜单中，单击 应用程序控制。
  2. 取消勾选 启用读写扫描 勾选框。
上一个题目： 关于扫描受控程序
下一个题目： 关于此计算机上的设备控制


关于此计算机上的设备控制

如果在此计算机上没有使用管理控制台管理 Sophos Endpoint Security and Control，那么，不会包括设备控制功能。

设备控制可以通过管理控制台启用或禁用。如果设备控制是启用的，它可能会使您在维护或排疑解难时，不能连接设备。如果出现这种情况，您可以暂时禁用此计算机上的设备控制。要了解信息，请参见 暂时禁用设备控制。

上一个题目： 禁用扫描受控应用程序
下一个题目： 受控制的是什么类型的设备？


受控制的是什么类型的设备？

设备控制阻断或运行在计算机上的以下类型的设备：存储设备、网络设备、短距设备 (short range) 以及媒体设备。

存储

  • 可移动存储设备（如：USB 闪存，PC 读卡器，以及外置硬盘）
  • 光学介质驱动器（CD-ROM/DVD/Blu-ray 驱动器）
  • 软盘驱动器
  • 安全的移动存储设备（例如，硬件加密的 USB 闪存）

网络

  • 调制解调器
  • 无线连接（Wi-Fi 接口，802.11 标准）

此计算机上的设备控制策略可能处于 阻断桥接 模式，它会在计算机（通常是通过以太网连接的方式）连接到物理网络时，禁用无线或调制解调网络适配器。一旦计算机与物理网络断开了连接，无线或调制解调网络适配器会顺畅地重新启用。

短距 (short range)

  • 蓝牙接口
  • 红外接口（(IrDA 红外接口）

媒体

  • MTP/PTP

    这包括手机、平板电脑、数码相机、媒体播放器和其他使用媒体传输协议 (MTP) 或图片传输协议 (PTP) 连接到电脑的设备。

上一个题目： 关于此计算机上的设备控制
下一个题目： 暂时禁用设备控制


暂时禁用设备控制

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您是 SophosAdministrator 组的成员， 而想要连接某设备到该计算机，进行维护工作，或障碍排除工作（例如：从某 CD 上安装软件），您可以暂时禁用设备控制。

要禁用此计算机上的设备控制：

  1. 在 配置 菜单中，单击 设备控制。
  2. 清除勾选 启用 Sophos Device Control 勾选框。
上一个题目： 受控制的是什么类型的设备？
下一个题目： 配置数据控制日志


配置数据控制日志

  1. 在 配置 菜单中，单击 设备控制。
  2. 在 日志记录级别 下，选择以下选项之一：
    • 单击 无 以停止日志记录。
    • 单击 普通 以日志记录摘要信息，出错消息，等等。
    • 单击 详尽 以提供比通常多得多的活动的信息。仅在需要用它来处理出现的问题时，才使用这一设置，因为，日志记录的内容会迅速增加。
  3. 在 日志归档 下，按照屏幕上显示的说明做。
上一个题目： 暂时禁用设备控制
下一个题目： 查看设备控制日志


查看设备控制日志

在 主页 页面的 设备控制 下，单击 查看设备控制日志。
要了解有关 主页 页面的信息，请参见 关于主页。
您可以从日志记录页中，复制日志记录到剪贴板，也可以用电子邮件发送日志记录，或者，直接打印日志记录。

要在日志记录中查找特定的文本，单击 查找 并输入您想查找的文本内容。

上一个题目： 配置数据控制日志
下一个题目： 关于此计算机上的数据控制


关于此计算机上的数据控制

如果在此计算机上没有使用管理控制台管理 Sophos Endpoint Security and Control，那么，不会包括数据控制功能。

可以通过管理控制台发布的策略可以启用或禁用数据控制。不过，如果您是 SophosAdministrator 组的成员，您可以为了进行维护或排错，而暂时禁用计算机上的数据控制：要了解信息，请参见 暂时禁用数据控制。

上一个题目： 查看设备控制日志
下一个题目： 暂时禁用数据控制


暂时禁用数据控制

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您是 SophosAdministrator 组的成员，您可以为了进行维护或排错，而暂时禁用计算机上的数据控制：

  1. 在 配置 菜单中，单击 数据控制。
  2. 清除勾选 启用 Sophos Data Control 勾选框。
上一个题目： 关于此计算机上的数据控制
下一个题目： 怎样添加文件到存储设备？


怎样添加文件到存储设备？

如果在计算上启用了数据控制，那么，数据控制策略可能会阻断使用以下方法将文件添加到受控制的存储设备的尝试：

  • 从程序中保存数据
  • 使用 DOS 复制命令
  • 使用资源管理器在设备中创建新文件

如果看到桌面警报对此发出的警告，您应该将文件保存到硬盘或网络驱动器上，然后，通过“资源管理器”将它复制到存储设备中。

上一个题目： 暂时禁用数据控制
下一个题目： 配置数据控制日志


配置数据控制日志

  1. 在 配置 菜单中，单击 数据控制。
  2. 在 日志记录级别 下，选择以下选项之一：
    • 单击 无 以停止日志记录。
    • 单击 普通 以日志记录摘要信息，出错消息，等等。
    • 单击 详尽 以提供比通常多得多的活动的信息。仅在您需要测试新的数据控制规则时使用此设置，因为，日志记录的内容会迅速增加。
  3. 在 日志归档 下，按照屏幕上显示的说明做。
上一个题目： 怎样添加文件到存储设备？
下一个题目： 查看数据控制日志


查看数据控制日志

在 主页 页面的 数据控制 下，单击 查看数据控制日志。
要了解有关 主页 页面的信息，请参见 关于主页。
您可以从日志记录页中，复制日志记录到剪贴板，也可以用电子邮件发送日志记录，或者，直接打印日志记录。

要在日志记录中查找特定的文本，单击 查找 并输入您想查找的文本内容。

上一个题目： 配置数据控制日志
下一个题目： 关于此计算机上的网页控制


关于此计算机上的网页控制

Sophos Web Control 为在您的公司网络中，网络外，以及漫游的终结点计算机提供保护，控制，和报告。

注： 此功能没有包括在所有的用户授权使用许可协议中。如果您想要使用它，您可能需要更改您的用户授权使用许可协议。

如果在此计算机上没有使用管理控制台管理 Sophos Endpoint Security and Control，那么，不会包括网页控制功能。

通过管理控制台发布的策略可以启用或禁用网页控制。不过，如果您是 SophosAdministrator 组的成员，您可以暂时禁用计算机上的网页控制。要了解有关怎样做的信息，请参见 暂时禁用网页控制。

上一个题目： 查看数据控制日志
下一个题目： 暂时禁用网页控制


暂时禁用网页控制

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您是 SophosAdministrator 组的成员，您可以为了进行维护或排错，而暂时禁用网页控制，以后在重新启用它。

要禁用此计算机上的网页控制：

  1. 在 配置 菜单中，单击 网页控制。
  2. 取消勾选 启用网页控制 勾选框。
上一个题目： 关于此计算机上的网页控制
下一个题目： 开始使用防火墙


开始使用防火墙

当防火墙首次安装后，您可能需要配置它。您是否需要配置，取决于它是怎样被安装的。有两种类型的安装：

  • 安装在联网计算机上，并从管理控制台管理。
  • 安装在独立使用的计算机上，并从该计算机管理。

从管理控制台管理的防火墙

如果防火墙已安装并从管理控制台管理，那么，它会根据策略设置的规则来允许或阻断应用程序和通讯流。

除非策略将防火墙放入交互模式（见下）中，不会有任何消息提示您，您不需要对防火墙进行任何配置。

从计算机管理的防火墙

如果防火墙是从计算机上管理的，那么，建议您先创建规则允许常用的应用程序和服务（如：网络浏览器和电子邮件客户端）的网络访问。

要了解更多有关创建规则的信息，请参见 关于配置防火墙。

防火墙也将从交互模式（见下）中开始。保留防火墙在交互模式中一段时间，以便能够允许或阻断您使用的其它应用程序和服务。

一旦您配置了防火墙，它将识别您常用的应用程序，这时，建议您更换到某个非交互模式中去。

要了解信息，请参见 更改到非交互模式。

什么是交互模式？

在交互模式中，防火墙会询问您允许或阻断任何没有应用规则的应用程序和通讯流。

要了解有关怎样处理来自防火墙的消息的信息，请参见 关于交互模式。

在 Windows 8 和之后版本的计算机上，交互式模式不可用。您必须添加指定的策略规则来允许或阻断应用程序。或者，您可以在管理控制台中使用事件查看器，以交互方式管理应用程序。

上一个题目： 暂时禁用网页控制
下一个题目： 关于配置防火墙


关于配置防火墙

您可以用各种方式配置防火墙，然后启用它。如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

一些常用的功能列示如下：

  • 启用交互模式
  • 筛选 ICMP 消息
  • 允许 LAN 上所有的通讯流
  • 允许 FTP 下载
  • 创建全局规则
  • 允许应用程序
  • 允许应用程序启动隐藏进程
  • 允许应用程序使用原始套接字
  • 使用检查和鉴定应用程序
上一个题目： 开始使用防火墙
下一个题目： 临时禁用防火墙


临时禁用防火墙

如果您是 SophosAdministrator 组的成员，您可以为了进行维护或排错，而暂时禁用防火墙，以后在重新启用它。

即使您重新启动计算机，Sophos Endpoint Security and Control 还是会将您在此所作的设置保留。如果您禁用防火墙，您的计算机将处于非保护状态，直到您重新启用防火墙。

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，勾选主路径或副路径旁的 允许所有的通讯流 勾选框。
上一个题目： 关于配置防火墙
下一个题目： 允许电子邮件


允许电子邮件

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。
  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 单击 添加，找到该电子邮件应用程序，然后，双击它。
该电子邮件应用程序作为受信任的程序而被允许。

受信任的应用程序会被允许完全的，无条件的网络访问，包括访问因特网。为了更安全，您可以应用 Sophos 提供的预置规则：

  1. 在允许的应用程序列表中，单击电子邮件应用程序。
  2. 单击 自定义>从预置中添加规则> 电子邮件客户端。
上一个题目： 临时禁用防火墙
下一个题目： 允许使用网页浏览器


允许使用网页浏览器

注： 如果您允许使用网页浏览器，您同时也允许 FTP 访问。
  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 单击 添加，找到该网页浏览器，然后，双击它。
该网页浏览器作为受信任的程序而被允许。

受信任的应用程序会被允许完全的，无条件的网络访问，包括访问因特网。为了更安全，您可以应用 Sophos 提供的预置规则：

  1. 在允许的应用程序列表中，单击网页浏览器应用程序。
  2. 单击 自定义 >从预置中添加规则 >浏览器。
上一个题目： 允许电子邮件
下一个题目： 允许 FTP 下载


允许 FTP 下载

注： 如果您已经允许使用可以访问 FTP 服务器的网页浏览器，那么，您不需要再次允许 FTP 下载。
  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 单击 添加，找到该 FTP 应用程序，然后，双击它。
该 FTP 应用程序作为受信任的程序而被允许。

受信任的应用程序会被允许完全的，无条件的网络访问，包括访问因特网。为了更安全，您可以应用 Sophos 提供的预置规则：

  1. 在允许的应用程序列表中，单击 FTP 应用程序。
  2. 单击 自定义 > 从预置中添加规则 > FTP 客户端。
上一个题目： 允许使用网页浏览器
下一个题目： 允许 LAN 上所有的通讯流


允许 LAN 上所有的通讯流

要允许 LAN（局域网）上的计算机之间的所有通讯流：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 LAN 标签页中，按照以下说明做：
    • 单击 检测 LAN 以检测您的计算机所在的 LAN，并将其添加到网络地址列表中。
    • 单击 添加。在 选择地址 对话框中，选择 地址格式，输入域名或 IP 地址，然后，单击 添加。
      注： 如果您勾选了 本地网络（自动检测），那么，您不需要进行任何输入。此选项在 Windows 8 及以后版本中不可用。要了解关于本地网络检测的信息，请参见 关于本地网络检测。
  4. 单击 确定，以关闭 选择地址 对话框。
  5. 在 LAN 设置 列表中，为网络勾选 信任的 勾选框。

注意

  • 如果您允许 LAN（局域网）上的计算机之间的所有通讯流，您同时也就允许 LAN 上的文件和打印机共享。
上一个题目： 允许 FTP 下载
下一个题目： 允许在 LAN 上共享所有的文件和打印机


允许在 LAN 上共享所有的文件和打印机

注： 如果您已经 LAN（局域网）上的计算机之间的所有通讯流，那么，您不必再进行允许文件和打印机共享的操作。

要允许在 LAN 上共享所有的文件和打印机：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 LAN 标签页中，按照以下说明做：
    • 单击 检测 LAN 以检测您的计算机所在的 LAN，并将其添加到网络地址列表中。
    • 单击 添加。在 选择地址 对话框中，选择 地址格式，输入域名或 IP 地址，然后，单击 添加。
      注： 如果您勾选了 本地网络（自动检测），那么，您不需要进行任何输入。此选项在 Windows 8 及以后版本中不可用。要了解关于本地网络检测的信息，请参见 关于本地网络检测。
  4. 单击 确定，以关闭 选择地址 对话框。
  5. 在 LAN 设置 列表中，为 LAN 勾选 NetBIOS 勾选框，以允许 LAN 上的文件和打印机共享。
要了解有关怎样阻断或允许在 LAN 设置 列表中没有列示的其它的局域网 (LAN) 中的 文件和打印机共享，请参见以下主题：
  • 阻断不想要的文件和打印机共享
  • 允许灵活控制文件和打印机共享

要了解怎样允许 LAN 上的所有通讯流，请参见 允许 LAN 上所有的通讯流。

上一个题目： 允许 LAN 上所有的通讯流
下一个题目： 允许灵活控制文件和打印机共享


允许灵活控制文件和打印机共享

如果您想要更灵活地控制网络中的文件和打印机共享（例如：单项 NetBIOS 通讯流），您可以这样做：

  1. 允许文件和打印机在 LAN 设置 列表中没有列示的其它的局域网 (LAN) 中共享。这将允许按照防火墙的规则来处理这些局域网中的 NetBIOS 通讯流。
  2. 创建“高优先级通用规则”，允许与具有适当的 NetBIOS 端口和协议的主机往来通讯。建议您不是通过使用默认规则，而是通过创建通用规则，明确地阻断所有不想要的文件和打印机共享通讯流。

要允许文件和打印机在 LAN 设置 列表中没有列示的其它的局域网 (LAN) 中共享：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 LAN 标签页中，取消勾选 阻断其它网络的文件和打印机共享 勾选框。
上一个题目： 允许在 LAN 上共享所有的文件和打印机
下一个题目： 阻断不想要的文件和打印机共享


阻断不想要的文件和打印机共享

要阻断没有在 LAN 标签页中的 LAN 设置 列表中指定的局域网上的文件和打印机共享：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 LAN 标签页中，勾选 阻断其它网络的文件和打印机共享 勾选框。
上一个题目： 允许灵活控制文件和打印机共享
下一个题目： 允许应用程序


允许应用程序

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 单击 添加，找到该应用程序，然后，双击它。
该程序将作为受信任的程序而被允许。

受信任的应用程序会被允许完全的，无条件的网络访问，包括访问因特网。为了更安全，您可以应用一个或多个应用程序规则到特定的条件中，应用程序须满足该条件才能运行。

  • 要创建应用程序规则
  • 应用预置的应用程序规则
上一个题目： 阻断不想要的文件和打印机共享
下一个题目： 阻断应用程序


阻断应用程序

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 如果应用程序没有在列表中，请单击 添加，找到该应用程序，然后，双击它。
  5. 在列表中选择应用程序，然后，单击 阻断。
上一个题目： 允许应用程序
下一个题目： 阻断 IPv6


阻断 IPv6

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 基于操作系统：
    • 在 Windows 7 或更早的操作系统中，在 常规 标签页中的 阻断 下，选择 阻断 IPv6 包。
    • 在 Windows 8 或更新版本中，在全局规则选项卡中，选择阻止所有 IPv6 数据流。
上一个题目： 阻断应用程序
下一个题目： 开启或关闭使用校验和


开启或关闭使用校验和

如果您启用使用校验和验证应用程序，那么，您将信任或阻断通过校验和来自动识别的应用程序（您也可以手动添加校验和）。如果应用程序不匹配校验和，那么，它会被阻断。

如果禁用此选项，应用程序通过它们的文件名来被识别。

要开启或关闭使用校验和验证应用程序：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 基于操作系统：
    • 在 Windows 7 及更早的操作系统中，在 阻断 下，取消勾选 使用校验和验证应用程序 复选框。
    • 在 Windows 8 或以后版本中，单击应用程序选项卡，并取消勾选使用校验和验证应用程序复选框。
    要开启使用校验和验证应用程序，请勾选该复选框。
上一个题目： 阻断 IPv6
下一个题目： 开启或关闭阻断已修改的进程


开启或关闭阻断已修改的进程

注： 该选项在 Windows 8 及以后版本中不可用，因为它通过 Sophos Anti-Virus HIPS 技术自动进行处理。

恶意软件可能会通过修改所运行的受信任的程序在内存中的进程，而越过防火墙，然后，通过已修改的进程代表恶意软件自身访问网络。

您可以配置防火墙检测并阻断在内存中已修改的进程。

要开启或关闭阻断已修改的进程：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 常规 标签页的 阻断 部分中，取消勾选 如果内存被其它应用程序修改，则阻断进程。(仅限32位操作系统) 勾选框，关闭阻断已修改的进程。
    要开启阻断已修改的进程，请勾选该勾选框。
如果防火墙检测到内存中的某个进程已被修改，它会添加规则，以防止已修改的进程访问网络。

注意

  • 我们不建议您永久地关闭阻断已修改的进程。您应该只在需要时，才关闭它。
  • 在 64 位版的 Windows 上不支持阻断已修改的进程。
  • 只会阻断已修改的进程。不会阻断修改的程序访问网络。
上一个题目： 开启或关闭使用校验和
下一个题目： 筛选 ICMP 消息


筛选 ICMP 消息

Internet 控制消息协议 (ICMP) 消息允许联网计算机共享出错和状态信息。您可以允许或阻断特定类型的流入或流出的 ICMP 消息。

您应该只在熟悉网络协议的情况下，才筛选 ICMP 消息。要了解对 ICMP 消息类型的说明，请参见 ICMP 消息类型说明。

要筛选 ICMP 消息：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 ICMP 标签页。界面会因操作系统的不同而不同：
    • 在 Windows 7 或更早的操作系统中，勾选 流入 或 流出 勾选框，以允许流入或流出特定类型的消息。
    • 在 Windows 8 和以后版本中，ICMP 消息是按照类型分为各个部分的。您可以从下拉列表中选择通用的设置，或者，可以单击 详情 查看或编辑这些设置。
上一个题目： 开启或关闭阻断已修改的进程
下一个题目： ICMP 消息类型说明


ICMP 消息类型说明

网络错误报告

目标不可访问，回显回复
当路由器不能送达某 IP 数据报时，会发出此消息。数据报是在 TCP/IP 网络中传输的数据单元，或数据包。
源抑制
如果主机或路由器接收到数据的速度太快，而无法应付时，会发出此消息。此消息是请求源降低数据报的传输率。
超时
如果数据报在路由器中传输时，达到了路由器的最大限制，路由器会发出此消息。
参数问题
如果在传输数据报的过程中，出现问题而无法继续时，路由器会发出此消息。此问题的一个潜在根源是无效的数据报报头。

网络故障排除

回显请求，回显回复
用于测试目标是否能够访问，及其状态。主机会发送一个回显请求，并监听回应的回显回复。最常见的做法是使用 ping 命令。

IPv4 网络地址和路由配置

重定向
如果某路由器收到本应该发送给别的路由器的数据报，会发出此消息。此消息包含源在今后应该定向发送数据报的地址。它被用来优化网络通讯流的路由。
路由器公告，路由器请求
允许主机知晓路由器的存在状况。路由器通过 路由器公告 消息，定期播报它们的 IP 地址。主机也会通过播报 路由器请求 消息来请求某个路由器的地址，对此，路由器会使用 路由器公告 来回复
时间戳请求，时间戳回复
用于同步化主机之间的时钟，以及估计传输时间。
信息请求，信息回复
已过时这些消息早先被主机用来决定它们的内部网络地址，但现在被认为已过时，不应该再使用。
地址掩码请求，地址掩码回复
用于查找子网掩码（即：定义网络的地址位）。主机向路由器发送 地址掩码请求，并为此接收 地址掩码回复。
上一个题目： 筛选 ICMP 消息
下一个题目： 恢复防火墙默认设置


恢复防火墙默认设置

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 管理配置 下，单击 恢复默认值。
上一个题目： ICMP 消息类型说明
下一个题目： 关于交互式模式


关于交互式模式

注： 交互模式在 Windows 8 及以后版本中不可用。您必须添加指定的策略规则来允许或阻断应用程序。或者，您可以在管理控制台中使用事件查看器，以交互方式管理应用程序。

在交互式模式中，每当未知的应用程序或服务请求网络访问时，防火墙会显示一个学习对话框。学习对话框会询问您是否此次允许通讯流，或阻断通讯流，或是否为该类型的通讯流创建规则。

在交互式模式中，您将看到以下类型的学习对话框：

  • 隐藏进程学习对话框
  • 协议学习对话框
  • 应用程序学习对话框
  • 原始套接字学习对话框
  • 校验和学习对话框
上一个题目： 恢复防火墙默认设置
下一个题目： 启用交互模式


启用交互模式

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 常规 标签页的 工作模式 下，单击 交互式。
上一个题目： 关于交互式模式
下一个题目： 更改到非交互模式


更改到非交互模式

有两种非交互模式：
  • 默认允许
  • 默认阻断

在非交互模式中，防火墙使用您的规则自动处理网络通讯流。没有匹配任何规则的网络通讯流，要么全部被允许（如果它是流出通讯流），要么全部被阻断。

要更改到非交互模式：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 常规 标签的 工作模式 下，选择 默认允许 或 默认阻断。
上一个题目： 启用交互模式
下一个题目： 隐藏进程学习对话框


隐藏进程学习对话框

隐藏进程是应用程序启动另外的应用程序，为它执行某些网络访问的进程。恶意的应用程序有时可以通过以下技巧避开防火墙：它启动某个受信任的应用程序去访问网络，而不是自己去访问。

隐藏进程学习对话框，显示有关隐藏进程和启动它的应用程序的信息。

  • 启用隐藏进程学习对话框
上一个题目： 更改到非交互模式
下一个题目： 启用隐藏进程学习对话框


启用隐藏进程学习对话框

如果您使用交互模式，当检测到新的启动时，防火墙会显示学习对话框。

如果您使用交互模式而此选项没有被勾选，新的启动会被阻断启动隐藏线程。

要启用隐藏进程学习对话框：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 进程 标签。
  4. 请勾选 就新的启动给出警告 勾选框。
上一个题目： 隐藏进程学习对话框
下一个题目： 协议学习对话框


协议学习对话框

如果防火墙检测到系统的网络活动无法与特定的应用程序关连，那么，它会提示创建协议规则。

协议学习对话框，显示有关未识别的网络活动（即：协议和远程地址）的信息。.

上一个题目： 启用隐藏进程学习对话框
下一个题目： 应用程序学习对话框


应用程序学习对话框

如果防火墙检测到某应用程序试图以没有遵照规则的方式访问网络时，它会提示创建应用程序规则。

应用程序学习对话框，显示有关未识别的网络活动（即：远程服务和远程地址）的信息。

上一个题目： 协议学习对话框
下一个题目： 原始套接字学习对话框


原始套接字学习对话框

低级插口允许进程控制数据在网络中传输的各个环节，这可以被用于恶意目的。

如果防火墙检测到低级插口试图以没有遵照规则的方式访问网络时，它会提示创建低级插口规则。

低级插口学习对话框，显示有关低级插口的信息。

  • 启用低级插口学习对话框
上一个题目： 应用程序学习对话框
下一个题目： 启用低级插口学习对话框


启用低级插口学习对话框

如果您使用交互模式，当检测到低级插口试图以没有遵照规则的方式访问网络时，防火墙会显示学习对话框。

如果您使用交互模式而此选项没有被勾选，低级插口会被阻断访问网络。

要启用低级插口学习对话框：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 进程 标签。
  4. 请勾选 就使用低级插口给出警告 勾选框。
上一个题目： 原始套接字学习对话框
下一个题目： 检查和学习对话框


检查和学习对话框

如果防火墙检测到新的或修改了的应用程序，它会显示检查和学习对话框。

仅当使用校验和来鉴定应用程序时，才会显示校验和学习对话框。详情参见开启或关闭使用检查和。

如果您想要允许该应用程序访问网络，您必须必须将它的检查和（独一无二的识别符）添加到识被的检查和列表中。

选择以下选项之一：

  • 将此应用程序的检查和添加到现有的检查和中 允许多个版本的此应用程序。
  • 将此应用程序的检查和替换任何现有的检查和 用请求访问的此应用程序的检查和，替换此应用程序的所有的现有的检查和，这样，便只允许此应用程序的最新版本进行访问。
  • 阻断此应用程序直到重新启动它 此时阻断此应用程序。
上一个题目： 启用低级插口学习对话框
下一个题目： 关于防火墙配置文件


关于防火墙配置文件

Sophos Client Firewall 使您能够将防火墙的常规配置和规则作为配置文件导出。您可以使用此功能，完成以下任务：

  • 备份和恢复您全部的防火墙配置。
  • 保存常规配置并将它安装到多个计算机上。
  • 在一台计算机上为应用程序创建规则，并将这些规则导出，供具有同样应用程序设置的其它计算机使用。
  • 使用管理控制台合并在数台不同的计算机上设置的配置，以创建对网络中所有计算机都有效的策略。

上一个题目： 检查和学习对话框
下一个题目： 导出防火墙配置文件


导出防火墙配置文件

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 单击 导出。
  3. 提供您的配置文件的名称和路径，然后，单击 保存。
上一个题目： 关于防火墙配置文件
下一个题目： 导入防火墙配置文件


导入防火墙配置文件

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 单击 导入。
  3. 选择配置文件，并单击 打开。
  4. 按照屏幕上的说明做。
上一个题目： 导出防火墙配置文件
下一个题目： 关于防火墙规则


关于防火墙规则

全局规则

全局规则应用于所有的网络通讯和应用程序，即使这些应用程序具有应用程序规则。

应用程序规则

针对一个应用程序您可以具有一个或多个规则。您可以既可以使用 Sophos 创建的预设的规则，也可以创建子定义的规则，更好地控制应用程序的访问。

要了解默认全局和应用程序规则的相关信息，请参见 http://www.sophos.com/en-us/support/knowledgebase/57757.aspx。

上一个题目： 导入防火墙配置文件
下一个题目： 关于规则应用的次序


关于规则应用的次序

对于要使用低级插口的连接，只会检查全局规则。

对于不使用低级插口的连接，根据连接的网络地址是否在 LAN 标签页里的列表中，会检查不同的规则。

如果是在 LAN 标签页中列示的网络地址，那么，会检查以下规则：

  • 如果该地址已标记为 信任的，那么，该连接中的所有通讯流都会被允许，不会做进一步的检查。
  • 如果该地址已标记为 NetBIOS，那么，会允许在连接中满足以下标准的任何文件和打印机共享：
    连接 | 端口 | 范围
    TCP | 远程 | 137-139 或 445
    TCP | 本地 | 137-139 或 445
    UDP | 远程 | 137 或 138
    UDP | 本地 | 137 或 138

如果网络地址没有列示在 LAN 标签页中，那么，会按照以下次序检查其它的防火墙规则：

  1. 任何在 LAN 标签页中不被允许的 NetBIOS 通讯流，会按照 阻断其它网络的文件和打印机共享 勾选框的设置情况来处理。
    • 如果该勾选框是勾选的，那么，该通讯流会被阻断。
    • 如果该勾选框是取消勾选的，那么，该通讯流会按照现存的规则处理。
  2. 最优先的通用规则，会按照列示它们的次序，依次检查。
  3. 如果尚未有任何规则应用到连接中，那么，会检查应用程序规则。
  4. 如果连接仍然未被处理，那么，会按照列示它们的次序，应用通常优先的全局规则。
  5. 如果没有找到用于处理连接的规则，那么：
    • 在 默认允许 模式中，通讯流会被允许（如果它是流出通讯流）。
    • 在 默认阻断 模式中，通讯流会被阻断。
    • 在 交互 模式中，用户会被要求决定如何处理。此模式在 Windows 8 及以后版本中不可用。
    注： 如果您尚未更改工作模式，那么，防火墙将会处于 默认阻断 模式。
上一个题目： 关于防火墙规则
下一个题目： 关于本地网络检测


关于本地网络检测

注： 此选项在 Windows 8 及以后版本中不可用。

您可以将计算机的本地网络指派给防火墙规则。

当它启动时，防火墙会确定在计算机的本地网络，然后，监控本地网络中发生的任何更改。如果检测到任何更改，防火墙会为新的本地网络地址更新本地网络规则。

警告：
我们强烈建议您在配置可能应用于“办公室之外”的路径中的本地网络规则时，谨慎从事。要了解更多信息，请参见 创建副路径配置。
上一个题目： 关于规则应用的次序
下一个题目： 创建全局规则


创建全局规则

重要： 我们建议您只有在熟悉网络协议的情况下，才创建全局规则。

全局规则应用于所有的网络通讯，以及尚未有任何规则的应用程序。

要创建全局规则：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 全局规则 标签。
  4. 单击 添加。
  5. 在 规则名称 下，输入规则的名称。
    该规则名称必须不同于列表中的任何规则的名称。两个全局规则不能具有相同的名称。
  6. 在 Windows 8 或以后版本中，在协议下，选择要使用的协议。
  7. 要在任何应用程序规则或普通优先的全局规则之前应用规则，请勾选超过应用程序规则的优先级勾选框。
    要了解有关规则应用的先后次序的信息，请参见 关于规则应用的次序。
  8. 在 请选择规则将要处理的事件 下，选择为了应用规则，连接必须满足的条件。
  9. 在请选择规则响应措施中，选择允许它或阻断它。
  10. 按照以下的说明之一做：
    • 要在初始连接存在的同时，允许其它连接从同一个远程地址进行流入和流出，那么，请勾选 并发连接。此选项仅适用于 TCP 规则。
    • 要灵活地允许来自基于初始连接的远程计算机的回答，请选择 状态检查。此选项仅适用于 UDP 规则。
    注： 在 Windows 8 及以后版本中，这些选项不会显示，因为始终会使用状态检测，且不支持并行连接。
  11. 在 规则描述 下，单击一个下划线值。
上一个题目： 关于本地网络检测
下一个题目： 编辑全局规则


编辑全局规则

重要： 我们建议您只有在熟悉网络协议的情况下，才更改全局规则。

要编辑全局规则：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 全局规则 标签。
  4. 在 规则 列表中，选择您想要编辑的规则。
  5. 单击 编辑。
    要了解更多有关全局规则设置的信息，请参见 创建全局规则。
上一个题目： 创建全局规则
下一个题目： 复制全局规则


复制全局规则

要复制全局规则，并将它添加到规则列表中：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 全局规则 标签。
  4. 在 规则 列表中，选择您想要复制的规则。
  5. 单击 复制。
上一个题目： 编辑全局规则
下一个题目： 删除全局规则


删除全局规则

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 全局规则 标签。
  4. 在 规则 列表中，选择您想要删除的规则。
  5. 单击 删除。
上一个题目： 复制全局规则
下一个题目： 更改全局规则应用的次序


更改全局规则应用的次序

全局规则是按照它们在规则列表中从上自下出现的次序来应用的。

要更改全局规则应用的次序

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 全局规则 标签。
  4. 在 规则 列表中，单击您想要在列表中移动的规则。
  5. 单击 上移 或 下移。
上一个题目： 删除全局规则
下一个题目： 应用预置的应用程序规则


应用预置的应用程序规则

Sophos 创建了一组预置的应用程序规则。要添加预置的规则到某应用程序的规则列表中：
  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 在列表中选择应用程序，然后，单击 Custom 旁的箭头。
  5. 指向 从预置中添加规则，然后，单击预置。
上一个题目： 更改全局规则应用的次序
下一个题目： 要创建应用程序规则


要创建应用程序规则

要创建允许精确地控制应用程序访问的自定义的规则：
  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 在列表中选择应用程序，然后，单击 自定义。
    您还可以双击列表中的应用程序。
  5. 在 应用程序规则 对话框中，单击 添加。
  6. 在 规则名称 下，输入规则的名称。
    该规则名称必须不同于列表中的任何规则的名称。两个应用程序规则，并能具有同样的名称，但是两个应用程序可以各有一个具有同样名称的规则。
  7. 在 Windows 8 或以后版本中，在协议下，选择要使用的协议。
  8. 在 请选择规则将要处理的事件 下，选择为了应用规则，连接必须满足的条件。
  9. 在请选择规则响应措施中，选择允许它或阻断它。
  10. 按照以下的说明之一做：
    • 要在初始连接存在的同时，允许其它连接从同一个远程地址进行流入和流出，那么，请勾选 并发连接。此选项仅适用于 TCP 规则。
    • 要灵活地允许来自基于初始连接的远程计算机的回答，请选择 状态检查。此选项仅适用于 UDP 规则。
    注： 在 Windows 8 及以后版本中，这些选项不会显示，因为始终会使用状态检测，且不支持并行连接。
  11. 在 规则描述 下，单击一个下划线值。
上一个题目： 应用预置的应用程序规则
下一个题目： 编辑应用程序规则


编辑应用程序规则

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 在列表中选择应用程序，然后，单击 自定义。
    您还可以双击列表中的应用程序。
  5. 在 应用程序规则 对话框，单击 编辑。
  6. 在 规则名称 下，输入规则的名称。
    该规则名称必须不同于列表中的任何规则的名称。两个应用程序规则，并能具有同样的名称，但是两个应用程序可以各有一个具有同样名称的规则。
  7. 在 Windows 8 或以后版本中，在协议下，选择要使用的协议。
  8. 在 请选择规则将要处理的事件 下，选择为了应用规则，连接必须满足的条件。
  9. 在请选择规则响应措施中，选择允许它或阻断它。
  10. 按照以下的说明之一做：
    • 要在初始连接存在的同时，允许其它连接从同一个远程地址进行流入和流出，那么，请勾选 并发连接。此选项仅适用于 TCP 规则。
    • 要灵活地允许来自基于初始连接的远程计算机的回答，请选择 状态检查。此选项仅适用于 UDP 规则。
    注： 在 Windows 8 及以后版本中，这些选项不会显示，因为始终会使用状态检测，且不支持并行连接。
  11. 在 规则描述 下，单击一个下划线值。
上一个题目： 要创建应用程序规则
下一个题目： 复制应用程序规则


复制应用程序规则

要复制应用程序规则，并将它添加到规则列表中：
  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 在列表中选择应用程序，然后，单击 自定义。
    您还可以双击列表中的应用程序。
  5. 在应用程序规则对话框内，选择您希望复制的规则，单击复制。
上一个题目： 编辑应用程序规则
下一个题目： 删除应用程序规则


删除应用程序规则

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 在列表中选择应用程序，然后，单击 自定义。
  5. 在 应用程序规则 对话中，选择您想要计划的报告，并单击 计划。
上一个题目： 复制应用程序规则
下一个题目： 更改应用程序规则应用的次序


更改应用程序规则应用的次序

应用程序规则是按照它们在规则列表中从上自下出现的次序来应用的。

要更改应用程序规则应用的次序：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 应用程序 标签。
  4. 在列表中选择应用程序，然后，单击 自定义。
    您还可以双击列表中的应用程序。
  5. 在 规则 列表中，单击您想要在列表中移动的规则。
  6. 单击 上移 或 下移。
上一个题目： 删除应用程序规则
下一个题目： 允许应用程序启动隐藏进程


允许应用程序启动隐藏进程

注： 该选项在 Windows 8 及以后版本中不可用，因为它通过 Sophos Anti-Virus HIPS 技术自动进行处理。

应用程序有时会启动另外的隐藏进程，为它执行某些网络访问。

恶意的应用程序可以通过以下技巧避开防火墙：它启动某个受信任的应用程序去访问网络，而不是自己去访问。

在某个隐藏进程首次被检测到时，防火墙会向管理控制台发送警报（如果此功能已启用）。

要允许应用程序启动隐藏进程：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 进程 标签。
  4. 在上方区域，单击 添加 按钮。
  5. 找到该应用程序，然后，双击它。
如果您使用交互模式，当检测到新的启动时，防火墙会显示学习对话框。
  • 启用交互模式
  • 启用隐藏进程学习对话框
上一个题目： 更改应用程序规则应用的次序
下一个题目： 允许应用程序使用原始套接字


允许应用程序使用原始套接字

注： 此选项在 Windows 8 及以后版本中不可用。防火墙以与普通套接字相同的方式对待原始套接字。

某些应用程序可以通过原始套接字访问网络，这允许它们控制数据在网络中传输的各个环节。

恶意的应用程序可以通过虚假的 IP 地址利用原始套接字，或发送蓄意损坏的消息。

在某个低级插口首次被检测到时，防火墙会向管理控制台发送警报（如果此功能已启用）。

要允许应用程序通过原始套接字访问网络：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 进程 标签。
  4. 在下方区域，单击 添加 按钮。
  5. 找到该应用程序，然后，双击它。
如果您使用交互模式，当检测到低级插口时，防火墙会显示学习对话框。
  • 启用交互模式
  • 启用低级插口学习对话框
上一个题目： 允许应用程序启动隐藏进程
下一个题目： 使用检查和鉴定应用程序


使用检查和鉴定应用程序

每个版本的应用程序都具有独一无二的检查和。防火墙可以使用此检查和决定是否允许某个应用程序。

依照默认值，防火墙会检查每个运行的应用程序的检查和。如果检查和是未知的或已更改，防火墙会阻断它，或者（在交互模式中）询问用户应该怎样做。

在某个新的或已修改的应用程序首次被检测到时，防火墙会向管理控制台发送警报（如果此功能已启用）。

要添加检查和到允许的检查和列表中：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 单击 检查和 标签。
  4. 单击 添加。
  5. 找到该应用程序，然后，双击它。
如果您使用交互模式，当检测到新的或修改过的应用程序时，防火墙会显示学习对话框。
  • 启用交互模式
  • 启用隐藏进程学习对话框
上一个题目： 允许应用程序使用原始套接字
下一个题目： 关于位置感知


关于位置感知

位置感知是 Sophos Client Firewall 中的功能，可以根据当前网络适配器的位置，将防火墙配置指派给您的计算机上的各个网络适配器。

最常使用此功能的情形是，您使用公司的笔记型电脑在家中工作。您同时使用两个网络连接：

  • 您通过 VPN 客户端和 虚拟网络适配器，连接到办公网络，以便工作。

  • 您通过网线和 物理网络适配器，连接到您的ISP，以便个人使用。

在这种情形下，您需要将办公配置应用到虚拟的办公连接中，以及（通常限制更严格的）非办公配置应用到非办公的 ISP 连接中。

注： 非办公配置将要求足够的规则，以允许建立“虚拟的”办公连接。
上一个题目： 使用检查和鉴定应用程序
下一个题目： 设置位置感知


设置位置感知

  1. 定义您的主路径的网关 MAC 地址或域名的列表。一般地，它们是您的办公网络。

  2. 创建将用于您的主路径的防火墙配置。一般地，这些配置的限制相对较少。

  3. 创建副路径的防火墙配置。一般地，这些配置的限制相对较多。
  4. 选择要应用的配置。

根据您使用的检测方法，防火墙会获得您的各个计算机网络适配器的 DNS 或网关地址，然后，将这些地址与您的地址列表进行匹配。

  • 如果您的列表中的任何地址与任何网络适配器的地址匹配，那么，该适配器会被指派针对 主路径 的配置。
  • 如果您的列表没有任何地址与任何网络适配器的地址匹配，那么，该适配器会被指派针对 副路径 的策略。

活动的路径会在 Sophos Endpoint Security and Control 窗口中的 状态 窗格板中出现。如果两种配置都被应用了，那么，会出现 Active = Both。

重要： 当以下两个条件同时满足时，副路径的配置将从 交互 模式转到 默认阻断 模式：
  • 主路径和副路径都处于活动状态。
  • 主路径配置不是交互模式。
上一个题目： 关于位置感知
下一个题目： 定义主路径


定义主路径

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 单击 路径检测 标签页。
  3. 在 检测方法 下，单击您想要用来定义主路径的方法旁的 配置：
    选项 | 描述
    通过 DNS 识别路径 | 您创建对应主路径的域名和预期 IP 地址的列表。
    通过 网关 MAC 地址识别路径 | 您创建对应主路径的网关 MAC 地址的列表。
  4. 按照屏幕上的说明做。
上一个题目： 设置位置感知
下一个题目： 创建副路径配置


创建副路径配置

当它检测到您没有连接到您的主路径时，防火墙会使用您的副路径配置。
  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 勾选 为副路径添加配置 勾选框。

现在可以设置您的副路径的配置。要了解怎样做的信息，请参见 关于配置防火墙 以及 配置防火墙 部分中的其它主题。

警告：
如果此计算机是笔记型电脑，并且用于办公场所之外，那么，它可能会连接未知的本地网络。如果发生这种情况，那么，将本地网络作为地址的副路径配置中的防火墙规则，可能会意想不到地允许未知的通讯流。因此，我们强烈建议在将本地网络规则作为副路径配置的一部分时，谨慎从事。
上一个题目： 定义主路径
下一个题目： 选择要应用的配置


选择要应用的配置

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 常规 标签页的 应用的路径 下，单击以下选项之一：
    选项 | 描述
    为检测到的路径应用配置 | 防火墙会根据位置感知的检测设置（按照 设置位置感知 中的说明） 将主路径或副路径的配置应用到各个网络连接中。
    应用主路径配置 | 防火墙会将主路径配置应用到所有的网络连接中。
    应用副路径配置 | 防火墙会将副路径配置应用到所有的网络连接中。
上一个题目： 创建副路径配置
下一个题目： 关于防火墙报告发送


关于防火墙报告发送

依照默认值，防火墙会向管理控制台报告状态更改，事件，以及错误。

防火墙状态更改

防火墙将以下更改视为状态更改：

  • 更改工作模式
  • 更改软件版本
  • 更改防火墙是否允许所有通讯流的配置
  • 更改防火墙是否遵照策略

如果您工作在交互式模式中，您的防火墙配置可能会有意地与通过管理控制台应用的策略不同。在这种情况下，当您更改某些防火墙配置时，您可以选择不向管理控制台发送“策略不一致”的警报。

要了解更多信息，请参见 关闭或打开报告本地更改。

防火墙事件

事件 是指您的计算机上的未知的应用程序试图通过网络连接与另一台计算机通讯。

您可以阻止防火墙向管理控制台报告事件。

要了解更多信息，请参见 关闭报告未知的网络通讯流。

上一个题目： 选择要应用的配置
下一个题目： 关闭或打开报告本地更改


关闭或打开报告本地更改

注： 此选项在 Windows 8 及以后版本中不可用。

如果您的防火墙配置与策略不同，您可以 关闭报告本地更改。

关闭报告本地更改，可以使防火墙停止向管理控制台发送，有关更改了全局策略，应用程序，进程，或检查和的“策略不同”的警报。您想要这样做的原因可能是，例如，当您使用交互模式时，有些设置可能会被使用学习对话框而更改。

如果此计算机上的防火墙配置，应该与策略一致，那么，您应该 打开报告本地更改。

要关闭报告本地更改：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 常规 标签页中的 报告发送 下，取消勾选 如果对通用规则，应用程序，进程，或检查和进行了本地更改，那么，在管理控制台显示相关的警报。 勾选框，将报告本地更改关闭。
    要打开报告本地更改，请勾选该勾选框。
上一个题目： 关于防火墙报告发送
下一个题目： 关闭报告未知的网络通讯流


关闭报告未知的网络通讯流

您可以使防火墙不向管理控制台报告未知的网络通讯流。防火墙将没有规则可依照的通讯流，视为未知的通讯流。

要使防火墙不向管理控制台报告未知的网络通讯流：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 规则 标签页中的 阻断，勾选 使用检查和鉴定应用程序 勾选框。
  4. 在 报告发送 下，取消勾选 向管理控制台报告未知的应用程序和通讯流 勾选框。
上一个题目： 关闭或打开报告本地更改
下一个题目： 关闭报告防火墙错误


关闭报告防火墙错误

重要： 我们不建议您永久性地关闭报告防火墙错误。您应该只在需要时，才关闭报告。

要防火墙不向管理控制台报告错误：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 常规 标签页中的 报告发送 下，取消勾选 向管理控制台报告出错 勾选框。
上一个题目： 关闭报告未知的网络通讯流
下一个题目： 配置桌面消息发送


配置桌面消息发送

您可以控制防火墙显示的桌面消息。

在交互模式中不会显示未知的应用程序和通讯流的通知，因为，同样的信息会显示在学习对话框中。

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 配置 下，单击您想要配置的路径旁的 配置。
  3. 在 常规 标签页中的 桌面消息发送 下，按照以下说明做：
    • 要显示针对防火墙警告和错误的通知，请勾选 显示警告和错误 勾选框。
    • 要显示针对未知的应用程序和通讯流的通知，请勾选 显示未知的应用程序和通讯流 勾选框。
上一个题目： 关闭报告防火墙错误
下一个题目： 关于防火墙日志查看器


关于防火墙日志查看器

Sophos Client Firewall 日志查看器使您能够查看，过滤，以及保存以下详情：

  • 所有的连接
  • 被允许或阻断的连接
  • 防火墙事件
  • 系统日志
上一个题目： 配置桌面消息发送
下一个题目： 打开防火墙日志查看器


打开防火墙日志查看器

在 主页 页面的 防火墙 下，单击 查看防火墙日志。
要了解有关 主页 页面的信息，请参见 关于主页。
上一个题目： 关于防火墙日志查看器
下一个题目： 配置防火墙日志记录


配置防火墙日志记录

要管理防火墙的事件日志数据库的容量和内容：

  1. 在 主页 页面中的 防火墙 下，单击 配置防火墙。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 单击 日志文件 标签。
  3. 要管理防火墙的事件日志数据库的容量和内容，选择以下选项之一：
    • 要允许数据库没有限制地扩大，请单击 保留所有记录。
    • 要清空旧的日志记录，请单击 删除旧的记录，然后，配置 日志清除设置。
  4. 在 日志清除设置 下，选择以下的一个或多个选项：
    • 勾选 删除 勾选框，然后，在 ...天之后的记录 文本框中输入或选择数字。
    • 勾选 保留 勾选框，然后，在...条以下的记录 文本框中输入或选择数字。
    • 勾选 保持 勾选框，然后，在...MB 以下的大小 文本框中输入或选择数字。
上一个题目： 打开防火墙日志查看器
下一个题目： 更改防火墙日志查看器的外观


更改防火墙日志查看器的外观

  1. 在 主页 页面的 防火墙 下，单击 查看防火墙日志。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 查看 菜单中，单击 布局。
  3. 在 自定义视图 对话框中，选择要隐藏或显示的项目。
    • 控制台树 会出现在左手边的窗格板中。
    • 工具栏 会显示在防火墙日志查看器的顶端。
    • 描述栏 会显示在右手边的窗格板的数据的上方。
    • 状态栏 会出现在防火墙日志查看器的底端。
上一个题目： 配置防火墙日志记录
下一个题目： 自定义数据格式


自定义数据格式

您可以更改用来在防火墙日志中显示以下数据项目的格式：
  • 显示端口为数字或名称，例如：HTTP 或 80。
  • 显示应用程序为图标，文件路径，或图标和文件路径。
  • 指定用于显示数据传输速度的单位的大小，例如：KB 或 MB。
  • 隐藏或显示分隔线。

要自定义数据格式：

  1. 在 主页 页面的 防火墙 下，单击 查看防火墙日志。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 查看 菜单中，单击 自定义。
  3. 选择您想要的选项。
上一个题目： 更改防火墙日志查看器的外观
下一个题目： 隐藏或显示防火墙日志查看器中的栏目


隐藏或显示防火墙日志查看器中的栏目

  1. 在 主页 页面的 防火墙 下，单击 查看防火墙日志。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在以详情窗格板显示栏目的控制台树中，单击某项目。
  3. 在 查看 菜单中，选择 添加/删除栏目。
    您也可以右击任何栏目的栏标。
  4. 在 栏目 对话框中，按照以下说明之一做：
    • 要隐藏某个栏目，请取消勾选它的勾选框。
    • 要显示某个栏目，请勾选它的勾选框。
上一个题目： 自定义数据格式
下一个题目： 重排防火墙日志查看器中的栏目


重排防火墙日志查看器中的栏目

  1. 在 主页 页面的 防火墙 下，单击 查看防火墙日志。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在以详情窗格板显示栏目的控制台树中，单击某项目。
  3. 在 查看 菜单中，选择 添加/删除栏目。
    您也可以右击任何栏目的栏标。
  4. 在 栏目 对话框中，单击栏目名称，然后，单击 上移 或 下移 以更改栏目的位置。

注意

  • 您还可以使用鼠标左右拖曳栏目，在详情窗格板中重排栏目。在您拖曳栏目时，栏目栏标之间的高亮显示，表明了栏目的新位置。
  • 您可以使用鼠标拖曳栏标，调整栏目的尺寸。
上一个题目： 隐藏或显示防火墙日志查看器中的栏目
下一个题目： 在防火墙日志中筛选记录


在防火墙日志中筛选记录

您可以创建筛选器分类防火墙日志记录。

要筛选防火墙日志记录：

  1. 在 主页 页面的 防火墙 下，单击 查看防火墙日志。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在控制台树中，选择某个日志。
  3. 在 操作 菜单，单击 添加筛选。
  4. 请按照筛选向导中的操作指导做。
筛选器会出现在控制台树中您想要进行筛选的日志的节点下方。
上一个题目： 重排防火墙日志查看器中的栏目
下一个题目： 从防火墙日志中导出全部记录


从防火墙日志中导出全部记录

要从防火墙日志中将全部记录导出到文本或 CSV 文件中：

  1. 在 主页 页面的 防火墙 下，单击 查看防火墙日志。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在控制台树中，选择某个日志。
  3. 请右击记录列表，然后，单击 导出全部记录。
  4. 在 文件名 文本框中，输入文件的名称。
  5. 在 保存类型 列表中，单击您想要保存的文件类型。
上一个题目： 在防火墙日志中筛选记录
下一个题目： 导出从防火墙日志中选择的记录


导出从防火墙日志中选择的记录

要从防火墙日志中将所选的记录导出到文本或 CSV 文件中：

  1. 在 主页 页面的 防火墙 下，单击 查看防火墙日志。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在控制台树中，选择某个日志。
  3. 选择您想要导出的记录。
    如果记录更新迅速，请在 查看 菜单中，取消勾选 自动刷新 勾选框。
  4. 在 措施 菜单中，单击 导出所选记录。
  5. 在 文件名 文本框中，输入文件的名称。
  6. 在 保存类型 列表中，单击您想要保存的文件类型。
上一个题目： 从防火墙日志中导出全部记录
下一个题目： 立即更新


立即更新

依照默认值，如果您总是连接到公司网络中的，Sophos AutoUpdate 会每 10 分钟进行一次更新，或者，如果您总是连接到因特网络中的，则会每 60 分钟进行一次更新。

如果您是通过拨号连接因特网的，那么，Sophos AutoUpdate 会在您连接到因特网或您的网络中时，进行更新，并且，随后每 60 分钟进行一次更新。

要即时更新：

请右击 Sophos Endpoint Security and Control 系统托盘图标，然后，单击 立即更新。
上一个题目： 导出从防火墙日志中选择的记录
下一个题目： 计划更新


计划更新

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

您可以指定 Sophos Anti-Virus 进行的更新时间或频率。

  1. 在 配置 菜单中，单击 更新。
  2. 单击 计划 标签。
  3. 选择 启用自动更新，然后，输入 Sophos AutoUpdate 将进行更新的频率（以分钟计）。
    如果是从公司网络中下载更新文件，那么，依照默认值，每隔 10 分钟更新一次。
    如果是通过因特网从 Sophos 服务器下载更新文件，那么，Sophos AutoUpdate 的更新频率不能低于每 60 分钟进行一次。
上一个题目： 立即更新
下一个题目： 设置更新源


设置更新源

如果您想要 Sophos AutoUpdate 能够进行自动更新，您就必须为 Sophos Anti-Virus 指定下载更新文件的地方。

  1. 在 配置 菜单中，单击 更新。
  2. 单击 主路径 标签。
  3. 在 地址 列表中，更新服务器的输入 UNC 路径或网页地址。

    要通过因特网从 Sophos 直接下载更新文件，请在 地址 列表中选择 Sophos。

  4. 在 用户名 文本框中，请输入将要用来访问更新服务器的帐户的 用户名。
    如果“用户名”需要指明域，才算合格有效，请使用 域\用户名。
  5. 在 密码 文本框中，请输入将要用来访问更新服务器的帐户的密码。
上一个题目： 计划更新
下一个题目： 设置备用更新源


设置备用更新源

您可以设置一个备用更新源。如果 Sophos AutoUpdate 无法从常规更新源进行更新，它会尝试从备用更新源进行更新。

  1. 在 配置 菜单中，单击 更新。
  2. 单击 副路径 标签。
  3. 在 地址 列表中，更新服务器的输入 UNC 路径或网页地址。

    要通过因特网从 Sophos 直接下载更新文件，请在 地址 列表中选择 Sophos。

  4. 在 用户名 文本框中，请输入将要用来访问更新服务器的帐户的 用户名。
    如果“用户名”需要指明域，才算合格有效，请使用 域\用户名。
  5. 在 密码 文本框中，请输入将要用来访问更新服务器的帐户的密码。
上一个题目： 设置更新源
下一个题目： 通过代理服务器更新


通过代理服务器更新

如果 Sophos AutoUpdate 是通过因特网来进行更新的，您就必须输入任何您用以连接到因特网的代理服务器的详情。

  1. 在 配置 菜单中，单击 更新。
  2. 单击 主路径 或 副路径 标签页。
  3. 单击 代理详情。
  4. 勾选 通过代理服务器访问路径 勾选框。
  5. 输入代理服务器的 地址 和 端口 号。
  6. 输入用来接入代理服务器的 用户名 和 密码。
    如果“用户名”需要指明域，才算合格有效，请使用 域\用户名。
上一个题目： 设置备用更新源
下一个题目： 通过拨号连接进行更新


通过拨号连接进行更新

要通过拨号连接到因特网进行更新：

  1. 在 配置 菜单中，单击 更新。
  2. 单击 计划 标签。
  3. 选择 在拨号连接时作更新检查。
每当您连接到因特网时，Sophos AutoUpdate 就会进行更新。
上一个题目： 通过代理服务器更新
下一个题目： 限制更新使用的带宽


限制更新使用的带宽

要避免 Sophos AutoUpdate 在您需要一些带宽以作它用时（如：下载电子邮件）， 占用了所有的带宽，您可以限制它使用的带宽量。

  1. 在 配置 菜单中，单击 更新。
  2. 单击 主路径 或 副路径 标签页。
  3. 单击 高级。
  4. 勾选 限制带宽使用量 勾选框，移动滑块设定 Sophos AutoUpdate 使用的带宽量。
    注： 如果您设定的带宽量超过了实际可用的带宽量，Sophos AutoUpdate 将使用所有的带宽。
上一个题目： 通过拨号连接进行更新
下一个题目： 日志记录更新活动


日志记录更新活动

您可以配置 Sophos Anti-Virus 以便在日志文件中记录更新活动。

  1. 在 配置 菜单中，单击 更新。
  2. 单击 日志记录 标签。
  3. 勾选 记录 Sophos AutoUpdate 活动日志 勾选框。
  4. 在 日志文件大小上限 文本框中，输入或选择以 MB 计量的日志文件大小。
  5. 在 日志记录级别 列表中，选择 普通 或 详尽 日志记录。
    详尽的日志记录提供比通常的活动多得多的活动的信息，因而，日志文件的尺寸也会快速增大。请仅在为了排解疑难而需要详尽的日志记录时，才使用此选项。
上一个题目： 限制更新使用的带宽
下一个题目： 查看更新日志文件


查看更新日志文件

  1. 在 配置 菜单中，单击 更新。
  2. 单击 日志记录 标签。
  3. 单击 查看日志文件。
上一个题目： 日志记录更新活动
下一个题目： 关于此计算机上的介入防范


关于此计算机上的介入防范

介入防范使您能够防范已知的恶意软件，以及防止未经授权的用户（对计算机安全了解不多的用户）通过 Sophos Endpoint Security and Control 用户界面，卸载或禁用 Sophos 安全软件。

注： 介入防范不针对具备丰富的计算机技术知识的用户。它无法防范专门瓦解操作系统的检测功能的恶意软件。此类的软件只能通过对安全隐患和可疑行为的扫描，才能被发现。要了解更多信息，请参见“Sophos Anti-Virus”（第 4 章）部分。

介入防范对于此计算机的用户意味着什么？

SophosUsers 和 SophosPowerUsers

介入防范不会影响到 SophosUser 和 SophosPowerUser 组中的成员。当介入防范启用时，他们将能够执行所有通常已经授权执行的任务，并不需要输入介入防范密码。

SophosUsers 或 SophosPowerUsers 组的成员不能启用或禁用介入防范。

要了解更多的有关各 Sophos 组经过授权可以执行的任务的信息，请参见 关于 Sophos 组。

SophosAdministrators

SophosAdministrator 组的成员可以启用或禁用介入防范。

如果在此计算机上使用了管理控制台管理 Sophos Endpoint Security and Control，在控制台中设置的介入防范策略，决定介入防范配置和密码。如果介入防范是从控制台启用的，那么，在需要执行任何以下任务时，请向控制台管理员要求密码。

如果您是 SophosAdministrator 组的成员，并且介入防范是启用的，那么，您必须知道介入防范密码，才能执行以下的任务：

  • 重新配置读写扫描或可疑行为检测的设置。要了解更多信息，请参见 输入介入防范密码以配置软件。
  • 禁用介入防范。要了解更多信息，请参见 禁用介入防范。
  • 从“控制面板”卸载 Sophos Endpoint Security and Control 组件（Sophos Anti-Virus，Sophos Client Firewall，Sophos AutoUpdate，Sophos Remote Management System）。
  • 通过“控制面板”卸载 Sophos SafeGuard Disk Encryption。

不知道该密码的 SophosAdministrator 组成员可以执行除了上述的任务之外的其它任务。

如果介入防范是禁用的，但是介入防范的密码已事先设置，那么，在重新启用介入防范之前，您必须使用 验证用户 选项，验证您自身。当介入防范禁用时，所有其它供 SophosAdministrators 组使用的配置选项都会启用。要了解有关重新启用介入防范的信息，请参见 重新启用介入防范。

上一个题目： 查看更新日志文件
下一个题目： 启用介入防范


启用介入防范

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

在首次安装 Sophos Endpoint Security and Control 时，介入防范是禁用的。如果您是 SophosAdministrator 组的成员，您可以启用介入防范。

要启用介入防范：

  1. 在 主页 的 介入防范 下，单击 配置介入防范。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 介入防范配置 对话框中，选择 启用介入防范 勾选框。
  3. 单击 密码 文本框下的 设置。在 介入防范密码 对话框中，输入并确认密码。
    提示： 密码长度必须至少有 8 个字符，并且必须包含数字和大小写字母。
上一个题目： 关于此计算机上的介入防范
下一个题目： 禁用介入防范


禁用介入防范

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您是 SophosAdministrator 组的成员，您就可以禁用介入防范。

要禁用介入防范：

  1. 如果您尚未验证您自身，并且在 主页 上的 配置介入防范 选项不可用，那么，在进行到步骤 2 之前，请按照 输入介入防范密码以配置软件 中的操作指导做。
  2. 在 主页 的 介入防范 下，单击 配置介入防范。
    要了解有关 主页 页面的信息，请参见 关于主页。
  3. 在 介入防范配置 对话框中，取消勾选 启用介入防范 勾选框，并单击 确定。
上一个题目： 启用介入防范
下一个题目： 重新启用介入防范


重新启用介入防范

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

如果您是 SophosAdministrator 组的成员，您就可以重新启用介入防范。

要重新启用介入防范：

  1. 在 主页 中的 介入防范 下，单击 验证用户。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 介入防范验证 对话框中，输入介入防范密码，并单击 确定。
  3. 在 主页 的 介入防范 下，单击 配置介入防范。
  4. 在 介入防范配置 对话框中，选择 启用介入防范 勾选框。
上一个题目： 禁用介入防范
下一个题目： 关于介入防范密码


关于介入防范密码

当介入防范启用时，如果您想要配置读写扫描，配置可疑行为检测，或者，禁用介入防范，那么，您必须输入介入防范密码。您必须是 SophosAdministrator 组的成员，才能这样做。

在打开 Sophos Endpoint Security and Control 后，您只需输入介入防范密码一次。如果您关闭了 Sophos Endpoint Security and Control，然后再次打开了它，您需要再次输入该密码。

如果您想要卸载任何 Sophos Endpoint Security and Control 组件，那么，您必须先输入介入防范密码，并禁用介入防范，然后，再卸载软件。

如果介入防范是禁用的，但是介入防范的密码已事先设置，那么，在重新启用介入防范之前，您必须输入密码。

您需要输入介入防范密码，以便启用介入防范，如果：

  • 您先前已经启用了介入防范，创建了介入防范密码，然后又禁用了介入防范。
  • 已在管理控制台中创建了介入防范密码，但是介入防范尚未启用。
上一个题目： 重新启用介入防范
下一个题目： 输入介入防范密码以配置软件


输入介入防范密码以配置软件

如果您是 SophosAdministrator 组的成员，您可以输入介入防范密码，对您自己进行身份验证。

要对自己进行身份验证：

  1. 在 主页 中的 介入防范 下，单击 验证用户。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 介入防范验证 对话框中，输入介入防范密码，并单击 确定。
上一个题目： 关于介入防范密码
下一个题目： 更改介入防范密码


更改介入防范密码

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

要更改介入防范密码，您必须是 SophosAdministrator 组的成员。

要更改介入防范密码

  1. 如果您尚未验证您自身，并且在 主页 上的 配置介入防范 选项不可用，那么，在进行到步骤 2 之前，请按照 输入介入防范密码以配置软件 中的操作指导做。
  2. 在 主页 的 介入防范 下，单击 配置介入防范。
    要了解有关 主页 页面的信息，请参见 关于主页。
  3. 在 介入防范配置 对话框中，单击 密码 文本框下的 更改。
  4. 在 介入防范密码 对话框中，输入并确认新的密码。
    提示： 密码长度应该至少有 8 个字符，并且包含数字和大小写字母。
上一个题目： 输入介入防范密码以配置软件
下一个题目： 卸载 Sophos 安全软件


卸载 Sophos 安全软件

如果您是 SophosAdministrator 组的成员，您可以通过“控制面板”卸载 Sophos 安全软件：

  • Sophos Endpoint Security and Control 组件（Sophos Anti-Virus，Sophos Client Firewall，Sophos AutoUpdate，Sophos Remote Management System）。
  • Sophos SafeGuard Disk Encryption

要在介入防范启用的情况下，卸载 Sophos 安全软件：

  1. 在 主页 中的 介入防范 下，单击 验证用户。
    要了解有关 主页 页面的信息，请参见 关于主页。
  2. 在 介入防范验证 对话框中，输入介入防范密码，并单击 确定。
  3. 在 主页 的 介入防范 下，单击 配置介入防范。
  4. 在 介入防范配置 对话框中，取消勾选 启用介入防范 勾选框，并单击 确定。
    介入防范会被禁用。
  5. 在 控制面板 中，打开 添加/删除程序，找到您想要删除的软件，并单击 更改/删除 或 删除。按照屏幕上的操作指导，卸载软件。
上一个题目： 更改介入防范密码
下一个题目： 查看介入防范日志


查看介入防范日志

介入防范日志将显示两种类型的事件：

  • 顺利的介入防范验证事件，显示已验证的用户的名称，以及验证的时间。
  • 不成功的介入尝试事件，显示涉及的 Sophos 软件产品或组件的名称，介入尝试的时间，以及进行介入尝试的用户的详情。

要查看介入防范日志，您必须是 SophosAdministrator 组的成员。

要查看介入防范日志：

在 主页 的 介入防范 下，单击 查看介入防范日志。
要了解有关 主页 页面的信息，请参见 关于主页。
您可以从日志记录页中，复制日志记录到剪贴板，也可以用电子邮件发送日志记录，或者，直接打印日志记录。

要在日志记录中查找特定的文本，单击 查找 并输入您想查找的文本内容。

上一个题目： 卸载 Sophos 安全软件
下一个题目： 关于更新失败


关于更新失败

要了解某更新失败的更多信息，请查看更新日志记录，有关如何查看的信息，请参见 查看更新日志文件。

以下各节将解释，为什么更新可能会失败，以及您可以怎样更改设置，以解决这个问题。

  • Sophos Endpoint Security and Control 联系的是错误的更新源
  • Sophos Endpoint Security and Control 无法使用您的代理服务器
  • 没有正确地计划安排自动更新
  • 没有进行维护的更新源
上一个题目： 查看介入防范日志
下一个题目： Sophos Endpoint Security and Control 联系的是错误的更新源


Sophos Endpoint Security and Control 联系的是错误的更新源

  1. 在 配置 菜单中，单击 更新。
  2. 在 主路径 标签页中，检查更新源的地址和帐户详情是否与您的系统管理员提供的一致。
    （要了解有关配置 主路径 标签的信息，请参见 设置更新源。）
上一个题目： 关于更新失败
下一个题目： Sophos Endpoint Security and Control 无法使用您的代理服务器


Sophos Endpoint Security and Control 无法使用您的代理服务器

如果 Sophos Endpoint Security and Control 是通过因特网进行更新的，您必须确保您设定代理服务器（如果有）是可以使用的。

  1. 在 配置 菜单中，单击 更新。
  2. 在 主路径 标签页中，单击 代理详情。
  3. 确保代理服务器地址，端口号，以及帐户详情都是正确的。
    要了解有关输入代理详情的信息，请参见 通过代理服务器更新。
上一个题目： Sophos Endpoint Security and Control 联系的是错误的更新源
下一个题目： 没有正确地计划安排自动更新


没有正确地计划安排自动更新

  1. 在 配置 菜单中，单击 更新。
  2. 单击 计划 标签。（要了解有关 计划 标签的信息，请参见 计划更新。）
  3. 如果您的计算机是在网络中的，或者您的计算机是通过宽带连接因特网进行更新的，请选择 启用自动更新，并输入更新频率。如果您是通过拨号连接因特网进行更新的，请选择 在拨号连接时进行更新检查。
上一个题目： Sophos Endpoint Security and Control 无法使用您的代理服务器
下一个题目： 没有进行维护的更新源


没有进行维护的更新源

您的公司可能已经移走了，您通过其进行更新（在网络中，或者在网页服务器中）的目录。另一种情况是，他们可能没有保留该目录。

如果您认为可能是这种情况，请联系您的网络管理员。

上一个题目： 没有正确地计划安排自动更新
下一个题目： 没有清除的安全隐患


没有清除的安全隐患

如果 Sophos Anti-Virus 没有从您的计算机上清除安全隐患，这可能是因为以下的原因。

自动清除被禁用

如果 Sophos Anti-Virus 没有试图进行清除，请检查是否已启用了自动清除。要了解有关怎样启用自动清除的信息，请参见以下主题：
  • 配置读写扫描的清除
  • 配置单击右键扫描的清除
  • 配置自定义扫描的清除

在读写扫描中，不能对广告软件和可能不想安装的应用程序进行自动清除。

清除失败

如果 Sophos Anti-Virus 无法清除安全隐患（"清除失败"），这可能是因为它无法清除该类型的安全隐患，或者，您没有足够的读写权限。

要求完全的计算机扫描

在 Sophos Anti-Virus 能够将安全隐患从您的计算机中清除之前，您可能需要对计算机进行完全扫描，检测多组件安全隐患所涉及的所有组件，或者，检测先前隐藏在文件中的安全隐患。

  1. 要扫描计算机上的所有硬盘，包括其引导扇区，请运行 扫描我的电脑。要了解信息，请参见 运行完整计算机扫描。
  2. 如果安全隐患还是没有被彻底检测到，这可能是因为您的读写权限不足，或者因为计算机中有些含有安全隐患的组件的驱动器，或文件夹，被排除在扫描外。有关详细信息，请参阅从读写扫描中排除项目。请检查排除扫描项目的列表。如果有项目出现在列表中，请从列表中删除这些项目，然后，再次扫描您的计算机。

可移动介质被写保护

如果处理的是可移动介质（如：软盘，CD），请确保它没有被写保护。

NTFS 卷被写保护

如果处理的是 NTFS 卷 （Windows XP 或以后），请确保它没有被写保护。

报告发现病毒／间谍软件碎片

Sophos Anti-Virus 不会对病毒／间谍软件碎片进行清除，因为它并没有发现与之确切对应的病毒／间谍软件。请参见 报告发现病毒／间谍软件碎片。

上一个题目： 没有进行维护的更新源
下一个题目： 报告发现病毒/间谍软件碎片


报告发现病毒/间谍软件碎片

如果报告发现病毒/间谍软件碎片，请按照以下说明做：

  1. 立即更新您的保护措施，这样，Sophos Anti-Virus 会有最新的病毒识别文件。
  2. 运行完全的计算机扫描
  • 立即更新
  • 运行完全的计算机扫描

如果仍然报告发现病毒/间谍软件碎片，请联系Sophos 技术支持寻求建议。

  • 技术支持

报告病毒/间谍软件碎片，表明文件的某一部分与病毒/间谍软件的某一部分一致。出现这种情况，可能有三种原因：

已知病毒/间谍软件的变种

许多新病毒/间谍软件都是建立在已知病毒/间谍软件的基础之上的，所以某些已知病毒/间谍软件的典型的病毒/间谍软件代码的碎片，就可能会出现在新的病毒/间谍软件中。如果报告发现了病毒／间谍软件碎片，这就有可能是 Sophos Anti-Virus 发现了有可能会活动起来的新的病毒／间谍软件。

已损坏的病毒

许多病毒在复制自身的过程中出现缺陷，这使得它们在感染目标文件时出错。病毒中不能起作用的部分（可能是实质部分）就可能出现在宿主文件中，而 Sophos Anti-Virus 检测到的就是这一部分。已损坏的病毒是不会传播的。

含有病毒/间谍软件的数据库

在运行完全计算机扫描时，Sophos Anti-Virus 可能会报告在数据库文件中有病毒／间谍软件碎片。如果出现这种情况，不要删除该数据库。请联系Sophos 技术支持寻求建议。

要了解有关联系技术支持的信息，请参见 技术支持。

上一个题目： 没有清除的安全隐患
下一个题目： 部分检测到的安全隐患


部分检测到的安全隐患

要扫描所有的磁盘驱动器，包括引导区，请在计算机上运行完整计算机扫描。

  • 运行完全的计算机扫描
如果安全隐患还是没有被彻底检测到，这可能是因为计算机中有些含有安全隐患的组件的驱动器，或文件夹，被排除在扫描外。如果某些项目在排除列表中，请删除它们，然后再扫描您的计算机。
  • 从即时扫描中排除项目

如果安全隐患还是没有被完全检测到，那么，可能是因为您没有足够的访问权限。

Sophos Anti-Virus 可能不能够彻底检测到或者删除，有组件安装在网络驱动器上的安全隐患。

上一个题目： 报告发现病毒/间谍软件碎片
下一个题目： 广告软件或可能不想安装的应用程序 (PUA) 从隔离区中消失


广告软件或可能不想安装的应用程序 (PUA) 从隔离区中消失

如果某个被 Sophos Anti-Virus 检测到的广告软件或可能不想安装的项目，未经您采取任何措施，就从隔离区管理器中消失，那么，该广告软件或 PUA 可能已被其它用户通过管理控制台批准或清除了。请查看批准的广告软件和可能不想安装的应用程序的列表，了解它是否已被批准。要了解具体怎样做，请参见 批准广告软件和可能不想安装的应用程序。

上一个题目： 部分检测到的安全隐患
下一个题目： 计算机的运行变慢


计算机的运行变慢

如果您的计算机的运行变慢，这有可能是有可能不想安装的应用程序，正在您的计算机上运行和监控。如果您启用了读写扫描，您也许可能会看到许多桌面消息警报，提醒您发现了可能不想安装的应用程序。要解决这一问题，请按照以下说明做。

  1. 运行扫描我的电脑，以检测该可能不想安装的应用程序的所有组件。要了解信息，请参见 运行完整计算机扫描。
    注： 如果在扫描之后，该可能不想安装的应用程序只是部分被检测到，则请参见部分检测到的安全隐患中的步骤 2。
  2. 清除您的计算机上的广告软件或可能不想安装的应用程序。要了解具体怎样做，请参见 处置隔离区中的广告软件和可能不想安装的应用程序。
上一个题目： 广告软件或可能不想安装的应用程序 (PUA) 从隔离区中消失
下一个题目： 允许访问引导区受到感染的驱动器


允许访问引导区受到感染的驱动器

重要： 如果使用了管理控制台管理此计算机上的 Sophos Endpoint Security and Control，那么，它会覆盖您在此所作的任何更改。

依照默认值，Sophos Anti-Virus 会阻止访问引导区感染了病毒的可移动介质。

要允许访问（例如，从感染了引导区病毒的软盘上复制文件）：

  1. 单击 主页 > 防病毒和 HIPS > 配置防病毒和 HIPS > 配置 > 读写扫描。
  2. 在 扫描 标签页中，勾选t 允许访问引导区感染病毒的驱动器 勾选框。
重要： 一旦您完成了访问磁盘，请取消勾选该勾选框，请将磁盘从计算机中移走，这样，计算机在重新启动时，不会因此而再次被感染。
上一个题目： 计算机的运行变慢
下一个题目： 无法访问 Sophos Endpoint Security and Control 区域


无法访问 Sophos Endpoint Security and Control 区域

如果您无法使用或者配置 Sophos Endpoint Security and Control 的某些特定部分，这可能是因为，特定的 Sophos 用户组的成员访问这些部分受到限制。

要了解更多有关 Sophos 用户组的信息，请参见 关于 Sophos 组。

上一个题目： 允许访问引导区受到感染的驱动器
下一个题目： 弥补病毒造成的破坏


弥补病毒造成的破坏

要弥补病毒造成的破坏，取决于病毒是怎样感染了计算机的。

病毒造成的破坏

有些病毒不会造成什么损失，有的造成的损失则大到您要重置硬盘才能弥补。

有的病毒逐渐地对数据资料做微小的改变。这种损害会很难发现。

做些什么？

阅读 Sophos 网站中的安全隐患分析部分是很重要的，并且要在清除之后，仔细检查文件。请参见 获取清除信息 以了解怎样从 Sophos 网站中查看有关病毒的破坏作用的详情。

完善的备份是关键。如果您之前没有做这样的备份，请开始备份文件，以备将来之需。

有时，您可以从被病毒损坏的磁盘上恢复数据。Sophos 可以提供一些工具软件，修复某些病毒造成的损害。

请联系Sophos 技术支持寻求建议。

要了解有关联系技术支持的信息，请参见 技术支持。

上一个题目： 无法访问 Sophos Endpoint Security and Control 区域
下一个题目： 弥补广告软件和可能不想安装的应用程序造成的破坏


弥补广告软件和可能不想安装的应用程序造成的破坏

在清除广告软件和可能不想安装的应用程序的过程中，并不一定能完全弥补已造成的破坏。

操作系统已被修改

某些广告软件和可能不想安装的应用程序会修改 Windows 操作系统，比如，更改您的因特网连接设置。Sophos Anti-Virus 无法总能够将系统中的设置，恢复到被安装了广告软件和可能不想安装的应用程序之前的值。比如，如果某个广告软件／可能不想安装的应用程序，更改了浏览器的默认主页，但 Sophos Anti-Virus 是无法知道先前的那个默认主页是什么的。

没有清除的实用小程序

某些广告软件和可能不想安装的应用程序会安装一些实用小程序到您的计算机上，如扩展名为.dll 或.ocx 等的文件。如果这些实用小程序是无害的（也就是说, 它们并不具有广告软件和可能不想安装的应用程序的那些特性），比如，某个语言库，而且也没有被整合到广告软件和可能不想安装的应用程序中，那么，Sophos Anti-Virus 并不会将其检测为广告软件和可能不想安装的应用程序的一部分。在这种情况下，这样的文件不会在广告软件或可能不想安装的应用程序被清除后，也被从计算机中清除。

广告软件或可能不想安装的应用程序是您所需要的软件程序的一部分

有时候某些广告软件或可能不想安装的应用程序，是您想要安装的软件程序的一部分，并且是运行该软件程序所必需的。如果您删除这样的广告软件或可能不想安装的应用程序，则整个软件程序可能会停止在您的计算机上运行。

做些什么？

阅读 Sophos 网站中的安全隐患分析部分是很重要的。请参见 获取清除信息 以了解怎样从 Sophos 网站中查看有关广告软件或可能不想安装的应用程序的破坏作用的详情。

为了能够将您的系统及其设置恢复到先前的状态，您应该定时备份您的系统。您还应该备份，您想要使用的软件的原始的可执行程序文件。

要了解更多有关弥补广告软件和可能不想安装的应用程序造成的破坏的信息和建议，请联系 Sophos 技术支持。

要了解有关联系技术支持的信息，请参见 技术支持。

上一个题目： 弥补病毒造成的破坏
下一个题目： 报告密码错误


报告密码错误

如果您在试图计划某个自定义扫描时，出现有关密码的出错消息，那么，请确保：

  • 用户帐户的密码是正确的
  • 密码不能为空

要确保密码正确，请检查 控制面板 用户帐户 中的用户帐户的属性。

上一个题目： 弥补广告软件和可能不想安装的应用程序造成的破坏
下一个题目： “服务失败”出错消息


“服务失败”出错消息

症状

您看到以下出错消息之一出现在公告区域：
  • 防病毒和 HIPS：服务失败
  • 防火墙：服务失败

原因

您计算机上的 Sophos Endpoint Security and Control 服务之一失败，需要重新启动。

解决问题

  1. 通过 Windows，打开服务。
  2. 按照以下的说明之一做：
    • 如果您看到 防病毒和 HIPS：服务失败 的出错消息，请右击 Sophos Anti-Virus，然后，单击 重新启动。
    • 如果您看到 防火墙：服务失败 的出错消息，请右击 Sophos Client Firewall Manager，然后，单击 重新启动。

注意

  • 要打开服务，请单击 开始，单击 控制面板，双击 管理工具，然后，双击 服务。
上一个题目： 报告密码错误
下一个题目： 防火墙日志记录数据库已损坏


防火墙日志记录数据库已损坏

症状

当使用防火墙日志记录查看器时，会出现出错消息“当前的 Sophos Client Firewall 日志记录数据库已损坏。”

原因

防火墙的事件日志数据库已损坏，需要重新创建。

解决问题

您必须是该计算机上的 Windows Administrators 组的成员才能进行此任务。

  1. 通过 Windows，打开服务。
  2. 右击 Sophos Client Firewall Manager，然后，单击 停止。

  3. 使用“资源管理”器，找到 C:\Documents and Settings\All Users\Application Data\Sophos\Sophos Client Firewall\logs。

    要查看此隐藏的文件夹，您需要显示“资源管理器”中隐藏的文件或文件夹。

  4. 删除 op_data.mdb。
  5. 在“服务”中，右击 Sophos Client Firewall Manager，然后，单击 开始。

注意

  • 要打开服务，请单击 开始，单击 控制面板，双击 管理工具，然后，双击 服务。
上一个题目： “服务失败”出错消息
下一个题目： 用语表


用语表

广告软件和可能不想安装的应用程序 (adware and PUAs)
广告软件显示广告，例如：弹出消息，它会影响用户的工作效率和系统的运行效率。PUA，可能不想安装的应用程序 (Potentially Unwanted Application)，是一种应用程序，它不一定是恶意程序，但它通常会被认为是不适合安装在大多数的公司的网络中。
应用程序规则 (application rule)
仅应用于往来于特定的应用程序的数据包（在网络中传输的数据）的规则。
批准管理器 (Authorization manager)
使您能够批准广告软件和可能不想安装的应用程序，可疑文件，以及出现可疑行为的应用程序和缓冲区溢出的程序模块。
自动清除
无需用户的任何干预或认可，而执行的清除。
已阻断 (blocked)
一种状态，它显示应用程序（包括隐藏进程），连接，协议，ICMP 消息，等等，已被拒绝网络访问。
缓冲溢出检测 (buffer overflow detection)
用于检测缓冲溢出攻击。
检查和 (checksum)
每个版本的应用程序都具有独一无二的检查和。防火墙可以使用此检查和决定是否允许某个应用程序。
清除
清除是指通过消除文件或引导区中的病毒感染，移动或删除可疑文件，或者删除广告软件或可能不想安装的应用程序 (PUA) 的项目，来杜绝计算机上的安全隐患。对于扫描网页时检测到的安全隐患，则无法清除，因为所检测到的安全隐患并没有下载到您的计算机上。因此，不必采取任何操作。
内容控制列表 (CCL) (Content Control List (CCL))
指定文件内容的一组条件，例如，与其它形式的个人识别信息在一起的信用卡或借记卡号码，或银行帐号详情。有两种类型的内容控制列表：SophosLabs 内容控制列表，和自定义内容控制列表。
内容规则 (content rule)
一种规则，它包括一个或多个内容控制列表，并指定，如果用户试图传输匹配了规则中的全部内容控制列表的数据到指定目标路径 (destination) 时，采取的措施。
受控程序 (controlled application)
由于您公司的计算机安全策略，而被阻止在您的计算机上运行的程序。
自定义规则 (custom rule)
用户创建的规则，用来指定允许运行应用程序的条件。
数据控制
一种功能，用于减少从工作站计算机中意外丢失数据的机会。当工作站计算机的用户试图传输的文件，满足在数据控制策略和规则中定义的标准时，数据控制功能会采取相应的措施。例如，当某用户试图复制包含客户资料列表的电子表格文件到可移动的存储设备中时，或者，上传标记为机密的文档到 Webmail 帐户中时，数据控制功能会阻断此传输，如果事先的配置要求这样做。
数据视图 (data view)
根据在树视图中选择的项目，而显示不同的数据的视图。
描述栏 (description bar)
日志查看器中的栏，它出现在数据视图之上，显示当前在树视图中选择的项目的名称。
设备控制 (device control)
一种功能，用于减少从工作站计算机中意外丢失数据的机会，并且可以限制从网络外部引进和安装软件。当工作站计算机用户试图在他们的计算机上，使用某个未经批准的存储设备或网络设备时，该功能会采取措施。
下载信誉
从 Internet 下载的文件的信誉。信誉按文件的时间、来源、普遍性、深度内容分析和其他特征进行计算。它有助于确定文件是否安全或有潜在风险，以及如果下载是否会损坏用户的计算机。
扩展扫描 (extensive scanning)
扫描每个文件的每个部分。
防火墙事件 (firewall event)
当计算机上未知的应用程序，或操作系统，与另一台联网计算机通讯时，所采用的方式不是该计算机所特别指定方式时，所出现的情形。
防火墙策略 (firewall policy)
管理控制台所发布的，防火墙用来监控计算机对因特网和其它网络的连接的各种设置。
全局规则
应用于网络中所有尚无任何规则的网络连接和应用程序的规则。它们的优先性低于在“局域网 (LAN)” 页面中设置的规则。它们的优先程度低于应用程序规则（除非用户另有指定）。
隐藏进程 (hidden process)
应用程序有时会启动另外的隐藏进程，为它执行某些网络访问。恶意的应用程序可能通过以下技巧避开防火墙：它启动某个受信任的应用程序去访问网络，而不是自己去访问。
高优先级通用规则 (high-priority global rule)
在应用任何其它通用规则或应用程序规则之前，就应用的规则。
主机入侵防范系统 (HIPS)
执行前行为分析和运行时行为分析的总称。
ICMP
"Internet Control Message Protocol"(Internet 控制消息协议) 的缩写一种网络层的因特网协议，它提供与 IP 数据包处理有关的错误矫正和其它信息。
ICMP 设置 (ICMP settings)
ICMP 设置指定允许哪些类型网络管理通讯。
即时消息 (instant messaging)
受控程序的一类，即时消息客户端应用程序（如：MSN）。
交互模式
一种防火墙模式。在这种模式中，当防火墙检测到没有相应的规则的网络通讯流时，它会显示一个或多个学习对话框。此功能只应用于 Windows 7 及更高的 Sophos Client Firewall。
学习对话框 (learning dialog)
当某个未知的应用程序请求网络访问时，要求用户选择是允许还是阻断网络活动的对话框。此功能只应用于 Windows 7 及更高的 Sophos Client Firewall。
日志清除设置 (log cleanup settings)
控制何时删除记录的设置。
日志查看器 (log viewer)
一种窗体，用户可以在其中查看事件数据库中的详情，诸如，已被允许或阻断的连接，系统日志，以及任何出现过的警报，等等。
恶意数据流检测(Malicious Traffic Detection)
此功能可检测受影响的计算机和攻击者的命令和控制服务器之间的通信。
手动清除
使用特别的清除感染程序或实用工具，或者，通过手动方式删除文件，而执行的清除。
匹配 (match)
与在内容控制列表中定义的内容一致。
NetBIOS（网络基本输入/输出系统）
网络基本输入/输出系统（Network Basic Input/Output System）的缩写。为操作系统，I/O 总线，以及网络之间提供接口的软件。几乎所有基于 Windows 的局域网 (LAN) 都是基于 NetBIOS 的。
网络协议 (network protocol)
使网络中的计算机能够相互连接，以及能够以最少的错误交换信息的一组规则或标准。
非交互模式 (non-interactive mode)
一种防火墙模式。在这种模式中，对于没有相应的规则的网络通讯流，防火墙要么全部阻断它们，要么全部允许它们。
普通扫描 (normal scanning)
只扫描各个文件中最有可能被病毒感染的那些部分的扫描。
读写扫描 (on-access scan)
防范安全隐患的主要保护手段。当您复制，移动，或打开文件，或启动程序时，Sophos Anti-Virus 会扫描文件或程序，确保访问它不会对您的计算机造成安全隐患，或者，它已被批准使用。
即时扫描 (on-demand scan)
由您启用的一种扫描。您可以使用即时扫描计算机上您具有读权限的所有文件。
主配置 (primary configuration)
用于公司网络的防火墙配置，用户使用该网络的连接进行日常工作。
进程设置 (process settings)
指定是否允许修改了或隐藏的线程进行网络访问的设置。
隔离管理器
软件模块，它使您能够查看和处置被隔离的项目。
低级插口 (rawsocket)
低级插口允许进程控制数据在网络中传输的各个环节，这可以被用于恶意目的。
单击右键扫描 (right-click scan)
可以通过快捷菜单来运行的，扫描资源管理器中或桌面上的文件的一种扫描。
rootkit
一种特洛伊木马或类似的技术，它用来隐藏恶意的对象（进程，文件，注册键，或网络端口），避免计算机用户或系统管理员发现它们。
运行时行为分析
由可疑行为检测和缓冲溢出检测执行的动态分析。
扫描出错 (scanning error)
在扫描某个文件中出现的错误，例如：拒绝访问。
计划扫描 (scheduled scan)
在设定时间运行的，对您的计算机或计算机的某些部分进行的扫描。
副配置 (secondary configuration)
当用户没有连接到公司主网络中，但连接到了其它网络中（如：旅馆，或机场的无线网络，或其它公司网络。）时，所使用的防火墙配置。
间谍软件
通过隐蔽，欺骗，或劝诱等方式，将自身安装到用户的计算机上，并且未经用户的许可或知晓，将计算机上的信息发送给第三方的程序。
Sophos Live Protection
一种使用云计算技术的功能，它能不断地判断可疑文件是否成为安全隐患，并随时采取在 Sophos 防病毒保护配置中所指定的相应措施。
状态查看 (stateful inspection)
用于保留活动的 TCP and UDP 网络连接表的防火墙技术。只有与已知的连接状态匹配的数据包，才会被防火墙允许。
存储设备 (storage device)
可移动存储设备（例如：USB 闪存，PC 读卡器，和外接硬盘驱动器），CD/DVD 驱动器，软盘驱动器，以及安全的可移动存储设备（例如：SanDisk Cruzer Enterprise，Kingston Data Traveller，IronKey Enterprise，和带有硬件加密的 IronKey Basic USB 闪存）。
可疑行为检测 (suspicious behavior detection)
对运行在系统中的所有程序的行为进行的动态分析，以检测和阻断可能的恶意活动。
可疑文件 (suspicious file)
一种文件，在文件中出现了病毒中普遍具有，但又不仅是病毒中才具有的一系列特征。
系统内存 (system memory)
在应用程序和硬件处理的实际数据之间充当桥梁的内存。它由操作系统使用。
系统规则 (system rule)
将被应用于所有应用程序，以及将允许或阻断低级别的系统网络活动的规则。
介入防范 (tamper protection)
能够防范已知的恶意软件，以及防止未经授权的用户通过 Sophos Endpoint Security and Control 用户界面，卸载或禁用 Sophos 安全软件的一种功能。
安全隐患事件 (threat event)
检测或清除某安全隐患。
树视图 (tree view)
一种视图，它控制日志查看器将在数据视图中显示什么数据。
真实文件类型 (true file type)
经过分析文件的结构，而不是通过文件的文件扩展名，而确认的文件类型。这是一种更加可靠的确认文件类型的方法。
信任的应用程序 (trusted application)
被允许完全地，无条件地访问网络的应用程序。
未识别的病毒 (unidentified virus)
没有特定识别的病毒。
未知的通讯流 (unknown traffic)
防火墙没有相应的规则的，由某个应用程序或服务进行的网络访问。
病毒识别文件 (IDE) (virus identity file (IDE))
使 Sophos Anti-Virus 能够检测和清除特定的病毒，特洛伊木马，蠕虫的一种文件。
语音IP电话 (Voice over IP)
受控程序的一类，语音 IP 电话客户端应用程序。
工作模式 (working mode)
决定防火墙是要用户输入措施（“交互”模式），还是自动应用措施（“非交互模式”）的设置。Windows 8 或更高版本的 Sophos Client Firewall 中的交互模式已删除。
上一个题目： 防火墙日志记录数据库已损坏
下一个题目： 技术支持


技术支持

您可以通过以下各种方式获得 Sophos 产品的技术支持：

  • 访问 community.sophos.com/ 的 Sophos Community 论坛，并搜索遇到相同问题的其它用户。
  • 访问 www.sophos.com/en-us/support.aspx 中的 Sophos 技术支持知识库。
  • 在 www.sophos.com/en-us/support/documentation.aspx 中下载产品的技术文档。
  • 访问 https://secure2.sophos.com/support/contact-support/support-query.aspx 联系我们的技术支持团队。
上一个题目： 用语表
下一个题目： 法律声明


法律声明

版权所有 © 1989-2016 Sophos Limited。All rights reserved.本出版物的任何部分，都不得被以电子的、机械的、复印的、记录的或其它的一切手段或形式，再生，存储到检索系统中，或者传输。除非您是有效的被授权用户，并且根据您的用户授权使用许可协议中的条件，您可以再生本文档；或者，除非您事先已经获得了版权所有者的书面许可。

Sophos，Sophos Anti-Virus 以及 SafeGuard 都是 Sophos Limited，Sophos Group 和 Utimaco Safeware AG 的注册商标。所有其它提及的产品和公司的名称都是其所有者的商标或注册商标。

Apache

The Sophos software that is described in this document may include some software programs that are licensed (or sublicensed) to the user under the Apache License.A copy of the license agreement for any such included software can be found at http://www.apache.org/licenses/LICENSE-2.0

Boost C++ Libraries

Boost Software License - Version 1.0 - August 17th, 2003

Permission is hereby granted, free of charge, to any person or organization obtaining a copy of the software and accompanying documentation covered by this license (the “Software”) to use, reproduce, display, distribute, execute, and transmit the Software, and to prepare derivative works of the Software, and to permit third-parties to whom the Software is furnished to do so, all subject to the following:

The copyright notices in the Software and this entire statement, including the above license grant, this restriction and the following disclaimer, must be included in all copies of the Software, in whole or in part, and all derivative works of the Software, unless such copies or derivative works are solely in the form of machine-executable object code generated by a source language processor.

THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT.IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Common Public License

The Sophos software that is referenced in this document includes or may include some software programs that are licensed (or sublicensed) to the user under the Common Public License (CPL), which, among other rights, permits the user to have access to the source code.The CPL requires for any software licensed under the terms of the CPL, which is distributed in object code form, that the source code for such software also be made available to the users of the object code form.For any such software covered under the CPL, the source code is available via mail order by submitting a request to Sophos; via email to supportasia@sophos.com or via the web at http://www.sophos.com/en-us/zh-cn/support/contact-support.aspx.A copy of the license agreement for any such included software can be found at http://opensource.org/licenses/cpl1.0.php

ConvertUTF

Copyright 2001–2004 Unicode, Inc.

This source code is provided as is by Unicode, Inc. No claims are made as to fitness for any particular purpose.No warranties of any kind are expressed or implied.The recipient agrees to determine applicability of information provided.If this file has been purchased on magnetic or optical media from Unicode, Inc., the sole remedy for any claim will be exchange of defective media within 90 days of receipt.

Unicode, Inc. hereby grants the right to freely use the information supplied in this file in the creation of products supporting the Unicode Standard, and to make copies of this file in any form for internal or external distribution as long as this notice remains attached.

crt

# $FreeBSD$
# @(#)COPYRIGHT 8.2 (Berkeley) 3/21/94

The compilation of software known as FreeBSD is distributed under the following terms:

Copyright (c) 1992-2013 The FreeBSD Project.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the DOCUMENTATION and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The 4.4BSD and 4.4BSD-Lite software is distributed under the following terms:

All of the documentation and software included in the 4.4BSD and 4.4BSD-Lite Releases is copyrighted by The Regents of the University of California.

Copyright 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994 The Regents of the University of California.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgement: This product includes software developed by the University of California, Berkeley and its contributors.
  4. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The Institute of Electrical and Electronics Engineers and the American National Standards Committee X3, on Information Processing Systems have given us permission to reprint portions of their documentation.

In the following statement, the phrase "this text" refers to portions of the system documentation.

Portions of this text are reprinted and reproduced in electronic form in the second BSD Networking Software Release, from IEEE Std 1003.1-1988, IEEE Standard Portable Operating System Interface for Computer Environments (POSIX), copyright C 1988 by the Institute of Electrical and Electronics Engineers, Inc. In the event of any discrepancy between these versions and the original IEEE Standard, the original IEEE Standard is the referee document.

In the following statement, the phrase "This material" refers to portions of the system documentation.This material is reproduced with permission from American National Standards Committee X3, on Information Processing Systems.Computer and Business Equipment Manufacturers Association (CBEMA), 311 First St., NW, Suite 500, Washington, DC 20001-2178.The developmental work of Programming Language C was completed by the X3J11 Technical Committee.

The views and conclusions contained in the software and documentation are those of the authors and should not be interpreted as representing official policies, either expressed or implied, of the Regents of the University of California.

NOTE: The copyright of UC Berkeley's Berkeley Software Distribution ("BSD") source has been updated.The copyright addendum may be found at fttp://ftp.cs.berkeley.edu/pub/4bsd/README.Impt.License.Change and is included below.

July 22, 1999

To All Licensees, Distributors of Any Version of BSD:

As you know, certain of the Berkeley Software Distribution ("BSD") source code files require that further distributions of products containing all or portions of the software, acknowledge within their advertising materials that such products contain software developed by UC Berkeley and its contributors.

Specifically, the provision reads:

"3.All advertising materials mentioning features or use of this software must display the following acknowledgement: This product includes software developed by the University of California, Berkeley and its contributors."

Effective immediately, licensees and distributors are no longer required to include the acknowledgement within advertising materials.Accordingly, the foregoing paragraph of those BSD Unix files containing it is hereby deleted in its entirety.

William Hoskins
Director, Office of Technology Licensing
University of California, Berkeley

dtoa.c

The author of this software is David M. Gay.

Copyright © 1991, 2000 by Lucent Technologies.

Permission to use, copy, modify, and distribute this software for any purpose without fee is hereby granted, provided that this entire notice is included in all copies of any software which is or includes a copy or modification of this software and in all copies of the supporting documentation for such software.

THIS SOFTWARE IS BEING PROVIDED "AS IS", WITHOUT ANY EXPRESS OR IMPLIED WARRANTY.IN PARTICULAR, NEITHER THE AUTHOR NOR LUCENT MAKES ANY REPRESENTATION OR WARRANTY OF ANY KIND CONCERNING THE MERCHANTABILITY OF THIS SOFTWARE OR ITS FITNESS FOR ANY PARTICULAR PURPOSE.

ICU

ICU version 1.8.1 or later

COPYRIGHT AND PERMISSION NOTICE

Copyright © 1995–2008 International Business Machines Corporation and others

All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, provided that the above copyright notice(s) and this permission notice appear in all copies of the Software and that both the above copyright notice(s) and this permission notice appear in supporting documentation.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS.IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in this Software without prior written authorization of the copyright holder.

All trademarks and registered trademarks mentioned herein are the property of their respective owners.

IEEE Software Taggant Library

This software was developed by The Institute of Electrical and Electronics Engineers, Incorporated (IEEE), through the Industry Connections Security Group (ICSG) of its Standards Association.Portions of it include software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/), and those portions are governed by the OpenSSL Toolkit License.

IEEE License

Copyright (c) 2012 IEEE.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

    "This product includes software developed by the IEEE Industry Connections Security Group (ICSG)".

  4. The name "IEEE" must not be used to endorse or promote products derived from this software without prior written permission from the IEEE Standards Association (stds.ipr@ieee.org).
  5. Products derived from this software may not contain "IEEE" in their names without prior written permission from the IEEE Standards Association (stds.ipr@ieee.org).
  6. Redistributions of any form whatsoever must retain the following acknowledgment:

    "This product includes software developed by the IEEE Industry Connections Security Group (ICSG)".

THIS SOFTWARE IS PROVIDED "AS IS" AND "WITH ALL FAULTS."IEEE AND ITS CONTRIBUTORS EXPRESSLY DISCLAIM ALL WARRANTIES AND REPRESENTATIONS, EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION: (A) THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE; (B) ANY WARRANTY OF NON-INFRINGEMENT; AND (C) ANY WARRANTY WITH RESPECT TO THE QUALITY, ACCURACY, EFFECTIVENESS, CURRENCY OR COMPLETENESS OF THE SOFTWARE.

IN NO EVENT SHALL IEEE OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES, (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE AND REGARDLESS OF WHETHER SUCH DAMAGE WAS FORESEEABLE.

THIS SOFTWARE USES STRONG CRYPTOGRAPHY, WHICH MAY BE SUBJECT TO LAWS AND REGULATIONS GOVERNING ITS USE, EXPORTATION OR IMPORTATION.YOU ARE SOLELY RESPONSIBLE FOR COMPLYING WITH ALL APPLICABLE LAWS AND REGULATIONS, INCLUDING, BUT NOT LIMITED TO, ANY THAT GOVERN YOUR USE, EXPORTATION OR IMPORTATION OF THIS SOFTWARE.IEEE AND ITS CONTRIBUTORS DISCLAIM ALL LIABILITY ARISING FROM YOUR USE OF THE SOFTWARE IN VIOLATION OF ANY APPLICABLE LAWS OR REGULATIONS.

Info-ZIP

Copyright © 1990–2007 Info-ZIP.All rights reserved.

For the purposes of this copyright and license, “Info-ZIP” is defined as the following set of individuals:

Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, Ed Gordon, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Steven M. Schweda, Christian Spieler, Cosmin Truta, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White

This software is provided “as is,” without warranty of any kind, express or implied.In no event shall Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential damages arising out of the use of or inability to use this software.

Permission is granted to anyone to use this software for any purpose, including commercial applications, and to alter it and redistribute it freely, subject to the following restrictions:

  1. Redistributions of source code must retain the above copyright notice, definition, disclaimer, and this list of conditions.
  2. Redistributions in binary form (compiled executables and libraries) must reproduce the above copyright notice, definition, disclaimer, and this list of conditions in documentation and/or other materials provided with the distribution.The sole exception to this condition is redistribution of a standard UnZipSFX binary (including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this license, as long as the normal SFX banner has not been removed from the binary or disabled.
  3. Altered versions—including, but not limited to, ports to new operating systems, existing ports with new graphical interfaces, versions with modified or added functionality, and dynamic, shared, or static library versions not from Info-ZIP—must be plainly marked as such and must not be misrepresented as being the original source or, if binaries, compiled from the original source.Such altered versions also must not be misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered versions with the names "Info-ZIP" (or any variation thereof, including, but not limited to, different capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP.Such altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or the Info-ZIP URL(s), such as to imply Info-ZIP will provide support for the altered versions.
  4. Info-ZIP retains the right to use the names “Info-ZIP,” “Zip,” “UnZip,” “UnZipSFX,” “WiZ,” “Pocket UnZip,” “Pocket Zip,” and “MacZip” for its own source and binary releases.

Jansson

Copyright (c) 2009-2013 Petri Lehtinen <petri@digip.org>

Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

Lua

The Sophos software that is described in this document may include some software programs that are licensed (or sublicensed) to the user under the Lua License.A copy of the license agreement for any such included software can be found at http://www.lua.org/copyright.html

Microsoft 软件

本 Sophos 产品可能包括特定的 Microsoft 软件，授权给 Sophos 列入本文并在此处使用。

Mersenne Twister (mt19937ar.c)

Copyright (c) 1997–2002 Makoto Matsumoto and Takuji Nishimura.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. The names of its contributors may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

OpenSSL Cryptography and SSL/TLS Toolkit

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the original SSLeay license apply to the toolkit.See below for the actual license texts.Actually both licenses are BSD-style Open Source licenses.In case of any license issues related to OpenSSL please contact openssl-core@openssl.org.

OpenSSL license

Copyright © 1998-2011 The OpenSSL Project.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgment:

    “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit.(http://www.openssl.org/)”

  4. The names “OpenSSL Toolkit” and “OpenSSL Project” must not be used to endorse or promote products derived from this software without prior written permission.For written permission, please contact openssl-core@openssl.org.
  5. Products derived from this software may not be called “OpenSSL” nor may “OpenSSL” appear in their names without prior written permission of the OpenSSL Project.
  6. Redistributions of any form whatsoever must retain the following acknowledgment:

    “This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/)”

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS” AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).This product includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay license

Copyright © 1995–1998 Eric Young (eay@cryptsoft.com) All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).The implementation was written so as to conform with Netscape’s SSL.

This library is free for commercial and non-commercial use as long as the following conditions are adhered to.The following conditions apply to all code found in this distribution, be it the RC4, RSA, lhash, DES, etc., code; not just the SSL code.The SSL documentation included with this distribution is covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young’s, and as such any Copyright notices in the code are not to be removed.If this package is used in a product, Eric Young should be given attribution as the author of the parts of the library used.This can be in the form of a textual message at program startup or in documentation (online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. All advertising materials mentioning features or use of this software must display the following acknowledgement:

    “This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)”

    The word “cryptographic” can be left out if the routines from the library being used are not cryptographic related :-).

  4. If you include any Windows specific code (or a derivative thereof) from the apps directory (application code) you must include an acknowledgement:

    “This product includes software written by Tim Hudson (tjh@cryptsoft.com)”

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publically available version or derivative of this code cannot be changed. i.e. this code cannot simply be copied and put under another distribution license [including the GNU Public License.]

Protocol Buffers (libprotobuf)

Copyright 2008, Google Inc.

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of Google Inc. nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Code generated by the Protocol Buffer compiler is owned by the owner of the input file used when generating it.This code is not standalone and requires a support library to be linked with it.This support library is itself covered by the above license.

pstdint

Copyright (c) 2005-2007 Paul Hsieh
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the DOCUMENTATION and/or other materials provided with the distribution.
  3. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Simple ECMAScript Engine (SEE)

Copyright © 2003, 2004, 2005, 2006, 2007 David Leonard.All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of David Leonard nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

SQLCipher

Copyright © 2008-2012 Zetetic LLC

All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of the ZETETIC LLC nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY ZETETIC LLC ''AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL ZETETIC LLC BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

strcasestr.c

Copyright © 1990, 1993 The Regents of the University of California.All rights reserved.

This code is derived from software contributed to Berkeley by Chris Torek.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. Neither the name of the University nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS “AS IS” AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Udis86

Copyright (c) 2002-2009 Vivek Thampi
All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The views and conclusions contained in the software and documentation are those of the authors and should not be interpreted as representing official policies, either expressed or implied, of the FreeBSD Project.

Unicode

UNICODE, INC.LICENSE AGREEMENT – DATA FILES AND SOFTWARE

Unicode Data Files include all data files under the directories http://www.unicode.org/Public/, http://www.unicode.org/reports/, and http://www.unicode.org/cldr/data/.Unicode Software includes any source code published in the Unicode Standard or under the directories http://www.unicode.org/Public/, http://www.unicode.org/reports/, and http://www.unicode.org/cldr/data/.

NOTICE TO USER: Carefully read the following legal agreement.BY DOWNLOADING, INSTALLING, COPYING OR OTHERWISE USING UNICODE INC.'S DATA FILES ("DATA FILES"), AND/OR SOFTWARE ("SOFTWARE"), YOU UNEQUIVOCALLY ACCEPT, AND AGREE TO BE BOUND BY, ALL OF THE TERMS AND CONDITIONS OF THIS AGREEMENT.IF YOU DO NOT AGREE, DO NOT DOWNLOAD, INSTALL, COPY, DISTRIBUTE OR USE THE DATA FILES OR SOFTWARE.

COPYRIGHT AND PERMISSION NOTICE

Copyright © 1991–2007 Unicode, Inc. All rights reserved.Distributed under the Terms of Use in http://www.unicode.org/copyright.html.

Permission is hereby granted, free of charge, to any person obtaining a copy of the Unicode data files and any associated documentation (the "Data Files") or Unicode software and any associated documentation (the "Software") to deal in the Data Files or Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, and/or sell copies of the Data Files or Software, and to permit persons to whom the Data Files or Software are furnished to do so, provided that (a) the above copyright notice(s) and this permission notice appear with all copies of the Data Files or Software, (b) both the above copyright notice(s) and this permission notice appear in associated documentation, and (c) there is clear notice in each modified Data File or in the Software as well as in the documentation associated with the Data File(s) or Software that the data or software has been modified.

THE DATA FILES AND SOFTWARE ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT OF THIRD PARTY RIGHTS.IN NO EVENT SHALL THE COPYRIGHT HOLDER OR HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THE DATA FILES OR SOFTWARE.

Except as contained in this notice, the name of a copyright holder shall not be used in advertising or otherwise to promote the sale, use or other dealings in these Data Files or Software without prior written authorization of the copyright holder.

UnRAR

The source code of UnRAR utility is freeware.This means:

  1. All copyrights to RAR and the utility UnRAR are exclusively owned by the author - Alexander Roshal.
  2. The UnRAR sources may be used in any software to handle RAR archives without limitations free of charge, but cannot be used to re-create the RAR compression algorithm, which is proprietary.Distribution of modified UnRAR sources in separate form or as a part of other software is permitted, provided that it is clearly stated in the documentation and source comments that the code may not be used to develop a RAR (WinRAR) compatible archiver.
  3. The UnRAR utility may be freely distributed.It is allowed to distribute UnRAR inside of other software packages.
  4. THE RAR ARCHIVER AND THE UnRAR UTILITY ARE DISTRIBUTED “AS IS”.NO WARRANTY OF ANY KIND IS EXPRESSED OR IMPLIED.YOU USE AT YOUR OWN RISK.THE AUTHOR WILL NOT BE LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND OF LOSS WHILE USING OR MISUSING THIS SOFTWARE.
  5. Installing and using the UnRAR utility signifies acceptance of these terms and conditions of the license.
  6. If you don’t agree with terms of the license you must remove UnRAR files from your storage devices and cease to use the utility.

Thank you for your interest in RAR and UnRAR.

Alexander L. Roshal

Windows Template Library (WTL)

This product may contain Windows Template Library (WTL) and/or WixToolset code, which are licensed under the Common Public License 1.0.The source code for the components is available from Sophos, upon request, by emailing TPCRequest@sophos.com

wow64ext library

This is used in Sophos Virus Removal Tool as a shared library (wow64ext.dll), which may be removed or subsituted without affecting other functionality.Its use is covered by the following license:

General Public License

3, 29 August 2007

(c) 19982007 Free Software Foundation, Inc.

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

This version of the GNU Lesser General Public License incorporates the terms and conditions of version 3 of the GNU General Public License, supplemented by the additional permissions listed below.

  • 0.Additional Definitions.

    As used herein, "this License" refers to version 3 of the GNU Lesser General Public License, and the "GNU GPL" refers to version 3 of the GNU General Public License.

    “The Library" refers to a covered work governed by this License, other than an Application or a Combined Work as defined below.

    An "Application" is any work that makes use of an interface provided by the Library, but which is not otherwise based on the Library.Defining a subclass of a class defined by the Library is deemed a mode of using an interface provided by the Library.

    A "Combined Work" is a work produced by combining or linking an Application with the Library.The particular version of the Library with which the Combined Work was made is also called the "Linked Version".

    The "Minimal Corresponding Source" for a Combined Work means the Corresponding Source for the Combined Work, excluding any source code for portions of the Combined Work that, considered in isolation, are based on the Application, and not on the Linked Version.

    The "Corresponding Application Code" for a Combined Work means the object code and/or source code for the Application, including any data and utility programs needed for reproducing the Combined Work from the Application, but excluding the System Libraries of the Combined Work.

  1. Exception to Section 3 of the GNU GPL.

    You may convey a covered work under sections 3 and 4 of this License without being bound by section 3 of the GNU GPL.

  2. Conveying Modified Versions.

    If you modify a copy of the Library, and, in your modifications, a facility refers to a function or data to be supplied by an Application that uses the facility (other than as an argument passed when the facility is invoked), then you may convey a copy of the modified version:

    1. under this License, provided that you make a good faith effort to ensure that, in the event an Application does not supply the function or data, the facility still operates, and performs whatever part of its purpose remains meaningful, or
    2. under the GNU GPL, with none of the additional permissions of this License applicable to that copy.
  3. Object Code Incorporating Material from Library Header Files.

    The object code form of an Application may incorporate material from a header file that is part of the Library.You may convey such object code under terms of your choice, provided that, if the incorporated material is not limited to numerical parameters, data structure layouts and accessors, or small macros, inline functions and templates (ten or fewer lines in length), you do both of the following:

    1. Give prominent notice with each copy of the object code that the Library is used in it and that the Library and its use are covered by this License.
    2. Accompany the object code with a copy of the GNU GPL and this license document.
  4. Combined Works.

    You may convey a Combined Work under terms of your choice that, taken together, effectively do not restrict modification of the portions of the Library contained in the Combined Work and reverse engineering for debugging such modifications, if you also do each of the following:

    1. Give prominent notice with each copy of the Combined Work that the Library is used in it and that the Library and its use are covered by this License.
    2. Accompany the Combined Work with a copy of the GNU GPL and this license document.
    3. For a Combined Work that displays copyright notices during execution, include the copyright notice for the Library among these notices, as well as a reference directing the user to the copies of the GNU GPL and this license document.
    4. Do one of the following:

      0) Convey the Minimal Corresponding Source under the terms of this License, and the Corresponding Application Code in a form suitable for, and under terms that permit, the user to recombine or relink the Application with a modified version of the Linked Version to produce a modified Combined Work, in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source

      1) Use a suitable shared library mechanism for linking with the Library.A suitable mechanism is one that (a) uses at run time a copy of the Library already present on the user's computer system, and (b) will operate properly with a modified version of the Library that is interface-compatible with the Linked Version.

    5. Provide Installation Information, but only if you would otherwise be required to provide such information under section 6 of the GNU GPL, and only to the extent that such information is necessary to install and execute a modified version of the Combined Work produced by recombining or relinking the Application with a modified version of the Linked Version.(If you use option 4d0, the Installation Information must accompany the Minimal Corresponding Source and Corresponding Application Code.If you use option 4d1, you must provide the Installation Information in the manner specified by section 6 of the GNU GPL for conveying Corresponding Source.)
  5. Combined Libraries.

    You may place library facilities that are a work based on the Library side by side in a single library together with other library facilities that are not Applications and are not covered by this License, and convey such a combined library under terms of your choice, if you do both of the following:

    1. Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library facilities, conveyed under the terms of this License.
    2. Give prominent notice with the combined library that part of it is a work based on the Library, and explaining where to find the accompanying uncombined form of the same work.
  6. Revised Versions of the GNU Lesser General Public License.

    The Free Software Foundation may publish revised and/or new versions of the GNU Lesser General Public License from time to time.Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

    Each version is given a distinguishing version number.If the Library as you received it specifies that a certain numbered version of the GNU Lesser General Public License "or any later version" applies to it, you have the option of following the terms and conditions either of that published version or of any later version published by the Free Software Foundation.If the Library as you received it does not specify a version number of the GNU Lesser General Public License, you may choose any version of the GNU Lesser General Public License ever published by the Free Software Foundation.

    If the Library as you received it specifies that a proxy can decide whether future versions of the GNU Lesser General Public License shall apply, that proxy's public statement of acceptance of any version is permanent authorization for you to choose that version for the Library.

上一个题目： 技术支持